Jump to content
Latest News: (loading..)
Jack_mcs

Header Tags SEO

Recommended Posts

MY know issues were solved - iI did as post 2621. But still remains one issue and not sure how to correct this. it only happens when at product listing or info pages. At very top above the header appears this ( path standard ) If changing header tags config in admin then will appear at top of page.

 

You may view it here.

 

Thanks.

Already addressed in the last few pages.

 

Jack

Share this post


Link to post
Share on other sites
Well it looks like I was able to get the add-on working just fine on my site. Kind of surprises me if i may say so. Just one questions i have three error messages when I do the test run. I had four but fixed one. Two others I know what they mean but this one I am not sure. "Default Text Present: explain

The default root text, products new home, should be removed or changed for product_info.php with language ID of 1."

I placed some of my text in the tags before doing the test. So two are for duplicate entries. That i can fix But what about this one? Hey Jack just wanted to say if i could understand the instructions and get this working as easy as I did anyone could. Great job on the install instructions.

Pat

It means the text that comes with Header Tags for the index.php and other pages is still present. You need to delete or change it.

 

Jack

Share this post


Link to post
Share on other sites

Hello,

 

if i want to plug a "ucfirst(strtolower())" on "categories" description.

 

wich code should i touch ?

Share this post


Link to post
Share on other sites
I'm sorry Jack but i dont understand what you are saying. What text and where would it be present?

Pat

Go to admin->Header Tags SEO->Page Control and select product_info.php. See where it says, "products new home." If you want that displaying on your product pages, then leave it in. If not, erase or change it.

 

Jack

Share this post


Link to post
Share on other sites
Hello,

 

if i want to plug a "ucfirst(strtolower())" on "categories" description.

 

wich code should i touch ?

You can edit the index.php file where the description is displayed (two places) or edit Fill Tags where the description gets saved, or edit admin/categories.php where the description gets saved.

 

Jack

Share this post


Link to post
Share on other sites

Thanks Jack that fixed that how about two other messages, one is "Duplicate title found: explain for English exists more than once." The other is "Duplicate meta description found: explain for English exists more than once." I thought this was because I use the add-on before I tested it, but now I dont think it is that. Can you please tell me what is causing it. I have looked and did not see any duplicate entries so I am confused.

Pat

Share this post


Link to post
Share on other sites
You can edit the index.php file where the description is displayed (two places) or edit Fill Tags where the description gets saved, or edit admin/categories.php where the description gets saved.

 

Jack

 

 

oops, thanks for reply.

 

i was speaking about "category title" !

 

displayed in the <title>.

Share this post


Link to post
Share on other sites

I notice my product description tag conrent box is not right. Even though after running the fill tags with 120 characters and checking fill all tags under products and categories, the product description tag area contains anywhere from 10 to 120 characters. So why not all at 120 characters, is confusing.

 

Now here is a sample of what I am doing in entering in the product description area. Understanding I am ttrying to improve the way product descriptions look on the web pages.

 

<p style="text-align: justify"><span style="letter-spacing: 1px"><i><font size="5" color="#00FF00">T</font></i>he classic symbols of faith and the music of a dancing waterfall bring a joyful spiritual aura to your garden! Stunning fountain features a substantial faux-stone cross with the look of hand-hewn granite; from the graceful mouth of the topmost twining lily, clear cascades of water sparkle and shine. An absolutely amazing decoration, and an eloquent declaration of devotion! Fiber resin. UL Recognized cord. Assembly instructions included. Water capacity 7 liters.</span></p><span style="letter-spacing: 1px"><font color="#00FF00"><font face="Comic Sans MS">Dimensions:</font> </font></span> <hr /><span style="letter-spacing: 1px"> 19-5/8" x 10" x 35-5/8" high.</span>

 

So I am guessing it's counting the html languages as well. Is this correct? Am hoping in a way, this isn't the reason because of over 1500 products, this will crreat lots of extra hours of labor.

 

Thank you.

Share this post


Link to post
Share on other sites
Thanks Jack that fixed that how about two other messages, one is "Duplicate title found: explain for English exists more than once." The other is "Duplicate meta description found: explain for English exists more than once." I thought this was because I use the add-on before I tested it, but now I dont think it is that. Can you please tell me what is causing it. I have looked and did not see any duplicate entries so I am confused.

Pat

You have to compare the products found to see what the problem is. Sometimes it is just due to link products.

 

Jack

Share this post


Link to post
Share on other sites
oops, thanks for reply.

 

i was speaking about "category title" !

 

displayed in the <title>.

Edit it in the categories edit page or change the code in the admin/categories.php file or in includes/functions/header_tags.php.

 

Jack

Share this post


Link to post
Share on other sites
I notice my product description tag conrent box is not right. Even though after running the fill tags with 120 characters and checking fill all tags under products and categories, the product description tag area contains anywhere from 10 to 120 characters. So why not all at 120 characters, is confusing.

 

Now here is a sample of what I am doing in entering in the product description area. Understanding I am ttrying to improve the way product descriptions look on the web pages.

 

<p style="text-align: justify"><span style="letter-spacing: 1px"><i><font size="5" color="#00FF00">T</font></i>he classic symbols of faith and the music of a dancing waterfall bring a joyful spiritual aura to your garden! Stunning fountain features a substantial faux-stone cross with the look of hand-hewn granite; from the graceful mouth of the topmost twining lily, clear cascades of water sparkle and shine. An absolutely amazing decoration, and an eloquent declaration of devotion! Fiber resin. UL Recognized cord. Assembly instructions included. Water capacity 7 liters.</span></p><span style="letter-spacing: 1px"><font color="#00FF00"><font face="Comic Sans MS">Dimensions:</font> </font></span> <hr /><span style="letter-spacing: 1px"> 19-5/8" x 10" x 35-5/8" high.</span>

 

So I am guessing it's counting the html languages as well. Is this correct? Am hoping in a way, this isn't the reason because of over 1500 products, this will crreat lots of extra hours of labor.

 

Thank you.

Header Tags doesn't do anything with the products description. You'll need to ask in the general forum for help with that.

 

Jack

Share this post


Link to post
Share on other sites

I'm having a strange problem I can't figure out, any help would be appreciated.

 

Whenever I Include:Category in admin SEO control on index.php, I get text appended to html ouput. Source shows the text "path Standard" before <title>, on the same line with no break. This text does not appear on the home index page, only when I go into categories.

 

The same thing happens on products page when I Include:Category for products_info.php SEO admin.

 

I have made no contributions changes to either file above this point, and since the only thing they have in common at this point is calling application_top and includes/header_tags.php I am assuming this must be coming from header_tags.php. If it was coming from application_top wouldn't it be showing on other pages also?

 

I have made no changes to header_tags, so I am completely lost as to where this text is coming from.

 

I would be thankful for any suggestions.

Share this post


Link to post
Share on other sites

I have a new issue I just noticed. On the top of my pages I have this "path HEADER_TAGS_ADD_CATEGORY_PARENTS"

I have not added any new add-ons other than a random product display which is only one file. Any Idea what is causing this?

Pat

Share this post


Link to post
Share on other sites

My mistake it only seems to be happening on product_info pages. I have checked the product_info.php to see if I could find that line thinking there may be opening and closing tags missing, but no luck finding it there.

Pat

Share this post


Link to post
Share on other sites
I have a new issue I just noticed. On the top of my pages I have this "path HEADER_TAGS_ADD_CATEGORY_PARENTS"

I have not added any new add-ons other than a random product display which is only one file. Any Idea what is causing this?

Pat

 

It sounds like we're having the same problem. I've spent quite a bit of time going over the code and I can't figure it out.

 

It's funny because the path code used by index.php and product_info.php are different, so I am assuming it's something in the header_tags.php code. I'm a kinda newbie to php and code, though, so I may be wrong. :unsure:

Share this post


Link to post
Share on other sites
I have a new issue I just noticed. On the top of my pages I have this "path HEADER_TAGS_ADD_CATEGORY_PARENTS"

I have not added any new add-ons other than a random product display which is only one file. Any Idea what is causing this?

Pat

 

By the way, thanks for the clue. I found this in functions/header_tags.php:

 

  if (($type == 'cat' || $type == 'top') && ($pageTags['append_category'] || $defaultTags['default_logo_append_group'] || $defaultTags['default_logo_append_category']))
 {
   if ($category_depth == 'nested' || $category_depth == 'products' || $product)
   {
     $the_category_query = tep_db_query($catStr);
     $parentStr = '';

   echo 'path '.HEADER_TAGS_ADD_CATEGORY_PARENTS;  
     if (HEADER_TAGS_ADD_CATEGORY_PARENTS == 'Duplicate Categories' && $product && tep_db_num_rows($the_category_query) > 1) //selected product is in multiple categories

 

The only problem is, I dont see HEADER_TAGS_ADD_CATEGORY_PARENTS being defined anywhere before this. It obviously is because I'm getting "path Standard" for ouput. Now I just need to figure out where the "Standard" is being defined. It looks like it's coming from the database somewhere.... Any expert opinions out there?

Share this post


Link to post
Share on other sites
The only problem is, I dont see HEADER_TAGS_ADD_CATEGORY_PARENTS being defined anywhere before this. It obviously is because I'm getting "path Standard" for ouput. Now I just need to figure out where the "Standard" is being defined. It looks like it's coming from the database somewhere.... Any expert opinions out there?

 

see this post: http://forums.oscommerce.com/index.php?s=&...t&p=1394472

Edited by ajundra

Share this post


Link to post
Share on other sites

OK I think it is in the database. I noticed when I Include:Category in SEO admin I get an error message at the top of the screen that says "Missing sort orders are not allowed -> index.php". I went through all the category and product db tables, and every record seems to have all its attributes, so I'm stumped at this point. I think I'll go back through the install docs and make sure my databases have all the updates?

Share this post


Link to post
Share on other sites

 

Wow Thanks! I searched this topic 4 times with everything and that never came up. As to the whole 'sort order' issue, that was unrelated and was because I didn't read all the docs. Operator error: not putting the sort code in the box in admin SEO.

 

edit: P.S. Thanks Jack and everyone for all the help. This is a great contribution.

Edited by randallfox

Share this post


Link to post
Share on other sites

Hi,

 

I wonder if anyone can help me?

 

I have installed Header Tags SEO over a previous version of Header Tags on a RC2a STS oscommerce shop

 

I have gone through the install and setup the pages in admin but the page title on index still shows New Home Page Title after my main title.

 

Thanks in advance

Share this post


Link to post
Share on other sites

Thank-you so much Jack for your patiance. That fixed the problem just fine. After you gave that link and I read it then I remembered seeing it no long ago. Oh well good thing you are here. I Have to say though I love this add-on it is so easy now to place my meta tags on the pages.

Pat

Share this post


Link to post
Share on other sites
I'm having a strange problem I can't figure out, any help would be appreciated.

 

Whenever I Include:Category in admin SEO control on index.php, I get text appended to html ouput.

It means you made a mistake in the installation. You either added or delete a php delimiter.

 

Jack

Share this post


Link to post
Share on other sites
I have a new issue I just noticed. On the top of my pages I have this "path HEADER_TAGS_ADD_CATEGORY_PARENTS"

I have not added any new add-ons other than a random product display which is only one file. Any Idea what is causing this?

Pat

It means you made a mistake in the installation of the database changes.

 

Jack

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×