Jump to content
Latest News: (loading..)
Jack_mcs

Header Tags SEO

Recommended Posts

I have ran into problems right out the gate. I am trying to use the install for the sql but I am getting an error message about not finding a page. Here is the message.

Warning: require(includes/application_top.php) [function.require]: failed to open stream: No such file or directory in mysite.kysmiley/headertags_seo_install.php on line 13

 

Fatal error: require() [function.require]: Failed opening required 'includes/application_top.php' (include_path='.:/usr/local/lib/php-5.2.1/lib/php') inmysite.kysmiley/headertags_seo_install.php on line 13. I can use myphpadmin to import the the new database files. However there is two do i install the main one first then the update after? Or will I have trouble setting this add-on up if it cant open main files.

Pat

Share this post


Link to post
Share on other sites
thanks for this upgrade jack. :)

 

one small problem: the duplicate categories setting works for description and title tags but not for keywords. only one category is shown, followed by a comma. there it ends.

 

 

<title>Burning Babylon - Knives To The Treble : Mars Records : New Releases : Dub : Sofasound</title>
<meta name="Description" content="Created by Slade Anderson, the heavyweight riddims of Burning Babylons sound are firmly anchored in the 1970s Jamaican roots tradition, but with an ear for the neo dub stylings of the present day. : Mars Records : New Releases : Dub" />
<meta name="Keywords" content="Burning Babylon, Knives To The Treble , Mars Records , New Releases ," />

There is a typo that is probably the problem. In includes/functions/headertags.php, find this line

		$catKeywords = tep_not_null($parentStr) ? (str_replace(HEADER_TAGS_SEPARATOR_DESCRIPTION, HEADER_TAGS_SEPARATOR_KEYWORD, $parentStr) . $the_category['htc_keywrods_tag']) : $the_category['htc_keywords_tag'];

and replace with

		$catKeywords = tep_not_null($parentStr) ? (str_replace(HEADER_TAGS_SEPARATOR_DESCRIPTION, HEADER_TAGS_SEPARATOR_KEYWORD, $parentStr) . $the_category['htc_keywords_tag']) : $the_category['htc_keywords_tag'];

Please let me know if that fixes everything and I will get a corrected version uploaded.

 

Jack

Share this post


Link to post
Share on other sites
I have ran into problems right out the gate. I am trying to use the install for the sql but I am getting an error message about not finding a page. Here is the message.

Warning: require(includes/application_top.php) [function.require]: failed to open stream: No such file or directory in mysite.kysmiley/headertags_seo_install.php on line 13

 

Fatal error: require() [function.require]: Failed opening required 'includes/application_top.php' (include_path='.:/usr/local/lib/php-5.2.1/lib/php') inmysite.kysmiley/headertags_seo_install.php on line 13. I can use myphpadmin to import the the new database files. However there is two do i install the main one first then the update after? Or will I have trouble setting this add-on up if it cant open main files.

Pat

From the instructions

DATABASE CHANGES: Update the database. There are two ways to do this:

 

1 - use the "headertags_seo.sql" file and upload via phpmyadmin.

 

2 - copy the included headertags_seo_install.php file to your root directory

(where your index.php file is located). Then open your browser and type in

http://www.yoursite.com/headertags_seo_install.php (substitute your url, of

course). You should delete this file from your site once you have updated

the database successfully.

The statement
There are two ways to do this:
means either or - maybe I need to state that explicitly? As for the error, it is saying that the application_top.php file can't be found which most likely means you are trying to run the script from the wrong location.

 

Jack

Share this post


Link to post
Share on other sites
From the instructionsThe statementmeans either or - maybe I need to state that explicitly? As for the error, it is saying that the application_top.php file can't be found which most likely means you are trying to run the script from the wrong location.

 

Jack

Yep I understood that much Jack, what I was asking is that there is two sql files one is an upgrade. Do I do both. I uploaded the installsql to mysite.com then I tried to access it from mysite.com/headertags_seo_install.php I thought that is what the directions said.

Pat

Share this post


Link to post
Share on other sites
Yep I understood that much Jack, what I was asking is that there is two sql files one is an upgrade. Do I do both. I uploaded the installsql to mysite.com then I tried to access it from mysite.com/headertags_seo_install.php I thought that is what the directions said.

Pat

No, the update file is for when an update is being done to the database on a working installation. Those aren't really needed any longer. They were mainly meant for conversions from the Header Tags Cotroller contribution but this one has been out long enough now to no longer support that so I've deleted them from the package. Thanks for pointing that out.

 

Jack

Share this post


Link to post
Share on other sites

first of all, V_3.1.0 worked find. Today I updated to V_3.1.3. Results after running test with (show limit warnings) checked, a few things does not look right. At top it reads, suggested range is 60 120 characters. So at fill tags, I set characters for 120. After checking in categories/products, it displays 120 characters.

 

But the list shows every product stating so many xxx(characters long. For example on of the items states 34 characters to long. But as I stated the character count in categories is 120. (that includes letters and spaces).

 

Regardless how many times I do this over and over, it still states to many characters. Even tried just to see what would happen, I set fill tags to 300 characters, the test results still states the same, 34 characters to long.

 

So Jack or anyone else, what must I look for?

Share this post


Link to post
Share on other sites
first of all, V_3.1.0 worked find. Today I updated to V_3.1.3. Results after running test with (show limit warnings) checked, a few things does not look right. At top it reads, suggested range is 60 120 characters. So at fill tags, I set characters for 120. After checking in categories/products, it displays 120 characters.

 

But the list shows every product stating so many xxx(characters long. For example on of the items states 34 characters to long. But as I stated the character count in categories is 120. (that includes letters and spaces).

 

Regardless how many times I do this over and over, it still states to many characters. Even tried just to see what would happen, I set fill tags to 300 characters, the test results still states the same, 34 characters to long.

 

So Jack or anyone else, what must I look for?

 

 

Jack,

 

I have been using header tag SEO for a while now and as always find it very useful and the support you provide nothing short of excellant.

 

Can you please advise how I can remove the header tag of the catergory from my products page. As you can see on my site comfyearplugs the product pages also contain the discription for the catergory. If it helps, I have actually unchecked everything apart from 'products' within the module.

 

Thanks and regards. Peter.


I have built an online store solely with the help of this forum.

Share this post


Link to post
Share on other sites

Hi Jack, I'm back... :P

 

I need your opinion on a couple of things.

 

First (I'm sooo embarassed :blush: ) just noticed, I think my installed version is 3.0.

Would it be an easy update to version 3.1.2?

Only reason I'm not concidering 3.1.3 is because I really don't need - "the parent category names to be included in the title and meta tags."

 

Secondly, not long ago I posted problems regarding Google and my sites search results.

Refresher - a few months ago moved site from catalog to root, Google still displaying links for products in catalog folder.

Google is dening URL removal of my catalog folder even though I made the change to my htaccess file.

My host suggest I setup a 310 redirect, Google help forum suggested a 410 gone.

In your opinion which do you think would be best, 310 or 410?

 

Thanks for putting up with me. ;)


- :: Jim :: -

- My Toolbox ~ Adobe Web Bundle, XAMPP & WinMerge | Install ~ osC v2.3.3.4 -

Share this post


Link to post
Share on other sites
first of all, V_3.1.0 worked find. Today I updated to V_3.1.3. Results after running test with (show limit warnings) checked, a few things does not look right. At top it reads, suggested range is 60 120 characters. So at fill tags, I set characters for 120. After checking in categories/products, it displays 120 characters.

 

But the list shows every product stating so many xxx(characters long. For example on of the items states 34 characters to long. But as I stated the character count in categories is 120. (that includes letters and spaces).

 

Regardless how many times I do this over and over, it still states to many characters. Even tried just to see what would happen, I set fill tags to 300 characters, the test results still states the same, 34 characters to long.

 

So Jack or anyone else, what must I look for?

The lengths are suggestions, as mentioned in the docs, and don't take into account other parts of the url, as mentioned here. You should follow the instructions in this thread regarding the lengths and using a google sitemap account.

 

Jack

Share this post


Link to post
Share on other sites
Jack,

 

I have been using header tag SEO for a while now and as always find it very useful and the support you provide nothing short of excellant.

 

Can you please advise how I can remove the header tag of the catergory from my products page. As you can see on my site comfyearplugs the product pages also contain the discription for the catergory. If it helps, I have actually unchecked everything apart from 'products' within the module.

 

Thanks and regards. Peter.

Maybe you have the category option checked in the default section?

 

Jack

Share this post


Link to post
Share on other sites
Hi Jack, I'm back... :P

 

I need your opinion on a couple of things.

 

First (I'm sooo embarassed :blush: ) just noticed, I think my installed version is 3.0.

Would it be an easy update to version 3.1.2?

Only reason I'm not concidering 3.1.3 is because I really don't need - "the parent category names to be included in the title and meta tags."

 

Secondly, not long ago I posted problems regarding Google and my sites search results.

Refresher - a few months ago moved site from catalog to root, Google still displaying links for products in catalog folder.

Google is dening URL removal of my catalog folder even though I made the change to my htaccess file.

My host suggest I setup a 310 redirect, Google help forum suggested a 410 gone.

In your opinion which do you think would be best, 310 or 410?

 

Thanks for putting up with me. ;)

You should update to the latest version if there are database changes, which there are in several of them. Otherwise there won't be an easy way for you to upgrade to some later version. The "parent category" is an option and does not have to be used.

 

For old links, 301's should be used (I'm not familiar with 310 so I assume that is a typo). The 410 is used for pages that are no longer available, which is not the case when moving the shops location.

 

Jack

Share this post


Link to post
Share on other sites
Maybe you have the category option checked in the default section?

 

Jack

 

Thanks again Jack,

 

The problem with unchecking that box is that the page then only displays Mozilla Firefox for the categories although I have added the info into the catergory boxes. I would ideally like both the catergories to display its own tags as well as the products. Can this be done?

 

Regards. Peter.


I have built an online store solely with the help of this forum.

Share this post


Link to post
Share on other sites

Then something is not setup correctly. Maybe you did run Fill Tags. What does the test function report?

 

Jack

Share this post


Link to post
Share on other sites
You should update to the latest version if there are database changes, which there are in several of them. Otherwise there won't be an easy way for you to upgrade to some later version. The "parent category" is an option and does not have to be used.

 

For old links, 301's should be used (I'm not familiar with 310 so I assume that is a typo). The 410 is used for pages that are no longer available, which is not the case when moving the shops location.

 

Jack

 

Thank you so much Jack! :)

 

Version 3.1.3 it is then.

 

My bad... fingers quicker than my brain 301 LOL.

It sounded like 301 made more sense than a 410.

 

Thanks again, I truely appreciate all your help! ;)


- :: Jim :: -

- My Toolbox ~ Adobe Web Bundle, XAMPP & WinMerge | Install ~ osC v2.3.3.4 -

Share this post


Link to post
Share on other sites

Hi Jack, thanks again for a fantastic contribution, i have one minor bug when we open manufacture's page in admin none of the tag info is displayed yet it's in the db and is displayed on the front end, we do not have the problem on any other page ie product or category, can you please point me where i should be looking.

 

many thanks

Neil

 

Ps thanks jack my stupidity found it in admin/manufacturers.php all works fine ta

Edited by Deshosts

Share this post


Link to post
Share on other sites
Hi Jack, thanks again for a fantastic contribution, i have one minor bug when we open manufacture's page in admin none of the tag info is displayed yet it's in the db and is displayed on the front end, we do not have the problem on any other page ie product or category, can you please point me where i should be looking.

 

many thanks

Neil

If it was displaying before you installed Header Tags, then the admin/manufacturers.php edits are probably the problem.

 

Jack

Share this post


Link to post
Share on other sites
Then something is not setup correctly. Maybe you did run Fill Tags. What does the test function report?

 

Jack

 

Jack,

 

Just ran the test and got the following info:

 

Test Results

Default Text Present:

The default root text, products new home, should be removed or changed for product_info.php with language ID of 1.

Database/File Mismatch Error:

The number of file entries in the database (19) does not match the number in the includes/header_tags.php file (18).

Files not in the database:

/index.php

 

Regards. Peter.


I have built an online store solely with the help of this forum.

Share this post


Link to post
Share on other sites

Hi there Jack Again, sorry if this sounds like a stupid question. I had already downloaded the headertags SEO to my PC and uploaded the SQL files Last Friday, I did not get a chance to upload or do the changes to the other files to get the script working. I noticed today that you uploaded a new version 3.13 I downloaded it and just over wrote my existing version on my PC. I am reading all the updates and am a little confused. Do I worry about any of the update notes or just start with the 3.13 install notes? Like I said the only thing done on the server previously was the SQL that I can update easy. I dont want to mess things up on my setup. I cant just over write files so I have to edit files as I have other add-ons that may be effected by an over write.

Pat

Share this post


Link to post
Share on other sites
Jack,

 

Just ran the test and got the following info:

 

Test Results

Default Text Present:

The default root text, products new home, should be removed or changed for product_info.php with language ID of 1.

Database/File Mismatch Error:

The number of file entries in the database (19) does not match the number in the includes/header_tags.php file (18).

Files not in the database:

/index.php

 

Regards. Peter.

The last one is probably causing the problem. I suggest you replace the includes/header_tags.php file with the one from the contribution, run the uninstall and install scripts, run fill tags and go to page control so the pages will be added. It should work at that point.

 

Jack

Share this post


Link to post
Share on other sites
Hi there Jack Again, sorry if this sounds like a stupid question. I had already downloaded the headertags SEO to my PC and uploaded the SQL files Last Friday, I did not get a chance to upload or do the changes to the other files to get the script working. I noticed today that you uploaded a new version 3.13 I downloaded it and just over wrote my existing version on my PC. I am reading all the updates and am a little confused. Do I worry about any of the update notes or just start with the 3.13 install notes? Like I said the only thing done on the server previously was the SQL that I can update easy. I dont want to mess things up on my setup. I cant just over write files so I have to edit files as I have other add-ons that may be effected by an over write.

Pat

See the update file.

 

Jack

Share this post


Link to post
Share on other sites

MY know issues were solved - iI did as post 2621. But still remains one issue and not sure how to correct this. it only happens when at product listing or info pages. At very top above the header appears this ( path standard ) If changing header tags config in admin then will appear at top of page.

 

You may view it here.

 

Thanks.

Share this post


Link to post
Share on other sites

Well it looks like I was able to get the add-on working just fine on my site. Kind of surprises me if i may say so. Just one questions i have three error messages when I do the test run. I had four but fixed one. Two others I know what they mean but this one I am not sure. "Default Text Present: explain

The default root text, products new home, should be removed or changed for product_info.php with language ID of 1."

I placed some of my text in the tags before doing the test. So two are for duplicate entries. That i can fix But what about this one? Hey Jack just wanted to say if i could understand the instructions and get this working as easy as I did anyone could. Great job on the install instructions.

Pat

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×