Jump to content
Sign in to follow this  

Authorize.net Cannot Connect to server, check cURL and server settings

Recommended Posts

I have been at this for 2 days now. I have been consulting with CRE support since I am running the Pro version of their software. Basically, the supplied Auth.net module is not working for me. Originally I thought it could be the curl directory. I tried every possible combination and turns out I had it on there right the first time. After some more messing around and a day later with CRE support they tell me the reason it wont work is because I did not have OpenSSL compiled. So, I recompile with that option, change nothing else and then my secure.domain.com stops working entirely. I reinstall the SSL cert and this solves that problem, again though, same error "The server cannot connect to Authorize.net. Please check your cURL and server settings."


I am wondering if there is anything else I might need for this to work? I have config settings listed here hyperformanceparts.com/phpinfo.php


OpenSSL seems to be working, along with an up to date verion of curl. Is there anything else it could be?


Maybe iptables firewall is blocking connection?

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this