Jump to content
Sign in to follow this  
eeeek

contact short captcha v1-2

Recommended Posts

Hi All,

 

I recently downloaded and installed the "contact short captcha v1-2" - installation was simple enough and permissions on files and folders are correct. I sent an email to the author (Dimi) via the forum but since I don't know how often he may check that email, I am placing this here in the event anyone else has run into this or knows what the problem might be...

 

My thanks in advance for any help you can give.

 

Here's what I did (as per the instructions):

  • I have replaced the files:
    catalog/contact_us.php and
    catalog/includes/languages/english/contact_us.php

  • I have uploaded captcha.php to the /catalog/images directory and ensured the permissions both on the file and directory are set to 755 (and verified this multiple times...)

  • I changed the $captcha_encryption_key in catalog/contact_us.php and in catalog/images/captcha.php and made sure they matched....

However, when I go to the contact page now, even though it shows where the captcha image should be, what I get is: captcha-shot.gif

 

As you can see, no letters or numbers show up...just the box with lines in it... Am I missing something? Is there a particular version of the GD lib that must be installed? The GD library on my server is version 2.033 and my server is running PHP5 - is THAT a problem?

 

I have been monkeying around with this for a couple of weeks now & have searched the forums to no avail. Any help would be appreciated...

 

Kryss

Share this post


Link to post
Share on other sites

Not sure that this will work for you, but I once had a problemwithit not showing, and this is what I did.

 

Go to your phpMyadmin, click on the table for anti_robotreg and delete the contents, not the table, just the contents.

 

Let me know if that works. Your getting an image at least, when I had a problem before I wasnt even getting that, so I dont know if the same solution will work.


Follow the community build:

BS3 to osCommerce Responsive from the Get Go!

Check out the new construction:

Admin Gone to Total BS!

Share this post


Link to post
Share on other sites
Go to your phpMyadmin, click on the table for anti_robotreg and delete the contents, not the table, just the contents.

 

Thanks for the reply but, and I may just be blind as a bat, I see no table called "anti_robotreg" or anything remotely similar? :blink:

Share this post


Link to post
Share on other sites
Thanks for the reply but, and I may just be blind as a bat, I see no table called "anti_robotreg" or anything remotely similar? :blink:

Crap, just realized your using a different version. Im using anti-robot reg. Sorry, maybe it works simular though, is there a database table that works with yours that stores a session id?


Follow the community build:

BS3 to osCommerce Responsive from the Get Go!

Check out the new construction:

Admin Gone to Total BS!

Share this post


Link to post
Share on other sites
Crap, just realized your using a different version. Im using anti-robot reg. Sorry, maybe it works simular though, is there a database table that works with yours that stores a session id?

 

Hmm there is a "sessions" table but it is empty. This implementation is not yet live, so there would be no session data I don't believe...

 

Any other thoughts?

Share this post


Link to post
Share on other sites
Hmm there is a "sessions" table but it is empty. This implementation is not yet live, so there would be no session data I don't believe...

 

Any other thoughts?

No, the sessions table is a stock osc table. I wouldnt know without digging into the mod.

You might consider using this mod instead:

http://addons.oscommerce.com/info/1237

it does the same is is ready to go with a lot of other add ons.


Follow the community build:

BS3 to osCommerce Responsive from the Get Go!

Check out the new construction:

Admin Gone to Total BS!

Share this post


Link to post
Share on other sites
No, the sessions table is a stock osc table. I wouldnt know without digging into the mod.

You might consider using this mod instead:

http://addons.oscommerce.com/info/1237

it does the same is is ready to go with a lot of other add ons.

 

Thanks G.L. will give that a try and cross my fingers LOL :)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×