Jump to content
Sign in to follow this  
sw45859

CUSTOM COMPUTER CREATOR 7 RELEASED

Recommended Posts

yep people somethimes never contribute back the really nice things they do

 

well.. thats life

Share this post


Link to post
Share on other sites

I installed the CCC contrib today.

 

But when i try to add products to the database using the admin, i can select an categorie. When i do so i receive the PAGE NOT FOUND display.

 

What am i doing wrong here..

Edited by calimero1505

Share this post


Link to post
Share on other sites

Sounds as if you are not defining the page correctly or at all.

 

Post the URL that you are trying to reach.

 

And check you made all necessary adjustments to application_top.php and english.php if there are any.

Share this post


Link to post
Share on other sites

The worst thing in that shop is that he's also using OSCOMMERCE and not giving credit to it anywhere...can't see the "powered by"


Advice on forum are Free, Email or Pm to fix your site is work...which I charge for :)

-------------------

Share this post


Link to post
Share on other sites

Well, actually he could contribute and put the credit for oscommerce :)


Advice on forum are Free, Email or Pm to fix your site is work...which I charge for :)

-------------------

Share this post


Link to post
Share on other sites

In danger of going off topic, I must say...

 

There is no reason anybody should be forced into providing contributions or links back to OSC.

Yes I agree it would show appreciation if everyone did, but why are you dissin him/them (I say them because that site is huge!) when they have no responsibility to provide you with freebies??

 

Using OSC is down to each user as they see fit, and if they do not wish to share everything that is up to them.

Dont go shaming the guys just becos they dont!

 

Do as they have done if you need a mod, do it yourself.

Share this post


Link to post
Share on other sites

oh right yeh, gotcha. ;)

 

In which case you need to define this link in application_top, without it the link doesnt exist.

Share this post


Link to post
Share on other sites

Have a look at how the other defines work that you have entered into application_top for that mod, all OSC works the same, so if you have done one bit look at how that worked and do the same with this.

 

define('FILENAME_CC_ADD', 'fileurl.php');

 

You obviously need to make the fileurl.php to the link that it should be.

tbh - If you havent worked out the easy things like this, you are gonna struggle trying to use this PC config thing.

It needs a lot of work.

Share this post


Link to post
Share on other sites

Thanx.

 

I know various things about OSC, but i do not always know where to put the DEFINE's and stuff.

 

define('FILENAME_CC_ADD', 'fileurl.php');

I think this would be define('FILENAME_CC_ADD', 'ccc_add.php');?

Share this post


Link to post
Share on other sites

Ok, i found the problem

 

define('FILENAME_CC_ADD', 'ccc_add.php'); had to be

 

define('FILENAME_CCC_ADD', 'ccc_add.php');

 

Thanx for your help ;)

Share this post


Link to post
Share on other sites

Read back through the thread.

This is what virtually everyone has said, the same thing about the shopping cart.

 

Trust me if you cant make this work yourself, you are not going to get it running properly.

 

It needs too much work for people to casually sit down and make it work.

It needs someone to take it on as a project and finish off the bugs and clean up the work to make it all function properly.

 

Stephen has done a great job in what he has done so far, but it is far from a working mod.

 

If your desperate for it you might try paying someone to finish it properly.

Share this post


Link to post
Share on other sites

Why are the prices not linked to the database?

Is it possible to change category id and category number. I tried to but it didn't work. I made 1 category above intel motherboards and renumbered the rest. But when you build a system then a few category's disapear. The require and hidden options set correctly. Anyone a solution, or is this not possible?

Share this post


Link to post
Share on other sites

well guys, with all the problems i am going to make the contribution a stand alone, meaning i will make it almost like its own cart except for the admin area, i am going to polish it up alot, but when i get this done you should be able to link to it and everything will run almost independant of osc cart, hopefully that will stop some problems. sorry i have been so slow with responces but i have been trying to get my hosting company running and it has been taking alot of time, but i haven't forgotten about you guys who are needing this contribution working, i am also thinking about possibly putting a template to this if some of you guys can give me ideas on layouts or what parts would be best to have the ability to change around a little let me know.

Share this post


Link to post
Share on other sites

I tried to install the CCC but every time i try to add a custom build pc to my cart

it stops working. I took the custom_checkout that came with the contrib but I can't get it to work. It's the contrib with the custom build where you have to choose between intel and amd, but when you say "add to cart" it jumps to the build of an intel pc and it doesn't add the custom pc to the shopping cart.

Anybody who has an idee how to solve that, it would mean a great deal to me.

 

here is the link to my shop if you want to see what goes wrong: http://www.jbpc.be/build.php.

 

the site is in dutch, but the build page is still english/dutch so you should be able to test even if you aren't speaking dutch.

 

Greetz


Joost Billiet

Zaakvoerder JBPC

Share this post


Link to post
Share on other sites

Ok, people REALLY need to start readin this thread!

 

NO ONE has got this working properly without major change.

It is very buggy, mainly due to the different number of OSC versions as far as I can see.

 

So it is going to be very hard for someone to answer your question.

 

what this project needs if people want it to work is to sit down, break the code down and then rebuild it in order to make sure everyone knows what is where and how to make it work correctly with each snapshot of OSC.

 

It has been pointed out that one or two places have got it working, but look at them, motherboards.com have got it working, but they use OSC 2.1, so they no doubt spent a looooong time recreating this mod.

 

there is no quick fix to make it work is what I am basically saying, so you need to get a group of developers who need this mod to work together to make it work, or you need to pay someone yourself if your really in need of it.

 

I myself do not use this, and wont be either, but after playing with the code and modding it, I find that a lot of work needs to be done before this is gonna wrk bug free. IMHO - pay a programmer to do this for you if your desperate.

Share this post


Link to post
Share on other sites

check and see if your 22nd selection is set to required and hidden, because that will cause the error that is happening to your ccc. and cc are you not using it because you don't deal in computers or just don't like the contribution? because if not many people like it i am going to stop working on it and think of another contribution to make.

Share this post


Link to post
Share on other sites

yes as thick_as_mince said im aslo following ths contrib for quite a while now and indeed is one of the best out there

 

lets hope some more devs can help you to finish it :/

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×