Jump to content
Sign in to follow this  
sw45859

CUSTOM COMPUTER CREATOR 7 RELEASED

Recommended Posts

yep, it's out there, hopefully i got everything included in the zip file, if not please post here and let me know, also let me know of any suggestions of comments, without those then i wouldn't be able to make this great contribution because i wouldn't be able to think of something to do. HURRY AND GET IT IN THE CONTRIBUTIONS SECTION

Share this post


Link to post
Share on other sites

I seem to have no difference in the workings of this Stephen.

 

the build file is not looking to the database for the product categories, instead it is still relying on the english.php file.

 

CC.

Share this post


Link to post
Share on other sites

the build.php didn't change very much, the main changes are in the custom_computer.php java.php and custom_checkout.php.

Share this post


Link to post
Share on other sites

I took out the defines, but all that happened was the categories were not recognised.

So I set them in the admin section with no results.

 

Doesnt appear to work for me, so I have taken it off.

 

CC.

Share this post


Link to post
Share on other sites

hi ,steven

Congratulation for your good work on custom computer v7.0

 

here is my bug reports (i'm not found solution ) i'v already fixed some little.

 

BUG#5

when you forget to fill required field in ONLY AMD config and click "build" you redirect on a page with "error you have forget ....."

when you click "go-back" returning on build page , all forget filled fields are empty (no dropdown menu and nothing inside).

At this moment if you click "desactivate picture" you go back on a INTEL config (it seem to loose this $AMotherboard value).

THIS HAPPENE ONLY ON AN AMD CONFIG NOT WITH INTEL ????? strange because code seems to be correct.

 

BUG#6

 

when you forget to fill required field in AMD or INTEL config and click "build" you redirect on a page with "error you have forget ....."

when you click "go-back" returning on build page ,product that are forgotten to select are empty picture (not nosel.jpe) nothing are insisde

except the red cross (no image).

At this time if you click on any "enlarge picture" always the same pic are showing "motherboard picture"

 

Hope this can help

 

if someone solved these bugs please post here !!!

 

Keep up your good work steven :)

 

PrG-Matrix

Share this post


Link to post
Share on other sites

thank you VERY much prg-matrix for bringing that to my attention i have released a fix for those bugs, at least i think i got them all, you can get it in the contributions section. thank you again

Share this post


Link to post
Share on other sites

well its late, i forgot to fix the picture problem after the error with the red x in the pic, i'll fix that first thing in the mornin, so prolly hold off on downloading it until then

Share this post


Link to post
Share on other sites

hello,

 

i've got this message when i go to build.php page. I've read all the readme 3 times and i don't find any solution for this.

 

 

Warning: Failed opening 'member_shortcuts.php' for inclusion (include_path='.;c:php4pear') in c:appservwwwosccomcatalogbuild.php on line 443

 

i don't have any include rep so ????

config: Win XP pro + appserv 1.8

and there isn't any member_shortcut.php in any directory

so,

please help

 

pl_dtm


PL DTM

-----------------------------------------

Sur un malentendu, ... ?a pourrait marcher

Share this post


Link to post
Share on other sites

Take that bit out of the build.php page then.

 

It is probably a seperate piece of code that Stephen uses himself.

 

CC.

Share this post


Link to post
Share on other sites

Hi , good work stephen

 

picture probleme is solved , but it still buggy when you choose AMD and forget to fill required field , when come back , nothing inside dropdown list EXCEPT for motherboard and Processor.

 

For INTEL all is perfect (almost due to java limitation).

 

thx for this nice contribution ,

 

@+++

 

PrG-Matrix

 

Ps: you can test at http://www.progamers.d2g.com/osus/catalog/build.php

Share this post


Link to post
Share on other sites

prg i think in your case the language is the problem, in the custom_checkout find the line that begins with:

if( $HTTP_POST_VARS['motherboard'] == "AMotherboard" && $AMotherboard=="Please Select"

and put your default value in there, -- Choisissez -- in the place of please select

Share this post


Link to post
Share on other sites

Hi again stephen ,

sorry ignore my previous post :/

this is the stupid cache of easyPHP (local test). not considere the change of some modified files.

 

i cleaned the cache and all working fine now :))))

 

I'm happy

 

last thing to improve is the DB management ( i'll try to make an admin function to clean DB after 30 days for ex. if computer builded are not ordered).

 

great contribution stephen ,

 

Thx for all

 

PrG-Matrix

Share this post


Link to post
Share on other sites

thats a good idea i'll implement that in my next release. see thats the kind of things i want to know so i can make this computer creator the best it can be, if anyone else has any ideas feel free to post them.

Share this post


Link to post
Share on other sites

i'v noticed one little bug ,

if 1 or more of your product in a category dont have a model "products_model" then your dropdown list display the last record and not "please select"

 

:)

Share this post


Link to post
Share on other sites

I am installing 12/15/2002 - Custom_Computer_Creator_v7.zip (2.2-CVS) and I am getting the error listed below can anyone help Thanks

 

1146 - Table 'catalog.ccc' doesn't exist

 

select ccc_id as id, ccc_cname as name from ccc order by ccc_id

 

[TEP STOP]

Share this post


Link to post
Share on other sites

i just posted the new version that is linked above in the contributions section so the link above is no longer valid.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×