Jump to content
rigadin2

[Contribution] STS v4

Recommended Posts

If that's all it is, I'm going to kick myself!!! I use an installation that comes with Netfirms (www.netfirms.com) Could it be possible that they have some kind of corrupted installation? I am using a "clean" install there...and have never had that feature..... I'm going to get a copy or 2.2 and do a compare of the files side by side and see whats missing. DOH.... I have been trying to get this fixed for years...literally. Thanks. THANKS!

 

 

Well... Bad news... I just compared the entire install and there are no substantive differences between a clean version of osC 2.2 and the files I am using... I am at a loss.. Any ideas at all? I reloaded the index.php file from v2.2 just to be sure...and nothing changed. The english.php file is exactly the same except where I changed some wording. I used a program called "beyond compare" and I went file by file. There were some very minor things.... but nothing to eliminate that feature. :(

Share this post


Link to post
Share on other sites

Hi Guys,

 

I recently installed STS 4.1 on osCommerce. Everything works perfectly except the cart section. The whole layout of the cart page is scrambled. The quantity box is huge, whereas the product name column is very small. Plus the cart is larger than the standard table width size of my site. How do I fix that alignment and sizes of the columns?

 

Please see : http://www.origintechnologies.co.za/catalog. -->Select a product to buy and go to cart to see for yourself.

 

When I use the standard osCommerce page it displays perfectly so the error must be within STS. Where can I edit the Sizes of the columns?

 

Regards,

 

Edwin

Share this post


Link to post
Share on other sites

Hi there...

I thought I'd gotten past the 'newbe' stage and I'd be ready to stop asking studid questions, appears I was wrong :(

 

I've installed STS v4.0.7 and have it working correctly (I think). I've been playing around with designs, and have things displaying nicely.

 

My problem? $content is doing nothing at all. I have the category list on the side, all the other boxes, the logo up the top etc etc, I just don't have ANY content?! I know this is probably really simple, so please indulge me, what am I doing wrong? I thought I just have to display '$content', and the product info, or the main page or... etc will just show?

 

HELP!! THANKS :blush:

 

~Barbara~

Share this post


Link to post
Share on other sites
Hi there...

I thought I'd gotten past the 'newbe' stage and I'd be ready to stop asking studid questions, appears I was wrong :(

 

I've installed STS v4.0.7 and have it working correctly (I think). I've been playing around with designs, and have things displaying nicely.

 

My problem? $content is doing nothing at all. I have the category list on the side, all the other boxes, the logo up the top etc etc, I just don't have ANY content?! I know this is probably really simple, so please indulge me, what am I doing wrong? I thought I just have to display '$content', and the product info, or the main page or... etc will just show?

 

HELP!! THANKS :blush:

 

~Barbara~

:blush: :blush: :blush: Ignore my above post :)

I found a post that said said the $content tage grabs all the content between the left and right columsn.... Before I installed STS, I commented out the righthand column, I didn't want it displaying. Cos it was commented out, the $content tag was grabbing nothing. All fixed now :)

Share this post


Link to post
Share on other sites

Hi,

 

I just installed the STS4.1 for the first time, quite an easy installation process, but after installing and trying to open the page, the header appeared twice.

Could anyone tell me what did I do wrong and how to fix it? Thanks so much.

Share this post


Link to post
Share on other sites

Hellous...

 

I am trying to have the column controller working with STS v4. I actually manage to make it work, but... (of course) I hit a wall. For example, when I disable the category box on the left column, I get the "$categorybox" written there... >_<

 

Is there a way to fix the code to prevent the disabled boxes to be substituted by their variables? :(

 

Thanks for any help! :wub:

Share this post


Link to post
Share on other sites
Take a look at one of my stores and you will see the "text" catalog title on each page. Hat Over Heels. Select the "Hatalog" and it will take you to the store.

 

It appears you may have deleted a line from your index.php file or english.php file that displays the catagory title along with the catagory image. OsCommerce 2.2 displays both by default.

 

Hope this helps,

 

Bill Kellum

 

Bill. I uninstalled the entire store and reinstalled a clean downloaded version of osCommerce 2.2 and still... NO Category names onthe category pages?

 

I have reverted to my installation since the client is looking at it...but thats strange huh. Are you surre you arent using some kind of modification you forgot about?

Share this post


Link to post
Share on other sites

Installed it and working fine EXCEPT the popup window of the big product images doesn't appear - and it is not a problem of a popup blocker - tired it on several computers.

 

When I switch back to the regular os layout it works again...

 

I know this has been a problem in previous versions of STS 4.1 but what can it be now?

 

This is the only bug I have - so far....

Edited by badboo

Share this post


Link to post
Share on other sites
Hellous...

 

I am trying to have the column controller working with STS v4. I actually manage to make it work, but... (of course) I hit a wall. For example, when I disable the category box on the left column, I get the "$categorybox" written there... >_<

 

Is there a way to fix the code to prevent the disabled boxes to be substituted by their variables? :(

 

Thanks for any help! :wub:

 

If by disabling the category box on the left colum u mean commenting/removing code in column_left.php, then thats not the soln. You should only work on the html template, if u want to remove a box, u simply remove the variable ;)

Share this post


Link to post
Share on other sites
Bill. I uninstalled the entire store and reinstalled a clean downloaded version of osCommerce 2.2 and still... NO Category names onthe category pages?

 

I have reverted to my installation since the client is looking at it...but thats strange huh. Are you surre you arent using some kind of modification you forgot about?

Niel,

 

I tried to get this response back to you right away but the forums were down for several hours...

 

 

 

I'm sorry about leading you down the wrong path regarding your catagory names being listed at the top of each page. I forgot that I had hacked some code to get it to dynamically display the catagory name instead of the canned "Let's see what we have here" language. I kept poking my head back into the forums last night hoping for an opportunity to give you the correct information. I feel badly about it.

 

 

TO THE STS COMMUNITY: I know this doesn't really apply to STS directly, but I'm posting it anyway since most of the STS users are not familiar with PHP and I feel that fellow STS'ers could benefit from this little hack that works nicely along with the STS template theory.

 

 

 

To get rid of "Let's See What We Have Here" for your Categories and Sub-Categories, you can replace them with the name of the categories or subcategories name.

 

 

 

Here is how I hacked the OsCommerce code to do it:

 

 

 

Open the following file in a text editor:

/yourstore/index.php

 

 

 

Do a search for the following line of code:

<?php echo HEADING_TITLE; ?>

 

 

 

You will find three instances of each. Do the following:

 

 

 

To see the name of your CATAGORIES instead of "let's see what we have here" text,

 

just replace the first instance of the code:

<?php echo HEADING_TITLE; ?>

 

with the following:

 

<?php echo $category['categories_name'] ?>

 

 

To also have SUBCATEGORIES displayed dynamically as the CATAGORIES above, just replace the second instance of the code:

<?php echo HEADING_TITLE; ?>

 

with the following:

 

<?php 
 $category_query1 = tep_db_query("select cd.categories_name, c.categories_image from " . TABLE_CATEGORIES . " c, " . TABLE_CATEGORIES_DESCRIPTION . " cd where c.categories_id = '" . (int)$current_category_id . "' and cd.categories_id = '" . (int)$current_category_id . "' and cd.language_id = '" . (int)$languages_id . "'");
  $category1 = tep_db_fetch_array($category_query1);

if ($category1['categories_name'] != "") {echo $category1['categories_name'];} else { echo HEADING_TITLE;} 
?>

 

 

The third

<?php echo HEADING_TITLE; ?>

should be left alone so you do not need to modify it at all.

 

 

 

Don't forget to save your document as the same name as the original index.php. That's all there is to it.

If this is too daunting, or if you run into problems, let me know. Since I haven't useed this hack in a long time, I ran it on a test store and everything worked perfectly. :thumbsup:

 

 

Good luck,

Bill Kellum


Bill Kellum

 

Sounds Good Productions

STS Tutorials & more: STSv4.6, STS Add-ons (STS Power Pack), STS V4 Forum STS Forum FREE TEMPLATE

Share this post


Link to post
Share on other sites
Hi,

 

I just installed the STS4.1 for the first time, quite an easy installation process, but after installing and trying to open the page, the header appeared twice.

Could anyone tell me what did I do wrong and how to fix it? Thanks so much.

Rhoda,

 

To install it correctly, You will only need to download and install this and then this. :thumbsup:

 

The STS v4.1 by rigadin as well as the Index module v1.0.3 for STS4.

 

The two files between these two contributions have been known to cause problems such as double headers and php errors. ;)

 

Hope this helps,

 

Bill Kellum


Bill Kellum

 

Sounds Good Productions

STS Tutorials & more: STSv4.6, STS Add-ons (STS Power Pack), STS V4 Forum STS Forum FREE TEMPLATE

Share this post


Link to post
Share on other sites
Hellous...

 

I am trying to have the column controller working with STS v4. I actually manage to make it work, but... (of course) I hit a wall. For example, when I disable the category box on the left column, I get the "$categorybox" written there... >_<

 

Is there a way to fix the code to prevent the disabled boxes to be substituted by their variables? :(

 

Thanks for any help! :wub:

Alessandra, Why not just remove the tags? STS gives you the power to move the boxes anywhere you want them, and if you don't want them, just don't add the tag for that particular box.

 

 

 

Hope this helps,

 

Bill Kellum


Bill Kellum

 

Sounds Good Productions

STS Tutorials & more: STSv4.6, STS Add-ons (STS Power Pack), STS V4 Forum STS Forum FREE TEMPLATE

Share this post


Link to post
Share on other sites
Installed it and working fine EXCEPT the popup window of the big product images doesn't appear - and it is not a problem of a popup blocker - tired it on several computers.

 

When I switch back to the regular os layout it works again...

 

I know this has been a problem in previous versions of STS 4.1 but what can it be now?

 

This is the only bug I have - so far....

Did you forget to add the <!--$headcontent--> at the top of your html template page? This tag goes in the <head> of your template. It contains the charset of the page, meta tags, base href and javascript taken out of header.php. If you have this in the <head> section of your template and you are still having problems, take a look at your javascipt in the header.php page.

 

 

 

Hope this helps,

 

 

 

Bill Kellum


Bill Kellum

 

Sounds Good Productions

STS Tutorials & more: STSv4.6, STS Add-ons (STS Power Pack), STS V4 Forum STS Forum FREE TEMPLATE

Share this post


Link to post
Share on other sites
I'm trying to center and create a fixed width page. I used the Fixed Width Site with CSS contribute, and it works great, but not with STS. How can I get my site to be fixed-width and centered? Thanks in advance.
You can use standard HTML tags to get your desired result. I caution you though...the size of a browser is a personal thing for most "buyers" and you might lose a bunch of sales by resizing the width of their browsers.

 

 

 

To set a fixed width, I prefer to use tables in HTML. You can then set the attributes of the table such as size and justification. STS is an HTML template so all HTML rules apply. Have fun!

 

-Bill Kellum


Bill Kellum

 

Sounds Good Productions

STS Tutorials & more: STSv4.6, STS Add-ons (STS Power Pack), STS V4 Forum STS Forum FREE TEMPLATE

Share this post


Link to post
Share on other sites
Niel,

 

I tried to get this response back to you right away but the forums were down for several hours...

 

 

 

I'm sorry about leading you down the wrong path regarding your catagory names being listed at the top of each page. I forgot that I had hacked some code to get it to dynamically display the catagory name instead of the canned "Let's see what we have here" language. I kept poking my head back into the forums last night hoping for an opportunity to give you the correct information. I feel badly about it.

TO THE STS COMMUNITY: I know this doesn't really apply to STS directly, but I'm posting it anyway since most of the STS users are not familiar with PHP and I feel that fellow STS'ers could benefit from this little hack that works nicely along with the STS template theory.

 

 

 

To get rid of "Let's See What We Have Here" for your Categories and Sub-Categories, you can replace them with the name of the categories or subcategories name.

 

 

 

Here is how I hacked the OsCommerce code to do it:

 

 

 

Open the following file in a text editor:

/yourstore/index.php

 

 

 

Do a search for the following line of code:

<?php echo HEADING_TITLE; ?>

 

 

 

You will find three instances of each. Do the following:

 

 

 

To see the name of your CATAGORIES instead of "let's see what we have here" text,

 

just replace the first instance of the code:

<?php echo HEADING_TITLE; ?>

 

with the following:

 

<?php echo $category['categories_name'] ?>

To also have SUBCATEGORIES displayed dynamically as the CATAGORIES above, just replace the second instance of the code:

<?php echo HEADING_TITLE; ?>

 

with the following:

 

<?php 
 $category_query1 = tep_db_query("select cd.categories_name, c.categories_image from " . TABLE_CATEGORIES . " c, " . TABLE_CATEGORIES_DESCRIPTION . " cd where c.categories_id = '" . (int)$current_category_id . "' and cd.categories_id = '" . (int)$current_category_id . "' and cd.language_id = '" . (int)$languages_id . "'");
  $category1 = tep_db_fetch_array($category_query1);

if ($category1['categories_name'] != "") {echo $category1['categories_name'];} else { echo HEADING_TITLE;} 
?>

The third

<?php echo HEADING_TITLE; ?>

should be left alone so you do not need to modify it at all.

 

 

 

Don't forget to save your document as the same name as the original index.php. That's all there is to it.

If this is too daunting, or if you run into problems, let me know. Since I haven't useed this hack in a long time, I ran it on a test store and everything worked perfectly. :thumbsup:

Good luck,

Bill Kellum

 

Bill,

You are the MAN. I actually think I did this once, because I have one of the first osCommerce stores I did and it does have this like this...but I couldnt find it or remember how I did it. this is a MUST add on for everyone. I actually cant believe it doesnt come standard like this.... but anyway... I do appreciate your help. I owe you one ;)

Share this post


Link to post
Share on other sites
Bill,

You are the MAN. I actually think I did this once, because I have one of the first osCommerce stores I did and it does have this like this...but I couldnt find it or remember how I did it. this is a MUST add on for everyone. I actually cant believe it doesnt come standard like this.... but anyway... I do appreciate your help. I owe you one ;)

 

Worked perfectly! I cant believe I couldnt find this anywhere else. Hope fully others can find and use this. I cant imagine building a store without this as a feature. Thank you, thank you, thank you.

Share this post


Link to post
Share on other sites
Worked perfectly! I cant believe I couldnt find this anywhere else. Hope fully others can find and use this. I cant imagine building a store without this as a feature. Thank you, thank you, thank you.
I agree with this hack being a must.

 

Sorry my help came so late.... I missed the point of your question at first. My bad. Glad it all worked out though.

 

-Bill Kellum

Edited by bkellum

Bill Kellum

 

Sounds Good Productions

STS Tutorials & more: STSv4.6, STS Add-ons (STS Power Pack), STS V4 Forum STS Forum FREE TEMPLATE

Share this post


Link to post
Share on other sites

Has anyone provide any help on linking Article Manager into STS?

 

I added:

   $sts->start_capture();
  require(DIR_WS_BOXES . 'articles.php');
 $sts->stop_capture('articles.php', 'box');

 

Into sts_user_code.php

 

But once it was called in the template, got the error:

 

Fatal error: Cannot redeclare tep_show_topic() (previously declared in /home/mysite.com/htdocs/catalog/includes/boxes/articles.php:13) in /home/mysite.com/htdocs/catalog/includes/boxes/articles.php on line 13

 

Anyone managed to link Article Manager successfully?

Share this post


Link to post
Share on other sites
I agree with this hack being a must.

 

Sorry my help came so late.... I missed the point of your question at first. My bad. Glad it all worked out though.

 

-Bill Kellum

 

Well, not to push my luck - but the other thing I have been trying to find is a way to do is to have products that run out of stock NOT show up in the store anymore. Is that something easy to do? I looked at a couple of wildly complicated add-ons that dont really actually do that...but sort of. Again... this seems like something that everyone would want? At least all my client have wanted it...but I cant figure it out. Is it easily doable?

 

I feel like I already got 1 of my 3 wishes....so I'm trying to make it a good one...LOL

Share this post


Link to post
Share on other sites

Hi all,

 

Hate to say it, but im having the same problem as many other users. STS & Worldpay Callback not completing the order within my store.

I have spent many hours (far too many hours to honestly own up to!) searching and trying many of the solutions spread out across the forum, with no success.

 

I have a clean install of latest OSC, with STS v4.1 and Worldpay 4.0 - v1.8, not using SSL. The callback works fine when I turn STS system off, all orders are processed correctly. But when STS its switched on, Worldpay processes the payment, sends confirmation emails, and when it tries to send me back to the store to confirm the successful order, it seems to take me back to the sts template and the order isn't processed in the admin and the items stay in the cart. :huh:

 

 

This post is my last hope, if anyone has a successful solution to this problem, please...please can you let me know. Any help would be appreciated. :thumbsup:

 

 

Many thanks in advance

 

 

 

Lee

Share this post


Link to post
Share on other sites

:'(

Rhoda,

 

To install it correctly, You will only need to download and install this and then this. :thumbsup:

 

The STS v4.1 by rigadin as well as the Index module v1.0.3 for STS4.

 

The two files between these two contributions have been known to cause problems such as double headers and php errors. ;)

 

Hope this helps,

 

Bill Kellum

 

 

Bill,

 

Thanks a lot for answering my question. I tried to update the files, the double header was gone. However, the "Categories box" replaced the position of the old header if I set "Use Templat?" to false. That is, if I set "Use Template?" to false, the Categories box goes the top, if I set "Use Template?" to true I still have the double header. Any clues for why? :'( :'( :'( HELP!!!!! Thanks a lot! :thumbsup:

Share this post


Link to post
Share on other sites
:'(

 

 

Bill,

 

Thanks a lot for answering my question. I tried to update the files, the double header was gone. However, the "Categories box" replaced the position of the old header if I set "Use Templat?" to false. That is, if I set "Use Template?" to false, the Categories box goes the top, if I set "Use Template?" to true I still have the double header. Any clues for why? :'( :'( :'( HELP!!!!! Thanks a lot! :thumbsup:

Rhoda, did you get rid of the other two contributions from the STS Contributions page that were causing the double header issue? Like I mentioned earlier, those two contributions are known to cause the double header problem.

 

Bill Kellum

Edited by bkellum

Bill Kellum

 

Sounds Good Productions

STS Tutorials & more: STSv4.6, STS Add-ons (STS Power Pack), STS V4 Forum STS Forum FREE TEMPLATE

Share this post


Link to post
Share on other sites
Rhoda, did you get rid of the other two contributions from the STS Contributions page that were causing the double header issue? Like I mentioned earlier, those two contributions are known to cause the double header problem.

 

Bill Kellum

 

 

Bill,

 

Thanks a lot for your help. I finally got it right. :D :D Thanks again for your help :D :thumbsup:

Share this post


Link to post
Share on other sites

Hi,

I am trying to add a background image to the whole website using STS, but it seems not that simple to add a background image. Even a normal image I can't add, and changing colour of the text doesn't work. Is it ment to be simple like HTML/CSS?

Share this post


Link to post
Share on other sites
Alessandra, Why not just remove the tags? STS gives you the power to move the boxes anywhere you want them, and if you don't want them, just don't add the tag for that particular box.

 

I build website for others, that's why I wanted them to have a way of changing the infobox without having me going thru the code... :blush: Can't a code be created, like, if there is no box, show no code? :-" That would be way too good...

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×