Jump to content
rigadin2

[Contribution] STS v4

Recommended Posts

I have successfully installed STS v4.5.2 and am changing the design using css and standard html but when I view the store, I am not seeing any images, just the text.

 

Does anyone know what may be causing this?

 

Thanks

Share this post


Link to post
Share on other sites
I have successfully installed STS v4.5.2 and am changing the design using css and standard html but when I view the store, I am not seeing any images, just the text.

 

Does anyone know what may be causing this?

 

Thanks

Are the stock osC images showing, just the images that you added in your template giving you problems? If so, then it is a matter of setting the correct image path in your img src HTML tag within your template.

Bill Kellum

 

Sounds Good Productions

STS Tutorials & more: STSv4.6, STS Add-ons (STS Power Pack), STS V4 Forum STS Forum FREE TEMPLATE

Share this post


Link to post
Share on other sites

Sorry if this has been asked before, but I have been unable to find the answer in this (incredibly long :)) thread.

 

I know how to make a new template for each category, but how do I make a template for all categories and subcategories? The index.php_###.html works, but I'd rather not have to create another template every time a category gets added, even though it would just mean saving one of the existing ones under a new name. Seems inefficient and I don't want the phone to ring every time the customer adds something new.

 

Also, does this play well with any SEO friendly URL tools? Has anyone pointed the menus at the friendly URL, so the link has the keywords in it, using the templating system?

 

This is an incredibly cool and useful add-on. I was looking at probably 100's of hours of coding before I found this, and now I might be done by Tuesday :) Thanks for providing it for us.

 

Matt

Share this post


Link to post
Share on other sites
Sorry if this has been asked before, but I have been unable to find the answer in this (incredibly long :) ) thread.

 

I know how to make a new template for each category, but how do I make a template for all categories and subcategories? The index.php_###.html works, but I'd rather not have to create another template every time a category gets added, even though it would just mean saving one of the existing ones under a new name. Seems inefficient and I don't want the phone to ring every time the customer adds something new.

 

Also, does this play well with any SEO friendly URL tools? Has anyone pointed the menus at the friendly URL, so the link has the keywords in it, using the templating system?

 

This is an incredibly cool and useful add-on. I was looking at probably 100's of hours of coding before I found this, and now I might be done by Tuesday :) Thanks for providing it for us.

 

Matt

Matt, the STS User Manual (included with the contribution) details how the template process works by use of flow charts.

 

To make a template that would be used for any category that you didn't make a custom template for, you should use the filename "index.php.html", just as "product_info.php.html" is the template that would be used for all products that did not have a custom template. As the flow chart points out, if there is no specific template, no index.php.html or product_info.php.html, then the default template would be used.

 

STS out of the box has "sts_template.html" as the default template but this can be changed via the admin module.

Note: "index.php_0.html" is reserved for the home page template (use is optional).


Bill Kellum

 

Sounds Good Productions

STS Tutorials & more: STSv4.6, STS Add-ons (STS Power Pack), STS V4 Forum STS Forum FREE TEMPLATE

Share this post


Link to post
Share on other sites
Matt, the STS User Manual (included with the contribution) details how the template process works by use of flow charts.

 

To make a template that would be used for any category that you didn't make a custom template for, you should use the filename "index.php.html", just as "product_info.php.html" is the template that would be used for all products that did not have a custom template. As the flow chart points out, if there is no specific template, no index.php.html or product_info.php.html, then the default template would be used.

 

STS out of the box has "sts_template.html" as the default template but this can be changed via the admin module.

Note: "index.php_0.html" is reserved for the home page template (use is optional).

 

 

Perfect! Thanks.

Share this post


Link to post
Share on other sites

If you get this error:

 

Fatal error: Call to a member function on a non-object in /home/***/***/***/includes/classes/sts.php on line 185

 

Check your installation of STS, file includes/application_top.php .

 

This error does not show up all the time, only when some message is to be displayed at the top of the page.

 

- Chris


STS v4.5 SP5 is out, and check the STS Power Pack contribution too!

New thumbnailer using phpThumb: oscThumb. Works great.

Share this post


Link to post
Share on other sites

Matt,

 

I am using Ultimate SEO URL's by Chemo. They work just fine with STS ;) It automatically changes the URL so you don't need to change any of your menu's - the .htaccess file does it for you.

 

Hope that helps ;)

 

Sorry if this has been asked before, but I have been unable to find the answer in this (incredibly long :)) thread.

 

I know how to make a new template for each category, but how do I make a template for all categories and subcategories? The index.php_###.html works, but I'd rather not have to create another template every time a category gets added, even though it would just mean saving one of the existing ones under a new name. Seems inefficient and I don't want the phone to ring every time the customer adds something new.

 

Also, does this play well with any SEO friendly URL tools? Has anyone pointed the menus at the friendly URL, so the link has the keywords in it, using the templating system?

 

This is an incredibly cool and useful add-on. I was looking at probably 100's of hours of coding before I found this, and now I might be done by Tuesday :) Thanks for providing it for us.

 

Matt


~Tracy
 

Share this post


Link to post
Share on other sites

Article Manager Integration & STS 4.3

 

I was wondering if someone could point me to, or offer up some step by step instructions to getting article manager working with STS 4.3

 

I did a keyword search in the forums but was not able to find instructions on this.

Share this post


Link to post
Share on other sites

I don't think there is much to do to integrate Article Manager, only have to create a placeholder for the infoboxes, then use them on your template. Placeholders can be created in includes/modules/sts_inc/sts_user_code.php, there is an example in the file.

 

- Chris


STS v4.5 SP5 is out, and check the STS Power Pack contribution too!

New thumbnailer using phpThumb: oscThumb. Works great.

Share this post


Link to post
Share on other sites

1.) Do you customize the content, in [path to catalog]/includes/languages/english/index.php still?

 

 

 

2.) Do I use the stylesheet to customize just about anything on the index page of the cart or do will I need to go into the PHP ?

for instance to replace the infobox header bg w/ an image.. i can do that w/ the css right?

if any of you could llet me know which PHP files will probably need modified for customizing the interface, i would appreciate it

 

 

 

3.) Setting a fixed width for the body, is this advisable?

 

4.) changing the columns and all that , do i follow the knowledge base or is it different w/ the STS?

 

i guess i needd to know which files and modifications can the STS not do for me... any help

 

lata

 

kc

 

 

 

 

 

 

 

and ...

Share this post


Link to post
Share on other sites

also... where the heck do u color customize the infobox border .... i looked over the css for a hour looking for it... do i need ot access php file for that?

 

for the STS .. are u suppose to be modifying the sts_template.html? b/c that didn't work, ive been using the index.php.html is this correct or no?

Edited by kade119

Share this post


Link to post
Share on other sites

sorry to ask much, need to learn everything asap, for the different infobox headers, do those need to be changed more than just the english.php file?

Share this post


Link to post
Share on other sites

>_< That's me! I have installed, reinstalled, searched the forums ad nauseum for the last 2 nights trying to get STS to work. First I used 4.5. Then I thought maybe I should try 4.4. No matter what I do (including the infamous "refresh" bug) has gotten STS to show up in my modules list on the admin screen, even though I very clearly see if on the ftp server.

 

Can someone please help? I've even got my template all created, I just can't get it to turn on!

Share this post


Link to post
Share on other sites
I don't think there is much to do to integrate Article Manager, only have to create a placeholder for the infoboxes, then use them on your template. Placeholders can be created in includes/modules/sts_inc/sts_user_code.php, there is an example in the file.

 

- Chris

 

 

Chris - I have read the documentation, and looked at the example in the sts_user_code.php and I am just lost on what to do.

 

I added this to the sts_user_code.php"

   $sts->start_capture();
  require(DIR_WS_BOXES . 'articles.php');
  $sts->stop_capture('articles', 'box');

 

And in the column_right.php I have:

 

  // Article Manager
 require(DIR_WS_BOXES . 'authors.php');
 require(DIR_WS_BOXES . 'articles.php');

 

But it is not working and I am sure I am doing or missing something.

Share this post


Link to post
Share on other sites
Chris - I have read the documentation, and looked at the example in the sts_user_code.php and I am just lost on what to do.

 

I added this to the sts_user_code.php"

   $sts->start_capture();
  require(DIR_WS_BOXES . 'articles.php');
  $sts->stop_capture('articles', 'box');

 

And in the column_right.php I have:

 

  // Article Manager
 require(DIR_WS_BOXES . 'authors.php');
 require(DIR_WS_BOXES . 'articles.php');

 

But it is not working and I am sure I am doing or missing something.

 

Don't add the boxes in column_right.php, this file is not processed when STS is enabled. You have correctly prepare the placeholder in sts_user_code.php, now you can place $articles on your template, where you want.

 

- Chris


STS v4.5 SP5 is out, and check the STS Power Pack contribution too!

New thumbnailer using phpThumb: oscThumb. Works great.

Share this post


Link to post
Share on other sites
Don't add the boxes in column_right.php, this file is not processed when STS is enabled. You have correctly prepare the placeholder in sts_user_code.php, now you can place $articles on your template, where you want.

 

- Chris

 

I placed the $articles on the template, And when I click all articles I get the page. However when I click new articles I get:

Fatal error: Call to undefined function clean_html_comments() in /home/chineseh/public_html/includes/article_header_tags.php on line 134

 

 

http://www.chineseherbs.net/articles_new.html

Share this post


Link to post
Share on other sites

The $content is captured by STS during the processing of the page. If you want to modify the content of index.php, you have to modify index.php.

 

- Chris


STS v4.5 SP5 is out, and check the STS Power Pack contribution too!

New thumbnailer using phpThumb: oscThumb. Works great.

Share this post


Link to post
Share on other sites

Using STS 4.5

 

I am trying to change the index.php.html page so that it shows up only as the main page of the site, but when I change that file, the changes are showing throughout the site and not just on the main page. When I change the sts_template.html or default template, those changes only show up on certain pages, like the account page and shopping cart.

 

My question is, how do I get every page but the main page to show the changes on sts_template.html?

 

Thanks again for your help.

Share this post


Link to post
Share on other sites

I am having a problem using the Search feature when I have STS implemented. Works fine when not using my templates. When entering keywords into the search box, I get this error:

 

1064 - You have an error in your SQL syntax near 'distinct p.products_id) as total from products p left join manufacturers m usin' at line 1

 

select count(distinct p.products_id) as total from products p left join manufacturers m using(manufacturers_id), products_description pd left join specials s on p.products_id = s.products_id, categories c, products_to_categories p2c where p.products_status = '1' and p.products_id = pd.products_id and pd.language_id = '1' and p.products_id = p2c.products_id and p2c.categories_id = c.categories_id and ((pd.products_name like '%pendant%' or p.products_model like '%pendant%' or m.manufacturers_name like '%pendant%') )

 

[TEP STOP]

 

 

Any idea why this is happening or what the fix would be?

 

Thanks

Share this post


Link to post
Share on other sites
Using STS 4.5

 

I am trying to change the index.php.html page so that it shows up only as the main page of the site, but when I change that file, the changes are showing throughout the site and not just on the main page. When I change the sts_template.html or default template, those changes only show up on certain pages, like the account page and shopping cart.

 

My question is, how do I get every page but the main page to show the changes on sts_template.html?

 

Thanks again for your help.

Use index.php_0.html as your home page.

Bill Kellum

 

Sounds Good Productions

STS Tutorials & more: STSv4.6, STS Add-ons (STS Power Pack), STS V4 Forum STS Forum FREE TEMPLATE

Share this post


Link to post
Share on other sites
>_< That's me! I have installed, reinstalled, searched the forums ad nauseum for the last 2 nights trying to get STS to work. First I used 4.5. Then I thought maybe I should try 4.4. No matter what I do (including the infamous "refresh" bug) has gotten STS to show up in my modules list on the admin screen, even though I very clearly see if on the ftp server.

 

Can someone please help? I've even got my template all created, I just can't get it to turn on!

Jennifer, everyone who has experienced the issues that you are now encountering was related to either an incomplete or errant installation. You are missing some files in specific folders. Re-check how you are installing the STS files paying close attention to where you are uploading them to your server.


Bill Kellum

 

Sounds Good Productions

STS Tutorials & more: STSv4.6, STS Add-ons (STS Power Pack), STS V4 Forum STS Forum FREE TEMPLATE

Share this post


Link to post
Share on other sites
also... where the heck do u color customize the infobox border .... i looked over the css for a hour looking for it... do i need ot access php file for that?

You missed it in the CSS file. For an explaination of each CSS class in the stylesheet.css file, look here.


Bill Kellum

 

Sounds Good Productions

STS Tutorials & more: STSv4.6, STS Add-ons (STS Power Pack), STS V4 Forum STS Forum FREE TEMPLATE

Share this post


Link to post
Share on other sites
sorry to ask much, need to learn everything asap, for the different infobox headers, do those need to be changed more than just the english.php file?

There are different ways of doing this. In STS v4.5.2, you can just use the infobox templates to edit the individual headers. Look in the STS User Manual regarding the infobox templates.


Bill Kellum

 

Sounds Good Productions

STS Tutorials & more: STSv4.6, STS Add-ons (STS Power Pack), STS V4 Forum STS Forum FREE TEMPLATE

Share this post


Link to post
Share on other sites

Quick STS and HTC question

 

But first: Thank you. Especially you Bill, who convinced me to go this STS road. It's been a lot easier than playing with .php code.

 

To the question: Hello All,

 

I have STSv4.5 and I'd like to add HTC. What is the best way of doing this:

 

A: Uninstalling STS and then installing the bundle?

 

--OR--

 

B: Adding HTC?

 

If you say B, what is the best way of doing this? Are there particular instructions for STS users to add HTC?

 

Thank you in advance!

 

Best,

 

Chris

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×