Jump to content
rigadin2

[Contribution] STS v4

Recommended Posts

@Rigadin

 

your tipp works.

 

but if i use this code on the top of my template pages

<?php DEFINE ('STS_END_CHAR', '#'); ?>

 

the included .js files wont work.

 

 

how i can solve this ?

 

 

bg

Michael

Edited by mfg

Share this post


Link to post
Share on other sites

Have you add a # at the end of all your placeholders? Also to $headcontent ? Don't do it to $headcontent, and don't do it $extracss (if you use it, optional). It will work.

 

- Rigadin

Edited by rigadin2

STS v4.5 SP5 is out, and check the STS Power Pack contribution too!

New thumbnailer using phpThumb: oscThumb. Works great.

Share this post


Link to post
Share on other sites

Hi, I really like this contribution so far, it seems like my site is going to look a lot better now that I can use this. My only problem is that when I use the $content, nothing show up. It is just blank where that tag is. The menus and everything else shows up great, I just can't get the content to show up. Did I miss something, or is there a bug. Thanks for your time and help!!! :)

Share this post


Link to post
Share on other sites

+++STS , category $content template, different content template for deffierent categories Options+++

 

Dear friends ,

I'm using STS for templating my shop ... I should say it's great .

but I wanna know how to template the $content for different categories !

for example I chaged the layout for "index.php_1_9.html" and "index.php_1_24.html" , but I want to have different $content layout for these categories ...

how should I manage this !?

 

thanks in advanced for your kind help

regards

MajiD Fatemian

Share this post


Link to post
Share on other sites
Use the $cartlogo variable. If you are using a "custom" image for "My Cart", be sure to save it as images/header_cart.gif so that the $cartlogo will pull up the correct image. Another option would be to create your custom image and link it to your shopping_cart.php file.

 

Hope this helped,

 

Bill Kellum

 

What if that is not possible say in the sitemap contribution. Rather then having a simple text "Site Map" created by the contribution i want an image linked to the site map contribution.

 

I understand i can make more $ modules in STS. I am going to make one for sitemap. But this is an example also. Basically for just any link is it possible to have an image linked to a "$" command?

Share this post


Link to post
Share on other sites
+++STS , category $content template, different content template for deffierent categories Options+++

 

Dear friends ,

I'm using STS for templating my shop ... I should say it's great .

but I wanna know how to template the $content for different categories !

for example I chaged the layout for "index.php_1_9.html" and "index.php_1_24.html" , but I want to have different $content layout for these categories ...

how should I manage this !?

 

thanks in advanced for your kind help

regards

MajiD Fatemian

 

The $content of index.php is coming from index.php itself, STS does not modify it. If you want to change the look of this page, you have to change the php code.


STS v4.5 SP5 is out, and check the STS Power Pack contribution too!

New thumbnailer using phpThumb: oscThumb. Works great.

Share this post


Link to post
Share on other sites

hi,

 

after installing in my test-shop

i got this error messages

 

Template file does not exist: [includes/sts_templates/mysite/sts_template.php]

 

or

 

Template file does not exist: [includes/sts_templates/mysite/sts_template.php]

Warning: Cannot modify header information - headers already sent by (output started at I:\www.test-sc4y.de\includes\classes\sts.php:158) in I:\www.test-sc4y.de\includes\functions\general.php on line 29

 

i have activated all in modules.php

also i have tried to change the template path

 

at the moment only the index and categories display the templates.

 

 

what must i change ?

 

bg

Michael

Share this post


Link to post
Share on other sites

sorry,

i have made a install mistake.

 

it works great.

 

bg

Michael

Share this post


Link to post
Share on other sites

I have spent the longest time trying to get HTC and STS to play nice - and I keep coming back to a similar problem.

 

I've got the header information for the main and category pages coming from the templates, not from header tags controller - tis good. The problem with this is that header info for every product page in my catalog is blank - it is not retrieving them from the database.

 

If you'd like to look at my live store, its at http://www.goodkarmaflags.com

 

thank you kindly

Share this post


Link to post
Share on other sites
Hi, I really like this contribution so far, it seems like my site is going to look a lot better now that I can use this. My only problem is that when I use the $content, nothing show up. It is just blank where that tag is. The menus and everything else shows up great, I just can't get the content to show up. Did I miss something, or is there a bug. Thanks for your time and help!!! :)

 

I have fixed the above problem. I had deleted the right column and It will now work without that.

Share this post


Link to post
Share on other sites

I feel stupid just asking this question:

 

I installed STS 4.1 with the 2 updates on a fresh OSC, and I'm getting nothing on the Admin-Modules screen. That is to say, there is no STS sub-category under Modules.

 

I followed the instructions provided in the contribution but it's not happening. Help!

Share this post


Link to post
Share on other sites
I feel stupid just asking this question:

 

I installed STS 4.1 with the 2 updates on a fresh OSC, and I'm getting nothing on the Admin-Modules screen. That is to say, there is no STS sub-category under Modules.

 

I followed the instructions provided in the contribution but it's not happening. Help!

 

Never mind. I figured it out.

Share this post


Link to post
Share on other sites

I believe that you miss something in your install.

 

Have you made this correctly:

 

- admin/includes/boxes/modules.php:

find:

'<a href="' . tep_href_link(FILENAME_MODULES, 'set=payment', 'NONSSL') . '" class="menuBoxContentLink">' . BOX_MODULES_PAYMENT . '</a><br>' .

add after:

// START STS 4.1

'<a href="' . tep_href_link(FILENAME_MODULES, 'set=sts', 'NONSSL') . '" class="menuBoxContentLink">' . BOX_MODULES_STS . '</a><br>' .

// END STS 4.1

 

Edit: Sorry, did not see that you found the solution, so this reply is not needed but I can't delete it.

Rigadin

Edited by rigadin2

STS v4.5 SP5 is out, and check the STS Power Pack contribution too!

New thumbnailer using phpThumb: oscThumb. Works great.

Share this post


Link to post
Share on other sites

Thank you 4 a wonderful module!!!

This module is solves the problem that I had, and a wonderful item.

 

After it introduces it, it is annoyed by the symptom to which the header is

doubly displayed though I want you to teach.

 

Are not you about this symptom per mind?

The symptom doesn't change though it installed many times.

I want everyone's advice. >_<

Share this post


Link to post
Share on other sites
Greetings fellow STSers - (I recently posted the following in the old STS plus forum an then read about this new forum - so here it is)

 

I've sucessfully utilitized pretty much all of the template features in STS plus, including the recent addition for handling product_info templates specific to given category - works great by the way - thanks Rigadin.

 

However, I can not create a unique template specific to index.php (site home page). This does not seem to be a feature of STS or STS plus or have I missed something obvious here?

 

In my attempts, I have manually edited the index.php code to include a separate(non-template) html file that displays only for the home page. But with STS active my html file occurs at the $content# placeholder along with the rest of the default template and I don't want the template, just the content(separate html file).

 

If I could suppress STS only for index.php(home) display my prayers would be answered.... or does anybody have other strategies that I might employ here?

 

thxs

 

I am having this exact same problem as Hunabku. I have just spent 4 hrs with no success trying to do something that seems like it should be simple. All I want is for my home page to have its own template and then all other pages default to the "sts_template.html"

How can I define a template which is specific to only the site's home page (index.php) ?

Someone please help me I'm pulling my hair out over this...

Edited by hayesb2

Share this post


Link to post
Share on other sites
Thank you 4 a wonderful module!!!

This module is solves the problem that I had, and a wonderful item.

 

After it introduces it, it is annoyed by the symptom to which the header is

doubly displayed though I want you to teach.

 

Are not you about this symptom per mind?

The symptom doesn't change though it installed many times.

I want everyone's advice. >_<

 

I'm sorry.

 

osCommerce MS2 was clean installed though it was a situation, and this module was installed according to the explanation.

 

It doesn't update it from the module before.

Share this post


Link to post
Share on other sites

I just installed STS 4.1 and when I go to modules/STS I see the install button and when I click on it nothing happens. I have a fresh install of OS. I'm only two days into OS iwas on CC cart for a couple of months and so far am much happier with OS just hqave to get used to the differences and appreciate all the help I can get.

Share this post


Link to post
Share on other sites
I am having this exact same problem as Hunabku. I have just spent 4 hrs with no success trying to do something that seems like it should be simple. All I want is for my home page to have its own template and then all other pages default to the "sts_template.html"

How can I define a template which is specific to only the site's home page (index.php) ?

Someone please help me I'm pulling my hair out over this...

I already responded to hayesb2 personal message request, but thought it best to share it with the community. If you create an index.php.html template then you HAVE TO create a template for every catalog page in your site.

 

The other solution is to create an index.html file. The only concern with this is that certain links inside various php files, such as those associated with the "Continue" button, will take you directly to index.php.

 

The quick work around i came up with, is to place a redirect inside index.php to go to index.html. If I could have found a place to globally change the links to index.php and point them to index.html I would have.

 

If you are interested in the redirect you should place it at the top of the "else" statement inside index.php that has to do with displaying the default page - i.e. the home page.

 

Around line 283 find:

<?php
 } else { // default page
?>

change to:

<?php
 } else { // default page
	  //AC_MOD
	  tep_redirect(tep_href_link('index.html'));
?>

Share this post


Link to post
Share on other sites
I already responded to hayesb2 personal message request, but thought it best to share it with the community. If you create an index.php.html template then you HAVE TO create a template for every catalog page in your site.

 

The other solution is to create an index.html file. The only concern with this is that certain links inside various php files, such as those associated with the "Continue" button, will take you directly to index.php.

 

The quick work around i came up with, is to place a redirect inside index.php to go to index.html. If I could have found a place to globally change the links to index.php and point them to index.html I would have.

 

If you are interested in the redirect you should place it at the top of the "else" statement inside index.php that has to do with displaying the default page - i.e. the home page.

 

Around line 283 find:

<?php
 } else { // default page
?>

change to:

<?php
 } else { // default page
	  //AC_MOD
	  tep_redirect(tep_href_link('index.html'));
?>

 

 

 

 

Thank you for the quick answer.

Just one more thing..

If I put this index.html file in my root directory, I cant use the STS tags correct? If so, then I dont think thats what I'm looking for. I still want to utilize the STS tags. STS allows you to make unique template pages for all your products, manufacturers, categories, etc yet it wont allow you to make a unique template for your index page - the most important one! :) I hope someone can prove me wrong and its just something I'm overlooking...

Share this post


Link to post
Share on other sites
Thank you for the quick answer.

Just one more thing..

If I put this index.html file in my root directory, I cant use the STS tags correct? If so, then I dont think thats what I'm looking for. I still want to utilize the STS tags. STS allows you to make unique template pages for all your products, manufacturers, categories, etc yet it wont allow you to make a unique template for your index page - the most important one! :) I hope someone can prove me wrong and its just something I'm overlooking...

I would like to be proven wrong about that too. i'm not sure what you are refering to about not being able to use STS with an index.html in the root directory. Have you tried it?

 

As far as STS not supporting an index.php.html template without creating separate templates for all other pages. I know that is kinda of a pain - especially since there is no clear mention of it in the documentation. It would also be handy to have a list of all the necessary templates (default catalog file names) that one would have to create if they choose to use an index.php.html.

Share this post


Link to post
Share on other sites

I need some help...I am a newbie to scripting programs...OK with HTML..anyway... followed the installation to the letter and get these error codes. It's obvious where the error is, I just can't figure out what it is. My catalog page didn't display the new default page either after I stalled it.

 

Warning: main(/hsphere/local/home/rodrico/eratoys.com/catalog/includes/languages/english/modules/sts/sts_default.php): failed to open stream: No such file or directory in /hsphere/local/home/rodrico/eratoys.com/admin/modules.php on line 136

 

Warning: main(): Failed opening '/hsphere/local/home/rodrico/eratoys.com/catalog/includes/languages/english/modules/sts/sts_default.php' for inclusion (include_path='.:/usr/local/lib/php') in /hsphere/local/home/rodrico/eratoys.com/admin/modules.php on line 136

MODULE_STS_DEFAULT_TITLE 1

 

Warning: main(/hsphere/local/home/rodrico/eratoys.com/catalog/includes/languages/english/modules/sts/sts_index.php): failed to open stream: No such file or directory in /hsphere/local/home/rodrico/eratoys.com/admin/modules.php on line 136

 

Warning: main(): Failed opening '/hsphere/local/home/rodrico/eratoys.com/catalog/includes/languages/english/modules/sts/sts_index.php' for inclusion (include_path='.:/usr/local/lib/php') in /hsphere/local/home/rodrico/eratoys.com/admin/modules.php on line 136

MODULE_STS_INDEX_TITLE 2

 

Warning: main(/hsphere/local/home/rodrico/eratoys.com/catalog/includes/languages/english/modules/sts/sts_product_info.php): failed to open stream: No such file or directory in /hsphere/local/home/rodrico/eratoys.com/admin/modules.php on line 136

 

Warning: main(): Failed opening '/hsphere/local/home/rodrico/eratoys.com/catalog/includes/languages/english/modules/sts/sts_product_info.php' for inclusion (include_path='.:/usr/local/lib/php') in /hsphere/local/home/rodrico/eratoys.com/admin/modules.php on line 136

 

Any help would be appreciated

 

Rodrico

Share this post


Link to post
Share on other sites

There is a new index module on the contribution page. Changelog is as follow:

 

Changes:

- BUG CORRECTED: index.php_0.html template for main page was not working.

- ADDED: new module parameter to set in admin.

=> You now have the choice to look or not for templates of parent categories, if there is no template for the current category.

 

No need to create a template for each category if you want to have a template specific to the home page.

 

@rodrico: you have not copied all the STS files to your store, check your installation again, some files are missing.

 

- Rigadin


STS v4.5 SP5 is out, and check the STS Power Pack contribution too!

New thumbnailer using phpThumb: oscThumb. Works great.

Share this post


Link to post
Share on other sites

Does this version work with SEO? My cart is very heavily edited and unless it works with everything, i would not likely upgrade. The only option i need from this option is the ability to use php codes.

Share this post


Link to post
Share on other sites
There is a new index module on the contribution page. Changelog is as follow:

 

Changes:

- BUG CORRECTED: index.php_0.html template for main page was not working.

- ADDED: new module parameter to set in admin.

=> You now have the choice to look or not for templates of parent categories, if there is no template for the current category.

 

No need to create a template for each category if you want to have a template specific to the home page.

 

@rodrico: you have not copied all the STS files to your store, check your installation again, some files are missing.

 

- Rigadin

 

I've checked and double checked....unloaded and corrected. No changes. I might go to square one and do it a different way. Thanks

Share this post


Link to post
Share on other sites
Does this version work with SEO? My cart is very heavily edited and unless it works with everything, i would not likely upgrade. The only option i need from this option is the ability to use php codes.

 

Yes it works with SEO Ultimate URLs.

 

- Rigadin


STS v4.5 SP5 is out, and check the STS Power Pack contribution too!

New thumbnailer using phpThumb: oscThumb. Works great.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×