Jump to content
rigadin2

[Contribution] STS v4

Recommended Posts

Hi,

 

Im obviously doing something stupid here...

 

I installed sts on a new installlation, copied files, changed header_tags to 777, ran database setup.php... I am now trying to do the configuration... bI want to set use STS to true, but it wont change from false...

 

simple permissions problem? but where... :|

http://www.oscommerce.com/community/contri...all/search,STS4

060817 osCommerce patch for STSv4.2


Bill Kellum

 

Sounds Good Productions

STS Tutorials & more: STSv4.6, STS Add-ons (STS Power Pack), STS V4 Forum STS Forum FREE TEMPLATE

Share this post


Link to post
Share on other sites
Hello,

 

Just a simple question with using STS and Header Tags Controller together. In my admin section in header tags controller in text control all in the list are still red...do I need to add the header code to all in the files in the catelog folder with these 2 contribution working together??

 

Thanks,

 

Mike. :rolleyes:

 

Anyone a yes or a no? :D

Share this post


Link to post
Share on other sites

Answer is no. When using STS, you do not need to modify all the files located in the catalog folder in order to het header tags.

 

The admin part of header tags has nothing to do with STS. You should look in the header tags forum for an answer.

 

- Rigadin


STS v4.5 SP5 is out, and check the STS Power Pack contribution too!

New thumbnailer using phpThumb: oscThumb. Works great.

Share this post


Link to post
Share on other sites
Answer is no. When using STS, you do not need to modify all the files located in the catalog folder in order to het header tags.

 

The admin part of header tags has nothing to do with STS. You should look in the header tags forum for an answer.

 

- Rigadin

 

Paljon kiitoksia Chris :P

Share this post


Link to post
Share on other sites

well after 3 days fighting (I'm not programmer and I never learn php or HTML) seems that the key for my problem with Ultra PICS and STS4 is HTTP_GET_VARS so the question is how to send to popup_image php VAR 0,1,2, etc that means wich image to display.

of course there are other solutions (to have 6 diferent popup files for every diferent image,

this is original STS Code

$template_pinfo['product_popup']= '<script language="javascript"><!--'."\n".

'document.write(\'<a href="java script:popupWindow(\\\'' . tep_href_link(FILENAME_POPUP_IMAGE, 'pID=' . (int)$products_id) . '\\\')">' . $template_pinfo['imagesmall'] . '<br>' . TEXT_CLICK_TO_ENLARGE . '</a>\');'."\n".

'//--></script>'."\n".

'<noscript>'."\n".

'<a href="' . tep_href_link(DIR_WS_IMAGES . $product_info['products_image']) . '" target="_blank">'.$template_pinfo['imagesmall'] . '<br>' . TEXT_CLICK_TO_ENLARGE .'</a>'."\n".

'</noscript>'."\n";

 

and I would like to have product_popup2 with imagesmall2 and products_image_xl_2

if I define imagesmall2 its shown corect, also popuu is working, but always shows first image

because of the condiotion in popup_image.php

if (($HTTP_GET_VARS['image'] ==0) && ($products['products_image_lrg'] != '')) {

echo tep_image(DIR_WS_IMAGES . $products['products_image_lrg'], $products['products_name']);

so question is how to change this VARS

Thank you in advance

Share this post


Link to post
Share on other sites

Offtopic

Looks like with osc, STS4, EZnewfields and few more contributions is possible to achive functionallity as a "heavy weight" solutions like Inershop and IBM commerce suite. Probaby the only one that not available via contributions is ERP connectors (SAP, BANYAN)

Share this post


Link to post
Share on other sites

is there a user manual available, i've got the one with the download but doesn't really give any help in regards to customizing the look of the boxes and main content. I'm completely stuck at the moment. www.pulp-stationery.co.uk/shop (see!!!)

 

thanks

dave

Share this post


Link to post
Share on other sites

Hi,

i'm try to installing the sts v4 whit the fix path, in the oscommerce-2.2ms2-060817, but unfortunathely I can't see the STS bar in the admin pannel.

I need HELP!

 

Thanks,

Daniele

Share this post


Link to post
Share on other sites

Quick question: how do I go about making all the products within a category use a specific template?

 

I know how to make individual product templates but I'd obviously rather make one that covers the whole category than one for each and every product.

Share this post


Link to post
Share on other sites
is there a user manual available, i've got the one with the download but doesn't really give any help in regards to customizing the look of the boxes and main content. I'm completely stuck at the moment. www.pulp-stationery.co.uk/shop (see!!!)

 

thanks

dave

dave looks like your problem is in category contributions, not in sts

probably you have change box category.php with something else

amigaman

create product_info.php_cCatID.html - catid i s id of your category

in my case is product_info.php_c46.html

Share this post


Link to post
Share on other sites

any one to share some knowlage about custamisation of specials.php

is it possible to be made with STS ?

for example with EZnewfields and STS ?

Edited by addicted

Share this post


Link to post
Share on other sites

STS4 and Advance Shopping Cart contributions

take out all js from shoppingcart.php and put it in rollovers.js

inlcude

<script type="text/javascript" language="javascript" src="rollovers.js"></script> in sts_template

Share this post


Link to post
Share on other sites

Hello all.

 

I hope you can help me. I've spent the past 2 days trying to figure out why this mod suddenly isn't working corrrectly. I have it on 2 shops and it works on one and 1/2 the time on the other. When I add a product to the cart from the catergory, it sometimes makes it in. When I try to add it from the product page it does get added. I'm not sure where to look other that the content >> product info & the product info pages. I'm not getting any type of error messages, just no products in the cart. When I disable the mod and add the products to the cart it works 100%, so I know it's something I did in the sts coding.

 

the shop is at http://gifts.simplycleshaaromatics.com/catalog/index.php to get a clearer understanding of the problem.

 

Any help would be greatly appreciated.


Thanks!

Clesha

Share this post


Link to post
Share on other sites
STS4 and Advance Shopping Cart contributions

take out all js from shoppingcart.php and put it in rollovers.js

inlcude

<script type="text/javascript" language="javascript" src="rollovers.js"></script> in sts_template

STSv4.2 does not do anything with the JavaScript. It is taken from the default of the page being used as long as you have the correct parameters in the head section of your template as the User Manual instructs.

 

If you want to have custom JavaScript to be included in your templates, then you can try the following:

 

 

 

Place the file in your template folder and in the header of your template, add this:

 

 

<script LANGUAGE="JavaScript" SRC="$templatepath/yourjavascriptfile.js"></SCRIPT>

More JavaScript tips included in the "STS Tips, Tricks and How To's - Volume One" ebook available for free on the STS Power Pack contribution page. :thumbsup:

 

http://www.oscommerce.com/community/contributions,4456


Bill Kellum

 

Sounds Good Productions

STS Tutorials & more: STSv4.6, STS Add-ons (STS Power Pack), STS V4 Forum STS Forum FREE TEMPLATE

Share this post


Link to post
Share on other sites
Hello all.

 

I hope you can help me. I've spent the past 2 days trying to figure out why this mod suddenly isn't working corrrectly. I have it on 2 shops and it works on one and 1/2 the time on the other. When I add a product to the cart from the catergory, it sometimes makes it in. When I try to add it from the product page it does get added. I'm not sure where to look other that the content >> product info & the product info pages. I'm not getting any type of error messages, just no products in the cart. When I disable the mod and add the products to the cart it works 100%, so I know it's something I did in the sts coding.

 

the shop is at http://gifts.simplycleshaaromatics.com/catalog/index.php to get a clearer understanding of the problem.

 

Any help would be greatly appreciated.

Do you have the following code included in the head section of each template page?

 

 

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN">
<html $htmlparams>
<head>
<meta http-equiv="Content-Language" content="en-us">
<!--$headcontent-->
 <link rel="stylesheet" type="text/css" href="stylesheet.css">
</head>


Bill Kellum

 

Sounds Good Productions

STS Tutorials & more: STSv4.6, STS Add-ons (STS Power Pack), STS V4 Forum STS Forum FREE TEMPLATE

Share this post


Link to post
Share on other sites
is there a user manual available, i've got the one with the download but doesn't really give any help in regards to customizing the look of the boxes and main content. I'm completely stuck at the moment. www.pulp-stationery.co.uk/shop (see!!!)

 

thanks

dave

 

The boxes are customized through the stylesheet - I downloaded Infobox Customizer contribution which allows for an individual look to any or all of your infoboxes. I recommend using WinMerge or a similar product to help you with installing the contrib if you decide to use it.

 

The layout of the pages is determined on your .html page (look in catalog/includes/sts_templates/test (Bill recommends starting with the test folder and then moving to the full folder when you are more comfortable if you need to.

 

Tracy


~Tracy
 

Share this post


Link to post
Share on other sites
Do you have the following code included in the head section of each template page?

 

 

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN">
<html $htmlparams>
<head>
<meta http-equiv="Content-Language" content="en-us">
<!--$headcontent-->
 <link rel="stylesheet" type="text/css" href="stylesheet.css">
</head>

 

 

No, I don't have this in either shop. This is all I have:

 

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">

<html xmlns="http://www.w3.org/1999/xhtml">

<head>

<meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1" />

<title>Simply Clesha :: Gift Baskets</title>

<style type="text/css">

<!--

body {

margin-left: 0px;

margin-top: 0px;

margin-right: 0px;

margin-bottom: 0px;

}

.style2 { color: #43474c;

font-weight: bold;

font-family: "Times New Roman", Times, serif;

}

.style1 { font-size: small;

font-family: Arial, Helvetica, sans-serif;

color: #5A3C52;

}

.style5 {color: #5A3C52}

a:link {

color: #43474C;

text-decoration: none;

}

a:visited {

text-decoration: none;

}

a:hover {

text-decoration: underline;

}

a:active {

text-decoration: none;

}

-->

</style>

<script type="text/JavaScript">

<!--

function MM_preloadImages() { //v3.0

var d=document; if(d.images){ if(!d.MM_p) d.MM_p=new Array();

var i,j=d.MM_p.length,a=MM_preloadImages.arguments; for(i=0; i<a.length; i++)

if (a.indexOf("#")!=0){ d.MM_p[j]=new Image; d.MM_p[j++].src=a;}}

}

 

function MM_swapImgRestore() { //v3.0

var i,x,a=document.MM_sr; for(i=0;a&&i<a.length&&(x=a)&&x.oSrc;i++) x.src=x.oSrc;

}

 

function MM_findObj(n, d) { //v4.01

var p,i,x; if(!d) d=document; if((p=n.indexOf("?"))>0&&parent.frames.length) {

d=parent.frames[n.substring(p+1)].document; n=n.substring(0,p);}

if(!(x=d[n])&&d.all) x=d.all[n]; for (i=0;!x&&i<d.forms.length;i++) x=d.forms[n];

for(i=0;!x&&d.layers&&i<d.layers.length;i++) x=MM_findObj(n,d.layers.document);

if(!x && d.getElementById) x=d.getElementById(n); return x;

}

 

function MM_swapImage() { //v3.0

var i,j=0,x,a=MM_swapImage.arguments; document.MM_sr=new Array; for(i=0;i<(a.length-2);i+=3)

if ((x=MM_findObj(a))!=null){document.MM_sr[j++]=x; if(!x.oSrc) x.oSrc=x.src; x.src=a[i+2];}

}

//-->

</script>

</head>


Thanks!

Clesha

Share this post


Link to post
Share on other sites
Hi,

i'm try to installing the sts v4 whit the fix path, in the oscommerce-2.2ms2-060817, but unfortunathely I can't see the STS bar in the admin pannel.

I need HELP!

 

Thanks,

Daniele

 

It should be inside the Modules bar - is it there?

 

Tracy


~Tracy
 

Share this post


Link to post
Share on other sites
Quick question: how do I go about making all the products within a category use a specific template?

 

I know how to make individual product templates but I'd obviously rather make one that covers the whole category than one for each and every product.

 

You just have to name it with the category info in the name. So if your category number is 1, then your pagename would be "yourtemplatename.php_1.html"

 

If you have subcategories that you want new pages for then you have "yourtemplatename.php_1_17.html" where the number 1 is the parent category, and the number 17 is the subcategory.

 

Tracy


~Tracy
 

Share this post


Link to post
Share on other sites
Be sure to activate the Index and Product Info modules in the admin to use the above features.

 

 

Thanks for the detailed explanation, however there is one thing that I am still not sure about despite your answer and that of TraceyS. If I change the template for category '1' then the category page changes, the products in that category, once clicked upon, use the same product_info page as is default. As you have written I can make a specific index page for each item which allows me to control the template for a specific item.

 

What I need to know is - is it possible to make products '50','51',52' (all the products within a certain category) etc all share the same template distinct from the default.

 

The answers you have given allow me to change the category pages and specific individual items one by one - not all the items pages within a certain category.

 

Thanks again.

Share this post


Link to post
Share on other sites

You can have a template for all products inside a category by adding the category ID to the template name. Of course an example is better:

 

Let say you have a category 22 inside category 11, and want all products in category 22 to use the same content template. You have to name this template product_info.php_c11_22.html and place it in the 'content' folder (like catalog/includes/sts_templates/full/content/).

 

In the same way, you can create a content template product_info.php_c11.html that will be used for all products inside category 11 AND sub-categories (unless subcategories have their own template).

 

Now, as you probably know, content templates are only for the center of the page. If you want different header/columns/footer for products in a category 22, you have to create product_info.php_c11_22.html and place it your template folder (not in the content folder), someting like catalog/includes/sts_templates/full/ .

 

This is explain in chapter 3.9 of the STS documentation.

 

- Rigadin


STS v4.5 SP5 is out, and check the STS Power Pack contribution too!

New thumbnailer using phpThumb: oscThumb. Works great.

Share this post


Link to post
Share on other sites

There is a new release of STS, v4.3!

 

- Infobox templates now integrated inside STS, but can be turned off from the default module. Only 1 template can be used for both header and footer. The default template is cached, no need to read it from disk for each infobox.

 

- Some cleaning inside general.php: some tags were existing twice under different names, one was buggy, 4 were not useful (only placing an image with a link, can be done directly on the template). These changes gives more flexibility to store using several languages.

 

- In the process, 2 files were deleted, so even lighter than before!

 

 

Full changelog, install instructions, update instructions and documentation are available in the download section.

 

Enjoy!

 

- Rigadin


STS v4.5 SP5 is out, and check the STS Power Pack contribution too!

New thumbnailer using phpThumb: oscThumb. Works great.

Share this post


Link to post
Share on other sites

Hi,

 

I've installed STS 4.2 and upgraded now to 4.3 in hopes that my problem would magically go away, but it didn't :(. It has been mentioned on the forum before, but I was unable to find any answer that helped me fix it.

 

I started off with a somewhat modified OsCommerce-installation, and added STS 4.2 to it (the manual way) in order to integrate it into an existing design. This works well for the home page (/index.php).

 

However, when I click on a product (product_info.php), I get the following error-message:

 

Parse error: syntax error, unexpected $end in /path/to/shop/product_info.php on line 333

 

Line 332 is the last line in this document, it contains:

 

<?php require(DIR_WS_INCLUDES . 'application_bottom.php'); ?>

 

I get the same error when clicking on "Catalog" in the admin-interface:

 

Parse error: syntax error, unexpected $end in /path/to/shop/admin/categories.php on line 1145

 

Line 1144 is the last line, and it contains the exact same require-statement as mentioned above.

 

I have only the default template for STS enabled, however I tried to enable the product_info-specific one, but it didn't make any difference.

 

I've been searching forums and looking for missing '}' in the code for a while now, and cannot figure out what is going wrong..

 

Any help or pointers would be much appreciated.

 

Thanks,

Kristian

Share this post


Link to post
Share on other sites

Hi all,

this is driving me BONKERS and I hope someone can help.

I just did a fresh install of OSC - latest edition - no other contribs installed,

did the installation of the newest STS and it will NOT enable.

I have STS in my module list, I can edit the info, but when I update it does not activate or save my changes???

 

I have been through the instructions and do not know what I am doing wrong,

I re-copied all the files several times just to make sure (the modified AND the new files) just dragged the catalog dir and overwrote the files.

 

Please can someone help? I need to have a fully customized store up for next week.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×