Jump to content
rigadin2

[Contribution] STS v4

Recommended Posts

I have a store where I have STS and Header Tags SEO installed. In my header.php file, if I have any of the following lines, my store breaks to the point of a WHITE SCREEN :( in IE Explorer (although it works perfectly fine and well in Firefox). This is making me nuts! If I comment out everything, the store works fine minus any of the Header Tags SEO functionality which I need to work desperately. If anyone can throw me a bone on this one, I'll owe you my first born. (her name is Chloé, and she's a doll) :P

 

Julie

 

------- header.php code:

 

// START STS 4.1

 

$sts->restart_capture ('applicationtop2header'); // Capture header from the actual script, needed to take out javascript

 

// END STS 4.1

 

 

/*** Begin Header Tags SEO ***/

 

We include header_tags.php early on to make $header_tags_array available to subsequent scripts

if ( file_exists(DIR_WS_INCLUDES . 'header_tags.php') ) {

require(DIR_WS_INCLUDES . 'header_tags.php');

 

$sts->restart_capture ('headertags');

 

/*** End Header Tags SEO ***/

Share this post


Link to post
Share on other sites

I would check if I have any template for infoboxes that disable the header for boxes. If so, make a template for also purchased and leave the header in place

 

 

Multimixer you're a genius!

 

with your help pointing me to where I have to search I finally found the solution - simply added the infobox_header.php.html from the full template and voila - the heading is there.

 

Thank you very much.

 

@all

 

any ideas on the second issue?

 

Thanks

Roland

Share this post


Link to post
Share on other sites

Hi.

 

I have installed STS and have been spending some time trying to figure it out - reading the manual and forums etc.

 

So far I have the basics of the site laid out the way I want with a custom logo, header and left side bar for links etc.

 

My issue is that I cannot get a custom index page working. (this will be the main page people see when they arrive at the site)

 

The site generates my custom header, logo and side bar via index.html, but with the default OSC index.php in the main body ( Im using $content$ in the field)

 

What I want is to use my custom html/css main page design in place of the default text generated by the index.php.

 

I know I can alter the text easily enough by editing the includes/languages/english/index.php but I want to use the html/css version Ive designed in its place and eliminate all text.

 

Ive tried putting the index.php.html file into my sts_templates folder but Im not sure if thats what Im supposed to do and Ive tried a variety of combinations but to no avail..

 

Im sure Im missing sonmething very simple here - and Ive read the manual and it seems Im on the right track but nothing I do seems to work..

 

any pointers or advice would be great!

 

note; I have a good grasp of html and css and default OSC but Im still learning php in general..

 

Thanks!

 

- M

Share this post


Link to post
Share on other sites

Quick question : any simple way to only display an STS $categorybox on a homepage ONLY? With the structure being in .html (finding out it can take PHP though) I'm having trouble trying to differentiate between the 'homepage' and a 'other page' turning on and off the $categorybox. Ex. It'll show up on the home page, but not a "My account" page nor "My Cart" page?

Share this post


Link to post
Share on other sites

Hi.

 

I have installed STS and have been spending some time trying to figure it out - reading the manual and forums etc.

 

So far I have the basics of the site laid out the way I want with a custom logo, header and left side bar for links etc.

 

My issue is that I cannot get a custom index page working. (this will be the main page people see when they arrive at the site)

 

The site generates my custom header, logo and side bar via index.html, but with the default OSC index.php in the main body ( Im using $content$ in the field)

 

What I want is to use my custom html/css main page design in place of the default text generated by the index.php.

 

I know I can alter the text easily enough by editing the includes/languages/english/index.php but I want to use the html/css version Ive designed in its place and eliminate all text.

 

Ive tried putting the index.php.html file into my sts_templates folder but Im not sure if thats what Im supposed to do and Ive tried a variety of combinations but to no avail..

 

Im sure Im missing sonmething very simple here - and Ive read the manual and it seems Im on the right track but nothing I do seems to work..

 

any pointers or advice would be great!

 

note; I have a good grasp of html and css and default OSC but Im still learning php in general..

 

Thanks!

 

- M

 

 

nm I think I just had poorly nested css tables.. :-"

Share this post


Link to post
Share on other sites

Quick question : any simple way to only display an STS $categorybox on a homepage ONLY? With the structure being in .html (finding out it can take PHP though) I'm having trouble trying to differentiate between the 'homepage' and a 'other page' turning on and off the $categorybox. Ex. It'll show up on the home page, but not a "My account" page nor "My Cart" page?

 

Create a template and call it index.php_0.html.This will be your "homepage". Whatever you add to this will be displayed only at the homepage, for example the $categorybox$

 

@Mrmike: do the same, and if you don't want any default content to be displayed there, just don't use the $content$ tag and type in whatever you want and add any "css tables" you like

 

EDIT @ Mrmike: People don't enter a site always from the "entrance"

Edited by multimixer

Share this post


Link to post
Share on other sites

Yes, I have it working, whats the problem?

I cant seem to get the info box to display. Also the script stops a the article box and fails to load the rest of the page.

 

Thanks for your help

Eric


Eric

 

Keep up on osCommerce changes and updates at

Github | Understand osCommerce a little further at OsCommerce Documentation | Copy and paste your error message in Google add "in osCommerce" at the end to get relevant answers to most issues.

Share this post


Link to post
Share on other sites

I have a store where I have STS and Header Tags SEO installed. In my header.php file, if I have any of the following lines, my store breaks to the point of a WHITE SCREEN :( in IE Explorer (although it works perfectly fine and well in Firefox). This is making me nuts! If I comment out everything, the store works fine minus any of the Header Tags SEO functionality which I need to work desperately. If anyone can throw me a bone on this one, I'll owe you my first born. (her name is Chloé, and she's a doll) :P

 

Julie

Make sure in your sts template your head section look like this

<head>
<!--$headcontent-->
<link rel="stylesheet" type="text/css" href="$templatedir/stylesheet.css">
</head>

 

Only the <!--$headcontent--> needs to be there to get all the header tag code and head information to display


Eric

 

Keep up on osCommerce changes and updates at

Github | Understand osCommerce a little further at OsCommerce Documentation | Copy and paste your error message in Google add "in osCommerce" at the end to get relevant answers to most issues.

Share this post


Link to post
Share on other sites

Hi!

I have a problem with STS, i have this code i header in index.php.html:

<script language='javascript' type='text/javascript'>

 

function showDiv(pass) {

var divs = document.getElementsByTagName('div');

for(i=0;i<divs.length;i++){

if(divs.id.match(pass)){//if they are 'see' divs

if (document.getElementById) // DOM3 = IE5, NS6

divs.style.visibility="visible";// show/hide

else

if (document.layers) // Netscape 4

document.layers[divs].display = 'visible';

else // IE 4

document.all.divs.visibility = 'visible';

} else {

if (document.getElementById)

divs.style.visibility="hidden";

else

if (document.layers) // Netscape 4

document.divs.visibility = 'hidden';

else // IE 4

document.all.divs.visibility = 'hidden';

}

}

}

 

</script>

 

then this under the body tag:

<?php

if (HOLIDAY_SETTINGS == 'on')

{

?>

 

 

<div id="F512" >

 

<a href="javascript:showDiv('F256')"><img src="info.png" border="0"></a>

</div>

 

<div id="F256" style="position: absolute; left:250px; top:0px; visibility: hidden">

" here is the ordinary code for the page "

 

</div>

 

and my problem is that in the case i click the image the "normal" page shows ( that´s the point ) but every sts tag ex. $categorybox$ don´t show at all it´s blank in the space there it should be a category menu

 

Any idea how to make this work?

 

Regards Tony

Share this post


Link to post
Share on other sites

Just a quick question.

 

Does STS 4.6 work with OSc 2.3.1? If so, which set of install files should I use?

 

Thanks in advance

Any answers to this? About ready to hand edit and test.

John

Share this post


Link to post
Share on other sites

Any answers to this? About ready to hand edit and test.

John

 

No it's not working. If you want to use STS, then take the previous version (RC2a), upgrade it to 2.3 (using the upgrade guide) and then istall on it STS 4.6

Share this post


Link to post
Share on other sites

No it's not working. If you want to use STS, then take the previous version (RC2a), upgrade it to 2.3 (using the upgrade guide) and then istall on it STS 4.6

 

 

Can I make the assumption that eventually it will be upgraded to 2.3? If anybody knows

Share this post


Link to post
Share on other sites

Hi,

Not sure if you'll be able to help me or not, but as it's a layout issue and I'm using STS I thought I'd see what those of you with more knowledge than me thought.

 

All pages on my siteare looking and working as I wish in most browsers, Firefox, Chrome, Safari etc;

 

However, in Internet Explorer, the non osCommerce pages are also working fine for me, such as this, but the osCommerce pages are being laid out terribly, such as this. (The links need to be viewed in Internet Explorer to see the differences).

 

I know that IE causes problems that other browsers don't but I'm struggling to get it looking right. If I put text-align: center in my template, I get the whole page centred (but not with the full with border) but it also centers my text which I don't want.

 

I'm really struggling to work out how I can resolve this. Have any of you had similar issues or are you able to offer some advice on how I'd fix it?

 

Thanks

 

Steve

Edited by satkin2

Share this post


Link to post
Share on other sites

Hello, I´m using STS with Magic zoom. I need to increase the size of the thumb image located here /images/nameofpicture_thumb.jpg. This is just for product info page. How and where I can change that? The admin of oscommerce doesn´t show me any option to choose the size of thumbnail. Thank you. Isa

Share this post


Link to post
Share on other sites

Hi all, this might be a really stupid question, I've used STS before and LOVED it but it's been a couple of years. I have a fresh install of OSCommerce V2.3.1. I'm wanting to install the LATEST version of STS but want to make sure it's compatible with OSC V2.3.1. The STS V4 shows up in the V2.3.1 templates available on the forum but the documention/tutorial of STS V4 does not look like it indicates that it's compatiable. What is the best/latest greatest version STS install that is compatible for OSC V2.3.1?

Share this post


Link to post
Share on other sites

Hi all, this might be a really stupid question, I've used STS before and LOVED it but it's been a couple of years. I have a fresh install of OSCommerce V2.3.1. I'm wanting to install the LATEST version of STS but want to make sure it's compatible with OSC V2.3.1. The STS V4 shows up in the V2.3.1 templates available on the forum but the documention/tutorial of STS V4 does not look like it indicates that it's compatiable. What is the best/latest greatest version STS install that is compatible for OSC V2.3.1?

See posts 6046 and 6047 above.

 

John

Share this post


Link to post
Share on other sites

See posts 6046 and 6047 above.

 

John

 

 

Thank you so much John! :-) ETA: well how embarrassing that it was a few posts above! And I did try to search for this info before posting. Thx!

Edited by Dianna668

Share this post


Link to post
Share on other sites

Can I make the assumption that eventually it will be upgraded to 2.3? If anybody knows

 

 

I think that Bill Kellum is working on this read

 

 

See posts 6046 and 6047 above.

 

John

 

 

Hi all, I do hope I'm following forum rules so not to bump my own posts, if so I apologize in advance. I'm trying to figure out what to do with my store build. I've research Bill's article on STS and how OSC V2.3 works etc. I've debated using 2.3 and just deal with the PHP side of things which I'm quasi okay with, not an expert by far. However, after using STS a couple of years ago, I feel at a loss without it and would very much like to use it for this build. So I realize that I need one of the older versions, i.e. 2.2 RC2a, but now my dilemma is that I cannot find the download for any of the older versions below 2.3 and the new Beta 3. Does anyone know how I can obtain a V2.2 for download? Or have I missed the boat and can now no longer get it? i.e. meaning I'm out of luck to get to use STS? :(

 

I'm not too sure about V2.3 as it stands because of all the limited contributions for it. Most contributions seem to still be for 2.2 unless most still work with the new one. So that's a CON for using 2.3. But the PRO is that at least one is using the most latest full release version and I don't want to get outdated with a new store.

 

So I'm scratching my head on what is the best route to take. If OSC V3 official release will be ultimate then I can worry about that at that time, or if STS is released for the later versions. I'm thinking that I should just run with the V2.2 but now if I can find the download? Or any suggestion?

Share this post


Link to post
Share on other sites

So I'm scratching my head on what is the best route to take. If OSC V3 official release will be ultimate then I can worry about that at that time, or if STS is released for the later versions. I'm thinking that I should just run with the V2.2 but now if I can find the download? Or any suggestion?

 

 

For those who can't wait for the STSv5 release that is compatible with osCv2.3.1, I suggest the following:

1. upgrade to osCv2.3.1 using the upgrade guide but leave out the default osCommerce template upgrades.

2. Then, install STSv4.6 using the "manual" method within the STSv4.6 install instructions.

 

What the above will get you is the following:

1. The latest osCommerce stable build (minus the default template engine)

2. The latest version of the Simple Template System.

 

Note: Many are finding the default template engine that comes with osCv2.3.1 very daunting and limiting. By leaving out the template engine, you still get all of the great security upgrades that osCv2.3.1 brings as well as a very easy to use template system (STSv4.6).

 

:( I have experienced a string of tragedies in the last 3 months that has really taken up my time, hence, the long wait for STSv5.

 

:thumbsup: If anyone wants to collaborate on bringing STSv5 to a reality, and contribute, here is what should be considered:

 

1. STSv5 install needs to focus on either disabling the default template engine in osCv2.3.1, or better yet, configure STSv5 to take advantage of the new template engine and work along side of it (bring STS functionallity to the template engine).

 

2. The latter suggestion would continue the strong tradition of keeping STS an on/off option in the admin, meaning that if you want to see what your shop looks like without STS, just simply turn it off in the admin and then the default template engine would work just like a stock osCv2.3.1 shop.

The other benefit of this is that once the bulk of the other contributions are upgraded to work with osCv2.3.1, then STSv5 would not conflict with them. Yet, an even better scanario would be to have an either/or option in the admin to have STSv5 work along side of the default template engine or alone as the current STSv4.6 does. I metion this only because some designers may not want to use the grid system that comes with the default template engine and would rather stick with what they know, which is what makes STS so great anyway.

 

3. Redo all of the sample templates to work with STSv5/osCv2.3.1.

 

4. Consider droping support for older versions of osC (before v2.3.1). I don't recommend this as there is a huge shop base out there built on older versions of osCommerce.

 

If needed, you can send me your work/email contact info via a private message in this forum.


Bill Kellum

 

Sounds Good Productions

STS Tutorials & more: STSv4.6, STS Add-ons (STS Power Pack), STS V4 Forum STS Forum FREE TEMPLATE

Share this post


Link to post
Share on other sites

Hi Bill

Yes it appears to use sts_template.php.html ok for the product page but will not pick up product_info.php.html for the product page. Here is a link on the Ultimate SEO 5 thread but maybe I have missed someething

http://forums.oscommerce.com/index.php?app=core&module=search&do=quick_search&search_sort_by=date&search_sort_order=desc&type_2=topic&type_id_2=336702&search_term=sts&search_filter_app[forums]=1&st=25

 

any help much appreciated.

If I turn off Ultimate SEO5 all works OK.

 

I got exactly the same prob with ultimate seo url 5 pro from fwr, product_info.php.html does not display correctly.

if someone got a detailed solution please share, it seems also that the usu5 forum members have STS discrimination to discuss about that prob.

As many members got the same prob , I judged that I don't have a mistaken installation.

 

thanks for sharing a fix!

Edited by kyser

Share this post


Link to post
Share on other sites

Hi,

 

I am having trouble getting the boxes headertags.php, headertags_seo_silo.php to work properly inside sts.

 

Can you give me pointers on what code should go in which files.

 

I can get them showing but not properly.

 

Thanks in advance


Getting better with mods but no programmer am I.

Share this post


Link to post
Share on other sites

My link

 

The site above has the headertags seo contribution installed aswell as sts. Outside of sts it works fine.

 

Until I checked my code it didnt work quite like it should in sts.

 

I now have it working but as you can see from the link posted I have my left, right and content columns + the headertag box/s in another column.

 

I have trawlled through this time and time again, and have at least got somewhere with it but need to know where I should be looking to ressolve the headertag box remaining issue of correct placement.

 

Any help will be much appreciated.


Getting better with mods but no programmer am I.

Share this post


Link to post
Share on other sites

I am using sts templating for my site that I converted over from interspire to Oscommerce because it has SO MANY more modules and abilities:)

 

Anyways, I have searched this forum and cannot find a suitable answer, so please excuse this post if its a duplicate or if the answer is in plain site!!

 

With that said I am trying to include a header.php file for use in my templates, so that I can change the header once and be done. I have tried to include a header.php file into my index.php.html, but it does not work.

 

Anyone have any suggestions?

 

Thanks in advance!!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×