Jump to content
rigadin2

[Contribution] STS v4

Recommended Posts

Thanks for that information, but I have a few more questions.

 

Would it be possible to bring the page I created and put it in the index file in the oscommerce folder or would that just mess everything up more? Secondly, would I be able to use the "Content Outside OSC" to put all of the content that you would normally find inside OSC on to the page I created to match my homepage and then use sts to change the look of the boxes to match my page? And finally does this mean sts is strictly for changing the look of the original OSC store and images?

 

- Luc

 

 

Luc,

 

STS allows you to make your own home page using HTML and naming that page as so: index.php_0.html

This page would then be used as your home page. You would then make sure you have a default index template named index.php.html to be used for all of your other catalog pages. This is different from the default template page (sts_template.html). The sts_template.html is used for anyother page in your shop in which you have not created a specific template for such as your privacy.php and shipping.php pages.

 

See these posts for more information:

 

Important Posts for the STS newbie:

 

Post #3755: http://forums.oscomm...p;#entry1226986

 

Post #4326: http://forums.oscomm...p;#entry1303555

 

Post #4974: http://forums.oscomm...p;#entry1361366

 

Post #3772: http://forums.oscomm...p;#entry1227769

 

Post #3757: http://forums.oscomm...p;#entry1227006

 

Please review the above for insight on how the Simple Template System allows you to make templates for pages, categories, home page, products and infoboxes.

 

TIP

Here is a quick rundown of common template names:

 

  • sts_template.html
    • = Default template

    [*]index.php.html

    • = Default Category template (used for all category pages that do not have a specific template page created for it – if you didn’t have this template, STS would use sts_template.html).

    [*]index.php_0.html

    • = Home page template

    [*]index.php_x.html

    • = Specific category template where x = the category ID.

    [*]index.php_x_y.html

    • = Specific subcategory template where x = the category ID and y = the subcategory ID

    [*]product_info.php.html

    • = Default Product template (used for all products, in all categories, if no specific product template is found).

    [*]product_info.php_c23.html

    • = Product template for all products in a specific category (23 in this example – change to the category ID needed)

    [*]product_info.php_23.html

    • = CONTENT template for product ID 23. All content template should be saved in the SGP/content/ folder. Review the sample content template provided in the STS template “full/content” folder. The STS Module Product Info must be enabled in order to use this STS feature. This template is not recommended unless you really know what you are doing since you would need to make modifications to it if you ever added new osCommerce contributions to your shop.

    [*]popup_image.php.html

    • = Template for the product popup image.

    [*]index.php.mfr.html

    • = Default Manufacturer template page (used for all manufacturer pages that do not have a specific template page created for it - if you didn’t have this template, STS would use sts_template.html).

    [*]index.php.mfr_x.html

    • = Specific Manufacturer template where x = the manufacturer ID.
       
      Hope this was helpful,


Bill Kellum

 

Sounds Good Productions

STS Tutorials & more: STSv4.6, STS Add-ons (STS Power Pack), STS V4 Forum STS Forum FREE TEMPLATE

Share this post


Link to post
Share on other sites

Hi all,

 

I have a question, I'm trying to integrate the following contrib on my OSC which of course runs STS:

Ajax attributes images

 

What it does is simply linking an option to a an image, so that by slecting the corresponding option you can see a corresponding image in realtime.

 

Unfortunately, when the ajax call happens in product_info.php the result given is not the content I'm supposed to retrive but the HTML code of the STS template.

 

I suppose the two contributions have issues because of this code:

.....

 

Any work around suggested?

 

thanks!

 

I actually created my own options as images add-on and it works perfectly with STS. I don't see any reason why the one you are using would have any issues other than that contribution not being coded correctly to meet osC standards. If you are not using a content template for your product info pages, then STS would pick up the content changes you made in your standard product_info.php page automatically.

 

Here are some things to look into:

  1. Be sure you are calling the JavaScript needed in your template pages
  2. Be sure the Ajax add-on is working with STS turned off first
  3. You could look into not having STS template any pages created by this add-on (See Below).

How to exclude a page from being templated in STSv4.5.x:

 

In the sts_default.php file, find the following code:

 

 

if (strstr($scriptbasename, "popup") || strstr($scriptbasename, "info_shopping_cart"))
         return ''; // We don't use template for these scripts

Add your php file that you want STS to exclude and it will not template that file. Note: Add the script name as follows:

 

 

if (strstr($scriptbasename, "popup") || strstr($scriptbasename, "your_script_here")|| strstr($scriptbasename, "info_shopping_cart"))
         return ''; // We don't use template for these scripts

 

 

Hope this helped,

 

 

 


Bill Kellum

 

Sounds Good Productions

STS Tutorials & more: STSv4.6, STS Add-ons (STS Power Pack), STS V4 Forum STS Forum FREE TEMPLATE

Share this post


Link to post
Share on other sites

Hello

 

I've been experimenting with STS for a new site and I'm running my templates around in circles trying to solve what is probably a simple design issue.

 

I have STS 4.6 w/ Enchanced Specials, Simple Multi Images, and Fancy Tag for STS working perfectly. I am evolving a free template into a "multi" template with header/footer/sidebar/content pages using CSS.

 

My problem occurred when I was following a click stream through our "catalog":

 

Home > Pools > Inground > Accessories

 

Within the Accessories Sub-Catergory I have both products and other sub-categories (yes the logic is flawed, but..) I would like to display the sub-categories at the top and the products below.

 

I would also like to alter the layout of any sub_category pages with sub_categories within them... (wow that was painful)

 

I though that creating an index.php_X.html and index.php_X_X.html would solve this, but that only changes the product_info pages...

 

Please shed some light on this subject or maybe I'm simply not reading the Users Manual/Beginners Tut correctly...

 

thanks

-jt

 

First, be sure you have the STS Index module enabled.

 

Then, follow the template name structure for custom template pages. Another option is to create custom PHP code to handle this if you didn't want to create specific template pages for each sub-category (STS gives you the choice to do it eitherway).

 

See the common template names listed a few posts above.


Bill Kellum

 

Sounds Good Productions

STS Tutorials & more: STSv4.6, STS Add-ons (STS Power Pack), STS V4 Forum STS Forum FREE TEMPLATE

Share this post


Link to post
Share on other sites

Hello,

 

The front end of my store is working fine, but my admin tool is running very slowly. The tech support representative at my web hosting service said the following errors were showing on the server:

 

[sat Aug 14 02:47:02 2010] [error] [client 75.142.190.21] File does not exist: /home/lisassti/public_html/admin/includes/javascript/tiny_mce/plugins/codeprotect, referer: http://lisasstitchingpost.com/admin/categories.php?cPath=17

 

[sat Aug 14 02:47:02 2010] [error] [client 75.142.190.21] File does not exist: /home/lisassti/public_html/admin/includes/javascript/tiny_mce/plugins/ibrowser, referer: http://lisasstitchingpost.com/admin/categories.php?cPath=17

 

He said I should share the above errors with those of you on the OsC community forums and see if you could give me any directions that he might be able to assist me with.

 

Thank you in advance,

Lisa

Share this post


Link to post
Share on other sites

P.S. I'm not certain I posted in the correct thread. My store is running on osCommerce RC2a and STSv4.6--if that helps.

 

Thank you again,

 

Lisa

Share this post


Link to post
Share on other sites

Hello and welcome to osCommerce RC2a and STSv4.6. Sorry to see that you are having problems right at the start.

 

  • Be sure you are indeed uploading the modified template back onto your server in the same location.
  • Be sure you have the correct template set selected that you have made the modifications in (the folder where this modified template resides).
  • If the template set is using a index.php.html template, then you would need to modify that template as well.
  • If all esle fails, refresh the cache in your browser as you may be viewing an old cached page of your site. Try viewing your site from a different computer to see for sure.

Hope this helped,

 

 

I think this may be the problem. When I go to access the files through the admin panel in oscommerce i've noticed a double forward slash in the file path.

 

/home/artsbyam/public_html/oscommerce//includes

 

This isn't correct, is it? How do I go about fixing this? I've included a screen shot

 

Picture%202.png

Share this post


Link to post
Share on other sites

I actually created my own options as images add-on and it works perfectly with STS. I don't see any reason why the one you are using would have any issues other than that contribution not being coded correctly to meet osC standards. If you are not using a content template for your product info pages, then STS would pick up the content changes you made in your standard product_info.php page automatically.

 

Here are some things to look into:

  1. Be sure you are calling the JavaScript needed in your template pages
  2. Be sure the Ajax add-on is working with STS turned off first
  3. You could look into not having STS template any pages created by this add-on (See Below).

How to exclude a page from being templated in STSv4.5.x:

 

In the sts_default.php file, find the following code:

 

 

if (strstr($scriptbasename, "popup") || strstr($scriptbasename, "info_shopping_cart"))
         return ''; // We don't use template for these scripts

Add your php file that you want STS to exclude and it will not template that file. Note: Add the script name as follows:

 

 

if (strstr($scriptbasename, "popup") || strstr($scriptbasename, "your_script_here")|| strstr($scriptbasename, "info_shopping_cart"))
         return ''; // We don't use template for these scripts

 

 

Hope this helped,

 

Hey Bill,

nice to hear from you and thanks for replying (and for the great contrib!)

Here some more details:

 

I of course tried to deactivate STS and this way the contrib works perfectly.

I've checked and the scripts are correctly included or required in the template pages.

 

The thing is the following: The script calls for an image created in a div. It uses and HttpResponse which instead of giving back the picture alone it also give back also the rough structure of the sts template (the template code with placeholders)..

what is the contrib you managed to create for attribute pictures?

 

Thank you so much

Edited by Yak39

Share this post


Link to post
Share on other sites

Hey Bill,

nice to hear from you and thanks for replying (and for the great contrib!)

Here some more details:

 

I of course tried to deactivate STS and this way the contrib works perfectly.

I've checked and the scripts are correctly included or required in the template pages.

 

The thing is the following: The script calls for an image created in a div. It uses and HttpResponse which instead of giving back the picture alone it also give back also the rough structure of the sts template (the template code with placeholders)..

what is the contrib you managed to create for attribute pictures?

 

Thank you so much

 

 

wooops! No worries, the workaround you gave me was perfect, thanks for helping me out!

Share this post


Link to post
Share on other sites

Documentation change:

 

I have a suggestion to help make the STS User Manual a little more clear. In the 7.1 section on infoboxes where it says

 

Note: Include the name of the infobox filename in the template in the following format:

  • infobox_
    infoboxname
    .php.html

 

I finally found what the possible infoboxname values can be, the file names in the osCommerce catalog\includes\boxes directory. I kept thinking they were the placeholder names for the infoboxes, i.e. category for $categorybox$ or information for $informationbox$. I think it will be more clear if you reference the files names in the catalog\includes\boxes directory.

 

Thanks for a great tool,

 

Russ Petersen

Share this post


Link to post
Share on other sites

Documentation change:

 

I have a suggestion to help make the STS User Manual a little more clear. In the 7.1 section on infoboxes where it says

 

Note: Include the name of the infobox filename in the template in the following format:

  • infobox_
    infoboxname
    .php.html

 

I finally found what the possible infoboxname values can be, the file names in the osCommerce catalog\includes\boxes directory. I kept thinking they were the placeholder names for the infoboxes, i.e. category for $categorybox$ or information for $informationbox$. I think it will be more clear if you reference the files names in the catalog\includes\boxes directory.

 

Thanks for a great tool,

 

Russ Petersen

 

Russ,

 

Good point! To be honest, I thought I included that in the documentation. Good catch! I will modify the text in the next release. I have a update to be made very soon regarding the custom infoboxes so I will make this change along with that.

 

Thanks for posting,


Bill Kellum

 

Sounds Good Productions

STS Tutorials & more: STSv4.6, STS Add-ons (STS Power Pack), STS V4 Forum STS Forum FREE TEMPLATE

Share this post


Link to post
Share on other sites

I am having a problem with my admin panel after installing STS. I have seen this referenced here before and when I posted it in the regular installation forums I was sent here for help. Any help would be very much appreciated.

 

 

I copied all of the files STS installation instructions told me about, and went back to my admin panel and this is what happened.

 

 

Warning: require(includes/classes/navigation_history.php) [function.require]: failed to open stream: No such file or directory in C:\xampp\htdocs\catalog\admin\includes\application_top.php on line 128

 

Fatal error: require() [function.require]: Failed opening required 'includes/classes/navigation_history.php' (include_path='.;\xampp\php\PEAR') in C:\xampp\htdocs\catalog\admin\includes\application_top.php on line 128

 

 

 

 

Thanks in Advance!

Share this post


Link to post
Share on other sites

I am having a problem with my admin panel after installing STS. I have seen this referenced here before and when I posted it in the regular installation forums I was sent here for help. Any help would be very much appreciated.

 

 

I copied all of the files STS installation instructions told me about, and went back to my admin panel and this is what happened.

 

 

Warning: require(includes/classes/navigation_history.php) [function.require]: failed to open stream: No such file or directory in C:\xampp\htdocs\catalog\admin\includes\application_top.php on line 128

 

Fatal error: require() [function.require]: Failed opening required 'includes/classes/navigation_history.php' (include_path='.;\xampp\php\PEAR') in C:\xampp\htdocs\catalog\admin\includes\application_top.php on line 128

 

 

 

 

Thanks in Advance!

 

This is not a STS issue but rather most likely a user error on your part. You've accidentally copied the /catalog/includes/application_top.php into the admin. Be sure to follow the installation instructions very closely.


Bill Kellum

 

Sounds Good Productions

STS Tutorials & more: STSv4.6, STS Add-ons (STS Power Pack), STS V4 Forum STS Forum FREE TEMPLATE

Share this post


Link to post
Share on other sites

Hi everybody,

 

Version 4 is a major release of the excellent STS contribution that you can find here: http://www.oscommerce.com/community/contributions,1524,

 

I started a new thread to not mix with STS v2/v3 questions and because the v2/v3 thread has reached 147 pages! If you have problem with STS v2 or v3, please look here: http://forums.oscommerce.com/index.php?sho...c=58541&st=2920

 

 

The main advantages of this release are:

 

- Less code and several improvements, so should be faster..

- All templates are in their own folder, selection of folder is made in admin. Folder choice can be overwritten from URL for testing purposes.

- Use of modules for code specific to some pages (product_info.php for example), parameters accessible from admin (like shipping, payment or order total modules).

- Write own module for checkout, create account or else: easy to share like payment modules.

- Switch STS on/off from admin. When off, you will see your store like it was before STS installation.

- Debug mode still available from URL, but with a code defined by admin => works like a password.

- If STS is off, using debug mode from URL will turn it on only for you. Useful for testing without disturbing visitors.

- Ready for product page caching. Not implemented yet, but doors are open.

- Possibility to avoid sorting a big array (speed optimization), by adding a special char at the end of the placeholders, for example "$languages" becomes "$languages#". (Can be different on each template).

- Installation is still very easy, modifications only at beginning and end of some files.

- Possibility to have a template for header/columns/footer like always + a template for the content area. Useful with product_info: main template comes from the category where the product is, while the content itself is defined according to the product_info template.

- All boxes are now also available separately, no need to show specials if you want to show tell a friend box, no need to show best sellers if you want to show product notifications.

- Boxes that should not appear on certain pages will have an empty tag => customer won't see the placeholder name (try, in v2.x, $banner without having banner or $languages in checkout process page, you'll see what I mean.

- Possibility to write php script in the templates, like in STS v3.

- Compatible with templates made for STS v2 or v3

- Compatible with templates made for STS PLUS (STS v4.1 is based on STS PLUS 4.0.7, only few small modifications).

 

 

STS v4.1 is based on STS PLUS v4.0.7. STS PLUS itself is based on STS v3 but with so many changes in the code that I released it as a separate contribution.

Now, after positive feedback from the community and the blessing from the original author, Brian (great contribution, thanks Brian!), the code is back to where it belongs: STS.

 

Changelog from STS PLUS v4.0.7:

 

- UPDATED class sts.php: renewed some parts of the code. Include template file from within the sts class instead of from a separate function, so the template can use $this-> to access methods and variables from the sts class. Added function add_debug ($text, $br=true) that add text to the $sts->template['debug'] with a line break by default, it helps when you want to debug your store.

- DELETED sts_column_right.php as its 1 line code can be put directly in column_left.php

- UPDATED sts_footer.php: no need to record the variable columnright2footer as it does not contain any usable information. sts_display_output is now called from here.

- UPDATED examples in sts_user_code.php.

- UPDATED sts_display_output.php: do not display the template variable 'template_html' in debug mode because it makes the page very long and it only represents the source code of the page => you can look at the source code instead.

- UPDATED module sts_product_info.php v1.0.5 to use templates for products in a specific categories. Template product_info_c32 for products in category ID32 and in sub-categories. Works also for content templates.

- UPDATED sts_column_left.php to not show the reviews infobox when on the product_reviews_info.php page. The infobox and the page are using same variable names and it put mess when the infobox is called before the content of the page. This is a simple workaround. If you want the infobox to display all the time, you have to change the variable names inside the infobox (or inside the script of the page). I have not tested without STS, but I'm pretty sure that the problem is same, if the reviews infobox is placed in the left column.

 

 

You can also have a look at the STS PLUS thread here: http://forums.oscommerce.com/index.php?showtopic=187122, as many problems you will face have been discussed there.

 

- Rigadin

 

 

I got problem after install sts (with fresh oscommerce rc2a installation). See below (appear on my site)

http://nicheniaga.com/install/index.php

 

 

The webserver is not able to save the installation parameters to its configuration files.

 

The following files need to have their file permissions set to world-writeable (chmod 777):

 

/home/nichenia/public_html/includes/configure.php

/home/nichenia/public_html/admin/includes/configure.php

 

Nerry

Share this post


Link to post
Share on other sites

I got problem after install sts (with fresh oscommerce rc2a installation). See below (appear on my site)

http://nicheniaga.com/install/index.php

 

 

The webserver is not able to save the installation parameters to its configuration files.

 

The following files need to have their file permissions set to world-writeable (chmod 777):

 

/home/nichenia/public_html/includes/configure.php

/home/nichenia/public_html/admin/includes/configure.php

 

Nerry

 

As I told you, you didn't finish the installation of osCommerce correctly. Your issue is not related to STS Here is your other topic. You have already 3 post about this in the forum, please do not start more

Share this post


Link to post
Share on other sites

I almost hate asking questions about simple things, but I'm getting very lost. I've read the User Manual until I'm dizzy, but I still can't get the $content$ in a basic page to change. I've either created new product_info.php.html files or made little changes to every product_info.php.html I can find trying to see how to customize the information on each product. I've turned on the "Product Info" option the STS Module in Admin. I've also tried turning on the STS3 compatibility option, still no change.

 

I'm knocking my head against the wall and nothing changes on the page.

 

Are there any basic tutorials or "how to"s on changing the product information?

 

I've tried adding product_info.php.html files in these directories

catalog/includes/sts_templates/[i]template_name[/i]
catalog/includes/sts_templates/[i]template_name[/i]/content

 

Thanks again for the help,

Russ

Share this post


Link to post
Share on other sites

I almost hate asking questions about simple things, but I'm getting very lost. I've read the User Manual until I'm dizzy, but I still can't get the $content$ in a basic page to change. I've either created new product_info.php.html files or made little changes to every product_info.php.html I can find trying to see how to customize the information on each product. I've turned on the "Product Info" option the STS Module in Admin. I've also tried turning on the STS3 compatibility option, still no change.

 

I'm knocking my head against the wall and nothing changes on the page.

 

Are there any basic tutorials or "how to"s on changing the product information?

 

I've tried adding product_info.php.html files in these directories

catalog/includes/sts_templates/[i]template_name[/i]
catalog/includes/sts_templates/[i]template_name[/i]/content

 

Thanks again for the help,

Russ

 

It's not very clear what you mean when saying "how to change the product information" STS.

 

STS will not help you to change the information itself. This you do via your admin->catalog by adding prices, images, descriptions to each product. STS will help you in the way to display this information. If you don't want the product info pages to look same like your other pages, you can create a product_info.php.html template in 2 different ways

 

1) Top level template (to be placed in includes/sts_templates/templatename/): Here you can change the general appereance of the product info page, ie not to have a specials box on the left or whatever. The actula content of the page comes stil via the $content$ tag, that means all content of the regular product_info.php as it is definded/styled in this file

 

2) Content template (to be placed in includes/sts_templates/templatename/content): Here you can control each element of the product info page, ie where do you want the price, description, image etc to be placed?

To have this, you need to turn the "product info" option of STS on in your admin. All tags used in this content templae are defined in the file includes/modules/sts_inc/product_info.php. You can go there and apply any css or whatever to the various tags, so that your page looks unique.

 

You can also have a different styling for each product or all products of one category on both levels

 

You can go through this recent post by Bill for a better insight

 

Luc,

 

STS allows you to make your own home page using HTML and naming that page as so: index.php_0.html

This page would then be used as your home page. You would then make sure you have a default index template named index.php.html to be used for all of your other catalog pages. This is different from the default template page (sts_template.html). The sts_template.html is used for anyother page in your shop in which you have not created a specific template for such as your privacy.php and shipping.php pages.

 

See these posts for more information:

 

Important Posts for the STS newbie:

 

Post #3755: http://forums.oscomm...p;#entry1226986

 

Post #4326: http://forums.oscomm...p;#entry1303555

 

Post #4974: http://forums.oscomm...p;#entry1361366

 

Post #3772: http://forums.oscomm...p;#entry1227769

 

Post #3757: http://forums.oscomm...p;#entry1227006

 

Please review the above for insight on how the Simple Template System allows you to make templates for pages, categories, home page, products and infoboxes.

 

TIP

Here is a quick rundown of common template names:

 

  • sts_template.html
    • = Default template

    [*]index.php.html

    • = Default Category template (used for all category pages that do not have a specific template page created for it – if you didn’t have this template, STS would use sts_template.html).

    [*]index.php_0.html

    • = Home page template

    [*]index.php_x.html

    • = Specific category template where x = the category ID.

    [*]index.php_x_y.html

    • = Specific subcategory template where x = the category ID and y = the subcategory ID

    [*]product_info.php.html

    • = Default Product template (used for all products, in all categories, if no specific product template is found).

    [*]product_info.php_c23.html

    • = Product template for all products in a specific category (23 in this example – change to the category ID needed)

    [*]product_info.php_23.html

    • = CONTENT template for product ID 23. All content template should be saved in the SGP/content/ folder. Review the sample content template provided in the STS template “full/content” folder. The STS Module Product Info must be enabled in order to use this STS feature. This template is not recommended unless you really know what you are doing since you would need to make modifications to it if you ever added new osCommerce contributions to your shop.

    [*]popup_image.php.html

    • = Template for the product popup image.

    [*]index.php.mfr.html

    • = Default Manufacturer template page (used for all manufacturer pages that do not have a specific template page created for it - if you didn’t have this template, STS would use sts_template.html).

    [*]index.php.mfr_x.html

    • = Specific Manufacturer template where x = the manufacturer ID.
       
      Hope this was helpful,

Share this post


Link to post
Share on other sites

The error message is telling you the truth...the template file does not exist in that path. In your case, you have set the "Use Infobox Templates" to true in the STS Default Module in the Admin section of your store, BUT, you have your template folder set to use the "test" folder.

 

Take a look at your test folder and you will see that it does not have a folder in it called "boxes". This is by design since the test folder should only be used to "test" the STS installation and then move on from there.

 

:thumbsup: I would suggest that at the very least you change your template folder to "full". Once you get the hang of STS, you can add as many template folders that you desire, one for each season, holiday, full moon, etc. Just make sure you include the "boxes" and "content" folders in each of your new template folders.

 

Hello friends,

 

I've done installation of sts module. Now, I m trying to install new template. This file I got from here http://freeoscommerc...e/?template=009 I've upload those file inside 'upload' folder into my web server, (includes/sts_templates). Then my setting on sts module, is

Default template (v2.1.2)

 

Use Templates?

true

 

Code for debug output

debug

 

Files for normal template

sts_user_code.php

 

Base folder

includes/sts_templates/freeoscommerce_009

 

Template folder

boxes

 

Default template file

freeoscommerce_009.html

 

Use template for infoboxes

true

 

But, when I reload my website, the template still not change plus the error saying that, Template file does not exist: [includes/sts_templates/freeoscommerce_009boxes/freeoscommerce_009.html]

 

please refer my website at http://www.nicheniaga.com/index.php

 

Please give an advice. TQ

 

Nerry-

Share this post


Link to post
Share on other sites

Hello friends,

 

I've done installation of sts module. Now, I m trying to install new template. This file I got from here http://freeoscommerc...e/?template=009 I've upload those file inside 'upload' folder into my web server, (includes/sts_templates). Then my setting on sts module, is

Default template (v2.1.2)

 

Use Templates?

true

 

Code for debug output

debug

 

Files for normal template

sts_user_code.php

 

Base folder

includes/sts_templates/freeoscommerce_009

 

Template folder

boxes

 

Default template file

freeoscommerce_009.html

 

Use template for infoboxes

true

 

But, when I reload my website, the template still not change plus the error saying that, Template file does not exist: [includes/sts_templates/freeoscommerce_009boxes/freeoscommerce_009.html]

 

please refer my website at http://www.nicheniaga.com/index.php

 

Please give an advice. TQ

 

Nerry-

 

Can anyone give the thread link related to my questions. TQ

 

Nerry-

Share this post


Link to post
Share on other sites

 

 

Nerry-

 

 

Your settings are wrong. They should be the following:

 

Use Templates?

true

 

Code for debug output

debug

 

Files for normal template

sts_user_code.php

 

Base folder

includes/sts_templates

 

Template folder

freeoscommerce_009

 

Default template file

freeoscommerce_009.html (although I strongly recommend to change the name of this template to sts_template.html)

 

Use template for infoboxes

true


Bill Kellum

 

Sounds Good Productions

STS Tutorials & more: STSv4.6, STS Add-ons (STS Power Pack), STS V4 Forum STS Forum FREE TEMPLATE

Share this post


Link to post
Share on other sites

Your settings are wrong. They should be the following:

 

Use Templates?

true

 

Code for debug output

debug

 

Files for normal template

sts_user_code.php

 

Base folder

includes/sts_templates

 

Template folder

freeoscommerce_009

 

Default template file

freeoscommerce_009.html (although I strongly recommend to change the name of this template to sts_template.html)

 

Use template for infoboxes

true

 

Owh, my fault..thank Bkellum.

 

I've made a correction. Now its working. TQ

Share this post


Link to post
Share on other sites

Hi all, can someone please help a n00b?

 

I got STS installed and its great, also got a neat template installed. Thing is I don't for the life of me know where to change the company logo, by default it just says the name of my site in text but I want to use a .gif image.

 

Please help :'(

Share this post


Link to post
Share on other sites

Hi, I installed oscommerce on my site, but couldn't install sucessfuly sts 4.6 on it. Below is the whole procedure I did, please let me know where I'm making the mistake...

 

1.I uploaded the contents of sts folder (5 folders)to catalog folder (buy/catalog/includes/module)

 

2. Then i uploaded the rc2 & ms2 folders to several locatoion but without success.

 

I specifically didn't understand which files to replace (where it says modify oscommerce file)

 

Please let me know step by step

 

 

thanks & regards :)

Khan

Share this post


Link to post
Share on other sites

Hi, I installed oscommerce on my site, but couldn't install sucessfuly sts 4.6 on it. Below is the whole procedure I did, please let me know where I'm making the mistake...

 

1.I uploaded the contents of sts folder (5 folders)to catalog folder (buy/catalog/includes/module)

 

2. Then i uploaded the rc2 & ms2 folders to several locatoion but without success.

 

I specifically didn't understand which files to replace (where it says modify oscommerce file)

 

Please let me know step by step

 

 

thanks & regards :)

Khan

 

Read this post

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×