Jump to content
Latest News: (loading..)
rigadin2

[Contribution] STS v4

Recommended Posts

Thanks guys.

 

Bill, do you mean like the 'Developer Tools' F12 function in IE?

 

 

Yes, that would be the one. If you go to View | Class ID Information, you will see the style associated with each element on your page.


Bill Kellum

 

Sounds Good Productions

STS Tutorials & more: STSv4.6, STS Add-ons (STS Power Pack), STS V4 Forum STS Forum FREE TEMPLATE

Share this post


Link to post
Share on other sites

STS + Ultra Pics + lightbox

 

You need to do a couple of things...

 

At the end of this solution I should make :

 

-----------------

 

Then, in your content template (template_folder/content/product_info.php.html), add your new STS tags where you want them: For example:

$products_image_sm_1$

 

-----------------

 

But I don't have template_folder/content/product_info.php.html :( . I am using freeoscommerce_009 template . When I press on enlarge button nothing happens . If STS is disabled enlarge works good.

Share this post


Link to post
Share on other sites

STS + Ultra Pics + lightbox

 

You need to do a couple of things...

 

At the end of this solution I should make :

 

-----------------

 

Then, in your content template (template_folder/content/product_info.php.html), add your new STS tags where you want them: For example:

$products_image_sm_1$

 

-----------------

 

But I don't have template_folder/content/product_info.php.html sad.gif . I am using freeoscommerce_009 template . When I press on enlarge button nothing happens . If STS is disabled enlarge works good.

 

thumbsup.gif Then you should simply add the folder to that template set and put your content template inside it. It's not called Simple Template System for nothing whistling.giflaugh.gif


Bill Kellum

 

Sounds Good Productions

STS Tutorials & more: STSv4.6, STS Add-ons (STS Power Pack), STS V4 Forum STS Forum FREE TEMPLATE

Share this post


Link to post
Share on other sites

bkellum;

 

Sorry if this question been asked b4.. Im running a rc2a store now, since i have been using it for a while, do i need to re-do everything once i install this STS v4.6? Ie; the product i need to relist and re-type all the T&C, Shipping Terms etc etc? Thanks.

Share this post


Link to post
Share on other sites

bkellum;

 

Sorry if this question been asked b4.. Im running a rc2a store now, since i have been using it for a while, do i need to re-do everything once i install this STS v4.6? Ie; the product i need to relist and re-type all the T&C, Shipping Terms etc etc? Thanks.

 

 

Nope, as STS doesn't care what products you have or don't have.

 

When updating your admin/modules.php file, be sure to take a look at this post first.


Bill Kellum

 

Sounds Good Productions

STS Tutorials & more: STSv4.6, STS Add-ons (STS Power Pack), STS V4 Forum STS Forum FREE TEMPLATE

Share this post


Link to post
Share on other sites

Did anyone ever find a solution why product_info.php.html will not display with Ultimate SEO URLS 5

 

Driving me mad, it must be something simple!

I am using 4.58

Share this post


Link to post
Share on other sites

Did anyone ever find a solution why product_info.php.html will not display with Ultimate SEO URLS 5

 

Driving me mad, it must be something simple!

I am using 4.58

 

 

Quite frankly, I never knew it was an issue, with STS at least.


Bill Kellum

 

Sounds Good Productions

STS Tutorials & more: STSv4.6, STS Add-ons (STS Power Pack), STS V4 Forum STS Forum FREE TEMPLATE

Share this post


Link to post
Share on other sites

Hi Bill

Yes it appears to use sts_template.php.html ok for the product page but will not pick up product_info.php.html for the product page. Here is a link on the Ultimate SEO 5 thread but maybe I have missed someething

http://forums.oscommerce.com/index.php?app=core&module=search&do=quick_search&search_sort_by=date&search_sort_order=desc&type_2=topic&type_id_2=336702&search_term=sts&search_filter_app[forums]=1&st=25

 

any help much appreciated.

If I turn off Ultimate SEO5 all works OK.

Share this post


Link to post
Share on other sites

I just installed STS4.6 and trying to load different templates. When I go to admin->modules->STS->default... my template folder dropdown list is empty. My Base Folder contains many folders like single, multiple, blank, blue_hash etc. As per the installation document, this folders should show up in the drop down list so that I can select any one of them and switch to a different template instantly. I can not change the default folder from single to something else. Please advice if there is any problem with my installation. I did the fresh installation twice.

Share this post


Link to post
Share on other sites

I just installed STS4.6 and trying to load different templates. When I go to admin->modules->STS->default... my template folder dropdown list is empty. My Base Folder contains many folders like single, multiple, blank, blue_hash etc. As per the installation document, this folders should show up in the drop down list so that I can select any one of them and switch to a different template instantly. I can not change the default folder from single to something else. Please advice if there is any problem with my installation. I did the fresh installation twice.

 

 

Double check your modifications to the admin/modules.php file.

 

thumbsup.gif If it helps, compare your admin/modules.php with the one that came with the contribution as the modifications have already been made in that file to ease installation.


Bill Kellum

 

Sounds Good Productions

STS Tutorials & more: STSv4.6, STS Add-ons (STS Power Pack), STS V4 Forum STS Forum FREE TEMPLATE

Share this post


Link to post
Share on other sites

Double check your modifications to the admin/modules.php file.

 

thumbsup.gif If it helps, compare your admin/modules.php with the one that came with the contribution as the modifications have already been made in that file to ease installation.

 

You are right. Actually I was using STSv4.6 with the preinstalled osCommerce on the webhosting service provider server. Finally, after so many failed attempts, I installed myself new version of osCommerce and it worked!!!!.

Thanks for your support.

Share this post


Link to post
Share on other sites

Before I start, I have read a lot (STS manual,oscommerce forum & goole)for 2 days now.

1) I installed STS Template ... works fine

2) Installed Microsoft Expression for editing

3) Designed a html website

 

My problem is were and how to insert the tags (ie $banner$)

Do I remove the picture and put the tags there or is it in the coding

 

I am reading the manual I just don't know were to insert these, or I just don't get it.

 

I also opened up the STS template index file to look at that, but that's were I get confused more.

That because there is no image just the tags.

 

Any help would be appreciated.

Share this post


Link to post
Share on other sites

Before I start, I have read a lot (STS manual,oscommerce forum & goole)for 2 days now.

1) I installed STS Template ... works fine

2) Installed Microsoft Expression for editing

3) Designed a html website

 

My problem is were and how to insert the tags (ie $banner$)

Do I remove the picture and put the tags there or is it in the coding

 

I am reading the manual I just don't know were to insert these, or I just don't get it.

 

I also opened up the STS template index file to look at that, but that's were I get confused more.

That because there is no image just the tags.

 

Any help would be appreciated.

 

Hi Wendy, nice to see you in the STS forum. Let me try to bother you again with my "useless knockings" :)

 

I don't know what microfoft expression looks like, but I guess that what you designed is a plain static html page. I also don't know what picture you are referring too, but I guess it must be an image of the template.

 

However: STS is a way to put a "skin" over, or around, the dynamically created content of the php pages. Using sts doesn't mean that your site will turn into a static html, so you can not use just a static html design. It needs still to display dynamic content, and this happens via the $tags$.

 

In other words: Whatever is going to remain same on all pages, like for example a large header image, this you can put into your html directly, as you would do for a regular static page. Everything else, everything that will be "produced" dynamically needs to be added as a $tag$.

 

What is a $tag$? It is a way to "transfer" dynamically created content in a short way into a template. Each $tag$ needs to be defined first ofcourse, so that the template "understand" what it means. For example:

$sts->template['login'] = '<a href=' . tep_href_link(FILENAME_LOGIN, '', 'SSL') . '>' .  HEADER_TITLE_LOGIN . '</a>';

This here defines the tag $login$. Definition happens in file includes/modules/sts_inc/general.phpWherever I place it into my template, I will get a link "login" leading to login.php. In static html I would make just a link, in sts I use the tag instead. What sts do now is, to create the "environment" around this link. In my template I have for example

	
        <div class="headleftcol1">
	<div class="langcur">$languagebox$</div>
	<div class="toplogin">$login2$$logoff$ | $register2$$myaccount$ | $history$</div>
</div>

You can see how tags are getting created in the files of includes/modules/sts_inc/ folder. There is also a list of predefined tags in the user manual. You can create as many tags as you want your self, for any element that you want to place precisely into your template. You can place them wherever you like and into any "environment" you like.

 

Some of the tags inlude already a formatting that comes from the actual php page. That is for example for the $content$ tag, that displays the actual php file content, for example the contact_us.php as it i designed in contact_us.php.html. To change this, you need either to go into the php file to change the design, or to create tags for any element that this page displays

 

What you can not do, is to design your template in a "visual editor". I mean you can, but you will not see how he actual page looks like until you use a server (online or offline via XAMPP etc)

 

The best would be, you take one of the existing templates of the package and try around till you get the result you want. I would first make just the default template and then go slowly to more specific templates for index, products, boxes, modules etc. Try moving tags around, cancel some or add some new and watch the results over your server.

 

After you get the "logic" of the story, you will see that it is very easy to do

Share this post


Link to post
Share on other sites

Thank you, George

 

I think I will do just that, play around with one of the templates until I get the hang of it.

 

Sorry we got off on the wrong foot, but I really appreciate the help.

Share this post


Link to post
Share on other sites

Hey all, I'm not really sure this is where to post this but here goes. I'm using STS v4 and so far love it. I have only one problem that I just can't seem to find the answer to. I've searched here for a while. If the answer is here forgive me.

 

I'm looking for a way to control the width of the $catmenu. I found the question ask but never answered. I know the default is for it to set to the width of your longest category text, in the drop down. I'm using both a left and right column and would like to get the width of both the same. This isn't my live site but you can look here and see what I'm talking about. http://xtreme-rc-hobbies.net/store2/

 

I can control the width of everything but the $catmenu. Please help if you can.

 

Thanks

Share this post


Link to post
Share on other sites

Hi Bill, I am currently trying to use your Quick Horizontal Search in STS and I have entered the code but how do I call it to display on the page? Do i need to create a info box for it?

 

Any help I get here would be greatly appreciated! :)

 

Wendell

Share this post


Link to post
Share on other sites

Hi Bill,

 

I have downloaded your modernrc2a template and installed it and was pleased to see the quick horizontal search was included! Thank you for that contribution!

 

But now I have a new issue I am sure you will know the answer to. when i go to my home page now all I get is this message:

 

Fatal error: Call to undefined method breadcrumb::last() in /home/kelownac/public_html/index.php on line 336

 

I am assuming that something in the update has changed the way my breadcrumb works, but I am not savvy enough to know how to apply the fix.

 

I hope you or someone else may be able to help with this! :)

 

Thanks!

 

Wendell

Share this post


Link to post
Share on other sites

Hi Bill,

 

I have downloaded your modernrc2a template and installed it and was pleased to see the quick horizontal search was included! Thank you for that contribution!

 

But now I have a new issue I am sure you will know the answer to. when i go to my home page now all I get is this message:

 

Fatal error: Call to undefined method breadcrumb::last() in /home/kelownac/public_html/index.php on line 336

 

I am assuming that something in the update has changed the way my breadcrumb works, but I am not savvy enough to know how to apply the fix.

 

I hope you or someone else may be able to help with this! :)

 

Thanks!

 

Wendell

 

This is also happening when the checkout process is complete and the page tries to redirect.

 

Thanks!

 

Wendell

Share this post


Link to post
Share on other sites

Hey all, I'm not really sure this is where to post this but here goes. I'm using STS v4 and so far love it. I have only one problem that I just can't seem to find the answer to. I've searched here for a while. If the answer is here forgive me.

 

I'm looking for a way to control the width of the $catmenu. I found the question ask but never answered. I know the default is for it to set to the width of your longest category text, in the drop down. I'm using both a left and right column and would like to get the width of both the same. This isn't my live site but you can look here and see what I'm talking about. http://xtreme-rc-hobbies.net/store2/

 

I can control the width of everything but the $catmenu. Please help if you can.

 

Thanks

 

Okay, found a way to somewhat control the $catmenu width. It didn't matter if I used a set width in a table, the $catmenu would still stretch out to the width of the longest subcategory name. After searching and trying everything I could think of, I finally had the idea to remove the subcategories from the drop down. Turns out it worked great for me. Not only did it reduce the width so much that I have equal columns, it also much cleaned up the drop down menu. Not when a customer selects a category the content page that pulls up gives them the subcategories to choose. Quick, clean, and less confusing. All it takes is a manual edit of what this drop down displays. Hopes this helps someone.

Share this post


Link to post
Share on other sites

Hi Bill,

 

I have downloaded your modernrc2a template and installed it and was pleased to see the quick horizontal search was included! Thank you for that contribution!

 

But now I have a new issue I am sure you will know the answer to. when i go to my home page now all I get is this message:

 

Fatal error: Call to undefined method breadcrumb::last() in /home/kelownac/public_html/index.php on line 336

 

I am assuming that something in the update has changed the way my breadcrumb works, but I am not savvy enough to know how to apply the fix.

 

I hope you or someone else may be able to help with this! :)

 

Thanks!

 

Wendell

 

6 hours later I have found the error :lol:

 

the error is that the word "last" should read "trail" after loading modernrc2a template.

 

Cheers!

 

Wendell

Edited by wsandwith

Share this post


Link to post
Share on other sites

Hi all,

 

I have a question about the installation of STS in an existing OsC RC2.2 setup.

 

The manual states that, in case of an existing install, a couple of files have to be modified. I did this for all mentioned files and replaced them with the modified versions. It all works fine....except for one file! It is mentioned in the STS manual under: 2.5.1 catalog/admin/modules.php

 

When I performed the edit, for some reason the STS module in the Admin panel (under "modules") returns a blank page when I click on it. I have double and triple checked all modified files and I am sure it's THIS file causing the problem: catalog/admin/modules.php

 

Is there anyone who can help me with this?

I have pasted the to be modified code instructions (from the STS manual) below.

 

2.5.1 catalog/admin/modules.php

 

Find:

 

switch ($set) {

 

Add after

 

// START STS 4.1

case 'sts':

$module_type = 'sts';

$module_directory = DIR_FS_CATALOG_MODULES . 'sts/';

$module_key = 'MODULE_STS_INSTALLED';

define('HEADING_TITLE', HEADING_TITLE_MODULES_STS);

break;

// END STS 4.1

 

 

Find:

 

eval('$keys .= ' . $value['set_function'] . "'" . $value['value'] . "', '" . $key . "');");

} else {

 

Replace with:

 

eval('$keys .= ' . $value['set_function'] . "'" . $value['value'] . "', '" . $key . "');");

// STS V4.6 drop start

} else {

if($key == 'MODULE_STS_TEMPLATE_FOLDER'){

$dir_name = array();

if ($handle = opendir('../'.MODULE_STS_TEMPLATES_FOLDER.'/')) {

while (false !== ($file = readdir($handle))) {

$pos = strpos($file, ".");

if($pos === false){

$dir_name[] = array("id" => $file, "text" => $file);

$i++;

}

}

closedir($handle);

}

$keys .= tep_draw_pull_down_menu('configuration[MODULE_STS_TEMPLATE_FOLDER]', $dir_name, $value['value']);

}else{

$keys .= tep_draw_input_field('configuration[' . $key . ']', $value['value']);

}

}

// STS V4.6 drop end

Share this post


Link to post
Share on other sites

I'm trying to setup a product info page without the $content tag. I've changed the product_info module to reflect using the template, but can't seem to get the add to cart button to do anything. It shows up on the page, but doesn't actually link to the add the product to the cart. Am I missing something?

 

					<table style="width: 100%">
					<tr>
						<td>$imagelarge<br>
     					  </td>
					</tr>
					<tr>
						<td><center>
						<h2>Price per box:
						$regularprice</center></h2>
						</td>
					</tr>
					<tr>
						<td><center>
						$addtocartbutton</center></td>
					</tr>
				</table>

Share this post


Link to post
Share on other sites

 

 

 

Double check your modifications to the admin/modules.php file.

 

thumbsup.gif If it helps, compare your admin/modules.php with the one that came with the contribution as the modifications have already been made in that file to ease installation.


Bill Kellum

 

Sounds Good Productions

STS Tutorials & more: STSv4.6, STS Add-ons (STS Power Pack), STS V4 Forum STS Forum FREE TEMPLATE

Share this post


Link to post
Share on other sites

I'm trying to setup a product info page without the $content tag. I've changed the product_info module to reflect using the template, but can't seem to get the add to cart button to do anything. It shows up on the page, but doesn't actually link to the add the product to the cart. Am I missing something?

 

The product_info page is a big form. There are predefined tags $startform and $endform that you can use in your content template product_info.php.html to create the form easily. I guess that the thing you are missing is that you don't use them

 

You need to wrap the product related content into this form, everything that needs to be "sent" to the cart. You don't need to include ie related products or also purchased etc

Share this post


Link to post
Share on other sites

Hello, I have a little doubt.

 

I am modifying files to install the sts, particularly now the admin / includes / boxes / modules.php

 

according to the manual I have to look:

 

.'' BOX_MODULES_PAYMENT. ''

 

and then write:

 

/ / START STS 4.1

.'' BOX_MODULES_STS. .''

/ / END STS 4.1

 

Part of code is this:

 

if ($ selected_box == 'modules') (

$ Contents [] = array ('text' => '<a href="'. Tep_href_link(FILENAME_MODULES,'set=payment','NONSSL').'" Class="menuBoxContentLink">'. BOX_MODULES_PAYMENT. '</ a> <br> '.

'<a Href="'. Tep_href_link(FILENAME_MODULES,'set=shipping','NONSSL').'" Class="menuBoxContentLink">'. BOX_MODULES_SHIPPING. '</ A> <br>'.

'<a Href="'. Tep_href_link(FILENAME_MODULES,'set=ordertotal','NONSSL').'" Class="menuBoxContentLink">'. BOX_MODULES_ORDER_TOTAL. '</ A>');

)

and my question is .... :) Where is next? ... I guess it will be a triviality, but better to ask. I hope you can lend a hand. thanks

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×