Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Guest

[Contribution] STS v4

Recommended Posts

Guest
Bill,

 

One other thing I noted that may be of significance...in the includes/sts_user_code.php (which was removed from the server due to the upgrade) had included this snippet of code for the wishlist:

 

// Wish List 2.3 Start

$sts_block_name = 'wishlist';

require(STS_START_CAPTURE);

if (tep_session_is_registered('customer_id')) require(DIR_WS_BOXES . 'wishlist.php');

require(STS_STOP_CAPTURE);

$template['wishlist'] = strip_unwanted_tags($sts_block['wishlist'], 'wishlist');

// Wish List 2.3 End

 

I assume that this is theoretically replaced by this bit of code in the includes/modules/sts_inc/sts_user_code.php but I wasn't sure:

 

$sts->start_capture();

require(DIR_WS_BOXES . 'wishlist.php');

$sts->stop_capture('wishlist', 'box');

 

Jason

 

When translating from STS2 to STS4, you took away the 'if' condition that displays the box only to logged in users, which gives problem to not-logged in users as they don't have any customer ID, ID needed for the sql queries that retrieve the wishlist. Try this piece of code instead:

 

   $sts->start_capture();
  if (tep_session_is_registered('customer_id')) require(DIR_WS_BOXES . 'wishlist.php');
  $sts->stop_capture('wishlist', 'box');

 

- Rigadin

Share this post


Link to post
Share on other sites
When translating from STS2 to STS4, you took away the 'if' condition that displays the box only to logged in users, which gives problem to not-logged in users as they don't have any customer ID, ID needed for the sql queries that retrieve the wishlist. Try this piece of code instead:

 

   $sts->start_capture();
  if (tep_session_is_registered('customer_id')) require(DIR_WS_BOXES . 'wishlist.php');
  $sts->stop_capture('wishlist', 'box');

 

- Rigadin

 

Rigadin--

 

That worked! Things seem to be going smoothly now... Thanks so much!

 

Jason

Share this post


Link to post
Share on other sites
Guest
You may be able to use gzip by setting

zlib.output_compression = On

 

either in your php.ini or via a .htaccess file.

 

Worked for me!

 

HTH,

Iggy

 

Thanks Iggy

 

I put the following into top-level .htaccess and now have site-wide compression!!

 

php_flag zlib.output_compression On
php_value zlib.output_compression_level 5

 

Now I'm happy!!

 

Tony

Share this post


Link to post
Share on other sites
Becki, just scan through the instructions making sure you did not leave out any of the files that need to be copied over. The HTC version that I used was the 2.5.9 version since that one was found to be stable for me, but it would be VERY easy to make the updates to 2.5.9.1 if neccesary.

 

I will make the corrections in the installation text. Thanks for finding it.

 

-Bill Kellum

 

Bill,

 

I'm following your installation instructions for 'Upgrading from sts 4.0.7 to 4.2 and HTC'. I've got the point of comparing the HTC files with my own:

 

o catalog/admin/categories.php

o catalog/admin/manufacturers.php DONE

o catalog/admin/includes/filenames.php DONE

o catalog/admin/includes/column_left.php DONE

o catalog/admin/includes/functions/general.php

o catalog/admin/includes/lanquages/english.php DONE

o catalog/admin/includes/categories.php

o catalog/admin/includes/categories.php

 

I've done the easy ones! I started doing admin\categories which i think will never be right, I have open featured sets and ultrapics installed and it is proving to be an absolute nightmare, so many lines have been modded already that HTC mods aswell, I can't tell whats supposed to be copied and whats not, nor in which order, some things might not be commented in my original file aswell.

Anyway one of the problems is that for example HTC has 'text_product_description' whereas i have 'text_product_short' (presume is needed for featured sets), will leaving it as 'text_product_short' stop HTC working (this particular difference was in between the HTC comments) or do i have to put them both in - although i am no programmer so haven't got a clue what i'm doing!

 

My categories.php has 'stripslashes' in whereas the HTC doesn't - is the HTC file an older version?

 

Anyway, is there a function in winmerge that lets you copy only the different parts of a line to the other file - i.e it will combine the two? or does it only copy whole lines and sections as i'm doing at the moment. Although because of the differences in each line i'm having to manually copy and past litte bits anyway :(

 

OK - I couldn't find catalog/admin/includes/categories.php (and it's in the instruction twice?) in my store nor in the clean_osc set of files you gave?

 

Thanks for any help!!!

 

Becki

Share this post


Link to post
Share on other sites

Hello,

 

I have a problem :

 

I have installed the upload STS correctly and its work. But i try to add a new language the French and i have copy the file included in catalog\includes\languages\english\modules\sts into catalog\includes\languages\French\modules\sts

 

When i go on the website it look to work but when i go in the administator in Module STS i have error message :

 

Warning: main(c:/web/easyphp1-7/www/catalog/includes/languages/french/modules/sts/sts_default.php): failed to open stream: No such file or directory in c:\web\easyphp1-7\www\catalog\admin\modules.php on line 136

 

Warning: main(): Failed opening 'c:/web/easyphp1-7/www/catalog/includes/languages/french/modules/sts/sts_default.php' for inclusion (include_path='.;C:\WEB\EasyPHP1-7\php\pear\') in c:\web\easyphp1-7\www\catalog\admin\modules.php on line 136

 

 

Warning: main(c:/web/easyphp1-7/www/catalog/includes/languages/french/modules/sts/sts_index.php): failed to open stream: No such file or directory in c:\web\easyphp1-7\www\catalog\admin\modules.php on line 136

 

Warning: main(): Failed opening 'c:/web/easyphp1-7/www/catalog/includes/languages/french/modules/sts/sts_index.php' for inclusion (include_path='.;C:\WEB\EasyPHP1-7\php\pear\') in c:\web\easyphp1-7\www\catalog\admin\modules.php on line 136

 

Warning: main(c:/web/easyphp1-7/www/catalog/includes/languages/french/modules/sts/sts_product_info.php): failed to open stream: No such file or directory in c:\web\easyphp1-7\www\catalog\admin\modules.php on line 136

 

Warning: main(): Failed opening 'c:/web/easyphp1-7/www/catalog/includes/languages/french/modules/sts/sts_product_info.php' for inclusion (include_path='.;C:\WEB\EasyPHP1-7\php\pear\') in c:\web\easyphp1-7\www\catalog\admin\modules.php on line 136

 

I don't know what i must to do, please help me !

Share this post


Link to post
Share on other sites
Becki wrote:
My categories.php has 'stripslashes' in whereas the HTC doesn't - is the HTC file an older version?
It is from HTC version 2.5.9
Anyway, is there a function in winmerge that lets you copy only the different parts of a line to the other file - i.e it will combine the two? or does it only copy whole lines and sections as i'm doing at the moment. Although because of the differences in each line i'm having to manually copy and past litte bits anyway :(
Yes, that is what is so nice about using a file comparison tool such as WinMerge. You can make all of your changes within the program simply by sending only what is different from the file that is being compared one line at a time, so you are in complete control of the changes.
OK - I couldn't find catalog/admin/includes/categories.php (and it's in the instruction twice?) in my store nor in the clean_osc set of files you gave?

Thanks for any help!!!

Becki

Thanks for finding another mistake in the instructions. You are right. It should be as the following:

 

catalog/admin/categories.php

catalog/admin/manufacturers.php

catalog/admin/includes/filenames.php

catalog/admin/includes/column_left.php

catalog/admin/includes/functions/general.php

catalog/admin/includes/lanquages/english.php

catalog/admin/includes/languages/english/categories.php

 

Each one of the above files are in thier proper folder, just the instructions were messed up. I'm glad I haven't published the instructions on the Contributions page yet. We will have to assume these instructions to be in the "beta" stage until I finally get to publishing it on the osCommerce site. Thanks again for pointing these errors out. That's what is so great about open source software...Users helping Users!

 

By the way, I will post the exact changes in the files above on my web site as well as put them in the final release of the instructions.

 

Thanks,

 

Bill Kellum


Bill Kellum

 

Sounds Good Productions

STS Tutorials & more: STSv4.6, STS Add-ons (STS Power Pack), STS V4 Forum STS Forum FREE TEMPLATE

Share this post


Link to post
Share on other sites
Hello,

 

I have a problem :

 

I have installed the upload STS correctly and its work. But i try to add a new language the French and i have copy the file included in catalog\includes\languages\english\modules\sts into catalog\includes\languages\French\modules\sts

 

When i go on the website it look to work but when i go in the administator in Module STS i have error message :

 

Warning: main(c:/web/easyphp1-7/www/catalog/includes/languages/french/modules/sts/sts_default.php): failed to open stream: No such file or directory in c:\web\easyphp1-7\www\catalog\admin\modules.php on line 136

 

Warning: main(): Failed opening 'c:/web/easyphp1-7/www/catalog/includes/languages/french/modules/sts/sts_default.php' for inclusion (include_path='.;C:\WEB\EasyPHP1-7\php\pear\') in c:\web\easyphp1-7\www\catalog\admin\modules.php on line 136

 

 

Warning: main(c:/web/easyphp1-7/www/catalog/includes/languages/french/modules/sts/sts_index.php): failed to open stream: No such file or directory in c:\web\easyphp1-7\www\catalog\admin\modules.php on line 136

 

Warning: main(): Failed opening 'c:/web/easyphp1-7/www/catalog/includes/languages/french/modules/sts/sts_index.php' for inclusion (include_path='.;C:\WEB\EasyPHP1-7\php\pear\') in c:\web\easyphp1-7\www\catalog\admin\modules.php on line 136

 

Warning: main(c:/web/easyphp1-7/www/catalog/includes/languages/french/modules/sts/sts_product_info.php): failed to open stream: No such file or directory in c:\web\easyphp1-7\www\catalog\admin\modules.php on line 136

 

Warning: main(): Failed opening 'c:/web/easyphp1-7/www/catalog/includes/languages/french/modules/sts/sts_product_info.php' for inclusion (include_path='.;C:\WEB\EasyPHP1-7\php\pear\') in c:\web\easyphp1-7\www\catalog\admin\modules.php on line 136

 

I don't know what i must to do, please help me !

Are you referring to the STSv4.2 with Header Tags Controller 2.5.9? If so, the French folder has only been updated to allow Header Tags Controller to work in the admin using the French Language. It is not an STS module. It is an HTC module.

 

Hope this helps,

 

Bill Kellum


Bill Kellum

 

Sounds Good Productions

STS Tutorials & more: STSv4.6, STS Add-ons (STS Power Pack), STS V4 Forum STS Forum FREE TEMPLATE

Share this post


Link to post
Share on other sites
Guest
Hello,

 

I have a problem :

 

I have installed the upload STS correctly and its work. But i try to add a new language the French and i have copy the file included in catalog\includes\languages\english\modules\sts into catalog\includes\languages\French\modules\sts

 

When i go on the website it look to work but when i go in the administator in Module STS i have error message :

 

Warning: main(c:/web/easyphp1-7/www/catalog/includes/languages/french/modules/sts/sts_default.php): failed to open stream: No such file or directory in c:\web\easyphp1-7\www\catalog\admin\modules.php on line 136

 

Warning: main(): Failed opening 'c:/web/easyphp1-7/www/catalog/includes/languages/french/modules/sts/sts_default.php' for inclusion (include_path='.;C:\WEB\EasyPHP1-7\php\pear\') in c:\web\easyphp1-7\www\catalog\admin\modules.php on line 136

Warning: main(c:/web/easyphp1-7/www/catalog/includes/languages/french/modules/sts/sts_index.php): failed to open stream: No such file or directory in c:\web\easyphp1-7\www\catalog\admin\modules.php on line 136

 

Warning: main(): Failed opening 'c:/web/easyphp1-7/www/catalog/includes/languages/french/modules/sts/sts_index.php' for inclusion (include_path='.;C:\WEB\EasyPHP1-7\php\pear\') in c:\web\easyphp1-7\www\catalog\admin\modules.php on line 136

 

Warning: main(c:/web/easyphp1-7/www/catalog/includes/languages/french/modules/sts/sts_product_info.php): failed to open stream: No such file or directory in c:\web\easyphp1-7\www\catalog\admin\modules.php on line 136

 

Warning: main(): Failed opening 'c:/web/easyphp1-7/www/catalog/includes/languages/french/modules/sts/sts_product_info.php' for inclusion (include_path='.;C:\WEB\EasyPHP1-7\php\pear\') in c:\web\easyphp1-7\www\catalog\admin\modules.php on line 136

 

I don't know what i must to do, please help me !

 

 

I would try again with smallcap names (minuscules), I mean make a folder 'french' instead of 'French', same with the language code, 'fr' instead of 'FR'.

 

- Rigadin

Share this post


Link to post
Share on other sites

I installed STS v4.1 on a fresh OSC compilation. Everything works fine, until now when I am trying to design a content template.

 

My shop is centered and have a fixed width (955 px). The problem is that the product info page of the item that has the custom content template is much wider than the 955 px table limit. All the other products (ones with default template) display just fine within the set width of my webpage. I changed the table width in the content template to fit my existing website, but it didn't help at all, the width is still too wide and the alteration didn't seem to change anything.

 

Any help will be greatly appreciated.

Share this post


Link to post
Share on other sites
It is from HTC version 2.5.9

 

The stripslashes i'm referring to are not in the categories file you put on your website but are in my version of categories.php, and the piece of code isn't HTC commented. So it seemed it was only a difference in the basic file categories.php, I wondered if the categories.php that was edited with the HTC code was an old file to start with - hope this makes sense?! Anyway which is correct?!

 

Yes, that is what is so nice about using a file comparison tool such as WinMerge. You can make all of your changes within the program simply by sending only what is different from the file that is being compared one line at a time, so you are in complete control of the changes.Thanks,

 

Bill Kellum

 

OK i've been using the move left move right commands which moves a whole line etc but i didn't know you could move just say one word that is different - how do you do that?

 

I.e if you had two lines that were different (just for example - im sure this wouldn't make sense!);

 

1) include_once (DIR_WS_FUNCTIONS . 'clean_html_comments.php');

2) include_once (DIR_WS_FUNCTIONS . 'clean_html.php');

 

to

 

include_once (DIR_WS_FUNCTIONS . 'clean_html_comments.php' 'clean_html.php');

 

If i could do this it may help me out a lot because as i said im editing a line for HTC that has already been changed so i need to keep what was there before - i can't simply just paste over it with the HTC code.

 

Thank you

 

Becki

Share this post


Link to post
Share on other sites

I have STS 4.0.5 installed on MS2 Os commerce. But I having a problem with SSL.

When https is enabled some links came through correct with the https address, but appears some others appears only with the http. This is causing the page to display secure and non-secure content. Please Help!!!!

Share this post


Link to post
Share on other sites
Guest

Just added STS4.2

 

but under admin and modules

 

i get the link

 

BOX_MODULES_STS

 

which takes me to the sts modules page, and i have configured it according to the instructions but nothing happens to the site, no orangebar saying this is the default index.php

 

any ideas why?

Share this post


Link to post
Share on other sites
Just added STS4.2

 

but under admin and modules

 

i get the link

 

BOX_MODULES_STS

 

which takes me to the sts modules page, and i have configured it according to the instructions but nothing happens to the site, no orangebar saying this is the default index.php

 

any ideas why?

Re-check your installation. By the way, did you upgrade from STS Plus?

 

-Bill Kellum


Bill Kellum

 

Sounds Good Productions

STS Tutorials & more: STSv4.6, STS Add-ons (STS Power Pack), STS V4 Forum STS Forum FREE TEMPLATE

Share this post


Link to post
Share on other sites
I have STS 4.0.5 installed on MS2 Os commerce. But I having a problem with SSL.

When https is enabled some links came through correct with the https address, but appears some others appears only with the http. This is causing the page to display secure and non-secure content. Please Help!!!!

For starters, check your catalog/includes/configure.php. Some hosts have recently updated their cpanel accounts and for some strange reason, this has changed the code in several of my clients configure.php page. Most of the resulting problems have been broken image links but it is worth the effort to confirm all is well for you in this file.

 

Hope this helps,

 

Bill Kellum


Bill Kellum

 

Sounds Good Productions

STS Tutorials & more: STSv4.6, STS Add-ons (STS Power Pack), STS V4 Forum STS Forum FREE TEMPLATE

Share this post


Link to post
Share on other sites
Guest
I have STS 4.0.5 installed on MS2 Os commerce. But I having a problem with SSL.

When https is enabled some links came through correct with the https address, but appears some others appears only with the http. This is causing the page to display secure and non-secure content. Please Help!!!!

 

There was a bug with SSL links in first versions of STS4 (In fact at this time it was STS PLUS, a separate cotributions: versions 4.0.x are STS PLUS while versions >= 4.1 are official STS).

 

This bug has been fixed in STS PLUS 4.0.7, so you can upgrade to this version or to the latest STS version (v4.2 at this time).

 

- Rigadin

Share this post


Link to post
Share on other sites

Bill Kellum,

 

noted some differences in includes/classes/sts.php between STS4.2 and sts4.1 cally patch update. Can you elaborate as to why these differences below?

 

1. missing definintion of templates Images folder, why not include this definition

// Defines constants needed when working with templates
define('DIR_WS_TEMPLATE_IMAGES', STS_TEMPLATE_DIR . DIR_WS_IMAGES);

 

2. why not use not set function on line 47 ? v4.1 has

// Find the right template to use according to actual page and parameters. Displays normal output if no template returned
 if ( !tep_not_null($this->find_template()) ) {

versus in v4.2

  if ($this->find_template() == '') {

 

3. change in function update_from_url () drops support for PHP3 going from

function update_from_url () {
global $HTTP_GET_VARS, $sts_template_folder;

// Allow Debugging control from the URL
if ($HTTP_GET_VARS['sts_debug'] == MODULE_STS_DEBUG_CODE ) {
  $this->display_debug_output = true;
}

/*
$sts_template_id = $current_category_id; // *g*
*/
if (tep_not_null($HTTP_GET_VARS['sts_template'])) {
  $sts_template_folder = tep_db_prepare_input($HTTP_GET_VARS['sts_template']);
}

$template_folder_installed = explode (';', MODULE_STS_TEMPLATE_FOLDER);

  if ( !isset( $template_folder_installed[(int)$sts_template_folder] ) ) {  // default
  $sts_template_folder = 0;
   $this->template_folder = $template_folder_installed[$sts_template_folder];
} else {
  $this->template_folder = $template_folder_installed[(int)$sts_template_folder];
}

if (!tep_session_is_registered('sts_template_folder')) {
  tep_session_register('sts_template_folder');
}
 }

to

function update_from_url () {
// Allow Debugging control from the URL
if ($_GET['sts_debug'] == MODULE_STS_DEBUG_CODE) {
  $this->display_debug_output = true;
}

// Defines constants needed when working with templates
if ($_GET['sts_template']) {
  $this->template_folder = $_GET['sts_template'];
} else {
  $this->template_folder = MODULE_STS_TEMPLATE_FOLDER;
}
 }

4. why get rid global $PHP_SELF;

function find_template (){
 global $PHP_SELF;

Share this post


Link to post
Share on other sites

Bill Kellum,

one more thing instructions say that Differences from 4.1 to 4.2 include:

-Added: A new module parameter to set in admin.
You now have the choice to set STS to look for templates of parent categories.

what files are changed to see this parameter ?

Share this post


Link to post
Share on other sites

Are you seeing misplaced buffering as discussed in this post namely,

<!-- right_navigation_eof //-->
</table></td>
 </tr>
</table>
<!-- body_eof //-->

<!-- footer //-->
<!-- footer_eof //-->
</td></tr></table>
</body>
</html>
<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Strict //EN" "http://www.w3.org/TR/html4/strict.dtd">

if you updated STS 4.1 with Cally 's 14 Apr 2006 update.txt as I did, then that is the cause of your problem,

------------------------------------------
- catalog/includes/classes/sts.php
------------------------------------------
-> find ( in function start_capture )

  ob_end_clean(); // Clear out the capture buffer
  ob_start();

-> change to ( just del ob_end_clean(); ):

  ob_start();

is wrong. make sure to have

ob_end_clean(); // Clear out the capture buffer

in the block:

$block = ob_get_contents(); // Get content of buffer
ob_end_clean(); // Clear out the capture buffer
if ($block_name=='') return; // Not need to continue if we don't want to save the buffer

Share this post


Link to post
Share on other sites
Bill Kellum,

one more thing instructions say that Differences from 4.1 to 4.2 include:

-Added: A new module parameter to set in admin.
You now have the choice to set STS to look for templates of parent categories.

what files are changed to see this parameter ?

found it, I had to remove and reinstall admin > modules > sts > index to see this new parameter check parent template.

Share this post


Link to post
Share on other sites
The stripslashes i'm referring to are not in the categories file you put on your website but are in my version of categories.php, and the piece of code isn't HTC commented. So it seemed it was only a difference in the basic file categories.php, I wondered if the categories.php that was edited with the HTC code was an old file to start with - hope this makes sense?! Anyway which is correct?!

 

OK i've been using the move left move right commands which moves a whole line etc but i didn't know you could move just say one word that is different - how do you do that?

 

I.e if you had two lines that were different (just for example - im sure this wouldn't make sense!);

 

1) include_once (DIR_WS_FUNCTIONS . 'clean_html_comments.php');

2) include_once (DIR_WS_FUNCTIONS . 'clean_html.php');

 

to

 

include_once (DIR_WS_FUNCTIONS . 'clean_html_comments.php' 'clean_html.php');

 

If i could do this it may help me out a lot because as i said im editing a line for HTC that has already been changed so i need to keep what was there before - i can't simply just paste over it with the HTC code.

 

Thank you

 

Becki

 

Bill, anyone

 

Any pointers on these questions?

 

Thanks

 

Becki

 

Sorry to be a pain but trying to make the mods to cat.php are proving complicated to say the least, and I don't really know what needs to stay in due to the mods already made.

Share this post


Link to post
Share on other sites
Bill Kellum,

 

noted some differences in includes/classes/sts.php between STS4.2 and sts4.1 cally patch update. Can you elaborate as to why these differences below?

 

1. missing definintion of templates Images folder, why not include this definition

// Defines constants needed when working with templates
define('DIR_WS_TEMPLATE_IMAGES', STS_TEMPLATE_DIR . DIR_WS_IMAGES);

 

2. why not use not set function on line 47 ? v4.1 has

// Find the right template to use according to actual page and parameters. Displays normal output if no template returned
 if ( !tep_not_null($this->find_template()) ) {

versus in v4.2

  if ($this->find_template() == '') {

 

3. change in function update_from_url () drops support for PHP3 going from

function update_from_url () {
global $HTTP_GET_VARS, $sts_template_folder;

// Allow Debugging control from the URL
if ($HTTP_GET_VARS['sts_debug'] == MODULE_STS_DEBUG_CODE ) {
  $this->display_debug_output = true;
}

/*
$sts_template_id = $current_category_id; // *g*
*/
if (tep_not_null($HTTP_GET_VARS['sts_template'])) {
  $sts_template_folder = tep_db_prepare_input($HTTP_GET_VARS['sts_template']);
}

$template_folder_installed = explode (';', MODULE_STS_TEMPLATE_FOLDER);

  if ( !isset( $template_folder_installed[(int)$sts_template_folder] ) ) {  // default
  $sts_template_folder = 0;
   $this->template_folder = $template_folder_installed[$sts_template_folder];
} else {
  $this->template_folder = $template_folder_installed[(int)$sts_template_folder];
}

if (!tep_session_is_registered('sts_template_folder')) {
  tep_session_register('sts_template_folder');
}
 }

to

function update_from_url () {
// Allow Debugging control from the URL
if ($_GET['sts_debug'] == MODULE_STS_DEBUG_CODE) {
  $this->display_debug_output = true;
}

// Defines constants needed when working with templates
if ($_GET['sts_template']) {
  $this->template_folder = $_GET['sts_template'];
} else {
  $this->template_folder = MODULE_STS_TEMPLATE_FOLDER;
}
 }

4. why get rid global $PHP_SELF;

function find_template (){
 global $PHP_SELF;

A short answer: I have had several problems using cally's updates on a new install of osCommerce such as double headers, blank pages, errant code being displayed in the footer, etc. so I purposely left his edits out. I believe he needed those edits to make STS work on his modified osCommerce so that was great for him but not for the new installations.

 

-Bill Kellum


Bill Kellum

 

Sounds Good Productions

STS Tutorials & more: STSv4.6, STS Add-ons (STS Power Pack), STS V4 Forum STS Forum FREE TEMPLATE

Share this post


Link to post
Share on other sites
Bill, anyone

 

Any pointers on these questions?

 

Thanks

 

Becki

 

Sorry to be a pain but trying to make the mods to cat.php are proving complicated to say the least, and I don't really know what needs to stay in due to the mods already made.

Becki, I would suggest going to WinMerge.org and download the manual to get your detailed answers. I don't think it would be proper for me to outline what WinMerge can or can't do on the STS forum. With that said, I do believe it will do what you are looking for so give it a try...it's free.

Bill Kellum

 

Sounds Good Productions

STS Tutorials & more: STSv4.6, STS Add-ons (STS Power Pack), STS V4 Forum STS Forum FREE TEMPLATE

Share this post


Link to post
Share on other sites
A short answer: I have had several problems using cally's updates on a new install of osCommerce such as double headers, blank pages, errant code being displayed in the footer, etc. so I purposely left his edits out. I believe he needed those edits to make STS work on his modified osCommerce so that was great for him but not for the new installations.

 

-Bill Kellum

Bill, consider that

 

1. allows you to keep images related to chosen template in the same folder as that template

2. Semantics to use not set function is just being consistent with osComm development

3. Maintain PHP3 support for now

4. I am not sure about the reason behind that one, is it just security?

 

take care

Share this post


Link to post
Share on other sites

I hear that Credit Class & Gift voucher in both flavors install is a bear when u have STS. If you have integrated contribution CCGV contrib # 282 or CCGV(trad) contr # 4135 , plz chime in on how it went? any traps, mines, etc. to look for ?

Share this post


Link to post
Share on other sites
Bill, consider that

 

1. allows you to keep images related to chosen template in the same folder as that template

2. Semantics to use not set function is just being consistent with osComm development

3. Maintain PHP3 support for now

4. I am not sure about the reason behind that one, is it just security?

 

take care

Good comments. The 1-4 breakdown is very helpful. I have a test STS version with the above updates and will post if I experience any issues.

 

Thanks for the input, Bill Kellum


Bill Kellum

 

Sounds Good Productions

STS Tutorials & more: STSv4.6, STS Add-ons (STS Power Pack), STS V4 Forum STS Forum FREE TEMPLATE

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×