Jump to content
rigadin2

[Contribution] STS v4

Recommended Posts

By the way, I'm looking for the product tab contribution .

Is this contribution compatible with STS ?

 

thanks for your answer

Edited by numero7

STS 4.5.8

Share this post


Link to post
Share on other sites
By the way, I'm looking for the product tab contribution .

Is this contribution compatible with STS ?

 

thanks for your answer

 

 

Yes, it is compatible and the same thing applies regarding the Product Info "content" templates.


Bill Kellum

 

Sounds Good Productions

STS Tutorials & more: STSv4.6, STS Add-ons (STS Power Pack), STS V4 Forum STS Forum FREE TEMPLATE

Share this post


Link to post
Share on other sites
Jerry,

You would need to create a new STS tag in the includes/modules/sts_inc/sts_column_left.php file, under the current categorybox tag. Something like the following should do the trick:

 

<?php
/*
 $Id: sts_column_left.php,v 4.3.3 2006/03/12 22:06:41 rigadin Exp $

 osCommerce, Open Source E-Commerce Solutions
 [url="http://www.oscommerce.com"]http://www.oscommerce.com[/url]

 Copyright © 2005 osCommerce

 Released under the GNU General Public License

STS v4.3.3 by Rigadin (rigadin@osc-help.net)
Based on: Simple Template System (STS) - Copyright © 2004 Brian Gallagher - brian@diamondsea.com
*/

 $sts->restart_capture(); // Clear buffer but do not save it nowhere, no interesting information in buffer.
// Get categories box from db or cache  
 if ((USE_CACHE == 'true') && empty($SID)) {
   echo tep_cache_categories_box();
 } else {
   include(DIR_WS_BOXES . 'categories.php');
 }  
 $sts->restart_capture ('categorybox', 'box');  

// More Category Boxes contrib
$default_category_box_enabled_query = tep_db_query("select configuration_value from " . TABLE_CONFIGURATION . " where configuration_key = 'DEFAULT_CATEGORY_BOX_ENABLED' ");
$default_category_box_enabled = tep_db_fetch_array($default_category_box_enabled_query);

if ($default_category_box_enabled['configuration_value'] == 'true') {

 if ((USE_CACHE == 'true') && empty($SID)) {
   echo tep_cache_categories_box();
 } else {
   include(DIR_WS_BOXES . 'categories.php');
 }
}
 include(DIR_WS_BOXES . 'more_categories.php');
   $sts->restart_capture ('morecategorybox', 'box');
// More Category Boxes contrib  
{ 
// Get manufacturer box from db or cache  
 if ((USE_CACHE == 'true') && empty($SID)) {
   echo tep_cache_manufacturers_box();
 } else {
   include(DIR_WS_BOXES . 'manufacturers.php');
 }
 $sts->restart_capture ('manufacturerbox', 'box');

 require(DIR_WS_BOXES . 'whats_new.php');
 $sts->restart_capture ('whatsnewbox', 'box'); // Get What's new box

 require(DIR_WS_BOXES . 'search.php');
 $sts->restart_capture ('searchbox', 'box'); // Get search box

 require(DIR_WS_BOXES . 'information.php');
 $sts->restart_capture ('informationbox', 'box');  // Get information box

 require(DIR_WS_BOXES . 'shopping_cart.php');
 $sts->restart_capture ('cartbox', 'box'); // Get shopping cart box

 if (isset($HTTP_GET_VARS['products_id'])) include(DIR_WS_BOXES . 'manufacturer_info.php');
 $sts->restart_capture ('maninfobox', 'box'); // Get manufacturer info box (empty if no product selected)

 if (tep_session_is_registered('customer_id')) include(DIR_WS_BOXES . 'order_history.php');
 $sts->restart_capture ('orderhistorybox', 'box'); // Get customer's order history box (empty if visitor not logged)

 include(DIR_WS_BOXES . 'best_sellers.php');
 $sts->restart_capture ('bestsellersbox_only', 'box'); // Get bestseller box only, new since v4.0.5

// Get bestseller or product notification box. If you use this, do not use these boxes separately!  
 if (isset($HTTP_GET_VARS['products_id'])) {
   include(DIR_WS_BOXES . 'product_notifications.php');
$sts->restart_capture ('notificationbox', 'box'); // Get product notification box

// Get bestseller or product notification box. If you use this, do not use these boxes separately!    
   if (tep_session_is_registered('customer_id')) {
     $check_query = tep_db_query("select count(*) as count from " . TABLE_CUSTOMERS_INFO . " where customers_info_id = '" . (int)$customer_id . "' and global_product_notifications = '1'");
     $check = tep_db_fetch_array($check_query);
     if ($check['count'] > 0) {
       $sts->template['bestsellersbox']=$sts->template['bestsellersbox_only']; // Show bestseller box if customer asked for general notifications
     } else {
       $sts->template['bestsellersbox']=$sts->template['notificationbox']; // Otherwise select notification box
     }
   } else {
     $sts->template['bestsellersbox']=$sts->template['notificationbox']; // 
   }
 } else {
   $sts->template['bestsellersbox']=$sts->template['bestsellersbox_only'];
$sts->template['notificationbox']='';
 }

 include(DIR_WS_BOXES . 'specials.php');
 $sts->restart_capture ('specialbox', 'box'); // Get special box
 $sts->template['specialfriendbox']=$sts->template['specialbox']; // Shows specials or tell a friend

 if (isset($HTTP_GET_VARS['products_id']) && basename($PHP_SELF) != FILENAME_TELL_A_FRIEND) {
   include(DIR_WS_BOXES . 'tell_a_friend.php');
$sts->restart_capture ('tellafriendbox', 'box'); // Get tell a friend box
$sts->template['specialfriendbox']=$sts->template['tellafriendbox']; // Shows specials or tell a friend
 } else $sts->template['tellafriendbox']='';


// Get languages and currencies boxes, empty if in checkout procedure  
 if (substr(basename($PHP_SELF), 0, 8) != 'checkout') {
   include(DIR_WS_BOXES . 'languages.php');
   $sts->restart_capture ('languagebox', 'box');

   include(DIR_WS_BOXES . 'currencies.php');
   $sts->restart_capture ('currenciesbox', 'box');
 } else {
   $sts->template['languagebox']='';
   $sts->template['currenciesbox']='';
 }
 if (basename($PHP_SELF) != FILENAME_PRODUCT_REVIEWS_INFO) {
   require(DIR_WS_BOXES . 'reviews.php');
   $sts->restart_capture ('reviewsbox', 'box');  // Get the reviews box
 } else {
   $sts->template['reviewsbox']='';
 }
?>

 

Thank you for your time!!

Best regards

Jessica


Jessica Fuchs

Share this post


Link to post
Share on other sites

Hi,

 

I'm using STS and so far it's been good to me

 

When I open my page, it comes up with the standard page "new products for (month)". It gets the style from new_products.php.

 

There is another file product_listing.php, how do I set my site to load product_listing.php first by default, instead of new_products.php?

 

Thanks,

Eben

Share this post


Link to post
Share on other sites

Greetings Bill

 

Two questions, if I may

 

1)

A while back you posted this link and I would like to read up on how to integrate a "bought" template into STS - however the link doesn't seem to lead to the right place - Can you please re-post the link to the guide?

 

If your layout is a purchased template for osCommerce, see the following step by step guied on how to convert to a STS template: http://forums.oscommerce.com/index.php?sho...p;#entry1131089

 

 

2)

Why are there 2 forums for STS and which is really the "best" one to use? I posted question 1 in the other forum but didn't get a response (sorry for the double post!)

 

Thanks in advance

Sol

Share this post


Link to post
Share on other sites
Hi,

 

I'm using STS and so far it's been good to me

 

When I open my page, it comes up with the standard page "new products for (month)". It gets the style from new_products.php.

 

There is another file product_listing.php, how do I set my site to load product_listing.php first by default, instead of new_products.php?

 

Thanks,

Eben

 

 

Sorry, I had a weak moment. Sorted :blush:

Share this post


Link to post
Share on other sites
Greetings Bill

 

Two questions, if I may

 

1)

A while back you posted this link and I would like to read up on how to integrate a "bought" template into STS - however the link doesn't seem to lead to the right place - Can you please re-post the link to the guide?

 

 

 

 

2)

Why are there 2 forums for STS and which is really the "best" one to use? I posted question 1 in the other forum but didn't get a response (sorry for the double post!)

 

Thanks in advance

Sol

 

The link should still work.

 

Here it is again:

http://forums.oscommerce.com/index.php?sho...p;#entry1131089

 

Also, this forum is the "official" support thread for STS version 4 and above while the other forum is for older versions of STS.


Bill Kellum

 

Sounds Good Productions

STS Tutorials & more: STSv4.6, STS Add-ons (STS Power Pack), STS V4 Forum STS Forum FREE TEMPLATE

Share this post


Link to post
Share on other sites
The link should still work.

 

Here it is again:

http://forums.oscommerce.com/index.php?sho...p;#entry1131089

 

Also, this forum is the "official" support thread for STS version 4 and above while the other forum is for older versions of STS.

 

 

Hi Bill thanks for your reply.

 

You're right the link does work - however what I *meant* to say in my first post was - it doesn't seem to display the correct page? I couldn't find any relevant info on the pages surrounding that link. Admittedly I didn't search much beyond - was hoping you might recall the discussion thread and could find it faster than me...

 

Regards

Sol

 

 

UPDATE! Scrub that - I found it by SEARCHING for it *gasp* lol - It's on page 130 (post #2587) if anyone else wants to know! For some reason Bill's link takes you to the top of page 128 The lovely OSC forum software strikes again ;-)

Edited by ssnb

Share this post


Link to post
Share on other sites
UPDATE! Scrub that - I found it by SEARCHING for it *gasp* lol - It's on page 130 (post #2587) if anyone else wants to know! For some reason Bill's link takes you to the top of page 128 The lovely OSC forum software strikes again ;-)

 

Yep, that is the one. :rolleyes:


Bill Kellum

 

Sounds Good Productions

STS Tutorials & more: STSv4.6, STS Add-ons (STS Power Pack), STS V4 Forum STS Forum FREE TEMPLATE

Share this post


Link to post
Share on other sites

So..I have asked numerous questions on this forum since I have started my project. The only time i get a reply is when i post under the wrong topic. CAN SOMEONE PLEASE HELP ME FOR ONCE!?

 

My question is..

 

I am using STS. I am using the product info templates. What I would like to do is call the attributes individually instead of in one block. I need to be able to put attributes under different headings.

Example...Pizza

 

SIZE AND CRUST

-Size-?

-Crust-?

 

TOPPINGS

-Meats-?

-Veggies-?

Share this post


Link to post
Share on other sites
So..I have asked numerous questions on this forum since I have started my project. The only time i get a reply is when i post under the wrong topic. CAN SOMEONE PLEASE HELP ME FOR ONCE!?

 

My question is..

 

I am using STS. I am using the product info templates. What I would like to do is call the attributes individually instead of in one block. I need to be able to put attributes under different headings.

Example...Pizza

 

SIZE AND CRUST

-Size-?

-Crust-?

 

TOPPINGS

-Meats-?

-Veggies-?

 

Well, not with that attitude. You have only made 11 posts so I don't see that as "posting all over the place". In regards to posting all over the place, you should post only in the support thread that your request is specific to or you are for sure to be ignored. Remember, this is FREE support.

 

Regarding your question...

 

You are not going to be able to do that without coming up with some custom code on your part or searching the contribution area to see if someone has already done it for you.

 

Have you looked in the STSv4 Power Pack site for this (this is a site dedicated to all STS addons)?


Bill Kellum

 

Sounds Good Productions

STS Tutorials & more: STSv4.6, STS Add-ons (STS Power Pack), STS V4 Forum STS Forum FREE TEMPLATE

Share this post


Link to post
Share on other sites
Well, not with that attitude. You have only made 11 posts so I don't see that as "posting all over the place". In regards to posting all over the place, you should post only in the support thread that your request is specific to or you are for sure to be ignored. Remember, this is FREE support.

 

Regarding your question...

 

You are not going to be able to do that without coming up with some custom code on your part or searching the contribution area to see if someone has already done it for you.

 

Have you looked in the STSv4 Power Pack site for this (this is a site dedicated to all STS addons)?

 

 

Thank you. Thats all i wanted. An answer or some direction. I'm still new to posting on forums. I wasn't trying to have an attitude...... Its just that i see questions like, how do i change my font color being answered everywhere. I thought mine was a legitimate question that others might want to know. I only ask a question after I'm truly stumped. So, thank you.

Share this post


Link to post
Share on other sites
Thank you. Thats all i wanted. An answer or some direction. I'm still new to posting on forums. I wasn't trying to have an attitude...... Its just that i see questions like, how do i change my font color being answered everywhere. I thought mine was a legitimate question that others might want to know. I only ask a question after I'm truly stumped. So, thank you.

 

 

Take a look at the "Attribute Sort Copier" STS addon in the Power Pack site. That may be what you need.


Bill Kellum

 

Sounds Good Productions

STS Tutorials & more: STSv4.6, STS Add-ons (STS Power Pack), STS V4 Forum STS Forum FREE TEMPLATE

Share this post


Link to post
Share on other sites
Take a look at the "Attribute Sort Copier" STS addon in the Power Pack site. That may be what you need.

 

 

Yeah I tried that. It just gave a bunch of errors. I'll work around it or try and figure it out myself. Thank you again thou.

 

Another question..

 

I got live support phponline mod installed. How can i capture that to work properly in STS?

Share this post


Link to post
Share on other sites

Hello,

 

I am using OS Commerce 2.2rc2 with STSv458. I would like to have a page where a user can choose between 2 products and add either of them to their cart from that page. Is there a way to do this?

 

To clarify, I would like one page showing multiple products and enabling a user to go directly from the multiple product view page to add any single product to their cart without having to first go to a specific page for that individual product.

 

Thanks for any and all help & suggestions.

Share this post


Link to post
Share on other sites
Hello,

 

I am using OS Commerce 2.2rc2 with STSv458. I would like to have a page where a user can choose between 2 products and add either of them to their cart from that page. Is there a way to do this?

 

To clarify, I would like one page showing multiple products and enabling a user to go directly from the multiple product view page to add any single product to their cart without having to first go to a specific page for that individual product.

 

Thanks for any and all help & suggestions.

 

maybe you can adapt this ? http://addons.oscommerce.com/info/6842


STS 4.5.8

Share this post


Link to post
Share on other sites

Thanks numero7... I'm a little hesitant to add new contributions at this point but I will look into that one more...

 

I think i may have found an answer to my question by looking at Google Chrome's "inspect element" on some other OSCommerce websites... If i make a web link like the following it seems to add the specific product to the cart.

 

http://www.yourwebsite.com/product_info.ph...;products_id=28

 

So i can simply make an image or type some text and use an <a href=...> to bypass the individual product page and go right to the beginning of the check out process. I'm not sure if there is a better way to accomplish my goal of having multiple products ready to purchase from a single page but this way seems to do the trick!

 

I'm still open to alternate suggestions if someone out there has any...

 

As well if anyone thinks my work around is a bad idea i would definitely like to hear about it.

Share this post


Link to post
Share on other sites
Thanks numero7... I'm a little hesitant to add new contributions at this point but I will look into that one more...

 

I think i may have found an answer to my question by looking at Google Chrome's "inspect element" on some other OSCommerce websites... If i make a web link like the following it seems to add the specific product to the cart.

 

http://www.yourwebsite.com/product_info.ph...;products_id=28

 

So i can simply make an image or type some text and use an <a href=...> to bypass the individual product page and go right to the beginning of the check out process. I'm not sure if there is a better way to accomplish my goal of having multiple products ready to purchase from a single page but this way seems to do the trick!

 

I'm still open to alternate suggestions if someone out there has any...

 

As well if anyone thinks my work around is a bad idea i would definitely like to hear about it.

 

good idea but in my opinion it will work with small catalog. if you have large catalog it can be tricky to edit each product linked if for example you want delete one position... (hope i'm clear because my english is not so perfect)


STS 4.5.8

Share this post


Link to post
Share on other sites
Hello,

 

I am using OS Commerce 2.2rc2 with STSv458. I would like to have a page where a user can choose between 2 products and add either of them to their cart from that page. Is there a way to do this?

 

To clarify, I would like one page showing multiple products and enabling a user to go directly from the multiple product view page to add any single product to their cart without having to first go to a specific page for that individual product.

 

Thanks for any and all help & suggestions.

 

This is a standard feature in osCommerce. Set it up in the admin.

  • Display cart after adding product
  • Display Buy Now Column

There you go.


Bill Kellum

 

Sounds Good Productions

STS Tutorials & more: STSv4.6, STS Add-ons (STS Power Pack), STS V4 Forum STS Forum FREE TEMPLATE

Share this post


Link to post
Share on other sites

Hi to all, I have a question:

 

Lets say I want to create a link to an existing page in my template, lets say specials.php. So I have 2 options to do this with the same result:

 

1) I add into my template directly

		<a href="<?php echo tep_href_link(FILENAME_SPECIALS); ?>"  class="linSt1"><?php echo(LINK_SPECIALS); ?></a>

 

2) I make a tag that includes the link and text

 $sts->template['specials'] = '<a href=' . tep_href_link(FILENAME_SPECIALS) .' class="linSt1">' .  LINK_SPECIALS . '</a>';

 

and then I use $specials in my template

 

(Language definition for LINK_SPECIALS exist of course)

 

My question: Does any of this 2 ways has any handicaps compared to the other? Should one of the 2 be avoided?

Share this post


Link to post
Share on other sites
Pat,

 

The modern template for STS uses the following tag to bring in the logo: $cataloglogo

 

Did you try removing the tag? This would be the most obvious first step to take as I mentioned you can easily add any image directly to your template page just as you would any HTML page.

 

Otherwise, you could edit the tag to your liking. All STS tags are created in the includes/modules/sts_inc/ files.

 

The $cataloglogo tag is created in this file: includes/modules/sts_inc/general.php

 

This is the code in that file:

 

	$sts->template['cataloglogo'] = '<a href="' . tep_href_link(FILENAME_DEFAULT) . '">' . tep_image(STS_TEMPLATE_DIR.'images/'.$language . '/header_logo.gif', STORE_NAME) . '</a>'; // Modified in v4.3

 

So, as you can see in the code, the actual image being used is header_logo.gif.

  1. You could either upload an image using the same file name.
  2. You could simply remove the tag and then add your image directly to the template
  3. You could edit the tag to display the image that you want to use.

 

 

 

How do I change this so that i cn use the STORE_LOGO instead of the filename, in my header.php.html file?

 

Thanks


Getting better with mods but no programmer am I.

Share this post


Link to post
Share on other sites

I installed STS and have created some templates but I'm having trouble finding the location to change the font size. for example I have the following code for the catalog_shopping_cart.php.html file:

<table border="0" cellpadding="0" cellspacing="1" width="100%">
 <tr>
   <td width="100%">
   <table border="0" cellpadding="0" cellspacing="0" width="100%">
     <tr>
       <td width="100%"><font face="Eras Demi ITC" size="6" color="#FF0000">
       xxxxxxxxxxx</font><p>
       <font face="Eras Demi ITC" size="6" color="#FF0000">
       $content 

       </font></p>
       <p><font face="Eras Demi ITC" size="6" color="#FF0000">
       xxxxxxxxxxx</font></td>
     </tr>
   </table>
   </td>
 </tr>
</table>

 

The code created the following:cart.jpg

 

As you can see the "Eras Demi ITC" font works for all the text, but the color and size only worked on the Xs I added for this example. I realize the remainder of the font would be controlled elsewhere to allow the proper color for the links, etc.. My question is - Where is this controlled? I tried changing the stylesheet but no luck. All I really need to do is decrease the font size to 10pt. I just can't seem to find the right place to get this done.

 

Thanks

Dale

Share this post


Link to post
Share on other sites

Hello,

 

I am running sts v4 with a bunch of add ons. I have been running my store for about a year with no trouble, I use lightbox2 with no problem but now I wanted to do a custom template product info page so i activated the option in the admin, everything works great except the lightbox no longer works and the large images just open to a new page, I am sure its a simple fix but been trying for two days and can't find what the problem is. I also have installed more pics 6

 

Thanks in advance.

Share this post


Link to post
Share on other sites

Hello,

 

I am running sts v4 with a bunch of add ons. I have been running my store for about a year with no trouble, I use lightbox2 with no problem but now I wanted to do a custom template product info page so i activated the option in the admin, everything works great except the lightbox no longer works and the large images just open to a new page, I am sure its a simple fix but been trying for two days and can't find what the problem is. I also have installed more pics 6

 

Thanks in advance.

 

 

http://addons.oscommerce.com/info/1032

 

i think this may help me, i will post when i am done.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×