Jump to content
rigadin2

[Contribution] STS v4

Recommended Posts

I really hope someone reads this and can offer a suggestion. It seems that all of a sudden my product info pages stopped reading the CSS file. I was working on only one page trying to get a background to show up in the middle section. The only thing I altered in the CSS file was that I created a class for the background. Then I put the class on one page and all of a suddenbow none of my 20 info pages are reading the CSS file. I even removed the class from the CSS file and still did not change anything. This is really strange that it is doing this and I can not understand why. Can anyone else offer any tips/

Pat

Share this post


Link to post
Share on other sites
I really hope someone reads this and can offer a suggestion. It seems that all of a sudden my product info pages stopped reading the CSS file. I was working on only one page trying to get a background to show up in the middle section. The only thing I altered in the CSS file was that I created a class for the background. Then I put the class on one page and all of a suddenbow none of my 20 info pages are reading the CSS file. I even removed the class from the CSS file and still did not change anything. This is really strange that it is doing this and I can not understand why. Can anyone else offer any tips/

Pat

 

Are you sure it does not have anything to do with your browser cache setting? Try viewing your site using a different computer to help rule this out or clear the cache in the browser.


Bill Kellum

 

Sounds Good Productions

STS Tutorials & more: STSv4.6, STS Add-ons (STS Power Pack), STS V4 Forum STS Forum FREE TEMPLATE

Share this post


Link to post
Share on other sites
Sorry, if the question was asked already (I used the search, but could not read 255 pages of answers :blink: )

 

I want to use my own product_info content area.

 

I put my own product_info.php.html in the content directory and I installed the STS product_info module in the admin area.

 

But nothing happend - the default template is shown.

 

Can anybody help me with this question.

I really hate it when someone posts a negative comment such as "255 pages of answers". That is like saying there is just too many words in a dictionary or this encyclopedia has just too much information. I see the length of this support thread as a VERY positive thing. But, just like any source of information, you need to learn how to find what you need....

 

First, the forum search function is a big waste of time. Use Google instead.

 

Here are some Google search tips:

 

Search the entire forum:

site:forums.oscommerce.com sts

site:forums.oscommerce.com "insert your search text here without the quotes"

 

Search the contributions:

site:http://www.oscommerce.com/community/contributions simple template system

site:http://www.oscommerce.com/community/contributions "insert the search contribution name here without the quotes"

 

Search the STSv4 Support thread:

site:forums.osCommerce.com [Contribution] sts v4

site:forums.osCommerce.com [Contribution] sts v4 "insert contribution support thread heading here without the quotes"

 

 

Hope that helps you find what you need in this valuable source of information. ;)


Bill Kellum

 

Sounds Good Productions

STS Tutorials & more: STSv4.6, STS Add-ons (STS Power Pack), STS V4 Forum STS Forum FREE TEMPLATE

Share this post


Link to post
Share on other sites
Hi

 

I want to edit the conent part of my homepage of my shop. Should I make a new template based on test/sts_template.html, rename it index.php_0.html, remove the $content placeholder and replace it with my own content...

 

Yes, you can easily do it as you described (this is the preferred method for the home page template). For other pages, you will need to either edit the actual PHP source or create a content template that will used where you have the $content tag.

 

See the following post regarding content templates:

 

http://forums.oscommerce.com/index.php?sho...p;#entry1303553


Bill Kellum

 

Sounds Good Productions

STS Tutorials & more: STSv4.6, STS Add-ons (STS Power Pack), STS V4 Forum STS Forum FREE TEMPLATE

Share this post


Link to post
Share on other sites
Can anyone offer any tips on modifying the content template. (product.info.php_26.html I have looked it over but there seems to be lots of place holders in it that are already in the left and right columns. And yes I have been reading on this I just wish that the person who made these instructions in PDF format also made them in .doc the text in the pdf file is so small even with my glasses on I cant read what I printed, and i'm the type that like to print and read and study away from the PC.

Pat

 

I wrote the documents. The STS User Manual is in Microsoft Word format, at least the latest version is (STSv4.5.8).


Bill Kellum

 

Sounds Good Productions

STS Tutorials & more: STSv4.6, STS Add-ons (STS Power Pack), STS V4 Forum STS Forum FREE TEMPLATE

Share this post


Link to post
Share on other sites
Well since there are 254 pages of info and search isn't narrowing things down beyond telling me somewhere in the 254 pages might be my answer, guess I'll post and see what I get. After searching and reading for a couple days now I still don't have an answer so here goes.

 

Got a new osc setup, with the STS 4.5.8 setup, managed to work with my stylesheet and get satisfied for an initial setup. Think I have the Carousel setup already, once I get to adding it to a template (not verified yet but all file mods and uploads have been made)

 

The store has about 8 catagories, 2 of which I want to have the $content display a repeating table of the catalog (almost 500 items in one catagory and 100 in the other) 4 or 5 columns of icons linking to product details. I have DW CS4 so this is no problem, I can do, without to much loss of hair.

 

Figure I need to create an html template for the $content area. As I see so far, I create an html as 'tabledisplay.php.html' in the '/catalog/includes/sts_templates/full/content' folder, how do I call it to $content when someone selects one of the 2 catagories only.

 

My Html is fairly good, but my php and java is "just enough to be dangerous".

 

See the Search Tips just a few posts above this:

 

http://forums.oscommerce.com/index.php?s=&...t&p=1393024


Bill Kellum

 

Sounds Good Productions

STS Tutorials & more: STSv4.6, STS Add-ons (STS Power Pack), STS V4 Forum STS Forum FREE TEMPLATE

Share this post


Link to post
Share on other sites
How do you test templates without changing the template in admin. I dont want to disturb my clients.

Pat

 

 

The STS User Manual for STSv4.5.8 has a chapter on this very subject. Very simple to do.


Bill Kellum

 

Sounds Good Productions

STS Tutorials & more: STSv4.6, STS Add-ons (STS Power Pack), STS V4 Forum STS Forum FREE TEMPLATE

Share this post


Link to post
Share on other sites

Thanks Bill, yes I have your DOC that came with the add-on, but this one is one that I downloaded seperately. It may have been written by Rigadin2 he says it is you manual but in PDF format, yet his shows stuff yours does not. Maybe there was a problem with the download but in your document there are a few links like product info module documentation does not work it says page does not exist. So I have read the other pdf file with a little trouble and tried to follow those instructions. I did notice something on your doc. 3.9.2 If i understand this correct it says that for example the content section of the page template to work it needs to be located in the content folder. Is that what I am to understand? If so that my be my problem I did not store them in that folder. Please advise then let me know about the documentation I seem to be missing. Please understand I have been doing lots of reading and learning but get confused at times with some things I dont fully understand

Pat

Share this post


Link to post
Share on other sites
I really hate it when someone posts a negative comment such as "255 pages of answers". That is like saying there is just too many words in a dictionary or this encyclopedia has just too much information. I see the length of this support thread as a VERY positive thing. But, just like any source of information, you need to learn how to find what you need....

 

 

Hope that helps you find what you need in this valuable source of information. ;)

 

I totally agree that I have to learn how to find the information - and thanks for the tipps.

 

I didn't want to annoy you. I had just hours of searching with no result - so I was annoyed. Sorry.

 

I thought I could use the forum without other search methods like google. Often you have in forums sub-categories for such a big theme lik sts. But it is like it is - I will now use google.

Share this post


Link to post
Share on other sites
I totally agree that I have to learn how to find the information - and thanks for the tipps.

 

I didn't want to annoy you. I had just hours of searching with no result - so I was annoyed. Sorry.

 

I thought I could use the forum without other search methods like google. Often you have in forums sub-categories for such a big theme lik sts. But it is like it is - I will now use google.

 

Yeah, for some reason the search function in this forum will not work properly when searching using smaller words. Since Google crawls this thread, it is better to use Google as you will get what you are looking for a lot faster.

 

I agree about the sub-categories but we have to deal with how this forum is setup. Let me know if you can't find what you are looking for after using the Google methods.


Bill Kellum

 

Sounds Good Productions

STS Tutorials & more: STSv4.6, STS Add-ons (STS Power Pack), STS V4 Forum STS Forum FREE TEMPLATE

Share this post


Link to post
Share on other sites

Light box contribution? Can anyone tell me exactly what this is? Is it a full template or just an add-on for other templates. Also which one works best with STS? How will it change the look to the site?

Pat

Share this post


Link to post
Share on other sites

Hi,

 

I have template.html which includes the overall layout and contains $content, $categories, and a few other variables.

 

I wanted to change the way login.php looks so I created a login.php.html file and placed it in the /contents/ directory. So when I visit example.com/login.php shouldn't it invoke the template.html file and replace the $content var with the data that's in login.php.html?

 

Am I understanding this correctly?

Share this post


Link to post
Share on other sites

HTC and STS 4.5.8 Is there an HTC add-on for STS 4.5.8 I found one that included 4.5.2 but not one for 4.5.8 I don't want to regress on my STS version so what is recommended.

Pat

Share this post


Link to post
Share on other sites

It seems like I may have found out part of my content template problem. However when I select use templates for product info from the admin section and place the templates in the content section they do not read the CSS file. Should I place a copy of the CSS file in the content folder or is it just a matter of figuring out the correct relative URL to use?

Pat

Share this post


Link to post
Share on other sites

never mind on that last post it was asier to just put a copy of my stylesheet.css file in the content folder than to try to figure the url path. Now to test the content background.

Pat

Share this post


Link to post
Share on other sites
never mind on that last post it was asier to just put a copy of my stylesheet.css file in the content folder than to try to figure the url path. Now to test the content background.

Pat

 

 

$templatedir/stylesheet.css


Bill Kellum

 

Sounds Good Productions

STS Tutorials & more: STSv4.6, STS Add-ons (STS Power Pack), STS V4 Forum STS Forum FREE TEMPLATE

Share this post


Link to post
Share on other sites
Remove each STS module in the admin by clicking on the "Remove" button. This will remove it from the cache and clear the temp database. Then log out of your admin. Now, log into your admin and install the STS Default module and leave the existing settings except for changing the template folder from "test" to "full".

 

Check your shop to see if everything is OK.

 

Im facing the same problem and Ive tried ur steps

1) Remove STS module

2) Log Out from admin

3) Log in admin

4) Install STS default

when i checked at shop its ill displaying same error ..

Hope you can help

Share this post


Link to post
Share on other sites

Thanks Bill that helps. Now that things are sinking in maybe i can get things the way i want them. I just need the HTC that will work with STS 4.5.8

Share this post


Link to post
Share on other sites
Im facing the same problem and Ive tried ur steps

1) Remove STS module

2) Log Out from admin

3) Log in admin

4) Install STS default

when i checked at shop its ill displaying same error ..

Hope you can help

 

Problem solved!

After I install i changed the base folder, the error occur because i changed it ..

Share this post


Link to post
Share on other sites
Thanks Bill that helps. Now that things are sinking in maybe i can get things the way i want them. I just need the HTC that will work with STS 4.5.8

 

See the following:

 

http://forums.oscommerce.com/index.php?sho...p;#entry1086557

 

Or

 

Install HTC SEO (the latest version has STS installation instructions by Jack and myself).

Edited by bkellum

Bill Kellum

 

Sounds Good Productions

STS Tutorials & more: STSv4.6, STS Add-ons (STS Power Pack), STS V4 Forum STS Forum FREE TEMPLATE

Share this post


Link to post
Share on other sites

I made template.html which includes the overall layout of the site and contains $content, $categories, and a few other variables.

 

I wanted to change the way login.php looks so I created a login.php.html file and placed it in the /contents/ directory. So when I visit example.com/login.php shouldn't it invoke the template.html file and replace the $content var with the data that's in login.php.html?

 

Thanks for the help

Share this post


Link to post
Share on other sites

My Account, Cart Content & Checkout issues.

Hi,

I'm a Newbie to website building - have installed OSC 2.2 rc2a, then STSv458, then the modernrc2a template - but I can't get things like "My Account" to work. I just get the following error with anything on the top menu bar:

 

click "My Account" - The server can not find the requested page:

 

<mysitename>/account.php (port 443)

 

click "Cart Contents" - The server can not find the requested page:

 

<mysitename>/shopping_cart.php (port 443)

 

click "Checkout" - The server can not find the requested page:

 

<mysitename>/checkout_shipping.php (port 443)

 

These files are on my root dir (where I installed OSC) - but I'm still not sure how all this hangs together once I've installed STS & I'm pointed at the modernrc2a template.

 

If someone could point me at some documentation on how to switch common features on I would be very grateful.

 

Thanks

Silver

Share this post


Link to post
Share on other sites

Thanks Bill I tried the link you gave me and it messed up my program so bad I could not even reverse what I did to get it working. I had to reinstall the whole program. :-(

Pat

Share this post


Link to post
Share on other sites
Thanks Bill I tried the link you gave me and it messed up my program so bad I could not even reverse what I did to get it working. I had to reinstall the whole program. :-(

Pat

 

Too bad. I have had 100's of users let me know the step by step worked perfectly for them. I also have installed several HTC installations using my method with no issues at all. It pays to follow the instructions to a tee as well as make a backup before you do anything to your shop.


Bill Kellum

 

Sounds Good Productions

STS Tutorials & more: STSv4.6, STS Add-ons (STS Power Pack), STS V4 Forum STS Forum FREE TEMPLATE

Share this post


Link to post
Share on other sites
My Account, Cart Content & Checkout issues.

Hi,

I'm a Newbie to website building - have installed OSC 2.2 rc2a, then STSv458, then the modernrc2a template - but I can't get things like "My Account" to work. I just get the following error with anything on the top menu bar:

 

click "My Account" - The server can not find the requested page:

 

<mysitename>/account.php (port 443)

 

click "Cart Contents" - The server can not find the requested page:

 

<mysitename>/shopping_cart.php (port 443)

 

click "Checkout" - The server can not find the requested page:

 

<mysitename>/checkout_shipping.php (port 443)

 

These files are on my root dir (where I installed OSC) - but I'm still not sure how all this hangs together once I've installed STS & I'm pointed at the modernrc2a template.

 

If someone could point me at some documentation on how to switch common features on I would be very grateful.

 

Thanks

Silver

 

There are two versions of the "modern RC2a" template; a STS version by me and a stock osC version. Which one did you install?

 

DId your shop work properly before you installed the template? Did it work properly before you installed STS?


Bill Kellum

 

Sounds Good Productions

STS Tutorials & more: STSv4.6, STS Add-ons (STS Power Pack), STS V4 Forum STS Forum FREE TEMPLATE

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×