Jump to content
rigadin2

[Contribution] STS v4

Recommended Posts

Hello :)

 

I'm hoping somewhere here can point me in the right direction as to what files I should be double checking. I am trying to add an option to a slave product. For some reason it isn't showing up when viewing the Master or when clicking to Buy Now or Add to Cart. I can see options if I apply them to the Master products, but not to the Slaves. I do realize that this is the STS thread and not the Master Products thread - but I'm pretty sure there is an STS page that affects the display of the product_info.php file - isn't there?

 

I can find php coding for options on the catalog/product_info.php file and on the includes/modules/master_listing.php file. However, I don't have any options coding on the includes/modules/product_listing.php file. Should I? Any other files you can think of that I should check for the display of products? Should the options show in the cart?

 

Sorry - I've done so much modification and it was so long ago that I'm trying to jog my memory :blush:


~Tracy
 

Share this post


Link to post
Share on other sites

I've looked through this post and cannot find the answer to my question. I apologize if I overlooked it.

 

What is the purpose of the second "template folder" in STS? One is "test" and the other is "full". How are they different?

Share this post


Link to post
Share on other sites

The spanish dude deleted the english instructions from the package... Instead of just adding spanish. :blink:

Edited by Jammerious

Share this post


Link to post
Share on other sites
I've looked through this post and cannot find the answer to my question. I apologize if I overlooked it.

 

What is the purpose of the second "template folder" in STS? One is "test" and the other is "full". How are they different?

 

Steve,

 

I provided both folders as "sample" template folders to give you an idea of how to structure your own template folder as well as fill you in on the fact that you can have as many template folders that you want. For example: Holidays, Seasons, Special Sale Events, etc.

 

NOTE: The test folder has a template in it called "blank". The purpose of this template is to simply show you what specific STS Tags are needed in EACH of your template pages to make them work with STS.


Bill Kellum

 

Sounds Good Productions

STS Tutorials & more: STSv4.6, STS Add-ons (STS Power Pack), STS V4 Forum STS Forum FREE TEMPLATE

Share this post


Link to post
Share on other sites
The spanish dude deleted the english instructions from the package... Instead of just adding spanish. :blink:

 

 

Thanks for the heads up. I will try to get a new release posted soon.


Bill Kellum

 

Sounds Good Productions

STS Tutorials & more: STSv4.6, STS Add-ons (STS Power Pack), STS V4 Forum STS Forum FREE TEMPLATE

Share this post


Link to post
Share on other sites

Hello,

 

I hope this is in the correct place... I have searched the forums and have not been able to find help for this...

 

I have installed a fresh version of OSC 2.2rc2a and then immediately installed STS 4.5.8. I followed the instructions for the install, then I went and enabled STS in the admin.

 

I then went to view my store and all I am seeing is a white page with this error:

 

Fatal error: Call to a member function add_current_page() on a non-object in /home/bout/public_html/store/catalog/includes/application_top.php on line 312

 

Prior to installing STS, everything was working fine. I had not changed any "out of the box" settings yet. If anyone can assist me with this I would be very grateful!

 

Thank you,

Sarah

Edited by mom2twins

Share this post


Link to post
Share on other sites

Uninstalling and reinstalling everything fixed the problem. Not sure why the error was there in the first place as I did nothing different the second time around. :huh:

Share this post


Link to post
Share on other sites

I did the install kind of easy if I may add. I got a little confused and did the file uploads then also procedded to do the manual install. That kind of messed things up. I set the template folder as test like the instructions stated. It worked fine, if you consider the same regular OSC layout with the exception of the wording about the template being used. I installed STS 4.5.8 on Ver.2.2 RC 2a. I was reading the manual and it said somthing about mysite for the template so I changed the template folder from test to mysite. I know stupid. Then all I got was error messages so I changed the template folder back to test now I get the message on top of the page saying... "Template file does not exist: [includes/sts_templates/Test/sts_template.html]"... Anyone tell me what I did wrong and how to fix it. I am going to have to read this manual complete before trying to install, make, or modify templates. I hope it is not hard?

Pat

Share this post


Link to post
Share on other sites
I did the install kind of easy if I may add. I got a little confused and did the file uploads then also procedded to do the manual install. That kind of messed things up. I set the template folder as test like the instructions stated. It worked fine, if you consider the same regular OSC layout with the exception of the wording about the template being used. I installed STS 4.5.8 on Ver.2.2 RC 2a. I was reading the manual and it said somthing about mysite for the template so I changed the template folder from test to mysite. I know stupid. Then all I got was error messages so I changed the template folder back to test now I get the message on top of the page saying... "Template file does not exist: [includes/sts_templates/Test/sts_template.html]"... Anyone tell me what I did wrong and how to fix it. I am going to have to read this manual complete before trying to install, make, or modify templates. I hope it is not hard?

Pat

 

Hmm....

Is "Test" the same as "test"?

 

You should pay attention to the error messages as most of the time they will give you a clue as to where you went wrong.


Bill Kellum

 

Sounds Good Productions

STS Tutorials & more: STSv4.6, STS Add-ons (STS Power Pack), STS V4 Forum STS Forum FREE TEMPLATE

Share this post


Link to post
Share on other sites

Wow thanks Bill I did not see that I know enough about upper and lower case letters in html. Now to continue reading the manual and start playing to get this site looking the way I want it to.

Pat

Share this post


Link to post
Share on other sites

I'm really sorry if some of this has been answered already, I have searched and searched and haven't been able to find specific answers. I've been trying to wrap my brain around this all day so I can get a better shopping cart system going for my boutique, so I apologize if any of this has been covered.

 

Am I correct in understanding that only certain add ons can be used while using STS? If so, is this a complete list of the add ons that are available to use while using STS?

http://www.oscommerce.com/community/contributions,4456

 

I am really, really wanting to use this Propay add on. Is it possible to use this while using STS?

http://addons.oscommerce.com/info/6539

 

Lastly, is there an add on that is compatible with STS that allows you to add more options when adding a product? Such as color, size, etc. Also, is there an add on that is compatible with STS that makes urls search engine friendly? I didn't see either on the link I specified above, but I could be missing it. I have been up way too long today!

 

Thank you!

 

Sarah

Edited by mom2twins

Share this post


Link to post
Share on other sites

Is there anyway to get rid of that text on the main page. I have been trying and trying and keep screwing up. I even read and reread the manual for STS but still could not figure it out. I'm not totally dum but I keep taking out stuff that is needed on the page. Commands that dont look anything like what is is the manual. I even tried to look in mainpage define but it is not for V2.2 rc2a. Please help

Share this post


Link to post
Share on other sites

I have downloaded then uploaded the modern template rc2a I have tried to follow the install instruction but they tell me to up load folder modernrc2a I have search and search in the main folder and find no such folder just the modern template rc2a. Do I need to rename this folder?

Pat

Share this post


Link to post
Share on other sites
Is there anyway to get rid of that text on the main page. I have been trying and trying and keep screwing up. I even read and reread the manual for STS but still could not figure it out. I'm not totally dum but I keep taking out stuff that is needed on the page. Commands that dont look anything like what is is the manual. I even tried to look in mainpage define but it is not for V2.2 rc2a. Please help

 

This does not have anything to do with STS.

 

Upon a new install of osCommerce RC2a, your site homepage gives you all of the information you need to remove all of that "information".

 

STS gives installation options for each of the osCommerce 2.2 versions, including RC2a.


Bill Kellum

 

Sounds Good Productions

STS Tutorials & more: STSv4.6, STS Add-ons (STS Power Pack), STS V4 Forum STS Forum FREE TEMPLATE

Share this post


Link to post
Share on other sites
I have downloaded then uploaded the modern template rc2a I have tried to follow the install instruction but they tell me to up load folder modernrc2a I have search and search in the main folder and find no such folder just the modern template rc2a. Do I need to rename this folder?

Pat

 

My free STS template "Modern RC2a" that is available in the STS Power Pack site (a site dedicated to STS add-ons), is simply a new template folder. It assumes that you already have STS installed in your shop. If you just installed STS, then after uploading this add-on, you will have 3 template folders to choose from: full, test and now modernrc2a.

 

Obviously you are not familar with FTP. If you simply used a FTP client to upload the catalog folder over your existing catalog folder, then your FTP client software would have placed the modernrc2a template folder into your sts_templates folder automatically.


Bill Kellum

 

Sounds Good Productions

STS Tutorials & more: STSv4.6, STS Add-ons (STS Power Pack), STS V4 Forum STS Forum FREE TEMPLATE

Share this post


Link to post
Share on other sites
Am I correct in understanding that only certain add ons can be used while using STS? If so, is this a complete list of the add ons that are available to use while using STS?

http://www.oscommerce.com/community/contributions,4456

 

Sarah

 

No, you are not correct.

 

The STS Add-on site is merely a site of tips, tricks and helpful guides to be used along with STS. It also is a great place to upload contribution integration help guides if you want to share with the rest of the STS users. If you create new STS tags and want to share them, the STS Power Pack site would be the place to upload them.

 

The main STS download site should be a place where you can download the latest version of STS only. Any other uploads to that site only confuses everyone. This is why the STS Power Pack site was created; for all of the STS "extras".

 

All of the other osCommerce contributions will work with STS, except a different template system of course.


Bill Kellum

 

Sounds Good Productions

STS Tutorials & more: STSv4.6, STS Add-ons (STS Power Pack), STS V4 Forum STS Forum FREE TEMPLATE

Share this post


Link to post
Share on other sites
No, you are not correct.

 

The STS Add-on site is merely a site of tips, tricks and helpful guides to be used along with STS. It also is a great place to upload contribution integration help guides if you want to share with the rest of the STS users. If you create new STS tags and want to share them, the STS Power Pack site would be the place to upload them.

 

The main STS download site should be a place where you can download the latest version of STS only. Any other uploads to that site only confuses everyone. This is why the STS Power Pack site was created; for all of the STS "extras".

 

All of the other osCommerce contributions will work with STS, except a different template system of course.

 

Thanks for the clarification! I'm happy to hear that I was wrong this time! lol :)

Edited by mom2twins

Share this post


Link to post
Share on other sites

Thank-You Bill I found the madernrc2a folder and the rest of the things I needed to upload. The text file with the install instructions left out a few points on other things to upload in the folder to other folders. Anyway I got it working

Share this post


Link to post
Share on other sites
Thank-You Bill I found the madernrc2a folder and the rest of the things I needed to upload. The text file with the install instructions left out a few points on other things to upload in the folder to other folders. Anyway I got it working

 

 

Patrick,

 

I am glad you got it working. I hope you enjoy the new template. Be sure to real ALL of the instructions as there are a few options that are available to you that are NOT included in the install instructions but the files are included for your convenience. ;)


Bill Kellum

 

Sounds Good Productions

STS Tutorials & more: STSv4.6, STS Add-ons (STS Power Pack), STS V4 Forum STS Forum FREE TEMPLATE

Share this post


Link to post
Share on other sites

So, I installed this Login Box add on so I can have a customer login box on every page in the side column.

http://addons.oscommerce.com/info/2302

 

How can I create an STS tag to have it show up in my template?

 

I promise I won't ask this for every add on I am trying to use! :D I just need to know where to start. Thanks!

Share this post


Link to post
Share on other sites

Hi there sorry if this has been covered already but if it has I cant find it.

 

I downloaded and installed the STS stuff to allow me to edit the page in dreamweaver as my knowledge of code is non existent.

I am trying to get the home page to have a little bit of blurb from me and then just show a grid of all catagories.

 

also when i try to upload an image with a product it is not working. It just says Warning: No file uploaded.

 

thanks for any help on this

Share this post


Link to post
Share on other sites

Now I'm starting to feel like a pest here. A rather old one at that LOL. I looked at Bill's template sample and realized i did not need most of the stuff or coding on the page to get it to what I need. So I striped all but the place holders at the bottom. Now I have this TEXT_MAIN Right after the welcome back line. I cant seem to find it anywhere in the place holders or coding. Could this be from STS or did I remove something I should not have. Slowly I am getting this site to where I need it to be. I sure am learning lots though, it has been a long time since I played with coding, and I am still a beginner.

Pat

Share this post


Link to post
Share on other sites

Downward compatibility?

 

I'm building a site using STS. I built and tested it on my local machine, then on a remote test site. Everything looks fine, so the client said "go live". I uploaded everything (except configure.php) to the client's site, and now the template variables aren't being parsed.

 

partial screenshot, client name blacked out, using the STS default template for easy comparison:

 

templateT.jpg

 

I used the sts_debug function to see if there was any difference between the two sites. I can't see anything that would cause this, but I did notice that the live (problematic) site is running PHP 4.4.8, while my localhost is using PHP 5.2.6 and the test site is on 5.2.8.

 

Could this be causing the problem? I don't know if the live site can be updated to PHP 5.2x (shared server, control issues) -- is there something I need to do to make STS 4.5.5 downward-compatible? Or is the problem something else entirely, and if so where is it likely to lurk?

 

yours in wailing and gnashing of teeth,

 

Datagnostics.com

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×