Jump to content
rigadin2

[Contribution] STS v4

Recommended Posts

I just started using osC yesterday, so excuse me if I'm a bit slow on things.

 

I went ahead and set up STS, and got everything working save for a few things.

 

My content box shows none of my design. I think maybe I'm editing the wrong file. Which one is it supposed to be? Or is it possible that it isn't pulling my CSS from my index?

 

The friends/specials box thing just isn't showing, at all. Any ideas?

 

Also $counter is just displaying $counter, not the actual counter.

 

Other than those things I don't see any problems.

Jen,

Looks like you have several issues going on here. Try reinstalling STS again and test using the provided templates in the "full" template folder.


Bill Kellum

 

Sounds Good Productions

STS Tutorials & more: STSv4.6, STS Add-ons (STS Power Pack), STS V4 Forum STS Forum FREE TEMPLATE

Share this post


Link to post
Share on other sites
Hello Pat,

 

The correct tag would be $category_cssmenu.

Did you upload the optional additional categories_cssmenu.php file in includes/boxes/categories_cssmenu.php ?

 

 

I believe I did, Bill. I'll check as soon as I get this latest mess sorted. I'll keep you posted....

Share this post


Link to post
Share on other sites
Jen,

Looks like you have several issues going on here. Try reinstalling STS again and test using the provided templates in the "full" template folder.

 

When I first installed that worked fine. I checked it before I started editing my design for the template system.

 

But your response still doesn't answer my question of what file to edit to customize the content box, or why the two variables aren't working. :P

Share this post


Link to post
Share on other sites

Hi, Bill....

 

 

Hello Pat,

 

The correct tag would be $category_cssmenu.

Did you upload the optional additional categories_cssmenu.php file in includes/boxes/categories_cssmenu.php ?

 

Yes, it's up, same issue. The other issue with me breaking the shop front was to do with cookies needing cleared after editing the content (default text) file - so that's sorted again. Scared me for a bit... :blush:

 

So, I'm back to my basic OSC installation, STS installed and activated, the Modern theme applied and debug on - as seen here.

 

Any further ideas?

Share this post


Link to post
Share on other sites
Hi, Bill....

 

 

 

 

Yes, it's up, same issue. The other issue with me breaking the shop front was to do with cookies needing cleared after editing the content (default text) file - so that's sorted again. Scared me for a bit... :blush:

 

So, I'm back to my basic OSC installation, STS installed and activated, the Modern theme applied and debug on - as seen here.

 

Any further ideas?

Same idea as before...use the correct STS tag. You are using $categorycssmenu and the correct tag should be $category_cssmenu.

Bill Kellum

 

Sounds Good Productions

STS Tutorials & more: STSv4.6, STS Add-ons (STS Power Pack), STS V4 Forum STS Forum FREE TEMPLATE

Share this post


Link to post
Share on other sites
When I first installed that worked fine. I checked it before I started editing my design for the template system.

 

But your response still doesn't answer my question of what file to edit to customize the content box, or why the two variables aren't working. :P

The STS User Manual will and should answer most of your basic questions.

 

Did you create a STS tag named $counter since this is not a stock tag? I think you want the $numrequests tag.

Edited by bkellum

Bill Kellum

 

Sounds Good Productions

STS Tutorials & more: STSv4.6, STS Add-ons (STS Power Pack), STS V4 Forum STS Forum FREE TEMPLATE

Share this post


Link to post
Share on other sites
The STS User Manual will and should answer most of your basic questions.

 

Did you create a STS tag named $counter since this is not a stock tag? I think you want the $numrequests tag.

 

 

With the tell a friend/special box -- I put a special on to see if it worked, and that does show. The tell a friend option just isn't showing.

 

And, taken from http://www.oscommerce.com/community/contributions,1524

 

$date: The current date
$numrequests: The "XXX requests Since DATE" text
$counter: The page view counter
$footer: The footer output from footer.php
$banner: The banner output from footer.php

 

And as for the manual, it does tell you a lot of things that STS can do, and not so much on how to do them. Or maybe I don't understand them very well because I'm new to OsCommerce. I'll go look again.

Share this post


Link to post
Share on other sites

Okay, I think I got it all figured out but my content. The box thing seemed to be a misunderstanding on my part.

 

Looking through the manual file the $counter var is not in it, but it is on the weblink I gave. Outdated, maybe?

 

 

I have product_info.php which I used all of the tags from the supplied product_info file that came with STS, and just my HTML. All of the text is showing, but none of my html is.

 

Basically, with my layout, I used divlayers. I have a layer box at the top of the content for the titles/product names/etc and then a larger box below that for the rest of the content, so I figured I needed to do a custom layout for this to make it function properly.

 

Sorry for double posting, my edit button seems to have vanished.

Share this post


Link to post
Share on other sites
Okay, I think I got it all figured out but my content. The box thing seemed to be a misunderstanding on my part.

 

Looking through the manual file the $counter var is not in it, but it is on the weblink I gave. Outdated, maybe?

 

 

I have product_info.php which I used all of the tags from the supplied product_info file that came with STS, and just my HTML. All of the text is showing, but none of my html is.

 

Basically, with my layout, I used divlayers. I have a layer box at the top of the content for the titles/product names/etc and then a larger box below that for the rest of the content, so I figured I needed to do a custom layout for this to make it function properly.

 

Sorry for double posting, my edit button seems to have vanished.

Jen,

This is in response to your two previous posts above...

 

When viewing the STS contribution page (and any other contribution page for that matter), the oldest (outdated) text is displayed. However, the text in the most recent download (in this case it would be the STSv4.5.8) details all of the current information. The STS User Manual lists all of the stock up-to-date tags for STSv4.5.8.

STS is far more advanced than the origianl STS version that you referenced above. The original $counter tag was buggy and was replaced with the $numrequests tag.

 

If you are having issues with getting your layout to work, it could be from the actual box files and/or the stock stylesheet.css file. Try using the STS Infobox Template feature as well.

 

Hope this helped,


Bill Kellum

 

Sounds Good Productions

STS Tutorials & more: STSv4.6, STS Add-ons (STS Power Pack), STS V4 Forum STS Forum FREE TEMPLATE

Share this post


Link to post
Share on other sites
Jen,

This is in response to your two previous posts above...

 

When viewing the STS contribution page (and any other contribution page for that matter), the oldest (outdated) text is displayed. However, the text in the most recent download (in this case it would be the STSv4.5.8) details all of the current information. The STS User Manual lists all of the stock up-to-date tags for STSv4.5.8.

STS is far more advanced than the origianl STS version that you referenced above. The original $counter tag was buggy and was replaced with the $numrequests tag.

 

If you are having issues with getting your layout to work, it could be from the actual box files and/or the stock stylesheet.css file. Try using the STS Infobox Template feature as well.

 

Hope this helped,

 

I use info box templates to get my info boxes to format how I want -- It's all just text in those, though, no graphics.

 

I have tried everything I can think of to get my content box working with no luck.

Share this post


Link to post
Share on other sites

Bill,

 

Do not ask how this happened, but when I traced down the bug with the tag name rather than the content of the Product listing box, it turns out that in catalog/includes/modules/sts_inc/sts_column_left.php

 

Line 31 $sts->restart_capture ('category_cssmenu', 'box');

 

needed to be changed to

 

Line 31 $sts->restart_capture ('categorycssmenu', 'box');

 

so that it tied up with the rest of the template. Works fine now. I'll stress again, I uploaded the template right from the package without editing any files. Anyone else seen this?

 

Thanks again for your help in clarifying what the variable name should have been. keep up the good work!

 

Pat

Share this post


Link to post
Share on other sites

I use one template file for my whole site. I figured out how to change the look of the product_info $content placeholder

 

Now, is there any way to create a template for the $content placeholder of the store index.php.html template? or do I have to edit the index.php file manually?

 

Thanks in advance for your help

Edited by jrd1mra

Share this post


Link to post
Share on other sites
Bill,

 

Do not ask how this happened, but when I traced down the bug with the tag name rather than the content of the Product listing box, it turns out that in catalog/includes/modules/sts_inc/sts_column_left.php

 

Line 31 $sts->restart_capture ('category_cssmenu', 'box');

 

needed to be changed to

 

Line 31 $sts->restart_capture ('categorycssmenu', 'box');

 

so that it tied up with the rest of the template. Works fine now. I'll stress again, I uploaded the template right from the package without editing any files. Anyone else seen this?

 

Thanks again for your help in clarifying what the variable name should have been. keep up the good work!

 

Pat

Pat, I'm glad you got it worked out. I just checked the download and both the sts_column_left.php file and the sts_template.html file use the categorycssmenu tag so I'm not sure how yours was different.

 

Anyway, enjoy your template!

 

EVERYONE: If you are unaware, I uploaded a FREE STS template in the STS Addon site (STSv4 Power Pack - link in my signature below).


Bill Kellum

 

Sounds Good Productions

STS Tutorials & more: STSv4.6, STS Add-ons (STS Power Pack), STS V4 Forum STS Forum FREE TEMPLATE

Share this post


Link to post
Share on other sites
I use one template file for my whole site. I figured out how to change the look of the product_info $content placeholder

 

Now, is there any way to create a template for the $content placeholder of the store index.php.html template? or do I have to edit the index.php file manually?

 

Thanks in advance for your help

$content is taken from the php script you are running. For example, the $content for index.php is the piece of code you find in index.php, between the call of column_left and the call of column_right. If you want to modify it, you have to modify the script itself. You could also install a contribution to do this for you such as the Product Listing in Columns contribution.


Bill Kellum

 

Sounds Good Productions

STS Tutorials & more: STSv4.6, STS Add-ons (STS Power Pack), STS V4 Forum STS Forum FREE TEMPLATE

Share this post


Link to post
Share on other sites
Gina, there is more than one way to accomplish this. By far, the best way would be to stay within the osCommerce standards and add your language specific text within the defines in the includes/languages/english.php or german.php (etc.) files. I know this maybe daunting for a newbie but it is really quite simple if you take the time to think it through.

 

For example: Say you had a line of text such as "You cart is empty" and you need this to be language specific. You would add a line in each of your *language*.php files.

 

In includes/languages/english.php you would add:

define('ENTRY_HCART_EMPTY', 'Your cart is empty');

In includes/languages/german.php you would add:

define('ENTRY_HCART_EMPTY', 'Ihr Warenkorb ist leer');

 

You would do the same for all of your other languages.

 

Then, in your template, you would add some PHP code where you want the language specific text to appear:

 

<?php echo ENTRY_HCART_EMPTY; ?>

 

The above is the most rock solid way of doing this.

 

Thanks Bill, that was just what I was looking for, I was thinking too complicated and confusing myself....

 

Gina

Share this post


Link to post
Share on other sites
$content is taken from the php script you are running. For example, the $content for index.php is the piece of code you find in index.php, between the call of column_left and the call of column_right. If you want to modify it, you have to modify the script itself. You could also install a contribution to do this for you such as the Product Listing in Columns contribution.

 

Thanks for your help bill. I did see that in the manual but after seeing how easy it was to edit the other content sections I thought I was reading it wrong. I have been a little confused trying to wrap my head around installing and configuring oscommerce and three contributions with no previous experience with oscommerce.

Edited by jrd1mra

Share this post


Link to post
Share on other sites

I am trying to embed some flash images into my header.

 

I have tried doing this by editing the STS_template.html as follows but nothing shows no the site where the images should show I just have a big white space:

 

</head>
<body marginwidth="0" marginheight="0" topmargin="0" bottommargin="0" leftmargin="0" rightmargin="0">
<p> </p>
<table border="0" width="875px" cellspacing="0" align="center" cellpadding="0">
<tr class="header">
	<td width="132" height="79" valign="middle" bgcolor="#FFFFFF">
			 <div align="center"><img src="images/headerlogo.jpg" border="0"  align="center" >				   </div>
	<td width="536" valign="middle" bgcolor="#FFFFFF"><div align="center">
	  <p> </p>
	  <p>
		<script type="text/javascript">
AC_FL_RunContent( 'codebase','http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=7,0,19,0','width','550','height','200','title','ProductRange','src','../../../images/products','quality','high','pluginspage','http://www.macromedia.com/go/getflashplayer','movie','../../../images/products' ); //end AC code
</script><noscript><object classid="clsid:D27CDB6E-AE6D-11cf-96B8-444553540000" codebase="http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=7,0,19,0" width="550" height="200" title="Product Range">
		  <param name="movie" value="../../../images/products.swf">
		  <param name="quality" value="high">
		  <embed src="../../../images/products.swf" quality="high" pluginspage="http://www.macromedia.com/go/getflashplayer" type="application/x-shockwave-flash" width="550" height="200"></embed>
		</object></noscript>
	  </p>
	</div>

 

I'd really appreciate any help.

Share this post


Link to post
Share on other sites
I am trying to embed some flash images into my header.

Lotti,

 

See post #4735 in the older STS forum (I recently posted a rock solid solution on how to embed Flash into your STS template (or any other web page for that matter).

http://forums.oscommerce.com/index.php?s=&...t&p=1298555

 

Hope this helped,


Bill Kellum

 

Sounds Good Productions

STS Tutorials & more: STSv4.6, STS Add-ons (STS Power Pack), STS V4 Forum STS Forum FREE TEMPLATE

Share this post


Link to post
Share on other sites

how can I display reviews from the reviews page on the products pages. also how can i change the layout of the contents on the review page? cheers babe x

Share this post


Link to post
Share on other sites
how can I display reviews from the reviews page on the products pages. also how can i change the layout of the contents on the review page? cheers babe x

 

Create a product_info.php.html template and add the reviews tag (see STS User Manual for tag details).


Bill Kellum

 

Sounds Good Productions

STS Tutorials & more: STSv4.6, STS Add-ons (STS Power Pack), STS V4 Forum STS Forum FREE TEMPLATE

Share this post


Link to post
Share on other sites
Yeah I looked in the manual and there is no placeholder to put reviews on the product page.

 

I think we are talking about two different things here. I'm refering to a product info template, not the product info content template. You can create any template page and place the $reviewsbox tag in order to pull in the reviews for a particular product.

 

Otherwise, you may need to install a separate contribution that work along with STS such as the following:

 

http://www.oscommerce.com/community/contributions,734

 

I can not vouch for the above as I have yet to use it but it looks like what you are wanting.


Bill Kellum

 

Sounds Good Productions

STS Tutorials & more: STSv4.6, STS Add-ons (STS Power Pack), STS V4 Forum STS Forum FREE TEMPLATE

Share this post


Link to post
Share on other sites

ok but then to include it in the template... how would i make a tag to display it. cause even if i installed it the reviews wouldnt be on the STS template.

 

thanks for help so far very much though your the best mate, i respect your effots.

Edited by h3rB

Share this post


Link to post
Share on other sites
ok but then to include it in the template... how would i make a tag to display it. cause even if i installed it the reviews wouldnt be on the STS template.

 

thanks for help so far very much though your the best mate, i respect your effots.

 

Bob, take a look at the following post that details how STS interacts with other contributions:

http://forums.oscommerce.com/index.php?s=&...t&p=1252270

 

Hope this helps,


Bill Kellum

 

Sounds Good Productions

STS Tutorials & more: STSv4.6, STS Add-ons (STS Power Pack), STS V4 Forum STS Forum FREE TEMPLATE

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×