Jump to content
rigadin2

[Contribution] STS v4

Recommended Posts

No, it is not. You can include php within your template with STS v4.1.

 

Then why aren't the header and footer showing up? And why am I getting errors like:

 

Warning: main(): URL file-access is disabled in the server configuration in /home/content/u/t/i/utilikilted/html/store/includes/sts_templates/uk/main.php on line 34

 

Warning: main(http://216.69.130.253/global/boxes/footer.txt): failed to open stream: no suitable wrapper could be found in /home/content/u/t/i/utilikilted/html/store/includes/sts_templates/uk/main.php on line 34

 

Warning: main(): Failed opening 'http://216.69.130.253/global/boxes/footer.txt' for inclusion (include_path='.:/usr/local/lib/php') in /home/content/u/t/i/utilikilted/html/store/includes/sts_templates/uk/main.php on line 34

 

The same code works fine on other pages in my site like this one:

 

http://216.69.130.253/community/index.php

Share this post


Link to post
Share on other sites
Thanks for your reply, Paul. I almost got my HTC working. However, there are still some problems.

 

If I create a new page and enter special meta tags for that page through admin/Header Tags Page Control, the meta tags still remain default if I look at the page from the catalog side, even though they are saved correctly in admin/Header Tags Text Control. I tried to enter my special meta tags to english/header_tags.php and any other languages manually, but they don't change and still are default doesn't matter what I'm trying to do.

 

And for my index page, the title is displayed with the dash ( - ) in front of it, like: <title> - Company: The Solution Expert</title>. How can I remove that dash? I don't see it anywhere, not in my english/header_tags.php neither in admin/Header Tags Text Control. I don't know where can I find it to remove it?

 

Is anybody using STS with "Products Tabs" contribution. How can I implement tabs into my product_info template?

 

Thanks a lot for help.

 

 

Have you tried looking in includes\english.php to a search for "- Company" without the quotes of coarse.

 

Sorry I can't help you with fixing the tags in new pages but I would say the STS is most likely stripping your new tags.

 

Funkym

Share this post


Link to post
Share on other sites
First of all Rig, Thanks for a fantastic contribution that works great. Bill thanks for all your efforts at helping others with STS.

 

Let me qualify my question.

 

Installed a fresh fersion of OCS and then used the clean version to install STS. Setup my STS templete and now for some reason I have double boxes in the product_info.php page. I've read all the threads in this part of the forum at least three times and found that I needed to install the new index.php. That done, I'm still showing double boxes in the product_info.php page.

 

Here is a link to what I'm talking about.

 

Offending page

 

Any help and consideration would really be greatful.

 

Thanks Guy Fuller

 

 

Just to be sure before we start getting too deep in troubleshooting your problem, make sure you have installed STS v4.1 correctly...

 

 

 

To install it correctly, You will only need to download and install this and then this. (IMG:style_emoticons/default/thumbsup.gif)

(STS v4.1 as well as the Index module v1.0.3 for STS4.)

The two files between these two contributions have been known to cause problems such as double headers and php errors.

 

 

 

You also need to doublecheck your variables (placeholders). Some variables do not work as the name implies when used with others. I think this may be your problem. Look through the documentation for STS v4.1, particularily in the variable definitions. You will notice that some variables (placeholders) such as $bestsellersbox will actually display the "notification" box if certain "conditions" are net met.

 

Hope this helps,

 

Bill Kellum

 

 

Sorry Bill for not getting back to you sooner, yesterday was a busy day. I had already done my homework before installing STS4.7 and read this thread and installed the new index. Install was quite easy and straight forward as far as contributions go and it worked the first time. Then I noticed the offending boxes when it was pointed out to me by another member in the forums that looked at my page.

 

Anyway was able to look at the placeholders and noticed that the names are not the same as what I am using with a bare bones OCS Example is $bestsellersbox on my page is $bestsellers in STS 4.7. If I rename the offending box it will not show.

 

That is where I'm at at the moment. Unfortunately I won't have time today to work on this until tonight and the weekend.

 

Big thanks for getting back to me and finding me in the regular contribution area as I posted in the wrong place at first.

 

Guy Fuller

Share this post


Link to post
Share on other sites

Hi everyone

 

Im wondering if anyone has worked out how to get More Pics 6 working with STS?

 

Ive tried and just cant seem to get it working

 

Does it need a module coded to be addedinto the admin or is it just a matter of installing the module to get it work

Share this post


Link to post
Share on other sites

Hi All,

 

I KNOW this question has been answered before, but for the life of me, i still cannot figure this out! :)

 

I installed a clean oscommerce and sts, the lates version of each, July 2006, and when i enable STS, i get "3" heads for the page - the first shows the variables, the second and third have content. I keep seeing that you need to modify the application_bottom.php file, but those lines to change do not exist. I am assuming that many of the people who contribute to answering these questions are upgrading from previous versions, but if someone could just tell me, in simple language, what exactly i need to change, that would be much appreciated by me (am others i am sure! ;)

 

Thanks in advance!!!

Share this post


Link to post
Share on other sites

Hi Bill, I think I'm getting this new STS finallly. However I believe I installed the wrong file as I installed V4.07 as I confused the two different files. I didn't realize you have to mod all the templates to fit the look of your page design and thaought that just the one template would surfice changing the look of the entire site. Now I get it after looking at all the links in my site and seeing the different templates load. Rig did a very good job on the documentation, but I wish this would have been covered a little more.

 

Anyway I'm just going to start over and reinstall everything and this time do it the right way instead trying to figure out all the weird things that go wrong.

 

More questions to come I think.

 

Have a great 4th.

 

Guy Fuller

Share this post


Link to post
Share on other sites

Has anyone managed to integrate Master Products with STS 4? I can't figure out how to get a template variable for the slaves setup. I tried the contrib on the STS contrib page but it would seem it was geared towards an earlier version of STS. ANy help would be greatly appreciated.

 

Thanks

Shane

Share this post


Link to post
Share on other sites

Hi,

 

I'm having a problem with my infoboxes. I'd like all my infoboxes to show like: corner_left, contents, right_arrow, corner_right. But doesn't matter what I'm trying to do, it doesn't show like that. May be somebody can help me with this. Will be very much appreciated. Here is how my includes/classes/boxes.php looks like:

<?php

/*

$Id: boxes.php,v 1.1.1.1 2003/09/18 19:05:12 wilt Exp $

 

osCommerce, Open Source E-Commerce Solutions

http://www.oscommerce.com

 

Copyright © 2003 osCommerce

 

Released under the GNU General Public License

*/

 

class tableBox {

var $table_border = '0';

var $table_width = '100%';

var $table_cellspacing = '0';

var $table_cellpadding = '2';

var $table_parameters = '';

var $table_row_parameters = '';

var $table_data_parameters = '';

 

// class constructor

function tableBox($contents, $direct_output = false) {

$tableBox_string = '<table border="' . tep_output_string($this->table_border) . '" width="' . tep_output_string($this->table_width) . '" cellspacing="' . tep_output_string($this->table_cellspacing) . '" cellpadding="' . tep_output_string($this->table_cellpadding) . '"';

if (tep_not_null($this->table_parameters)) $tableBox_string .= ' ' . $this->table_parameters;

$tableBox_string .= '>' . "\n";

 

for ($i=0, $n=sizeof($contents); $i<$n; $i++) {

if (isset($contents[$i]['form']) && tep_not_null($contents[$i]['form'])) $tableBox_string .= $contents[$i]['form'] . "\n";

$tableBox_string .= ' <tr';

if (tep_not_null($this->table_row_parameters)) $tableBox_string .= ' ' . $this->table_row_parameters;

if (isset($contents[$i]['params']) && tep_not_null($contents[$i]['params'])) $tableBox_string .= ' ' . $contents[$i]['params'];

$tableBox_string .= '>' . "\n";

 

if (isset($contents[$i][0]) && is_array($contents[$i][0])) {

for ($x=0, $n2=sizeof($contents[$i]); $x<$n2; $x++) {

if (isset($contents[$i][$x]['text']) && tep_not_null($contents[$i][$x]['text'])) {

$tableBox_string .= ' <td';

if (isset($contents[$i][$x]['align']) && tep_not_null($contents[$i][$x]['align'])) $tableBox_string .= ' align="' . tep_output_string($contents[$i][$x]['align']) . '"';

if (isset($contents[$i][$x]['params']) && tep_not_null($contents[$i][$x]['params'])) {

$tableBox_string .= ' ' . $contents[$i][$x]['params'];

} elseif (tep_not_null($this->table_data_parameters)) {

$tableBox_string .= ' ' . $this->table_data_parameters;

}

$tableBox_string .= '>';

if (isset($contents[$i][$x]['form']) && tep_not_null($contents[$i][$x]['form'])) $tableBox_string .= $contents[$i][$x]['form'];

$tableBox_string .= $contents[$i][$x]['text'];

if (isset($contents[$i][$x]['form']) && tep_not_null($contents[$i][$x]['form'])) $tableBox_string .= '</form>';

$tableBox_string .= '</td>' . "\n";

}

}

} else {

$tableBox_string .= ' <td';

if (isset($contents[$i]['align']) && tep_not_null($contents[$i]['align'])) $tableBox_string .= ' align="' . tep_output_string($contents[$i]['align']) . '"';

if (isset($contents[$i]['params']) && tep_not_null($contents[$i]['params'])) {

$tableBox_string .= ' ' . $contents[$i]['params'];

} elseif (tep_not_null($this->table_data_parameters)) {

$tableBox_string .= ' ' . $this->table_data_parameters;

}

$tableBox_string .= '>' . $contents[$i]['text'] . '</td>' . "\n";

}

 

$tableBox_string .= ' </tr>' . "\n";

if (isset($contents[$i]['form']) && tep_not_null($contents[$i]['form'])) $tableBox_string .= '</form>' . "\n";

}

 

$tableBox_string .= '</table>' . "\n";

 

if ($direct_output == true) echo $tableBox_string;

 

return $tableBox_string;

}

 

function infoBoxHeaderTemplate($headertext,$right_arrow)

{

$btrace=debug_backtrace();

// var_dump(debug_backtrace());

$boxname=basename($btrace[1]['file'],".php");

// echo $boxname;

if (file_exists(STS_TEMPLATE_DIR."boxes/infobox_".$boxname."_header.php.html"))

{

$template=sts_read_template_file (STS_TEMPLATE_DIR."boxes/infobox_".$boxname."_header.php.html");

}

else

{

$template=sts_read_template_file (STS_TEMPLATE_DIR."boxes/infobox_header.php.html");

}

 

$template = str_replace('$headertext', $headertext, $template);

$template = str_replace('$right_arrow', $right_arrow, $template);

echo $template;

}

 

function infoBoxTemplate($content)

{

$btrace=debug_backtrace();

$boxname=basename($btrace[1]['file'],".php");

if (file_exists(STS_TEMPLATE_DIR."boxes/infobox_".$boxname.".php.html"))

{

$template=sts_read_template_file (STS_TEMPLATE_DIR."boxes/infobox_".$boxname.".php.html");

}

else

{

$template=sts_read_template_file (STS_TEMPLATE_DIR."boxes/infobox.php.html");

}

 

$template = str_replace('$content', $content, $template);

echo $template;

}

}

 

class infoBox extends tableBox {

function infoBox($contents) {

 

$info_box_contents = array();

$info_box_contents[] = array('text' => $this->infoBoxContents($contents));

$this->table_cellpadding = '1';

$this->table_parameters = 'class="infoBox"';

 

 

// START STS

require_once(DIR_WS_MODULES."sts/sts_infobox.php");

$sts_infobox=new sts_infobox();

if ($sts_infobox->enabled)

{

$this->infoboxtemplate($this->infoBoxContents($contents));

}

else

{

$this->tableBox($info_box_contents, true);

}

// END STS

 

}

 

function infoBoxContents($contents) {

$this->table_cellpadding = '3';

$this->table_parameters = 'class="infoBoxContents"';

$info_box_contents = array();

$info_box_contents[] = array(array('text' => tep_draw_separator('pixel_trans.gif', '100%', '1')));

for ($i=0, $n=sizeof($contents); $i<$n; $i++) {

$info_box_contents[] = array(array('align' => (isset($contents[$i]['align']) ? $contents[$i]['align'] : ''),

'form' => (isset($contents[$i]['form']) ? $contents[$i]['form'] : ''),

'params' => 'class="boxText"',

'text' => (isset($contents[$i]['text']) ? $contents[$i]['text'] : '')));

}

$info_box_contents[] = array(array('text' => tep_draw_separator('pixel_trans.gif', '100%', '1')));

return $this->tableBox($info_box_contents);

}

}

 

class infoBoxHeading extends tableBox {

function infoBoxHeading($contents, $left_corner = true, $right_corner = true, $right_arrow = true) {

$this->table_cellpadding = '0';

 

if ($left_corner == true) {

$left_corner = tep_image(DIR_WS_IMAGES . 'infobox/corner_left.gif');

} else {

$left_corner = tep_image(DIR_WS_IMAGES . 'infobox/corner_right_left.gif');

}

if ($right_arrow == true) {

$right_arrow = '<a href="' . $right_arrow . '">' . tep_image(DIR_WS_IMAGES . 'infobox/arrow_right.gif', ICON_ARROW_RIGHT) . '</a>';

} else {

$right_arrow = '';

}

if ($right_corner == true) {

$right_corner = $right_arrow . tep_image(DIR_WS_IMAGES . 'infobox/corner_right.gif');

} else {

$right_corner = $right_arrow . tep_draw_separator('pixel_trans.gif', '11', '14');

}

 

 

// START STS

require_once(DIR_WS_MODULES."sts/sts_infobox.php");

$sts_infobox=new sts_infobox();

if ($sts_infobox->enabled)

{

$info_box_contents = array();

$info_box_contents[] = array(array('params' => 'width="100%" class="infoBoxHeading"',

'text' => $contents[0]['text']));

 

$this->infoBoxHeaderTemplate($this->tablebox($info_box_contents),$right_arrow);

 

}

else

{

$info_box_contents = array();

$info_box_contents[] = array(array('params' => 'height="14" class="infoBoxHeading"',

'text' => $left_corner),

array('params' => 'width="100%" height="14" class="infoBoxHeading"',

'text' => $contents[0]['text']),

array('params' => 'height="14" class="infoBoxHeading" nowrap',

'text' => $right_corner));

$this->tableBox($info_box_contents, true);

}

// END STS

}

}

 

class contentBox extends tableBox {

function contentBox($contents) {

 

require_once(DIR_WS_MODULES."sts/sts_infobox.php");

$sts_infobox=new sts_infobox();

if ($sts_infobox->enabled)

{

$this->infoBoxTemplate($this->tableBox($contents));

}

else

{

$info_box_contents = array();

$info_box_contents[] = array('text' => $this->contentBoxContents($contents));

$this->table_cellpadding = '1';

$this->table_parameters = 'class="infoBox"';

$this->tableBox($info_box_contents, true);

}

}

 

function contentBoxContents($contents) {

$this->table_cellpadding = '4';

$this->table_parameters = 'class="infoBoxContents"';

 

return $this->tableBox($contents);

}

}

 

class contentBoxHeading extends tableBox {

function contentBoxHeading($contents) {

 

 

// START STS

require_once(DIR_WS_MODULES."sts/sts_infobox.php");

$sts_infobox=new sts_infobox();

if ($sts_infobox->enabled)

{

$info_box_contents = array();

$info_box_contents[] = array(array('params' => 'class="infoBoxHeading" width="100%"',

'text' => $contents[0]['text']));

 

$this->infoBoxHeaderTemplate($this->tablebox($info_box_contents),$right_arrow);

}

else

{

$this->table_width = '100%';

$this->table_cellpadding = '0';

 

$info_box_contents = array();

$info_box_contents[] = array(array('params' => 'height="14" class="infoBoxHeading"',

'text' => tep_image(DIR_WS_IMAGES . 'infobox/corner_left.gif')),

array('params' => 'height="14" class="infoBoxHeading" width="100%"',

'text' => $contents[0]['text']),

array('params' => 'height="14" class="infoBoxHeading"',

'text' => tep_image(DIR_WS_IMAGES . 'infobox/corner_right_left.gif')));

$this->tableBox($info_box_contents, true);

}

// END STS

 

}

}

 

class errorBox extends tableBox {

function errorBox($contents) {

$this->table_data_parameters = 'class="errorBox"';

 

 

// START STS

require_once(DIR_WS_MODULES."sts/sts_infobox.php");

$sts_infobox=new sts_infobox();

if ($sts_infobox->enabled)

{

$this->infoBoxTemplate($this->infoBoxContents($contents));

}

else

{

$this->tableBox($contents, true);

}

// END STS

}

}

 

class productListingBox extends tableBox {

function productListingBox($contents) {

$this->table_parameters = 'class="productListing"';

 

// START STS

require_once(DIR_WS_MODULES."sts/sts_infobox.php");

$sts_infobox=new sts_infobox();

if ($sts_infobox->enabled)

{

$this->infoBoxHeaderTemplate("","");

$this->infoBoxTemplate($this->tablebox($contents));

}

else

{

$this->tableBox($contents, true);

}

// END STS

 

}

}

 

class LangBox extends tableBox {

function LangBox($contents) {

$this->table_parameters = 'class="LangBox"';

$this->tableBox($contents, true);

 

// START STS

require_once(DIR_WS_MODULES."sts/sts_infobox.php");

$sts_infobox=new sts_infobox();

if ($sts_infobox->enabled)

{

$this->infoboxtemplate($this->LangBoxContents($contents));

}

else

{

$this->tableBox($info_box_contents, true);

}

// END STS

}

}

?>

Thanks in advance.

Share this post


Link to post
Share on other sites
Hi All,

 

I KNOW this question has been answered before, but for the life of me, i still cannot figure this out! :)

 

I installed a clean oscommerce and sts, the lates version of each, July 2006, and when i enable STS, i get "3" heads for the page - the first shows the variables, the second and third have content. I keep seeing that you need to modify the application_bottom.php file, but those lines to change do not exist. I am assuming that many of the people who contribute to answering these questions are upgrading from previous versions, but if someone could just tell me, in simple language, what exactly i need to change, that would be much appreciated by me (am others i am sure! ;)

 

Thanks in advance!!!

Jim, This is a well documented issue. Unfortunately, a few bad files have been uploaded in the download section of STS v4. It appears you have installed two of these files which cause the issues you are experiencing.

 

 

 

To install it correctly, You will only need to download and install this and then this. :thumbsup:

 

The STS v4.1 by rigadin as well as the Index module v1.0.3 for STS4.

 

The two files between these two contributions have been known to cause problems such as double headers and php errors. ;)

 

Hope this helps,

 

Bill Kellum

 

:( P.S. Sorry to everyone on the forum for having to repeat this solution so many times throughout this forum. Just trying to be helpful. :-


Bill Kellum

 

Sounds Good Productions

STS Tutorials & more: STSv4.6, STS Add-ons (STS Power Pack), STS V4 Forum STS Forum FREE TEMPLATE

Share this post


Link to post
Share on other sites

First I just want to give everyone involved w/ this contrib Kudos for all the work. Just finished installing this yesterday and I must say that it was a nice improvement over earlier versions. The older one was just a royal pain in the old poop shoot to install and use. V. 4.1 was just as sweet as silk to put in!!

 

I've got a suggestion for all you php wizzards that shouldn't be hard to implement. Unfortunatelly, I know about as much about php as a brick.

 

In the admin side where you tell sts what template you want to use...it would just be the poop to have that field become a drop down box w/ all your template names listed there..that way, you wouldn't have to try to remember what the name of your template is. It shouldn't be too terribly difficult to write up!

 

Thanks again to everyone for all the wonderful work on this!!!


I only do what my Rice Krispies tell me to do!

Share this post


Link to post
Share on other sites

Greets,

 

I may be missing something, in which case I would appreciate a point in the right direction; however, I'm trying to use some javaScript embedded in the header of an index.php.html file to alter the behaviour of a layer. The code works fine in a regular .html file outside of sts but doesnt seem to be recognised within the sts structure.

 

Any ideas?

 

Cheers and much thanks

Shane

Share this post


Link to post
Share on other sites

Hi there,

 

Wow. 4.1 is quite a leap from 2.x. Very nice work.

 

I had a quick question regarding SEF urls; do they work? Seems not from what I can tell. If that's the case are there any plans to implement it or has anyone done a workaround for it?

 

Thanks,

Iggy


Everything's funny but nothing's a joke...

Share this post


Link to post
Share on other sites
Greets,

 

I may be missing something, in which case I would appreciate a point in the right direction; however, I'm trying to use some javaScript embedded in the header of an index.php.html file to alter the behaviour of a layer. The code works fine in a regular .html file outside of sts but doesnt seem to be recognised within the sts structure.

 

Any ideas?

 

Cheers and much thanks

Shane

 

I think you need to add the javascript code into the sts javascript file to get it to load when working under STS

 

at least thats what ive found

Share this post


Link to post
Share on other sites

Hello!

 

Im experiencing a realy strange problem with STS together with Additional Images contribution.

 

Before I installed the update I had the two images at the contetn area, plus a double header. Now, when i get the update - in place of a additional header, i get a box with additional images. After turning off the use of content template and altering product_info.php I got the additional images in a propper place, plus the one at the top. Looks like similiar problem to double header issue.

 

(use of additional images were declared in the user_code.php and seams to work fine, so i presume its contribution error at some point)

 

Please help or let me know if you need any additional info to solve this issue.

 

Best regards!

Edited by VT_EdgeCrusher

Share this post


Link to post
Share on other sites
Hello!

 

Im experiencing a realy strange problem with STS together with Additional Images contribution.

 

Before I installed the update I had the two images at the contetn area, plus a double header. Now, when i get the update - in place of a additional header, i get a box with additional images. After turning off the use of content template and altering product_info.php I got the additional images in a propper place, plus the one at the top. Looks like similiar problem to double header issue.

 

(use of additional images were declared in the user_code.php and seams to work fine, so i presume its contribution error at some point)

 

Please help or let me know if you need any additional info to solve this issue.

 

Best regards!

 

Ignore me on this one, it was my mistake... Sorry for trouble!

Share this post


Link to post
Share on other sites
There is a new index module on the contribution page. Changelog is as follow:

 

Changes:

- BUG CORRECTED: index.php_0.html template for main page was not working.

- ADDED: new module parameter to set in admin.

=> You now have the choice to look or not for templates of parent categories, if there is no template for the current category.

 

No need to create a template for each category if you want to have a template specific to the home page.

 

@rodrico: you have not copied all the STS files to your store, check your installation again, some files are missing.

 

- Rigadin

 

I've tried to add the additional module but it's not working. On my admin page, I only get default in STS, and I can't uninstall it. I've replaced the file according to the readme.txt, but something seems to be wrong.

Share this post


Link to post
Share on other sites

How do I get my home page to come up as the way I've designed it using STS? After reading through all 17 pages of this topic, it seems that I have to install the index module v. 1.0.3, but the installation isn't working. (See previous post.) What do I need to do? I just can't see to figure this out...

 

(My apologies if this question is dumb because it's something so basic that I should know it.) :blush:

Share this post


Link to post
Share on other sites

I hate to add another "I have 2 headers" whinge to the pile already here, but I've downloaded and installed the 2 downloads Bill has pointed out numerous times and still have the same problem.

 

What might make my installation different is the use of the "Register Globals" patch files which allow me to bypass having Register_globals on.

 

Is anyone else running STS4.1 successfully WITH the register_globals patch? If so, please tell me how you've done so. If not, I'll have to find a better way to deal with the register_globals issue.

 

Thanks!

Edited by mariachi77

Share this post


Link to post
Share on other sites

hi all I have upgraded to STS 4.1 but for some reason cannot get the product_info.php template to work properly,

 

it cuts out after

 

Option Header:

Option Names: Option Choices

 

I don?t get the options or the buy now button

 

any suggestions?

 

Danny

Share this post


Link to post
Share on other sites

ok fixed that, needed to update the module in modules/sts

only thing now is that the Buy Now button doesnt add the product to the cart.

 

any help??

 

cheers

Danny

Share this post


Link to post
Share on other sites

Hello all,

 

thanx for the contribution STS 4.1. i have installed it and it works fine with HTC, extra images. however, when i enable search engine friendly urls, my product template does not appear but goes back to default osc product page. does sts 4.1 work with search engine friendly urls or not?

 

Thanks

Share this post


Link to post
Share on other sites

Fatal error: Call to undefined function: tep_not_null() in c:\sites\musitec\includes\classes\sts.php

?????????????

Share this post


Link to post
Share on other sites
Jim, This is a well documented issue. Unfortunately, a few bad files have been uploaded in the download section of STS v4. It appears you have installed two of these files which cause the issues you are experiencing.

 

To install it correctly, You will only need to download and install this and then this. :thumbsup:

 

The STS v4.1 by rigadin as well as the Index module v1.0.3 for STS4.

 

The two files between these two contributions have been known to cause problems such as double headers and php errors. ;)

 

I've done a few clean reinstalls of OsCommerce followed by the STS4.1 contribution and the Index module v1.0.3 update and I'm still getting 2 headers. I've activated register_globals on my server, so I no longer have that problem. Can anyone please tell me what I'm doing wrong?

Share this post


Link to post
Share on other sites

Has anyone gotten STS and Fast Easy Checkout to play well together.

 

The problem I'm having is that FEC calls a toggle_collapse javascript function. However the "collapse" aspect doesn't work. The form that's supposed to be collapsed is already expanded.

 

Here's the particular area of code that defines the form and the toggle_collapse function call:

 

<td height="35" class="infoboxheader" valign="middle"><?php echo LOGINBOX_EXSISTING_CUSTOMER_NOW ?><?php //echo tep_draw_checkbox_field('caccount', 'Y',$checked = false ,'id="togglenow"' ) . '  ' ; ?><input type="image" src="images/collapse_tcat.gif" name="row" value="1" onclick="return toggle_collapse('forumbit_2')"></td>

</tr><TBODY id=collapseobj_forumbit_2>

<td><p id="lorem2" >

<table border="0" width="100%" height="100%" cellspacing="0" cellpadding="2">

<tr class="infoBoxContents">

<td colspan="2"><?php echo tep_draw_separator('pixel_trans.gif', '100%', '10'); ?><?php echo tep_draw_form('login', tep_href_link(FILENAME_LOGIN, 'action=process', 'SSL')); ?></td>

</tr>

 

<td colspan="2"><?php //echo tep_draw_separator('pixel_trans.gif', '100%', '10'); ?></td>

</tr>

<tr class="infoBoxContents">

<td class="main"><b><?php echo ENTRY_EMAIL_ADDRESS; ?></b></td>

<td class="main"><?php echo tep_draw_input_field('email_address'); ?></td>

</tr>

<tr class="infoBoxContents">

<td class="main"><b><?php echo ENTRY_PASSWORD; ?></b></td>

<td class="main"><?php echo tep_draw_password_field('password'); ?></td>

</tr>

<tr>

<td colspan="2"><?php //echo tep_draw_separator('pixel_trans.gif', '100%', '10'); ?></td>

</tr>

<tr>

<td align="right"><?php echo tep_image_submit('button_login.gif', IMAGE_BUTTON_LOGIN); ?></P></td><td class="smallText" colspan="2"><?php echo '<a href="' . tep_href_link(FILENAME_PASSWORD_FORGOTTEN, '', 'SSL') . '">' . TEXT_PASSWORD_FORGOTTEN . '</a>'; ?></td>

 

</table> </form></td><script>toggle_collapse('forumbit_2')</script>

</tr> </TBODY>

 

The toggle_collapse function is defined in globals.js. I've tried putting the js code in header.php, between the <head> tags in sts_template.html. I guess I'm at a loss as to what to do to get this to work.

 

Any ideas or suggestions would be greatly appreciated!!


I only do what my Rice Krispies tell me to do!

Share this post


Link to post
Share on other sites

Ive got a weird issue ive just noticed thats started to happen

 

for some reason my pages are getting:

 

<!-- footer_eof //-->
</body>
</html>

 

added to the bottom of the page so its doubling the closing tags up and causing problems:

 

 

</body>
</html><!-- footer_eof //-->
</body>
</html>

 

i know the footer comment and the extra tags are coming from the original oscommerce files but i cant for the life of me figure out why???

 

anyone have any ideas?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×