Jump to content
rigadin2

[Contribution] STS v4

Recommended Posts

Check your install over and confirm that you have indeed uploaded the files to the right places.

Are the STS files for the main root includes or the admin includes

Share this post


Link to post
Share on other sites
Not sure where they go!!.

Now I have got these errors?

 

Warning: main(includes/classes/navigation_history.php): failed to open stream: No such file or directory in /hsphere/local/home/sharkcar/genesishealthfoods.com/catalog/admin/includes/application_top.php on line 128

 

Warning: main(includes/classes/navigation_history.php): failed to open stream: No such file or directory in /hsphere/local/home/sharkcar/genesishealthfoods.com/catalog/admin/includes/application_top.php on line 128

 

Fatal error: main(): Failed opening required 'includes/classes/navigation_history.php' (include_path='.:/usr/local/lib/php:/usr/local/share/pear') in /hsphere/local/home/sharkcar/genesishealthfoods.com/catalog/admin/includes/application_top.php on line 128

Share this post


Link to post
Share on other sites
Now I have got these errors?

 

Warning: main(includes/classes/navigation_history.php): failed to open stream: No such file or directory in /hsphere/local/home/sharkcar/genesishealthfoods.com/catalog/admin/includes/application_top.php on line 128

 

Warning: main(includes/classes/navigation_history.php): failed to open stream: No such file or directory in /hsphere/local/home/sharkcar/genesishealthfoods.com/catalog/admin/includes/application_top.php on line 128

 

Fatal error: main(): Failed opening required 'includes/classes/navigation_history.php' (include_path='.:/usr/local/lib/php:/usr/local/share/pear') in /hsphere/local/home/sharkcar/genesishealthfoods.com/catalog/admin/includes/application_top.php on line 128

 

The catalog works but admin is dead??

Share this post


Link to post
Share on other sites

Hi,

 

Is there a way to edit the table headings in the product listing? I have tried to edit the product_listing.php with no luck.

I want to use other headings than Model, Manufacturer and Quantity...

 

(Yes I have searched and browsed the forum without any success in this matter)

 

Thanks! :rolleyes:

Share this post


Link to post
Share on other sites
I will do a fresh install again damm!
Neil,

 

The folder structure should me maintained as set in the contribution.

For example, you should ftp everything inside of the STS folder, which would be the includes folder and everything in it to your catalog folder of your shop (http://mystore.com/catalog/).

 

Then you need to either FTP everything inside one of the osc version folders (Files for MS2, Files for RC1, or Files for RC2) to your catalog folder of your shop (http://mystore.com/catalog/).

 

Your catalog folder could be called anything from catalog, shop, store, or could be the very root of your domain such as http://mystore.com/.


Bill Kellum

 

Sounds Good Productions

STS Tutorials & more: STSv4.6, STS Add-ons (STS Power Pack), STS V4 Forum STS Forum FREE TEMPLATE

Share this post


Link to post
Share on other sites
Hi,

 

Is there a way to edit the table headings in the product listing? I have tried to edit the product_listing.php with no luck.

I want to use other headings than Model, Manufacturer and Quantity...

 

(Yes I have searched and browsed the forum without any success in this matter)

 

Thanks! :rolleyes:

John,

This is not a STS related question but I will help out anyway...

  1. Answer: http://forums.oscommerce.com/index.php?showtopic=165632
  2. How to search for the answer: Google this:
    site:forums.oscommerce.com table headings in the product listing



Bill Kellum

 

Sounds Good Productions

STS Tutorials & more: STSv4.6, STS Add-ons (STS Power Pack), STS V4 Forum STS Forum FREE TEMPLATE

Share this post


Link to post
Share on other sites
Neil,

 

The folder structure should me maintained as set in the contribution.

For example, you should ftp everything inside of the STS folder, which would be the includes folder and everything in it to your catalog folder of your shop (http://mystore.com/catalog/).

 

Then you need to either FTP everything inside one of the osc version folders (Files for MS2, Files for RC1, or Files for RC2) to your catalog folder of your shop (http://mystore.com/catalog/).

 

Your catalog folder could be called anything from catalog, shop, store, or could be the very root of your domain such as http://mystore.com/.

 

Thanks bill all works well now!!!

Share this post


Link to post
Share on other sites

I have just installed version 4.5.8 and get this error:

 

Warning: main(includes/classes/logger.php) [function.main]: failed to open stream: No such file or directory in /home/src/public_html/shop/admin/includes/application_top.php on line 74

 

Warning: main(includes/classes/logger.php) [function.main]: failed to open stream: No such file or directory in /home/src/public_html/shop/admin/includes/application_top.php on line 74

 

Warning: main(includes/classes/logger.php) [function.main]: failed to open stream: No such file or directory in /home/src/public_html/shop/admin/includes/application_top.php on line 74

 

Fatal error: main() [function.require]: Failed opening required 'includes/classes/logger.php' (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/src/public_html/shop/admin/includes/application_top.php on line 74

 

 

I have checked and rechecked everything is uploaded to the correct area - I noticed reference to a file called logger.php - I don't seem to have this in either admin\includes\classes or catalog\includes\classes neither can I see it in the STS contribution. I have a fresh install.

 

The catalog works fine it's the Admin that doesn't work. I have called my "catalog" directory "shop" but I don't think this should matter.

 

Thanks

Share this post


Link to post
Share on other sites
I have just installed version 4.5.8 and get this error:

 

Warning: main(includes/classes/logger.php) [function.main]: failed to open stream: No such file or directory in /home/src/public_html/shop/admin/includes/application_top.php on line 74

 

Warning: main(includes/classes/logger.php) [function.main]: failed to open stream: No such file or directory in /home/src/public_html/shop/admin/includes/application_top.php on line 74

 

Warning: main(includes/classes/logger.php) [function.main]: failed to open stream: No such file or directory in /home/src/public_html/shop/admin/includes/application_top.php on line 74

 

Fatal error: main() [function.require]: Failed opening required 'includes/classes/logger.php' (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/src/public_html/shop/admin/includes/application_top.php on line 74

I have checked and rechecked everything is uploaded to the correct area - I noticed reference to a file called logger.php - I don't seem to have this in either admin\includes\classes or catalog\includes\classes neither can I see it in the STS contribution. I have a fresh install.

 

The catalog works fine it's the Admin that doesn't work. I have called my "catalog" directory "shop" but I don't think this should matter.

 

Thanks

 

It's OK I got it to work, thanks

Share this post


Link to post
Share on other sites

Has anyone managed to get a wysiwyg editor working with STS and HTC - I have tried everything - I had a heavily modified site and have even resorted to going back to the beginning but as soon as I install STS with HTC I can't then install a wysiwyg editor. I think the conflict is with HTC rather than STS as turning STS doesn't help but thought someone might have this contribution with an editor installed.

 

Many thanks

Share this post


Link to post
Share on other sites
John,

This is not a STS related question but I will help out anyway...

  1. Answer: http://forums.oscommerce.com/index.php?showtopic=165632
  2. How to search for the answer: Google this:
    site:forums.oscommerce.com table headings in the product listing


 

 

Sorry Billl :'( And thanks a lot!!!!

 

I hope this question is STS related (I´m pretty sure it is). I´m using category templates. I include various text in them. When I then use product_info.php_XX.html the text included in the category templates gets included in the product listed as well (under/after $content)

 

Any suggestions?

Many thanks! :thumbsup:

Share this post


Link to post
Share on other sites

Hi Bill, as a non coder I need a wysiwyg editor, how does this work with STS v4.5.8 and how do I hook it up, as I need it, LOL.

 

Also how do I place a banner add on my site (every page at the bottom).

 

many thanks

Neil

Share this post


Link to post
Share on other sites
Hi Bill, as a non coder I need a wysiwyg editor, how does this work with STS v4.5.8 and how do I hook it up, as I need it, LOL.

 

Also how do I place a banner add on my site (every page at the bottom).

 

many thanks

Neil

Neil,

I would suggest either Microsoft Expression Web or Adobe Dreamweaver. Both are WYSIWYG and both have advantages/disadvantages over each other.

 

Using a WYSIWYG editor, you would simply open the template within the editor and add your images, text and so on. The STS contribution has sample templates to help you get started.

 

Regarding the banner: You could do it using the built in banner osCommerce function or just add a typical web banner in a footer.html template and then include the footer.html in your main template page. I have created a step by step on how to do this and posted it on the STSv4 Power Site (see link in my signature below).

 

Hope this helped you out,


Bill Kellum

 

Sounds Good Productions

STS Tutorials & more: STSv4.6, STS Add-ons (STS Power Pack), STS V4 Forum STS Forum FREE TEMPLATE

Share this post


Link to post
Share on other sites
Has anyone managed to get a wysiwyg editor working with STS and HTC - I have tried everything - I had a heavily modified site and have even resorted to going back to the beginning but as soon as I install STS with HTC I can't then install a wysiwyg editor. I think the conflict is with HTC rather than STS as turning STS doesn't help but thought someone might have this contribution with an editor installed.

 

Many thanks

Lottie,

I have STS, HTC and TinyMCE HTML editor installed together with no issues. Let me know what page(PHP file) are you stuck on and I could help you out with it.


Bill Kellum

 

Sounds Good Productions

STS Tutorials & more: STSv4.6, STS Add-ons (STS Power Pack), STS V4 Forum STS Forum FREE TEMPLATE

Share this post


Link to post
Share on other sites
Neil,

I would suggest either Microsoft Expression Web or Adobe Dreamweaver. Both are WYSIWYG and both have advantages/disadvantages over each other.

 

Using a WYSIWYG editor, you would simply open the template within the editor and add your images, text and so on. The STS contribution has sample templates to help you get started.

 

Regarding the banner: You could do it using the built in banner osCommerce function or just add a typical web banner in a footer.html template and then include the footer.html in your main template page. I have created a step by step on how to do this and posted it on the STSv4 Power Site (see link in my signature below).

 

Hope this helped you out,

 

Thanks Bill

 

regards

Neil

Share this post


Link to post
Share on other sites

Hi Bill, are there any other mods that work with sts v4 that will make my life easy in regards to design.

 

thanks

Neil

Share this post


Link to post
Share on other sites
Hi Bill, are there any other mods that work with sts v4 that will make my life easy in regards to design.

 

thanks

Neil

Neil,

I listed my suggestions regarding category box contributions in the STS User Manual and you can find some more suggestions at the STSv4 Power Pack site (a site dedicated to STS addons as well as tips and guides).


Bill Kellum

 

Sounds Good Productions

STS Tutorials & more: STSv4.6, STS Add-ons (STS Power Pack), STS V4 Forum STS Forum FREE TEMPLATE

Share this post


Link to post
Share on other sites
Neil,

I listed my suggestions regarding category box contributions in the STS User Manual and you can find some more suggestions at the STSv4 Power Pack site (a site dedicated to STS addons as well as tips and guides).

 

Ok thanks Bill

God Bless

Share this post


Link to post
Share on other sites

Ok I have a weird problem with the headers its not displaying properly in I.E. It shows a white spot.

In firefox it has no problem no white spot

messedye9.th.gif

 

Heres the code from

infobox.php.html which I assume is causing the problem

<table width="100%" border="0" cellspacing="0" cellpadding="0" style="border-collapse: collapse" bordercolor="#111111">
 <tr>
<td width="11">
<!--<img border="0" src="images/infobox/corner_left.gif" width="11" height="14"></td>-->
<td background="images/infobox_03.gif" class="infoBoxHeading" width="180" height="34" >$headertext</td>
 <!--  <td width="92" style="background-repeat: norepeat" bgcolor="#444444">$right_arrow</td>-->
<td width="11" background="images/infobox_04.gif" style="background-repeat: norepeat">
 <!--  <img border="0" src="images/infobox/corner_right.gif" width="11" height="14"></td>-->
 </tr>
</table>
<table width="100%" border="0" cellspacing="0" cellpadding="0" background="middle.gif" style="border-collapse: collapse" bordercolor="#111111">
 <tr>
  <td background="middle.gif"> </td>
<td bgcolor="#DBF1FF">$content</td>
<td> </td>
 </tr>
 <tr>
<td width="30"> </td>
<td width="100%"> </td>
<td width="31"> </td>

 

also in stylesheet its:

 

TD.infoBoxHeading {

color: white;

font-family: Verdana, Arial, Helvetica, sans-serif;

font-size: 11px;

/*font-weight: bold;*/

background: #2C2C2C url(header.gif) top left repeat-x;

height: 24px;

padding: 0 3px;

border-left: solid .05px #404040;

border-right: solid .05px #121212;

border-top: solid 1px #3C3C3C;

border-bottom: solid 1px #131313;

}

 

Not sure what the problem is any help would be great ! :) never saw a problem till I opened IE

Share this post


Link to post
Share on other sites

I fixed it it was the

border-left: solid .05px #404040;

border-right: solid .05px #121212;

border-top: solid 1px #3C3C3C;

border-bottom: solid 1px #131313;

causing problems in IE which seems weird to me, it looked better with the border hmmm

Share this post


Link to post
Share on other sites

Hi. First of all, thanks for this great module!

 

Now to my problem.

I want to be able to have a customized homepage but am having trouble to make it work.

I read in an earlier post that I just can make my home page look like I want it in index.php_0.html. But then when I try to go to the shop it just shows me the home page (since there is no call for $content).

Is there any way to change the content from displaying:

"What's New Here?

Welcome Guest! Would you like to log yourself in? Or would you prefer to create an account?"

to something I want without messing up the rest of the shop?

My site is currently here: http://83.233.144.19/catalog/index.php (the link saying "till Butiken" takes you to the shop)

 

Thanks in advance.

//Daniel

Share this post


Link to post
Share on other sites
Hi Bill, are there any other mods that work with sts v4 that will make my life easy in regards to design.

 

thanks

Neil

 

Is there anybody who managed to use the add-on Product Extra Fields (v2.0j) in combination with STSv4.5.8.

I am using OsCommerce version 2.2ms2.

 

First I installed STSv4.5.8 over a fresh OSC installation > everything ok

Second I installed Product Extra Fields and happened to work ok, but the extra fields are not visible on the shop-side (admin side works fine)

 

Tried to manage the problem by using the STSv4.5.2_and_PRODUCT_EXTRA_FIELD (21 augustus 2007 by njnj) but doesn't help.

 

Seems to me there is no up to date modification for combination like I mention above?

 

Somebody who uses the same configuration with succes?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×