Jump to content
Latest News: (loading..)
rigadin2

[Contribution] STS v4

Recommended Posts

Pat, I would be interested (and so would the rest of the STS community) in seeing what kind of "little PHP functions" that you have created STS tags for. We have created a site called the STSv4 Power Pack that is a collection of custom addons for STS. Would you like to share? :thumbsup:

The link is in my signature below (STSv4 Power Pack).

Thanks!

 

Sure, of course I'll share my little snippets. They are mostly things that I like to include in my header. Give me a couple more days to get them all ironed out and then I'll drop you a line. Still can't figure out why $catmenu doesn't retain the OsCSID so I'm also looking into that.

 

I have a couple other questions if I may. If these are answered in the STS help doc, just say so and I'll go back and read it again. But I didn't see anything on first pass:

 

How are language definition files handled with STS?

 

What about Javascript code? For example, I want to include a javascript popup but the sts_user_code.php doesn't like it. I'm thinking that I should just include it in the <head> </head> of my sts_template.html file instead of trying to shoehorn it into the sts_user_code.php. What do you think?

 

Edit: I just tried including the Javascript code in the <head> </head> of my sts_template.html and it all worked fine. So I guess that's what I'll do.

 

Thanks in advance,

Pat

Edited by 1Putts

Share this post


Link to post
Share on other sites

Hello again!!

 

I've managed to find most of the things I need to make changes, but I managed to botch something and I have no idea how. On my index page, the box for "new products for february" now displays "TABLE_HEADING_NEW_PRODUCTS" and I can not for the life of me figure out which file or what line I removed to do that... Can anyone help? I'm posting here cause I'm using STS to skin it, so I have no idea what file I would have messed up to cause that.

 

My site is here: http://www.mixologymakeup.com/catalog

 

Thanks!!!

Edited by jaqy

Share this post


Link to post
Share on other sites

Starting a new site, I want STS and HTC but I'm not sure which contribution to install - does the lastest STS contrib include HTC or should I install v4.3.2 or go for one of the STS power packs - I'm not sure which is best to choose. Could someone please offer some advice?

 

Thanks

 

Lotti

Share this post


Link to post
Share on other sites
Starting a new site, I want STS and HTC but I'm not sure which contribution to install - does the lastest STS contrib include HTC or should I install v4.3.2 or go for one of the STS power packs - I'm not sure which is best to choose. Could someone please offer some advice?

 

Thanks

 

Lotti

Lotti,

Use the latest of both (STSv4.5.8 and HTCv2.6.3) and follow my step by step guide (link in my signature below).


Bill Kellum

 

Sounds Good Productions

STS Tutorials & more: STSv4.6, STS Add-ons (STS Power Pack), STS V4 Forum STS Forum FREE TEMPLATE

Share this post


Link to post
Share on other sites
Hello again!!

 

I've managed to find most of the things I need to make changes, but I managed to botch something and I have no idea how. On my index page, the box for "new products for february" now displays "TABLE_HEADING_NEW_PRODUCTS" and I can not for the life of me figure out which file or what line I removed to do that... Can anyone help? I'm posting here cause I'm using STS to skin it, so I have no idea what file I would have messed up to cause that.

 

My site is here: http://www.mixologymakeup.com/catalog

 

Thanks!!!

Jacqueline,

Looks like you messed up one of your language files. Compare your language files with that of a stock osC (from the download). STS would not have caused this.


Bill Kellum

 

Sounds Good Productions

STS Tutorials & more: STSv4.6, STS Add-ons (STS Power Pack), STS V4 Forum STS Forum FREE TEMPLATE

Share this post


Link to post
Share on other sites
Lotti,

Use the latest of both (STSv4.5.8 and HTCv2.6.3) and follow my step by step guide (link in my signature below).

Many thanks use STSv4.5.2 last time, will update to STSv4.5.8 this time - can't imagine doing a site without STS!!!

Share this post


Link to post
Share on other sites
Sure, of course I'll share my little snippets. They are mostly things that I like to include in my header. Give me a couple more days to get them all ironed out and then I'll drop you a line. Still can't figure out why $catmenu doesn't retain the OsCSID so I'm also looking into that.

 

I have a couple other questions if I may. If these are answered in the STS help doc, just say so and I'll go back and read it again. But I didn't see anything on first pass:

 

How are language definition files handled with STS?

 

What about Javascript code? For example, I want to include a javascript popup but the sts_user_code.php doesn't like it. I'm thinking that I should just include it in the <head> </head> of my sts_template.html file instead of trying to shoehorn it into the sts_user_code.php. What do you think?

 

Edit: I just tried including the Javascript code in the <head> </head> of my sts_template.html and it all worked fine. So I guess that's what I'll do.

 

Thanks in advance,

Pat

Language definition files are handled the exact same way as a stock osC without STS installed. If you want, you could use the langid tag (look in the STS User Manual for the exact tag name) to add language specific images to your templates.

 

Regarding external JavaScript...

A couple of ways to do this:

  1. Insert a link to the JavaScript in the head section of your template just after the link to the stylesheet.css file.
    Example:
    <link rel="stylesheet" type="text/css" href="stylesheet.css">
    // begin call to javascript
    <script language="JavaScript">
    <script src="my_javascripts_folder/my_custom_javascript.js"></script>
    // end call to javascript
  2. Use the STS tag $extracss to link your custom JavaScript.
    You can use this placeholder if you want to dynamically add something in the html header, like an extra css file or JavaScript to load, depending on the page viewed.
     
    How to Use:
    Insert
    <!--$extracss-->

    between <head> and </head> of your template. It is important to keep the comment chars before and after the $extracss tag, otherwise it won't work.
     
    Code example: Here is a simple example to dynamically add a stylesheet to the template. This stylesheet is located in the same folder as the template itself. This code can be placed in includes/modules/sts_inc/sts_user_code.php.
     

    $sts->template['extracss'].= '<link rel="stylesheet" type="text/css" href="' . STS_TEMPLATE_DIR  .'stylesheet2.css">';



Bill Kellum

 

Sounds Good Productions

STS Tutorials & more: STSv4.6, STS Add-ons (STS Power Pack), STS V4 Forum STS Forum FREE TEMPLATE

Share this post


Link to post
Share on other sites

Thanks Bill,

 

Sorry for the delay in getting back to you, been out sick since last Friday afternoon

 

I will search again (tried searching before posting and didn't find anything). I don't want to exclude it from STS though as I want the formatting from STS for the look of the page <_< This is one of those issues I never got resolved first time around, so thought it would be nice to get it working correctly this time through :)

 

Hopefully a new search tomorrow will yield better results than last time ;)

 

Tracy, the reason it works without STS is because the author of the Testimonials contribution did not follow osC standards for creating the form. I know this has already been addressed in the forums but do not have that information available to me at the moment (maybe a search will locate it). Have you tried adding the file to the list of files to exclude from STS?

~Tracy
 

Share this post


Link to post
Share on other sites

So I'm trying to trouble shoot some issues that I'm having with oscommerce. I have installed the catalog and the catalog page is up and running. I've installed the newest version of sts_template, but when I validate the html I'm getting a doctype error that says:

 

This page is not Valid (no Doctype found)!

Result: Failed validation, 183 Errors

Address:

Modified: (undefined)

Server: Apache/2.2.8 (Unix) mod_ssl/2.2.8 OpenSSL/0.9.8b DAV/2 mod_auth_passthrough/2.1 mod_bwlimited/1.4

Size: (undefined)

Content-Type: text/html

Encoding: iso-8859-1

Doctype: (no Doctype found)

Root Element: br

 

 

But my page includes the following code:

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN">

<html dir="LTR" lang="en">

<head>

<meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1">

<title>Shaw's Saddlery</title>

 

 

Here is a link to my page: My Catalog

 

I have tried everything that I can think of to try and fix this with no result. Can someone please help me??? :'(

Edited by njj942

Share this post


Link to post
Share on other sites

Ok I've Got STSv4 & sort_order contributions installed on my OsComm.

 

Just a little error: when Categories are displayed at localhost/shop/catalog/index.php?cPath=0 level the top-right image goes blank.

Actually the image location is set like this: localhost/shop/catalog/includes/sts_templates/full/images/ meaning that it tries to load an image in the sts templates images folder but does not specify witch image...

 

In the other hand when i load a Category from my Catalog Menu the corresponding images appears as well.

 

Any idea of what's causing this?

Share this post


Link to post
Share on other sites

I do believe I have gotten Customer Testimonials 2.0 TO WORK with STS - WOO HOO!!!!

 

Ok - here is what I did (please let me know if you spot something I've done incorrectly).

 

In catalog/customer_testimonials.php

around lines 81 - 148 find this bit of code

<?php

if ($HTTP_GET_VARS['action']) {
switch ($HTTP_GET_VARS['action']) {
  case 'insert':
	$testimonials_id = tep_db_prepare_input($HTTP_POST_VARS['testimonials_id']);
	$testimonials_title = tep_db_prepare_input($HTTP_POST_VARS['testimonials_title']);
	$testimonials_url = tep_db_prepare_input($HTTP_POST_VARS['testimonials_url']);
	$testimonials_url_title = tep_db_prepare_input($HTTP_POST_VARS['testimonials_url_title']);
	$testimonials_name = tep_db_prepare_input($HTTP_POST_VARS['testimonials_name']);
	$testimonials_last_name = tep_db_prepare_input($HTTP_POST_VARS['testimonials_last_name']);
	$html_text = tep_db_prepare_input($HTTP_POST_VARS['html_text']);

	$testimonials_error = false;
	$messageStack = ERROR_HEADER;
	if (empty($testimonials_title)) {
	  $messageStack .= '['.ERROR_TESTIMONIALS_TITLE_REQUIRED.']';
	  $testimonials_error = true;
	}
	if (empty($testimonials_name)) {
	  $messageStack .= '['.ERROR_TESTIMONIALS_NAME_REQUIRED.']';
	  $testimonials_error = true;
	}
	if (empty($html_text)) {
	  $messageStack.= '['.ERROR_TESTIMONIALS_DESCRIPTION_REQUIRED.']';
	  $testimonials_error = true;
	}

	if (!$testimonials_error) {
	  $sql_data_array = array('testimonials_title' => $testimonials_title,
							  'testimonials_url' => $testimonials_url,
							  'testimonials_url_title' => $testimonials_url_title,
							  'testimonials_name' => $testimonials_name,
							  'testimonials_last_name' => $testimonials_last_name,
							  'testimonials_html_text' => $html_text);
	 if ($HTTP_GET_VARS['action'] == 'insert') {
	   $insert_sql_data = array('date_added' => 'now()',
								 'status' => '0');
		$sql_data_array = array_merge($sql_data_array, $insert_sql_data);
		tep_db_perform(TABLE_CUSTOMER_TESTIMONIALS, $sql_data_array);
		$testimonials_id = tep_db_insert_id();
	  }
	  echo '<tr><td colspan="2">' . tep_draw_separator('pixel_trans.gif', '1', '10') .' </td></tr>';
	  echo '<tr><td class="main">'. TEXT_TESTIMONIALS_SUCCESSFUL .'</td><td class="main"></td></tr>';
	  $testimonials_id = '';
	   $testimonials_title = '';
	   $testimonials_url = '';
	   $testimonials_url_title = '';
	   $testimonials_name = '';
	   $testimonials_last_name = '';
	   $html_text = '';
	} else {
	   echo '<tr><td colspan="2">' . tep_draw_separator('pixel_trans.gif', '1', '10') .' </td></tr>';
	   echo '<tr><td class="main">'. $messageStack .'</td><td class="main"></td></tr>';

	   $testimonials_id = tep_db_prepare_input($HTTP_POST_VARS['testimonials_id']);
	   $testimonials_title = tep_db_prepare_input($HTTP_POST_VARS['testimonials_title']);
	   $testimonials_url = tep_db_prepare_input($HTTP_POST_VARS['testimonials_url']);
	   $testimonials_url_title = tep_db_prepare_input($HTTP_POST_VARS['testimonials_url_title']);
	   $testimonials_name = tep_db_prepare_input($HTTP_POST_VARS['testimonials_name']);
	   $testimonials_last_name = tep_db_prepare_input($HTTP_POST_VARS['testimonials_last_name']);
	   $html_text = tep_db_prepare_input($HTTP_POST_VARS['html_text']);
	}
	break;
}
 }

?>

 

I changed it to this:

<?php

if ($HTTP_GET_VARS['action']) {
switch ($HTTP_GET_VARS['action']) {
  case 'insert':
	$testimonials_id = tep_db_prepare_input($HTTP_POST_VARS['testimonials_id']);
	$testimonials_title = tep_db_prepare_input($HTTP_POST_VARS['testimonials_title']);
	$testimonials_url = tep_db_prepare_input($HTTP_POST_VARS['testimonials_url']);
	$testimonials_url_title = tep_db_prepare_input($HTTP_POST_VARS['testimonials_url_title']);
	$testimonials_name = tep_db_prepare_input($HTTP_POST_VARS['testimonials_name']);
	$testimonials_last_name = tep_db_prepare_input($HTTP_POST_VARS['testimonials_last_name']);
	$html_text = tep_db_prepare_input($HTTP_POST_VARS['html_text']);


	if (empty($testimonials_title)) {
	  $messageStack->add('header', ERROR_TESTIMONIALS_TITLE_REQUIRED, 'warning');
	  $testimonials_error = true;
	}
	if (empty($testimonials_name)) {
	  $messageStack->add('header', ERROR_TESTIMONIALS_NAME_REQUIRED, 'warning');
	  $testimonials_error = true;
	}
	if (empty($html_text)) {
	  $messageStack->add('header', ERROR_TESTIMONIALS_DESCRIPTION_REQUIRED, 'warning');
	  $testimonials_error = true;
	}

	if (!$testimonials_error) {
	$testimonials_error = false;
	$messageStack->add('header', TEXT_TESTIMONIALS_SUCCESSFUL, 'warning');

	  $sql_data_array = array('testimonials_title' => $testimonials_title,
							  'testimonials_url' => $testimonials_url,
							  'testimonials_url_title' => $testimonials_url_title,
							  'testimonials_name' => $testimonials_name,
							  'testimonials_last_name' => $testimonials_last_name,
							  'testimonials_html_text' => $html_text);
	 if ($HTTP_GET_VARS['action'] == 'insert') {
	   $insert_sql_data = array('date_added' => 'now()',
								 'status' => '0');
		$sql_data_array = array_merge($sql_data_array, $insert_sql_data);
		tep_db_perform(TABLE_CUSTOMER_TESTIMONIALS, $sql_data_array);
		$testimonials_id = tep_db_insert_id();
	  }
	  echo '<tr><td colspan="2">' . tep_draw_separator('pixel_trans.gif', '1', '10') .' </td></tr>';
	  echo '<tr><td class="main">'. TEXT_TESTIMONIALS_SUCCESSFUL .'</td><td class="main"></td></tr>';
	  $testimonials_id = '';
	   $testimonials_title = '';
	   $testimonials_url = '';
	   $testimonials_url_title = '';
	   $testimonials_name = '';
	   $testimonials_last_name = '';
	   $html_text = '';
	} else {
	   echo '<tr><td colspan="2">' . tep_draw_separator('pixel_trans.gif', '1', '10') .' </td></tr>';

	   $testimonials_id = tep_db_prepare_input($HTTP_POST_VARS['testimonials_id']);
	   $testimonials_title = tep_db_prepare_input($HTTP_POST_VARS['testimonials_title']);
	   $testimonials_url = tep_db_prepare_input($HTTP_POST_VARS['testimonials_url']);
	   $testimonials_url_title = tep_db_prepare_input($HTTP_POST_VARS['testimonials_url_title']);
	   $testimonials_name = tep_db_prepare_input($HTTP_POST_VARS['testimonials_name']);
	   $testimonials_last_name = tep_db_prepare_input($HTTP_POST_VARS['testimonials_last_name']);
	   $html_text = tep_db_prepare_input($HTTP_POST_VARS['html_text']);
	}
	break;
}
 }

?>

 

It isn't absolutely perfect in that I don't know anything other than 'warning' to put at the end of the $messageStack bit, but it does allow the form submission to work and the errors show at the top of the page (as well as the successful submission message) in the pink banner.

 

Now I just need to figure out how to set it so that it doesn't load every testimonial in the database above the form when it returns results after clicking submit!! - LOL

 

 

Thanks Bill,

 

Sorry for the delay in getting back to you, been out sick since last Friday afternoon

 

I will search again (tried searching before posting and didn't find anything). I don't want to exclude it from STS though as I want the formatting from STS for the look of the page <_< This is one of those issues I never got resolved first time around, so thought it would be nice to get it working correctly this time through :)

 

Hopefully a new search tomorrow will yield better results than last time ;)


~Tracy
 

Share this post


Link to post
Share on other sites

I would like to first say thank-you for all the individuals who have helped develop the sts packages! WOW, this has been a big help in being able to manipulate OSCOMMERCE.

 

Now for the reason i am posting. I am trying to manipulate the $content. I am NOT wanting any products to first appear when a user visits my www.fishingretailsupply.com/catalog page. I am wanting just simple text and nothing more. What do i need to do to manipulate the $content variable to not capture anything but the text i enter.

I have already manipulated the code in the index.php down to just ----- define('TEXT_MAIN', ''); -------- and have had no luck being able to eliminate the tables and product that appears. ANy Help would be very much appreciated.

 

 

:)

Share this post


Link to post
Share on other sites
I would like to first say thank-you for all the individuals who have helped develop the sts packages! WOW, this has been a big help in being able to manipulate OSCOMMERCE.

 

Now for the reason i am posting. I am trying to manipulate the $content. I am NOT wanting any products to first appear when a user visits my www.fishingretailsupply.com/catalog page. I am wanting just simple text and nothing more. What do i need to do to manipulate the $content variable to not capture anything but the text i enter.

I have already manipulated the code in the index.php down to just ----- define('TEXT_MAIN', ''); -------- and have had no luck being able to eliminate the tables and product that appears. ANy Help would be very much appreciated.

 

 

:)

evan, It is even easier than that. Just create a "home page" template and name it index.php_0.html. Add any text you want but leave out the $content tag.

Bill Kellum

 

Sounds Good Productions

STS Tutorials & more: STSv4.6, STS Add-ons (STS Power Pack), STS V4 Forum STS Forum FREE TEMPLATE

Share this post


Link to post
Share on other sites
Ok I've Got STSv4 & sort_order contributions installed on my OsComm.

 

Just a little error: when Categories are displayed at localhost/shop/catalog/index.php?cPath=0 level the top-right image goes blank.

Actually the image location is set like this: localhost/shop/catalog/includes/sts_templates/full/images/ meaning that it tries to load an image in the sts templates images folder but does not specify witch image...

 

In the other hand when i load a Category from my Catalog Menu the corresponding images appears as well.

 

Any idea of what's causing this?

Jano,

I'm having a hard time following you on this one...

 

Do you have your images folder settings in configure.php pointed toward your STS images folder? That shouldn't be.


Bill Kellum

 

Sounds Good Productions

STS Tutorials & more: STSv4.6, STS Add-ons (STS Power Pack), STS V4 Forum STS Forum FREE TEMPLATE

Share this post


Link to post
Share on other sites
Now I just need to figure out how to set it so that it doesn't load every testimonial in the database above the form when it returns results after clicking submit!! - LOL

 

Ok - just in case someone is following the fun of getting Customer Testimonials 2.0 working with STS -

 

What I ended up doing to avoid the testimonials all loading everytime the form was submitted was changing to submission to call customer_testimonials2.php (add this into includes/filenames.php too) and I removed the portion of the script that loads the testimonials. This way, on submission, you just get your error or success message and the form :)


~Tracy
 

Share this post


Link to post
Share on other sites
evan, It is even easier than that. Just create a "home page" template and name it index.php_0.html. Add any text you want but leave out the $content tag.

 

Will this allow me to utilize a $searchbox in the right column? I failed to mention that. :blush:

Edited by evan wagner

Share this post


Link to post
Share on other sites
njj942,

at 10 p.m. est your page looks O.K, are you having troubles with a specific template?

 

 

Yeah it looks fine, but if you run a html validation on the page it comes back with a doctype missing error even though I have specified the doctype on the page.

 

CAN SOMEONE PLEASE HELP ME!!! Another user on here said that they were having the same problem so its not just me. I would like to get the doctype error resolved even though the page displays correctly.

 

Here is the error message that I am getting when I validate the page:

This page is not Valid (no Doctype found)!
Result: 	Failed validation, 194 Errors
Address: 	
Modified:	(undefined)
Server:	Apache/2.2.8 (Unix) mod_ssl/2.2.8 OpenSSL/0.9.8b DAV/2 mod_auth_passthrough/2.1 mod_bwlimited/1.4
Size:	(undefined)
Content-Type:	text/html
Encoding: 	iso-8859-1	
Doctype: 	(no Doctype found)	
Root Element: 	br

 

I have in my page the following code:

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN" "http://www.w3.org/TR/html4/loose.dtd">
<html dir="LTR" lang="en">
<head>
<meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1">
<title>Shaw's Saddlery</title>
<base href="http://shawssaddlery.com/catalog/">

 

Here is a link so that you can run the validation as well if need be: My Catalog

 

PLEASE PLEASE HELP ME!!! Its probably something stupid that I'm overlooking, but I can't seem to figure it out and I've tried everything that I can think of.

Share this post


Link to post
Share on other sites

Nathan,

 

Why do you think it is necessary to not use the default STS settings:

 

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN">
<html $htmlparams>
<head>
<!--$headcontent-->
 <link rel="stylesheet" type="text/css" href="stylesheet.css">
</head>

  1. You are inserting the title and metatags manually when it would be better to use the $headcontent tag to do this.
  2. You are missing the language code from the PHP pages since you are not using the $htmlparams tag.

The whole purpose that I created a blank template in the template "test" folder was so users could see the minumum code needed in each STS template. :thumbsup:


Bill Kellum

 

Sounds Good Productions

STS Tutorials & more: STSv4.6, STS Add-ons (STS Power Pack), STS V4 Forum STS Forum FREE TEMPLATE

Share this post


Link to post
Share on other sites
Nathan,

 

Why do you think it is necessary to not use the default STS settings:

 

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN">
<html $htmlparams>
<head>
<!--$headcontent-->
 <link rel="stylesheet" type="text/css" href="stylesheet.css">
</head>

  1. You are inserting the title and metatags manually when it would be better to use the $headcontent tag to do this.
  2. You are missing the language code from the PHP pages since you are not using the $htmlparams tag.

The whole purpose that I created a blank template in the template "test" folder was so users could see the minumum code needed in each STS template. :thumbsup:

 

Bill, thank you so much for your reply. So I just reverted the code back to the original code and I am still getting the error.

 

My html is as follows:

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN">
<html $htmlparams>
<head>
<!--$headcontent-->
 <link rel="stylesheet" type="text/css" href="stylesheet.css" />
</head>

 

But I'm still getting the doctype missing error from the validation. Here's a link to the validation page: Validation

 

What should I do?

 

Thanks again for the help :thumbsup:

Edited by njj942

Share this post


Link to post
Share on other sites
Bill, thank you so much for your reply. So I just reverted the code back to the original code and I am still getting the error.

 

My html is as follows:

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN">
<html $htmlparams>
<head>
<!--$headcontent-->
 <link rel="stylesheet" type="text/css" href="stylesheet.css" />
</head>

 

But I'm still getting the doctype missing error from the validation.

 

What should I do?

 

Thanks again for the help :thumbsup:

Nathan,

Try this:

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN"
"http://www.w3.org/TR/html4/loose.dtd">
<html $htmlparams>
<head>
<!--$headcontent-->
 <link rel="stylesheet" type="text/css" href="stylesheet.css" />
</head>

If that does not do it, you may have some server issues such as a PHP page starting as <? at the top of the file where it should be <?php.

 

On another note, it is well known that osC files do not validate very well.


Bill Kellum

 

Sounds Good Productions

STS Tutorials & more: STSv4.6, STS Add-ons (STS Power Pack), STS V4 Forum STS Forum FREE TEMPLATE

Share this post


Link to post
Share on other sites

Hi Bill, I am a non coder and a newbie, so far STS looks great except I have a small problem.

Can you please help, these are the error codes I get when in admin,

STS Modules

 

Warning: main(/hsphere/local/home/sharkcar/genesishealthfoods.com/catalog/includes/languages/english/modules/sts/sts_default.php): failed to open stream: No such file or directory in /hsphere/local/home/sharkcar/genesishealthfoods.com/catalog/admin/modules.php on line 136

 

Warning: main(/hsphere/local/home/sharkcar/genesishealthfoods.com/catalog/includes/languages/english/modules/sts/sts_default.php): failed to open stream: No such file or directory in /hsphere/local/home/sharkcar/genesishealthfoods.com/catalog/admin/modules.php on line 136

 

Warning: main(): Failed opening '/hsphere/local/home/sharkcar/genesishealthfoods.com/catalog/includes/languages/english/modules/sts/sts_default.php' for inclusion (include_path='.:/usr/local/lib/php:/usr/local/share/pear') in /hsphere/local/home/sharkcar/genesishealthfoods.com/catalog/admin/modules.php on line 136

 

Warning: main(/hsphere/local/home/sharkcar/genesishealthfoods.com/catalog/includes/languages/english/modules/sts/sts_index.php): failed to open stream: No such file or directory in /hsphere/local/home/sharkcar/genesishealthfoods.com/catalog/admin/modules.php on line 136

 

Warning: main(/hsphere/local/home/sharkcar/genesishealthfoods.com/catalog/includes/languages/english/modules/sts/sts_index.php): failed to open stream: No such file or directory in /hsphere/local/home/sharkcar/genesishealthfoods.com/catalog/admin/modules.php on line 136

 

Warning: main(): Failed opening '/hsphere/local/home/sharkcar/genesishealthfoods.com/catalog/includes/languages/english/modules/sts/sts_index.php' for inclusion (include_path='.:/usr/local/lib/php:/usr/local/share/pear') in /hsphere/local/home/sharkcar/genesishealthfoods.com/catalog/admin/modules.php on line 136

 

Warning: main(/hsphere/local/home/sharkcar/genesishealthfoods.com/catalog/includes/languages/english/modules/sts/sts_popup_image.php): failed to open stream: No such file or directory in /hsphere/local/home/sharkcar/genesishealthfoods.com/catalog/admin/modules.php on line 136

 

Warning: main(/hsphere/local/home/sharkcar/genesishealthfoods.com/catalog/includes/languages/english/modules/sts/sts_popup_image.php): failed to open stream: No such file or directory in /hsphere/local/home/sharkcar/genesishealthfoods.com/catalog/admin/modules.php on line 136

 

Warning: main(): Failed opening '/hsphere/local/home/sharkcar/genesishealthfoods.com/catalog/includes/languages/english/modules/sts/sts_popup_image.php' for inclusion (include_path='.:/usr/local/lib/php:/usr/local/share/pear') in /hsphere/local/home/sharkcar/genesishealthfoods.com/catalog/admin/modules.php on line 136

 

Warning: main(/hsphere/local/home/sharkcar/genesishealthfoods.com/catalog/includes/languages/english/modules/sts/sts_product_info.php): failed to open stream: No such file or directory in /hsphere/local/home/sharkcar/genesishealthfoods.com/catalog/admin/modules.php on line 136

 

Warning: main(/hsphere/local/home/sharkcar/genesishealthfoods.com/catalog/includes/languages/english/modules/sts/sts_product_info.php): failed to open stream: No such file or directory in /hsphere/local/home/sharkcar/genesishealthfoods.com/catalog/admin/modules.php on line 136

 

Warning: main(): Failed opening '/hsphere/local/home/sharkcar/genesishealthfoods.com/catalog/includes/languages/english/modules/sts/sts_product_info.php' for inclusion (include_path='.:/usr/local/lib/php:/usr/local/share/pear') in /hsphere/local/home/sharkcar/genesishealthfoods.com/catalog/admin/modules.php on line 136

 

so I can't install the sts module till this is fixed, I am sure it's a problem I caused when installing the mod.

regards

Neil :thumbsup:

Share this post


Link to post
Share on other sites
Hi Bill, I am a non coder and a newbie, so far STS looks great except I have a small problem.

Can you please help, these are the error codes I get when in admin,

STS Modules

 

Warning: main(/hsphere/local/home/sharkcar/genesishealthfoods.com/catalog/includes/languages/english/modules/sts/sts_default.php): failed to open stream: No such file or directory in /hsphere/local/home/sharkcar/genesishealthfoods.com/catalog/admin/modules.php on line 136

 

Warning: main(/hsphere/local/home/sharkcar/genesishealthfoods.com/catalog/includes/languages/english/modules/sts/sts_default.php): failed to open stream: No such file or directory in /hsphere/local/home/sharkcar/genesishealthfoods.com/catalog/admin/modules.php on line 136

 

Warning: main(): Failed opening '/hsphere/local/home/sharkcar/genesishealthfoods.com/catalog/includes/languages/english/modules/sts/sts_default.php' for inclusion (include_path='.:/usr/local/lib/php:/usr/local/share/pear') in /hsphere/local/home/sharkcar/genesishealthfoods.com/catalog/admin/modules.php on line 136

 

Warning: main(/hsphere/local/home/sharkcar/genesishealthfoods.com/catalog/includes/languages/english/modules/sts/sts_index.php): failed to open stream: No such file or directory in /hsphere/local/home/sharkcar/genesishealthfoods.com/catalog/admin/modules.php on line 136

 

Warning: main(/hsphere/local/home/sharkcar/genesishealthfoods.com/catalog/includes/languages/english/modules/sts/sts_index.php): failed to open stream: No such file or directory in /hsphere/local/home/sharkcar/genesishealthfoods.com/catalog/admin/modules.php on line 136

 

Warning: main(): Failed opening '/hsphere/local/home/sharkcar/genesishealthfoods.com/catalog/includes/languages/english/modules/sts/sts_index.php' for inclusion (include_path='.:/usr/local/lib/php:/usr/local/share/pear') in /hsphere/local/home/sharkcar/genesishealthfoods.com/catalog/admin/modules.php on line 136

 

Warning: main(/hsphere/local/home/sharkcar/genesishealthfoods.com/catalog/includes/languages/english/modules/sts/sts_popup_image.php): failed to open stream: No such file or directory in /hsphere/local/home/sharkcar/genesishealthfoods.com/catalog/admin/modules.php on line 136

 

Warning: main(/hsphere/local/home/sharkcar/genesishealthfoods.com/catalog/includes/languages/english/modules/sts/sts_popup_image.php): failed to open stream: No such file or directory in /hsphere/local/home/sharkcar/genesishealthfoods.com/catalog/admin/modules.php on line 136

 

Warning: main(): Failed opening '/hsphere/local/home/sharkcar/genesishealthfoods.com/catalog/includes/languages/english/modules/sts/sts_popup_image.php' for inclusion (include_path='.:/usr/local/lib/php:/usr/local/share/pear') in /hsphere/local/home/sharkcar/genesishealthfoods.com/catalog/admin/modules.php on line 136

 

Warning: main(/hsphere/local/home/sharkcar/genesishealthfoods.com/catalog/includes/languages/english/modules/sts/sts_product_info.php): failed to open stream: No such file or directory in /hsphere/local/home/sharkcar/genesishealthfoods.com/catalog/admin/modules.php on line 136

 

Warning: main(/hsphere/local/home/sharkcar/genesishealthfoods.com/catalog/includes/languages/english/modules/sts/sts_product_info.php): failed to open stream: No such file or directory in /hsphere/local/home/sharkcar/genesishealthfoods.com/catalog/admin/modules.php on line 136

 

Warning: main(): Failed opening '/hsphere/local/home/sharkcar/genesishealthfoods.com/catalog/includes/languages/english/modules/sts/sts_product_info.php' for inclusion (include_path='.:/usr/local/lib/php:/usr/local/share/pear') in /hsphere/local/home/sharkcar/genesishealthfoods.com/catalog/admin/modules.php on line 136

 

so I can't install the sts module till this is fixed, I am sure it's a problem I caused when installing the mod.

regards

Neil :thumbsup:

Check your install over and confirm that you have indeed uploaded the files to the right places.

Bill Kellum

 

Sounds Good Productions

STS Tutorials & more: STSv4.6, STS Add-ons (STS Power Pack), STS V4 Forum STS Forum FREE TEMPLATE

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×