Jump to content
rigadin2

[Contribution] STS v4

Recommended Posts

Hi,

 

May be this issue raised here before. I just installed Protx Direct system. WHen on checkout_payment.php page I clicked link which open new popupwindow i.e https://www.mysite.com/cvs_help.php, this open my STS tags template page. and showing all tags on this pages.

When I temporarly Turn off STS , click open new popup with exact information suppose to show.

 

I hope someone will help me and direct me in right file and code to fix as I am still php learner.

 

 

Regards

Zee

Zee,

STS allows you to "exempt" any PHP page that you do not need templated. You could do that for your situation or the following:

 

In your cvs_help.php page, find the following line of code:

 

require('includes/application_bottom.php');

Comment out that line so it looks like this:

//require('includes/application_bottom.php');

If that does not work, then you will have to use the "exempt" method which is described below:

 

How to exclude a page from being templated in STSv4.5.8:

 

In the sts_default.php file, find the following code:

if (strstr($scriptbasename, "popup") || strstr($scriptbasename, "info_shopping_cart"))
  return ''; // We don't use template for these scripts

Add your php file that you want STS to exclude and it will not template that file. Note: Add the script name as follows:

if (strstr($scriptbasename, "popup") || strstr($scriptbasename, "your_script_here")|| strstr($scriptbasename, "info_shopping_cart"))
  return ''; // We don't use template for these scripts

That should do the trick for you.

Hope this helped,


Bill Kellum

 

Sounds Good Productions

STS Tutorials & more: STSv4.6, STS Add-ons (STS Power Pack), STS V4 Forum STS Forum FREE TEMPLATE

Share this post


Link to post
Share on other sites
Zee,

STS allows you to "exempt" any PHP page that you do not need templated. You could do that for your situation or the following:

 

In your cvs_help.php page, find the following line of code:

 

require('includes/application_bottom.php');

Comment out that line so it looks like this:

//require('includes/application_bottom.php');

If that does not work, then you will have to use the "exempt" method which is described below:

 

How to exclude a page from being templated in STSv4.5.8:

 

In the sts_default.php file, find the following code:

if (strstr($scriptbasename, "popup") || strstr($scriptbasename, "info_shopping_cart"))
  return ''; // We don't use template for these scripts

Add your php file that you want STS to exclude and it will not template that file. Note: Add the script name as follows:

if (strstr($scriptbasename, "popup") || strstr($scriptbasename, "your_script_here")|| strstr($scriptbasename, "info_shopping_cart"))
  return ''; // We don't use template for these scripts

That should do the trick for you.

Hope this helped,

 

Thanks ALot Bill,

 

This first sugegstion really worked well for me , I commented require bottom as you suggested and there is no more problem at all.

 

You are great. and very helpfull . God bless you.

Kind Regards

 

Zee

Share this post


Link to post
Share on other sites
Does STSv4.5.8 working with OSC RC2 ?

 

I tried an install but my catalog went to a blank page... :huh:

 

Jano

 

 

I just installed it on a fresh copy of RC2, no problems. Make sure you copy all the files included with STS into the right place. Follow the installation instructions for RC1 and you shouldn't have any problems.

Share this post


Link to post
Share on other sites
Thanks Bill. I am using content templates but I can't figure out how to put all the info into sts_inc/product_info.php and make the variables for it. I'm still working on it though. :blink:

 

 

Just FYI to everyone....

 

I did not succeed in combining STS with Product Attribute Option Type Feature while using content templates. I did get it to work (like everyone else) without using a template for the product_info page. It turns out that customizing the stock product_info page isn't that hard. :blush:

 

Thanks for the help though!

 

Stacy

Share this post


Link to post
Share on other sites

Can I use STS to integrate OSCommerce into my website without having to change my website around at the mercy of OSCommerce templates?

 

I just want to be able to use simple tags or code as placeholders for add to cart, and so on, to make it fit on my page, which is very, very simple.

 

Thanks!

Share this post


Link to post
Share on other sites
Can I use STS to integrate OSCommerce into my website without having to change my website around at the mercy of OSCommerce templates?

 

I just want to be able to use simple tags or code as placeholders for add to cart, and so on, to make it fit on my page, which is very, very simple.

 

Thanks!

 

Yes Scubyfan You can!

If you already have a static content website template to work with, you can do this.

Basically by adding a link to the oscommerce index page from your static site. (eg online store)

You then make the sts_template.html file exactly like your existing site so it appears that the customer never left the original site.

You add the placeholders and code to the sts_template.html file and it works!

Its a little bit tricky, but definitly can be done.

I recommend dreamweaver for this.

 

Jackdog

Share this post


Link to post
Share on other sites
Can I use STS to integrate OSCommerce into my website without having to change my website around at the mercy of OSCommerce templates?

 

I just want to be able to use simple tags or code as placeholders for add to cart, and so on, to make it fit on my page, which is very, very simple.

 

Thanks!

Henry,

Ryan is correct in his response. As a matter of fact, this is probably the biggest reason why the Simple Template System is among the top 3 downloads ever of all the osCommerce contributions. STS makes it very simple to integrate osC into your existing site. :thumbsup:


Bill Kellum

 

Sounds Good Productions

STS Tutorials & more: STSv4.6, STS Add-ons (STS Power Pack), STS V4 Forum STS Forum FREE TEMPLATE

Share this post


Link to post
Share on other sites

That is terrific to hear. I will let you guys know how it works out and when I have some problems I hope you guys can help me out! :)

Share this post


Link to post
Share on other sites
Just Copy Files... :mellow:

 

I have uploaded STSv4.5.8 that includes RC2 files for an easy "copy over".

 

I also updated the STS User Manual, each STS Module configuration text as well as the install.html page.

 

I hope everyone finds it useful,


Bill Kellum

 

Sounds Good Productions

STS Tutorials & more: STSv4.6, STS Add-ons (STS Power Pack), STS V4 Forum STS Forum FREE TEMPLATE

Share this post


Link to post
Share on other sites
I have uploaded STSv4.5.8 that includes RC2 files for an easy "copy over".

 

I also updated the STS User Manual, each STS Module configuration text as well as the install.html page.

 

I hope everyone finds it useful,

 

Hi Bill,

 

Once again, I'm sorry to seem so impatient. I don't know why I make my life so difficult(telling my dad I'd have an online store ready by the end of this week! - silly me)

I'm happy with everything else, about 35 other contributions added to my test site. yay!

Today I'm taking the test site down and starting fresh knowing what works and what doesn't :)

 

Have you had a chance to look at my last post?

Is this possible with sts?

If the answer is too long to tell me how, may I seek your professional services? (at the going rate of coarse :)

 

Its just that if I cant figure it out, I have to scrap my last 5 days of work and buy an overpriced old template($174!!!) - as you can imagine, I don't want to do that.

 

Keep up the good work :)

Share this post


Link to post
Share on other sites
Hi Bill,

 

Once again, I'm sorry to seem so impatient. I don't know why I make my life so difficult(telling my dad I'd have an online store ready by the end of this week! - silly me)

I'm happy with everything else, about 35 other contributions added to my test site. yay!

Today I'm taking the test site down and starting fresh knowing what works and what doesn't :)

 

Have you had a chance to look at my last post?

Is this possible with sts?

If the answer is too long to tell me how, may I seek your professional services? (at the going rate of coarse :)

 

Its just that if I cant figure it out, I have to scrap my last 5 days of work and buy an overpriced old template($174!!!) - as you can imagine, I don't want to do that.

 

Keep up the good work :)

Ryan,

 

I don't have time at the moment to give a detailed response but in short you need to manually edit the code or install a contribution to do it for you (no matter if you buy a template or not you will still need to do this.

 

Take a look at the following contributions:

 

http://www.oscommerce.com/community/contributions,4491

http://www.oscommerce.com/community/contri...g+Column+Format

http://www.oscommerce.com/community/contributions,651

 

Hope this helps,


Bill Kellum

 

Sounds Good Productions

STS Tutorials & more: STSv4.6, STS Add-ons (STS Power Pack), STS V4 Forum STS Forum FREE TEMPLATE

Share this post


Link to post
Share on other sites

Hi Everybody!

 

STS is perfect! I installed it and everything is like butter! Finally a way to have osc with a nice design! :)

 

Now I have a problem with the "$regularprice" tag!

 

I have installed the "attribute price update v1.4" contribution and it doesn't work with STS. Or let's say it works when I disable "product info" in admin but i need the "product info" feature!

 

Is there a possible way to have a price update after switching attributes and use product info as STS module?????

 

Any help is appreciated! Don't forget I am not a PHP pro....so keep it on the down low! ;)

 

THANKS!


IT?s ALL good!!!

Share this post


Link to post
Share on other sites

Hi guys i need your help, I have created a template in a new folder catalog/includes/sts_templates/templates i have used dreamweaver to create the template but non of my pictures that i have inserted into the template show up when the page is loaded into the browser. I have a navigation bar created in fireworks that i exported to dreamweaver as a html file, this navigation bar also has a javascript file for the pop up menu and a css file for the look of the navigation bar. I have called all of these in the code but when loaded into the browser they dont work. Any ideas whats wrong? Have i not understood how the sts template works? Can you insert pictures into it like a logo i want for every page?

 

any help will be appreciated,

 

thanks

Share this post


Link to post
Share on other sites

This is my file structure, i have created a folder called templates in sts_templates, i have configured this in admin. I have also got a folder called images in templates. All the images for the template are store in a folder called images within the templates directory. All images are jpeg. How can i change the background colour? i tried changing it in the stylesheet.css in the BODY section, i applied new rules and made a link to the background image i wanted to use but its still white and im not sure how to change it.

Share this post


Link to post
Share on other sites
This is my file structure, i have created a folder called templates in sts_templates, i have configured this in admin. I have also got a folder called images in templates. All the images for the template are store in a folder called images within the templates directory. All images are jpeg. How can i change the background colour? i tried changing it in the stylesheet.css in the BODY section, i applied new rules and made a link to the background image i wanted to use but its still white and im not sure how to change it.

 

You need to put in the full address like:

http://yoursite.com/catalog/includes/sts_t...s/yourimage.jpg

 

and not like this:

images/yourimage.jpg


IT?s ALL good!!!

Share this post


Link to post
Share on other sites
Ryan,

 

I don't have time at the moment to give a detailed response but in short you need to manually edit the code or install a contribution to do it for you (no matter if you buy a template or not you will still need to do this.

 

Take a look at the following contributions:

 

http://www.oscommerce.com/community/contributions,4491

http://www.oscommerce.com/community/contri...g+Column+Format

http://www.oscommerce.com/community/contributions,651

 

Hope this helps,

 

Thanks Bill,

 

I have tried those but will try a bit harder.

If I really cant do it, can you do the changes? I'll pay you via soundsgoodpro/paypal?

 

Kind regards

Share this post


Link to post
Share on other sites

Hi again.

 

I still haven´t been able to implement an "add-link-to-cart"... Meaning that when customers click the product listed I want it to be added to the cart immediately without having to click on the Add to cart button. I have tried everything I can come up with but: No success. :angry:

 

Therefore am I putting my last hope to you Bill (or perhaps someone else as well). :rolleyes: :rolleyes:

Share this post


Link to post
Share on other sites

Hi Bill and Every one.

 

I am using simple template for all pages means one default template.

What I am was triying to do is to create template for index page (index.php.html or what ever name) for home page. which can display Star product or hot product on top, and same for categories or Manufacture pages.

I want to dispaly this Index (Home page) but when I created index.php.html this page is displaying on every index category and manufacture pages, as index.php links to them as well.

 

What name should I give to index.php.html which should work as only a Home page. is it possible.

 

Thanks

 

Zee

Share this post


Link to post
Share on other sites
You need to put in the full address like:

http://yoursite.com/catalog/includes/sts_t...s/yourimage.jpg

 

and not like this:

images/yourimage.jpg

Hey Jay, that wouldn't be a good idea if you plan to make your shop SSL (secure cert) since all of the image links would be insecure and the browser would be screaming "This site is not safe to make purchases"...not a good thing.

 

You are correct in that Hits issue is a image path issue.

 

Hits, you should modify your image links to make paths such as

<img src="$templatedir/images/logo.gif">

Basically you want to keep all of your paths relative.

 

Hope this helped,


Bill Kellum

 

Sounds Good Productions

STS Tutorials & more: STSv4.6, STS Add-ons (STS Power Pack), STS V4 Forum STS Forum FREE TEMPLATE

Share this post


Link to post
Share on other sites
Hi Bill and Every one.

 

I am using simple template for all pages means one default template.

What I am was triying to do is to create template for index page (index.php.html or what ever name) for home page. which can display Star product or hot product on top, and same for categories or Manufacture pages.

I want to dispaly this Index (Home page) but when I created index.php.html this page is displaying on every index category and manufacture pages, as index.php links to them as well.

 

What name should I give to index.php.html which should work as only a Home page. is it possible.

 

Thanks

 

Zee

Zee,

The STS User Manual explains how to name your templates (also in the different module HTML pages included in the docs folder).

 

You would want to name your home page index.php_0.html.


Bill Kellum

 

Sounds Good Productions

STS Tutorials & more: STSv4.6, STS Add-ons (STS Power Pack), STS V4 Forum STS Forum FREE TEMPLATE

Share this post


Link to post
Share on other sites
Zee,

The STS User Manual explains how to name your templates (also in the different module HTML pages included in the docs folder).

 

You would want to name your home page index.php_0.html.

 

 

Great Bill,

 

Thanks once again. all worked fine.

 

All the best

 

Zee

Share this post


Link to post
Share on other sites
Hits, you should modify your image links to make paths such as

<img src="$templatedir/images/logo.gif">

Basically you want to keep all of your paths relative.

 

Hey Bkellum! Thanks for the advice! :thumbsup:

I am not a PHP Pro and that was my solution but I will definatly try your solution to keep things safe! THankS! :rolleyes:

 

By the way.....

 

can anybody help me out with this problem? I had posted this some days ago and didn't get any answer yet! I would like to give it a try! :blush:

Hi Everybody!

 

STS is perfect! I installed it and everything is like butter! Finally a way to have osc with a nice design!

 

Now I have a problem with the "$regularprice" tag!

 

I have installed the "attribute price update v1.4" contribution and it doesn't work with STS. Or let's say it works when I disable "product info" in admin but i need the "product info" feature!

 

Is there a possible way to have a price update after switching attributes and use product info as STS module?????

 

Any help is appreciated! Don't forget I am not a PHP pro....so keep it on the down low!

 

THANKS!

 

PLEASE HEPL IF YOU CAN! THANKS!


IT?s ALL good!!!

Share this post


Link to post
Share on other sites

Hello, I've been using STS on all my stores and I couldn't live without it... I do have a question about a new site and I'm hoping for some guidance.

 

I've installed STSv4.5.8 on a new store and also installed Header Tags using the "How to install Header Tags Controller with the Simple Template System v4x" and I think I have it installed correctly and things are working.

 

However, I installed my SSL certificate and am testing the site and am having a problem getting my padlock to show up on the https pages. I've been pouring over the forums looking for suggestions, and one thing I'm wondering is is the following code could be causing the problem... the code (when I view source code) is:

 

<!-- start get_javascript(applicationtop2header) //-->

<script language="javascript"><!--

function session_win() {

window.open("http://www.mydomain.com/info_shopping_cart.php?osCsid=79ap2qvn77nqjqitn849bkids6","info_shopping_cart","height=460,width=430,toolbar=no,statusbar=no,scrollbars=yes").focus();

}

//--></script>

<!-- end get_javascript(applicationtop2header) //-->

 

It seems to be sts related. I have another site on the same hosting that uses an older version of sts and I don't see this code when I view source code. On that site, the SSL padlock is showing on the correct pages.

 

Am I on to something here, and if so, can somebody please guide me to how I can tweak it to make my SSL happy?

 

Many thanks,

Janet

Share this post


Link to post
Share on other sites
Many thanks,

Janet

Janet,

No, that should not look like that.

You should be getting this:

 

<!-- start get_javascript(applicationtop2header) //-->

<!-- end get_javascript(applicationtop2header) //-->

Are you adding in some extra JavaScript to the page? Also, does it really say "mydomain.com" or did you add that to the post?


Bill Kellum

 

Sounds Good Productions

STS Tutorials & more: STSv4.6, STS Add-ons (STS Power Pack), STS V4 Forum STS Forum FREE TEMPLATE

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×