Jump to content
Latest News: (loading..)
rigadin2

[Contribution] STS v4

Recommended Posts

Tom, It appears you have included a template file name in the STS Modules configuration....Don't do that. :-

 

 

Thanks for the quick reponse.....however I am not understanding that, I wen to my admin under sts modules and I have the following

 

Product image popup templates (v1.0.0)

 

Use template for the image popup page

true

 

Files to include

popup_image.php.html

 

 

 

Again sorry for being an idiot :-"

Share this post


Link to post
Share on other sites
Thanks for the quick reponse.....however I am not understanding that, I wen to my admin under sts modules and I have the following

 

Product image popup templates (v1.0.0)

 

Use template for the image popup page

true

 

Files to include

popup_image.php.html

 

 

 

Again sorry for being an idiot whistling.gif

It should read: popup_image.php

Bill Kellum

 

Sounds Good Productions

STS Tutorials & more: STSv4.6, STS Add-ons (STS Power Pack), STS V4 Forum STS Forum FREE TEMPLATE

Share this post


Link to post
Share on other sites
Lee,

This is not a STS issue. This thread is for STS support.

:thumbsup: Your problem proabably arises from files and folders having the wrong permission settings causing the admin to not be able to locate them.

 

Sorry about that. I thought it might be an STS problem since the all works fine until I install STS. I will look for the problem elsewhere.

Share this post


Link to post
Share on other sites
Sorry about that. I thought it might be an STS problem since the all works fine until I install STS. I will look for the problem elsewhere.

 

Resolved. My bad on the original STS install.

Share this post


Link to post
Share on other sites

Hi there, I am considering installing this STS v4 contribution, but before I do can someone tell me if it will be of benefit? I have a heavily modified site so I am thinking it might be very complicated and not work. The main reason I am looking at this modification is that I now take credit cards besides paypal and google checkout. I do not like the fact that my customers cannot see the total order details, products purchasing + shipping = total order amount, before they input their credit card info. With paypal or google checkout they are taken to the final screen where that info is. I am hoping that with this contrib I will somehow be able to add that info in either the shopping cart screen or the checkout shipping page. I saw a screen shot of oscommerce 3.0 shopping cart page which had the info right on it! Too bad that is not here yet. Anyway, can anyone advise me on this as I have been looking for a contribution to get this done for a while now. Thanks so much in advance!!!

Share this post


Link to post
Share on other sites

I'm still trying to get the Option Type Feature to work with STS and I've had no luck. Has anyone else got this to work? I'm getting desperate. :'(

Share this post


Link to post
Share on other sites

Hi,

 

Is it possible to use a template file in catalog/includes/sts_templates/full/boxes to pick up on the new box I defined in sts_user_code.php? If so, how do I name this file?

 

Thanks,

Mark.

Share this post


Link to post
Share on other sites
Hi,

 

Is it possible to use a template file in catalog/includes/sts_templates/full/boxes to pick up on the new box I defined in sts_user_code.php? If so, how do I name this file?

 

Thanks,

Mark.

Yes, as long as you setup your new box according to how osC creates boxes then just continue to use the same template naming syntax as the other infoboxes.


Bill Kellum

 

Sounds Good Productions

STS Tutorials & more: STSv4.6, STS Add-ons (STS Power Pack), STS V4 Forum STS Forum FREE TEMPLATE

Share this post


Link to post
Share on other sites
I'm still trying to get the Option Type Feature to work with STS and I've had no luck. Has anyone else got this to work? I'm getting desperate. :'(

This should work "out of the box" as long as you are not using Product Info content templates. The $content tag will pull in the options automatically.

 

If you are using content templates, then you will need to create the tags for the product info page for STS to pull in the extra option data.


Bill Kellum

 

Sounds Good Productions

STS Tutorials & more: STSv4.6, STS Add-ons (STS Power Pack), STS V4 Forum STS Forum FREE TEMPLATE

Share this post


Link to post
Share on other sites
Hi there, I am considering installing this STS v4 contribution, but before I do can someone tell me if it will be of benefit? I have a heavily modified site so I am thinking it might be very complicated and not work. The main reason I am looking at this modification is that I now take credit cards besides paypal and google checkout. I do not like the fact that my customers cannot see the total order details, products purchasing + shipping = total order amount, before they input their credit card info. With paypal or google checkout they are taken to the final screen where that info is. I am hoping that with this contrib I will somehow be able to add that info in either the shopping cart screen or the checkout shipping page. I saw a screen shot of oscommerce 3.0 shopping cart page which had the info right on it! Too bad that is not here yet. Anyway, can anyone advise me on this as I have been looking for a contribution to get this done for a while now. Thanks so much in advance!!!

 

 

STS is not able to change the informations on the checkout pages, you'll need to modify the pages manually, for example by adding the "order total" listing at the top of the payment page.

 

- Chris


STS v4.5 SP5 is out, and check the STS Power Pack contribution too!

New thumbnailer using phpThumb: oscThumb. Works great.

Share this post


Link to post
Share on other sites

Hi everybody,

 

I have succesfully installed the sts contribution and it is working great. Perfect! :)

 

Now I installed the contributions "attribute price update", "enforce attribute select" and "remove product from cart button". But they don't work under STS. When I switch over to normal osc layout they work.

 

Has anybody got a clue what I need to add to my template to be able to use those installed contributions listed above? Or any other hint how I can solve this problem?

 

I need to have a preview of the site working by Sunday....so I appreciate any hint! ;)

 

THANK YOU!

Edited by doorwish

IT?s ALL good!!!

Share this post


Link to post
Share on other sites

Ok so everything is installed - now I can modify the 'generic' looking theme by editing the sts template html file. However this won't change the way the info boxes appear? Which files do I need to modify to change the appearance of the infoboxes? Is it in the left/right column files or somewhere else?

 

Cheers

Share this post


Link to post
Share on other sites
Ok so everything is installed - now I can modify the 'generic' looking theme by editing the sts template html file. However this won't change the way the info boxes appear? Which files do I need to modify to change the appearance of the infoboxes? Is it in the left/right column files or somewhere else?

 

Cheers

:thumbsup: See chapter 6 of the STS User Manual.

Bill Kellum

 

Sounds Good Productions

STS Tutorials & more: STSv4.6, STS Add-ons (STS Power Pack), STS V4 Forum STS Forum FREE TEMPLATE

Share this post


Link to post
Share on other sites

Ok, quick question -

 

I have customised the look of my shop and edited infobox templates. However everything is pretty mundane using only two colours - http://scottwakehamltd.co.uk/oshop/index.php

 

I'd like the left hand table to be a different colour to coincide with the main website - I found the table html code in the template however this doesn't change it. I'm assuming I need to code it into the style.css template? I'll have a go later and confirm either way if noone else has said anything.

 

Cheers

Share this post


Link to post
Share on other sites

Sorry to double post but I cannot edit by previous one.

 

I added the border around the table on the left hand side. My next task is to put a border around the infobox "what's new" - so I edited the infobox template. This then applied a border around all of the headers i.e. categories, search etc. I tried making a new CSS class for it, however this still affects everything.

 

I have a feeling the answer is obvious, but I just can't think of it. Any help?

 

Cheers

Share this post


Link to post
Share on other sites
Sorry to double post but I cannot edit by previous one.

 

I added the border around the table on the left hand side. My next task is to put a border around the infobox "what's new" - so I edited the infobox template. This then applied a border around all of the headers i.e. categories, search etc. I tried making a new CSS class for it, however this still affects everything.

 

I have a feeling the answer is obvious, but I just can't think of it. Any help?

 

Cheers

OK..I'm assuming you read chapter 6 in the manual and you still do not understand it...

 

If you want a custom look for a specific infobox you would create a template just for that infobox. You do that by following the naming syntax listed in chapter 6. By doing this, it will not effect the other infoboxes.


Bill Kellum

 

Sounds Good Productions

STS Tutorials & more: STSv4.6, STS Add-ons (STS Power Pack), STS V4 Forum STS Forum FREE TEMPLATE

Share this post


Link to post
Share on other sites
Hi everybody,

 

I have succesfully installed the sts contribution and it is working great. Perfect! :)

 

Now I installed the contributions "attribute price update", "enforce attribute select" and "remove product from cart button". But they don't work under STS. When I switch over to normal osc layout they work.

 

Has anybody got a clue what I need to add to my template to be able to use those installed contributions listed above? Or any other hint how I can solve this problem?

 

I need to have a preview of the site working by Sunday....so I appreciate any hint! ;)

 

THANK YOU!

Try turning off your STS Product Info module so that you are not using STS Product_info content templates.

 

If you want to use the content template feature for you product_info.php file, then you'll need to make some changes in includes/modules/sts_inc/product_info.php.

:thumbsup: In general, the changes that a contribution makes in catalog/product_info.php must also be done in this file when using content templates.


Bill Kellum

 

Sounds Good Productions

STS Tutorials & more: STSv4.6, STS Add-ons (STS Power Pack), STS V4 Forum STS Forum FREE TEMPLATE

Share this post


Link to post
Share on other sites
This should work "out of the box" as long as you are not using Product Info content templates. The $content tag will pull in the options automatically.

 

If you are using content templates, then you will need to create the tags for the product info page for STS to pull in the extra option data.

 

 

Thanks Bill. I am using content templates but I can't figure out how to put all the info into sts_inc/product_info.php and make the variables for it. I'm still working on it though. :blink:

Share this post


Link to post
Share on other sites

I'm too lazy to read all the posts in this topic and neither the search function or the manual don't help me with this question.

I have STS 4.5 and I want to show all the products in a category in a table of 4 columns and 3 rows, rather than scrolling down the page with all the products in a list as it is by default in OSC.

 

How do I do this with STS 4.5?

Can anyone give me some directions on that one?

Thanks!

Share this post


Link to post
Share on other sites

Hi!

I wonder if someone can help me i have both STS and HTC installed but when i turn STS on the Header tags dont work and when i turn STS off HTC works, I have looked everywhere but dont find the problem.

 

Regards Tony

Share this post


Link to post
Share on other sites
Hi!

I wonder if someone can help me i have both STS and HTC installed but when i turn STS on the Header tags dont work and when i turn STS off HTC works, I have looked everywhere but dont find the problem.

 

Regards Tony

Tony, your issues are most likely associated with a bad integration of the two. Go over my step by step to be sure you have all your bases coverered (see link in my signature below).

Bill Kellum

 

Sounds Good Productions

STS Tutorials & more: STSv4.6, STS Add-ons (STS Power Pack), STS V4 Forum STS Forum FREE TEMPLATE

Share this post


Link to post
Share on other sites
I'm too lazy to read all the posts in this topic and neither the search function or the manual don't help me with this question.

I have STS 4.5 and I want to show all the products in a category in a table of 4 columns and 3 rows, rather than scrolling down the page with all the products in a list as it is by default in OSC.

 

How do I do this with STS 4.5?

Can anyone give me some directions on that one?

Thanks!

Robert...it is hard for me to answer a post that starts out stating the user is too lazy to search for the answer.... :blink:

Since I do not really believe that, I will try to help you out :rolleyes: ...

 

The only way you can do this strictly using STS is to create "static" links to each product and place them where you want them on the template. Now, this will work for a shop that has only one to slightly more products only. :thumbsup:

 

If you want a more dynamic solution and still have some design control using STS, you will need to edit the code yourself (product_listing.php) or install a contribution that does this for you such as the "Product Listing in columns" addon.


Bill Kellum

 

Sounds Good Productions

STS Tutorials & more: STSv4.6, STS Add-ons (STS Power Pack), STS V4 Forum STS Forum FREE TEMPLATE

Share this post


Link to post
Share on other sites

Hi, I downloaded STS 4.5.8, and the documentation indicates that it is for RC1. Dumb question, but figure I better get it answered before doing the install. Does it work for MS2 as well.

Share this post


Link to post
Share on other sites
Robert...it is hard for me to answer a post that starts out stating the user is too lazy to search for the answer.... :blink:

Well, the search function in this forum isn't working for me, either I find no results where I'm certain there should be results, or I get too many results that all point to the initial page of a few topics.

 

 

Since I do not really believe that, I will try to help you out :rolleyes: ...

Thanks!

 

 

The only way you can do this strictly using STS is to create "static" links to each product and place them where you want them on the template. Now, this will work for a shop that has only one to slightly more products only. :thumbsup:

Shoot! I thought it should be possible with STS

 

 

If you want a more dynamic solution and still have some design control using STS, you will need to edit the code yourself (product_listing.php) or install a contribution that does this for you such as the "Product Listing in columns" addon.

Great! I'll try that!

Thanks for your advice!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×