Jump to content
Latest News: (loading..)
rigadin2

[Contribution] STS v4

Recommended Posts

joanne,

Since you did not specify which version of osC you are using, I will assume that you have the 060817 version. That version of osC has a bug (Module Refresh Bug).

Here is the fix:

http://forums.oscommerce.com/index.php?sho...p;#entry1117449

 

As for the template naming, look in the STS User Manual under section 3.1, 3.3, 3.6, 3.7, 3.9 and so on. You decided to create you own default template (infinity_template.html) but you failed to specify this in the STS Default Module under the Default Template File name setting. This is the only place in the Modules setup that requires you to specify a template name. STS will automatically pick up the other templates accordingly (see STS User Manual sections listed above).

 

I'm sorry, I forgot to tell you that I have 2.2 RC1 installed.

 

I thought I had specified the settings properly.

 

I have:

 

Default template (v2.1.1)

 

Use Templates?

true

 

Code for debug output

debug

 

Files for normal template

sts_user_code.php

 

Base folder

includes/sts_templates/

 

Template folder

full

 

Default template file

infinity_template.html

 

Use template for infoboxes

false

 

This is not working. If I change the "Template Folder" to test it works fine. The file, infinity_template.html is in both places. Is this not the correct way to set it up?

 

Joanne

Share this post


Link to post
Share on other sites
I'm sorry, I forgot to tell you that I have 2.2 RC1 installed.

 

I thought I had specified the settings properly.

 

I have:

 

Default template (v2.1.1)

 

Use Templates?

true

 

Code for debug output

debug

 

Files for normal template

sts_user_code.php

 

Base folder

includes/sts_templates/

 

Template folder

full

 

Default template file

infinity_template.html

 

Use template for infoboxes

false

 

This is not working. If I change the "Template Folder" to test it works fine. The file, infinity_template.html is in both places. Is this not the correct way to set it up?

 

Joanne

It almost appears you have a cache issue.

Try this:

Go to your admin and then remove each STS Module. Once removed, Enable them again.

Also, rename your custom template to sts_template.html and leave all of the settings as default except for the template folder; change this to "full". Be sure you rename the custom template that you have in your "full" folder to test this out.

 

:thumbsup: It really doesn't benefit anything by renmaing the default template since the template name does not show up anywhere on your site (the user will never see it).


Bill Kellum

 

Sounds Good Productions

STS Tutorials & more: STSv4.6, STS Add-ons (STS Power Pack), STS V4 Forum STS Forum FREE TEMPLATE

Share this post


Link to post
Share on other sites

Okay, that worked! Thanks!

 

Let me see if I "get" how this is supposed to work now.

 

If I want to have a content page for categories, I will need to have a file index.php.html that has the categories placed the way I want them. I set "Use template for index page" to TRUE and list this file under "Files for index.php template". If I read the manual correctly, I do not need to list sts_user_code.php there as it is included by default.

 

I'm a little confused about how to set up the subcategories though. How do I name the file correctly for that?

 

For the product_info.php page my settings should be:

 

Use template for product info page

true

Enable STS3 compatibility mode

false

Files for normal template

sts_user_code.php

Files for content template

sts_user_code.php;product_info.php

 

This would use the sts_template as a default for the "outside" part and only change the content that I create. Correct?

 

A few other questions - I'm using Separate Pricing per Customer, Hide Categories for SPPC and Multi Column Listing. These mods heavily modify the index, product_info and product_listing files. Are there any considerations I should be aware of when working with STS?

 

Thanks so much for helping!

 

joanne

Share this post


Link to post
Share on other sites
I guess my next question would be....Why do you need your osC store inside a frameset?

Also, what is the name of the page that has the frameset, meaning if I were to visit your store, what page would I be visiting that had the frameset, and then what page are you trying to link to the frame?

 

My structure was wrong

 

i was trying to make the frameset the template, so when called, the frameset file would not be the template and then...

so i build up my template correctly and then coded a frameset calling my store sts template file and things worked...wow.... *shame*

anyway, thanks for your effort to help, the need of a frameset is that i wanna use a mp3 player on the store, always playing.

 

Cheers!

Share this post


Link to post
Share on other sites
Yes, take a look at the blank template in the STS templates folder "test". This template will show all of the required tags that make you STS template function correctly.

 

I don't get it - and maybe I explained bad - it's on a product page, when trying to enlarge a thumb nail pic, nothing happens (only the link is displayed down in the right part of page)? In the blank template page I only find

 

"<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN">

<html $htmlparams>

<head>

<meta http-equiv="Content-Language" content="en-us">

<!--$headcontent-->

<link rel="stylesheet" type="text/css" href="stylesheet.css">

</head>

<body>

<p>This is a blank template. Replace this text with your content. Enjoy!

Template by: Bill Kellum</p>

</body>

</html>"

 

should this help me?

 

Those pic are from the OsC samples which where installed from start.

 

Great contrib.

Share this post


Link to post
Share on other sites
Okay, that worked! Thanks!

 

Let me see if I "get" how this is supposed to work now.

 

If I want to have a content page for categories, I will need to have a file index.php.html that has the categories placed the way I want them. I set "Use template for index page" to TRUE and list this file under "Files for index.php template". If I read the manual correctly, I do not need to list sts_user_code.php there as it is included by default.

 

I'm a little confused about how to set up the subcategories though. How do I name the file correctly for that?

 

For the product_info.php page my settings should be:

 

Use template for product info page

true

Enable STS3 compatibility mode

false

Files for normal template

sts_user_code.php

Files for content template

sts_user_code.php;product_info.php

 

This would use the sts_template as a default for the "outside" part and only change the content that I create. Correct?

 

A few other questions - I'm using Separate Pricing per Customer, Hide Categories for SPPC and Multi Column Listing. These mods heavily modify the index, product_info and product_listing files. Are there any considerations I should be aware of when working with STS?

 

Thanks so much for helping!

 

joanne

joanne,

The docs folder of the contribution is actually an extension of the STS User Manual. In the module_product_info.html document, is spells out how STS will look for and decide on which template to use:

 

 

How it works, general product template:

 

 

Main templates are templates containing the columns, header and footer. The center of the page only contains the $content placeholder (and anything else you wish to place there).

 

With this module you have the possibility to define a separate "content template" that will replace the $content of the main template. Content templates must be located in the "content" folder inside the templates folder (includes/sts_templates/full/content by default).

 

 

When the module is enabled, it looks in the template folder to see what templates exist. It is possible to define templates based on the product ID or its category ID. Templates must be located in the templates folder (example: includes/sts_templates/full).

 

 

It works as so (first found, first used):

 

 

 

1. Check for a main template based on the product ID, (for example product with ID 4):

 

 

1.1 Use product_info.php_4.html if exists.

 

 

2. Check for category specific main template, based on the category ID where the product is located. (Example below with a product located in category 22, located in category 11)

 

 

2.1 Use product_info.php_c11_22.html if exists.

 

 

2.2 Use product_info.php_c11.html if exists.

 

 

2.3 Use product_info.php.html if exists.

 

 

3. No specific template found, use default template like defined in default module (by default it is sts_template.html)

 

Now that we have a main template, STS will look to see if there is a content template, based on product ID and the category where it belongs: example with product ID4:

 

 

1. Use product_info.php_4.html if exists.

 

 

2. Check for category specific content template, based on the category ID where the product is located. (Example below with a product located in category 22, located in category 11)

 

 

2.1 Use product_info.php_c11_22.html if exists.

 

 

2.2 Use product_info.php_c11.html if exists.

 

 

2.3 Use product_info.php.html if exists.

 

If no content template is found then do not use any, $content will come from the original catalog/product_info.php .

 

 

 

The Index templates work in the same manner except that there is no content template. You have the option of using the default template for all of your categories, or create specifc category templates per each and even having a home page template (index.php_0.html).

 

Don't forget to check out the STS Power Pack site for awesome STS addons and tips (link in my signature below). You will find other STS users who are using the same contributions as you and may have some tips to help you work out any potential issues.

 

:thumbsup: Product Info: Contributions that make changes in the product_info.php file, will aslo need those same changes made to the sts_inc/product_info.php file. This is only necessary if you are using product info "content" templates. It doesn't matter when using regular product_info.php.html templates.

 

The STS User Manual has more details on how to name your template pages.

Have fun,


Bill Kellum

 

Sounds Good Productions

STS Tutorials & more: STSv4.6, STS Add-ons (STS Power Pack), STS V4 Forum STS Forum FREE TEMPLATE

Share this post


Link to post
Share on other sites

I was wondering if there is a way to use the sts_template to point with different html.....what I mean is instead of the template to use the same template for instance the login.php, contact_us.php etc......I have built a site with a highlithing menu's.......basically with the user goes to contact_us......in the banner, the contact us is highlighted and the others are not......then you click home and then home highlights and others do not.......can you do this?

Share this post


Link to post
Share on other sites
I don't get it - and maybe I explained bad - it's on a product page, when trying to enlarge a thumb nail pic, nothing happens (only the link is displayed down in the right part of page)? In the blank template page I only find

 

"<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN">

<html $htmlparams>

<head>

<meta http-equiv="Content-Language" content="en-us">

 

<link rel="stylesheet" type="text/css" href="stylesheet.css">

</head>

<body>

<p>This is a blank template. Replace this text with your content. Enjoy!

Template by: Bill Kellum</p>

</body>

</html>"

 

should this help me?

 

Those pic are from the OsC samples which where installed from start.

 

Great contrib.

What I was referring to was that "every" template page needs to have the "required" code in order for your templates to have "osC" functionallity, such as the use of the "Click to Enlarge" function in the product pages. This particular function will not work unless STS pulls in the necessary JavaScript.

 

:thumbsup: STS does this when you place the $headcontent in the head section of your template (look to the blank template for an example on how this should be added using comments).


Bill Kellum

 

Sounds Good Productions

STS Tutorials & more: STSv4.6, STS Add-ons (STS Power Pack), STS V4 Forum STS Forum FREE TEMPLATE

Share this post


Link to post
Share on other sites
I was wondering if there is a way to use the sts_template to point with different html.....what I mean is instead of the template to use the same template for instance the login.php, contact_us.php etc......I have built a site with a highlithing menu's.......basically with the user goes to contact_us......in the banner, the contact us is highlighted and the others are not......then you click home and then home highlights and others do not.......can you do this?
Yes, but you will have to code it yourself just as you would with any other web site using JavaScript or PHP code, depending upon your skill. :thumbsup: If your PHP skill is on the lite side, don't be ashamed of "stealing" some from the many contributions available that do something close to what you are needing.

 

Just FYI: You can create a specific template for "any" page in your osC store, not just the product and category pages.


Bill Kellum

 

Sounds Good Productions

STS Tutorials & more: STSv4.6, STS Add-ons (STS Power Pack), STS V4 Forum STS Forum FREE TEMPLATE

Share this post


Link to post
Share on other sites
Thanks for the quick reply......could you point me in a name of the contribution?? not the greatest at php.....dont need an exact link but maybe a name??

Sure, go to the STS4 Power Pack site (link in my signature below) and download my contribution "Dynamenu for STSv4". The contribution simplifies the category box links into a menu that can be styled using CSS, no PHP skill required.

 

:thumbsup: You can use the menu to add in any other links as well. I know the horizontal option highlights the page that the user is viewing.

 

Hope this helped,


Bill Kellum

 

Sounds Good Productions

STS Tutorials & more: STSv4.6, STS Add-ons (STS Power Pack), STS V4 Forum STS Forum FREE TEMPLATE

Share this post


Link to post
Share on other sites
Sure, go to the STS4 Power Pack site (link in my signature below) and download my contribution "Dynamenu for STSv4". The contribution simplifies the category box links into a menu that can be styled using CSS, no PHP skill required.

 

:thumbsup: You can use the menu to add in any other links as well. I know the horizontal option highlights the page that the user is viewing.

 

Hope this helped,

 

Thanks for the quick reply.....I just want to make sure before I install this, that this will work with the dynamenu.... I have a html page I have created and designed that automatically does the highlighting for me, what I am wondering is that STS when you add the menu for it to goto login.php it uses the STS_template.html for all the .php files.......what I want to do is basically this....

 

user clicks login......it uses sts_template.html

user click privacy....it uses sts_template2.html

user click contact it uses sts_template3.html..... so when I place the $content.....it displays the correct information

 

Just want to check if I understand that dynamenu will work in this case.

 

Thanks for you help!

Share this post


Link to post
Share on other sites
What I was referring to was that "every" template page needs to have the "required" code in order for your templates to have "osC" functionallity, such as the use of the "Click to Enlarge" function in the product pages. This particular function will not work unless STS pulls in the necessary JavaScript.

 

:thumbsup: STS does this when you place the $headcontent in the head section of your template (look to the blank template for an example on how this should be added using comments).

 

What would the code be in this case, and how do I do - I'm too unexperienced (or too stupid) to know how to fix this?

 

Another question is if I install Header Tags ver 2.6.3 (is that the same as "HTC"?), will STS detect it and adjust to it?

Share this post


Link to post
Share on other sites
user clicks login......it uses sts_template.html

user click privacy....it uses sts_template2.html

user click contact it uses sts_template3.html..... so when I place the $content.....it displays the correct information

 

Just want to check if I understand that dynamenu will work in this case.

 

Thanks for you help!

No, you should name your templates login.php.html, privacy.php.html and so on.

Please read the STS User Manual for more details.


Bill Kellum

 

Sounds Good Productions

STS Tutorials & more: STSv4.6, STS Add-ons (STS Power Pack), STS V4 Forum STS Forum FREE TEMPLATE

Share this post


Link to post
Share on other sites
What would the code be in this case, and how do I do - I'm too unexperienced (or too stupid) to know how to fix this?

 

Another question is if I install Header Tags ver 2.6.3 (is that the same as "HTC"?), will STS detect it and adjust to it?

Lollo,

Regarding HTCv2.6.3, be sure to use my step by step installation guide that was created just for STS users who want to install Header Tags Controller (see link in my signature below).

 

Regarding your popup image problems, you should have the $headcontent in each of your templates, as you should have all of the tags listed in the blank template example in each of your templates. That is the reason for the blank template, to be a starting point for your custom template pages.

 

$headcontent

 

This placeholder is very important in the template. It takes care of html meta tags and javascript that are to be placed in the html header of the page.

 

It will place the following on your template:

- http-equiv meta tag with charset

- title meta tag (from $headertags)

- base URL

- Javascript found in includes/header.php

 

How to use:

 

Place <!--$headcontent--> between <head> and </head> in your template. It is important to keep the comment chars before and after $headcontent otherwise it won't work!

 

Here is an example:

 

<head>
<!--$headcontent-->
<link rel="stylesheet" type="text/css" href="stylesheet.css">
</head>

 

This would be the result of the example above:

 

 

<head>
<meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1">
<title>My Store - My little place on the web</title>
<base href=[url="http://mystore.com"]http://mystore.com[/url]>
<!-- start get_javascript(applicationtop2header) //-->

<!-- end get_javascript(applicationtop2header) //-->
<link rel="stylesheet" type="text/css" href="stylesheet.css">
</head>

 

This tag is created in: includes/classes/sts.php

 

Hope that cleared things up for you.


Bill Kellum

 

Sounds Good Productions

STS Tutorials & more: STSv4.6, STS Add-ons (STS Power Pack), STS V4 Forum STS Forum FREE TEMPLATE

Share this post


Link to post
Share on other sites

Hello! I found a thread regarding Option Type Feature with a reply by Rigadin to modify the sts_inc/product_info.php file and then not use the $optionnames variable in order to get the text box to show instead of a drop down. (Can't find the post again to refer to it.)

 

Anyway, I tried that and I couldn't get it to work. I haven't had much luck in getting a couple of contributions to work because I don't know how to properly edit that product_info file.

 

Anyone had any luck with the Option Type Feature and STS4?

 

Thanks!

Stacy

Share this post


Link to post
Share on other sites

Hi, hope someone can help

 

Have installed STS4 power pack and everything seemed to be OK. However when I followed the instructions for the 'Header Tags' module there was a fault.

In admin\catalog\catagories & products - licking the edit button does not take me to the edit page. :'(

 

When adding a product I seem to only have half the form, down to description, there are no buttons to save or cancel etc. :'(

this only happened after installing this contribution.

 

other contributions used are: -

  • Catagories_box
  • FEC 3.2 Quicker Install v4
  • Ipn

All working as expected

 

Does anyone have a clue to which file may be at fault? and if so what may be wrong. :huh:

I am fairly new to this, but willing to hunt around to find the fault/resolve if pointed in the right direction.

 

Thanks in advance :thumbsup:

Share this post


Link to post
Share on other sites
Hi, hope someone can help

 

Have installed STS4 power pack and everything seemed to be OK. However when I followed the instructions for the 'Header Tags' module there was a fault.

In admin\catalog\catagories & products - licking the edit button does not take me to the edit page. :'(

 

When adding a product I seem to only have half the form, down to description, there are no buttons to save or cancel etc. :'(

this only happened after installing this contribution.

 

other contributions used are: -

  • Catagories_box
  • FEC 3.2 Quicker Install v4
  • Ipn

All working as expected

 

Does anyone have a clue to which file may be at fault? and if so what may be wrong. :huh:

I am fairly new to this, but willing to hunt around to find the fault/resolve if pointed in the right direction.

 

Thanks in advance :thumbsup:

I wouldn't mind helping you but I need to know what contribution you tried installing. You mentioned STS4 Power Pack but that is not a contribution but rather a site that has a lot of contributions, tips, etc. to work with STS. :blink:

Bill Kellum

 

Sounds Good Productions

STS Tutorials & more: STSv4.6, STS Add-ons (STS Power Pack), STS V4 Forum STS Forum FREE TEMPLATE

Share this post


Link to post
Share on other sites
Hello! I found a thread regarding Option Type Feature with a reply by Rigadin to modify the sts_inc/product_info.php file and then not use the $optionnames variable in order to get the text box to show instead of a drop down. (Can't find the post again to refer to it.)

 

Anyway, I tried that and I couldn't get it to work. I haven't had much luck in getting a couple of contributions to work because I don't know how to properly edit that product_info file.

 

Anyone had any luck with the Option Type Feature and STS4?

 

Thanks!

Stacy

Stacy,

STS should pick up all of the code and produce the results through the $content tag. This will work only if you are not using "content" product_info.php.html templates, then STS will pick up the content from the osC product_info.php file.

If you are using content templates, then you will need to modify the sts_inc/product_info.php file as well.

 

Take a look in the STS Power Pack site. I think I seen a contribution to help you get this working with content templates (April 15, 2007). The instructions were written for STS Plus, but it will also work for any STSv4.x version of the Simple Template System.

 

Hope this helped you out,


Bill Kellum

 

Sounds Good Productions

STS Tutorials & more: STSv4.6, STS Add-ons (STS Power Pack), STS V4 Forum STS Forum FREE TEMPLATE

Share this post


Link to post
Share on other sites
Lollo,

Regarding HTCv2.6.3, be sure to use my step by step installation guide that was created just for STS users who want to install Header Tags Controller (see link in my signature below).

 

Regarding your popup image problems, you should have the $headcontent in each of your templates, as you should have all of the tags listed in the blank template example in each of your templates. That is the reason for the blank template, to be a starting point for your custom template pages.

 

$headcontent

 

This placeholder is very important in the template. It takes care of html meta tags and javascript that are to be placed in the html header of the page.

 

It will place the following on your template:

- http-equiv meta tag with charset

- title meta tag (from $headertags)

- base URL

- Javascript found in includes/header.php

 

How to use:

 

Place <!--$headcontent--> between <head> and </head> in your template. It is important to keep the comment chars before and after $headcontent otherwise it won't work!

 

Here is an example:

 

<head>
<!--$headcontent-->
<link rel="stylesheet" type="text/css" href="stylesheet.css">
</head>

 

This would be the result of the example above:

 

 

<head>
<meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1">
<title>My Store - My little place on the web</title>
<base href=[url="http://mystore.com"]http://mystore.com[/url]>
<!-- start get_javascript(applicationtop2header) //-->

<!-- end get_javascript(applicationtop2header) //-->
<link rel="stylesheet" type="text/css" href="stylesheet.css">
</head>

 

This tag is created in: includes/classes/sts.php

 

Hope that cleared things up for you.

 

Thank you Bill, I'm learning something new every day :rolleyes: - I will take a close look at this, and try to get this. Na thank you for nice work and great skill.

Share this post


Link to post
Share on other sites
Take a look in the STS Power Pack site. I think I seen a contribution to help you get this working with content templates (April 15, 2007). The instructions were written for STS Plus, but it will also work for any STSv4.x version of the Simple Template System.

 

Thanks Bill. I worked with it last night and again this morning and I just don't have the brains to make it work...yet. I'm going to keep working on it and I'll post back to let everyone know if I figured out a solution. In the meantime, if anyone comes across a solution, let me know please!

 

Thanks,

Stacy

Share this post


Link to post
Share on other sites
I wouldn't mind helping you but I need to know what contribution you tried installing. You mentioned STS4 Power Pack but that is not a contribution but rather a site that has a lot of contributions, tips, etc. to work with STS. :blink:

 

Hi

Sory about that, this is what was in the folder: -

  • (1) REGISTER GLOBALS FIX
     
    (2) STS 4.5.2
     
    (3) HTC 2.6.3
     
    (4) DYNAMENU

As stated before everything seemed fine until I went to edit catagories or add a new product.

help is much appreciated. :thumbsup:

Share this post


Link to post
Share on other sites

Help with a NOOB!!! to PHP and noob to STS too.

 

Here is a code snippet of product_info.php.html that i am trying to get to do something

 

<table border="0" cellpadding="3" cellspacing="0" width="98%" id="table50" height="154">
 <tbody>
<tr>
  <td valign="top">
  Please select from the option(s) available below that are available for 
	this Item. 
	<p style="margin-top: 0; margin-bottom: 0"> <p style="margin-top: 0; margin-bottom: 0">
	<b>$optionheader$</b><p style="margin-top: 0; margin-bottom: 0"> <table border="0" id="table51" width="316">
	<tbody>
	  <tr>
		<td> 
		<p align="center" style="margin-top: 0; margin-bottom: 0"><b>$optionnames$ </b><font size="4">
		</font> </td>
		<td>
		<p align="center" style="margin-top: 0; margin-bottom: 0">$optionchoices$<font size="4"> </font> </td>
	  </tr>
	</tbody>
  </table>
  </td>
</tr>
 </tbody>

 

 

What I am trying to do is test to see if the STS variable $optionnames$ has a value in it.

 

I think (again noob!) that this $template_pinfo['optionnames'] is REALLY what needs to be tested, but I could be way wrong too.

 

I got that from sts_debug output.

 

What I want to do is simple enough I just don't know php enough to test for the value correctly.

 

if the variable is empty, meaning I didn't assign a option or value to the option I would like to execute some HTML and skip some other

if the variable is not empty, meaning I assigned an option to the product then I want to execute some other HTML.

 

I have tried NULL testing, empty(), ==, but I know I am not doing it right.

 

Sometimes I get parse errors, sometimes I get some output but the logic doesn't work cause I get the same output whether I have an option set or not.

 

ANy help...Thanks

 

Nacman

Share this post


Link to post
Share on other sites
Hi

Sory about that, this is what was in the folder: -

  • (1) REGISTER GLOBALS FIX
     
    (2) STS 4.5.2
     
    (3) HTC 2.6.3
     
    (4) DYNAMENU

As stated before everything seemed fine until I went to edit catagories or add a new product.

help is much appreciated. :thumbsup:

 

OK..you installed a bundled contribution so you would need to ask your questions in that particular support thread for that bundle.

 

:thumbsup: Here is the link:

http://forums.oscommerce.com/index.php?sho...=267541&hl=

 

Hopefully the contribution author is still around to assist you.


Bill Kellum

 

Sounds Good Productions

STS Tutorials & more: STSv4.6, STS Add-ons (STS Power Pack), STS V4 Forum STS Forum FREE TEMPLATE

Share this post


Link to post
Share on other sites
What I am trying to do is test to see if the STS variable $optionnames$ has a value in it.

 

if the variable is empty, meaning I didn't assign a option or value to the option I would like to execute some HTML and skip some other

if the variable is not empty, meaning I assigned an option to the product then I want to execute some other HTML.

 

ANy help...Thanks

 

Nacman

Nacman,

This variable is defined "out of the box"....

 

$optionnames

The option names (color, size, ...) followed by a linebreak. Empty if no options available.

 

This placeholder is to be used in conjunction with $optionchoices, which displays the drop-down lists containing the option choices (blue, red, X, XL, ...).

 

$optionchoices

The option choices (blue, red, X, XL, ...) followed by a linebreak. Empty if no options available.

 

This placeholder is to be used in conjunction with $optionnames, which displays the name of the options (color, size, ...).

 

Place these two placeholders in a 2 columns html table, one column for each placeholder, so the option name and its correponding drop-down list will be aligned.

 

These placeholders are all built in catalog/includes/modules/sts_inc/product_info.php

 

So... I guess I'm not sure what you are wanting to do with these tags. They automatically show up if the product has options, if not, then they will not display anything. Do they not work for you?

Edited by bkellum

Bill Kellum

 

Sounds Good Productions

STS Tutorials & more: STSv4.6, STS Add-ons (STS Power Pack), STS V4 Forum STS Forum FREE TEMPLATE

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×