Jump to content
rigadin2

[Contribution] STS v4

Recommended Posts

Frank,

 

I will assume that you are using the 060817 version of osCommerce. If so, then you are experiencing the "Refresh bug".

See the following link to fix your problem (this is not related to STS):

 

http://forums.oscommerce.com/index.php?sho...p;#entry1117449

 

Hope this helped and yes, this is a long thread full of helpful information! Use the Google to search this thread for answers:

 

site:forums.osCommerce.com [Contribution] sts v4

 

 

Thanks Bill!

 

I checked those files and I do have the changes already in there. This is the RC1 version of osc. It's very odd. Any other suggestions? And thanks for the google link, that will help when searching with 2 letter words! :)

Share this post


Link to post
Share on other sites
Thanks Bill!

 

I checked those files and I do have the changes already in there. This is the RC1 version of osc. It's very odd. Any other suggestions? And thanks for the google link, that will help when searching with 2 letter words! :)

Frank,

Have you installed any other contributions lately, specifically any that would have modified the catalog/admin/modules.php and catalog/admin/includes/languages/*each language*/modules.php files?

 

STS adds a few lines of code to each of those files so do a file comparison with the files of the same name that were included with STSv4.5.8 to make sure you made the correct modifications. I recommend using Beyond Compare or WinMerge to do the comparison.


Bill Kellum

 

Sounds Good Productions

STS Tutorials & more: STSv4.6, STS Add-ons (STS Power Pack), STS V4 Forum STS Forum FREE TEMPLATE

Share this post


Link to post
Share on other sites
Frank,

Have you installed any other contributions lately, specifically any that would have modified the catalog/admin/modules.php and catalog/admin/includes/languages/*each language*/modules.php files?

 

STS adds a few lines of code to each of those files so do a file comparison with the files of the same name that were included with STSv4.5.8 to make sure you made the correct modifications. I recommend using Beyond Compare or WinMerge to do the comparison.

 

Thanks! I will check that out and post my results. I have another question at hand. With STS, it uses html files. How would I make the top header image keep the sessions? An example is... You log into the store, click a few items, add stuff to the cart, and then if you click on the header image to go back to the index page, you are signed out. Any suggestions?

 

Thanks, I'll post again soon.

Share this post


Link to post
Share on other sites
Thanks! I will check that out and post my results. I have another question at hand. With STS, it uses html files. How would I make the top header image keep the sessions? An example is... You log into the store, click a few items, add stuff to the cart, and then if you click on the header image to go back to the index page, you are signed out. Any suggestions?

 

Thanks, I'll post again soon.

Frank, the image is not really the issue but in how you create the link.

 

STS comes "out of the box" with a tag(s) you could use for your cart logo in the sts_inc/general.php file:

	$sts->template['cataloglogo'] = '<a href="' . tep_href_link(FILENAME_DEFAULT) . '">' . tep_image(STS_TEMPLATE_DIR.'images/'.$language . '/header_logo.gif', STORE_NAME) . '</a>'; // Modified in v4.3
$sts->template['urlcataloglogo'] = tep_href_link(FILENAME_DEFAULT);

So...

You could link the image to $urlcataloglogo and that would send the user to your index.php.html or index.php_0.html file.

Or...

You could save your logo image as header_logo.gif and save it in your sts_templates/*your template folder*/images/languages/english (and other languages)/header_logo.gif and then just add the $cataloglogo tag in your template.

 

Both methods above would keep the Session ID.

 

Further reading:

 

Take a look at the Knowledge Base article regarding Session ID's and Image Links:

 

http://oscommerce.info/kb/osCommerce/Catal..._and_Layout/227

 

<?php echo '<a href="' . tep_href_link(FILENAME_DEFAULT) . '">' . tep_image(DIR_WS_IMAGES . 'graphic.jpg', 'graphic text') . '</a>'; ?>

<?php echo '<a href="' . tep_href_link(FILENAME_DEFAULT) . '">' . tep_image(DIR_WS_IMAGES . 'logo.jpg', 'My Store') . '</a>'; ?>

 


Bill Kellum

 

Sounds Good Productions

STS Tutorials & more: STSv4.6, STS Add-ons (STS Power Pack), STS V4 Forum STS Forum FREE TEMPLATE

Share this post


Link to post
Share on other sites
To Sherrie:

Yes this can be done. I think the code that you need is in the includes/boxes/shopping_cart.php file. Take a look at the SQL string and then create a tag accordingly. I'm sorry that I do not have the time at the moment to help you further. Maybe someone else in this forum has some time for this.

 

To Everyone:

Sorry, I will not be available to post responses until after the week-end. :-

 

Today is my birthday so I will be spending it with my family. :rolleyes:

Happy New Year Everyone! :lol:

 

First of all, happy birthday! :)

 

Secondly, thanks for the hint on location - I'll try a few strings from there and see if I can figure it out. :)

Share this post


Link to post
Share on other sites
Frank, the image is not really the issue but in how you create the link.

 

STS comes "out of the box" with a tag(s) you could use for your cart logo in the sts_inc/general.php file:

	$sts->template['cataloglogo'] = '<a href="' . tep_href_link(FILENAME_DEFAULT) . '">' . tep_image(STS_TEMPLATE_DIR.'images/'.$language . '/header_logo.gif', STORE_NAME) . '</a>'; // Modified in v4.3
$sts->template['urlcataloglogo'] = tep_href_link(FILENAME_DEFAULT);

So...

You could link the image to $urlcataloglogo and that would send the user to your index.php.html or index.php_0.html file.

Or...

You could save your logo image as header_logo.gif and save it in your sts_templates/*your template folder*/images/languages/english (and other languages)/header_logo.gif and then just add the $cataloglogo tag in your template.

 

Both methods above would keep the Session ID.

 

Further reading:

 

Take a look at the Knowledge Base article regarding Session ID's and Image Links:

 

http://oscommerce.info/kb/osCommerce/Catal..._and_Layout/227

 

<?php echo '<a href="' . tep_href_link(FILENAME_DEFAULT) . '">' . tep_image(DIR_WS_IMAGES . 'graphic.jpg', 'graphic text') . '</a>'; ?>

<?php echo '<a href="' . tep_href_link(FILENAME_DEFAULT) . '">' . tep_image(DIR_WS_IMAGES . 'logo.jpg', 'My Store') . '</a>'; ?>

 

 

 

You rock Bill! The sessions problem was fixed by simply adding $urlcataloglogo as the link... AWESOME! And the STS problem was fixed by doing a compare with UPSchoice. The UPSchoice did in fact overwrite the STS admin module and took out some needed code. Thank you for your help!

Share this post


Link to post
Share on other sites

I just installed this and when I go to the admin side to enable it I click on sts and it doesnt do anything. I changed the files on the admin side but i didnt move any folders over. Did I miss something. Please let me know.

Thanks

Share this post


Link to post
Share on other sites
I just installed this and when I go to the admin side to enable it I click on sts and it doesnt do anything. I changed the files on the admin side but i didnt move any folders over. Did I miss something. Please let me know.

Thanks

Doug, what do you mean by "didn't move any folders over"?

 

You need to copy over the files in the same folder structure that the contribution is packed in otherwise it will not work.


Bill Kellum

 

Sounds Good Productions

STS Tutorials & more: STSv4.6, STS Add-ons (STS Power Pack), STS V4 Forum STS Forum FREE TEMPLATE

Share this post


Link to post
Share on other sites

hey bill, im basically done with the major editing of the site, check it out :) Site

 

Thanks for all the help from you and anyone else that has contributed :), lol sorry for some non-sts related or "dumb" questions, because im post happy

 

:)

Share this post


Link to post
Share on other sites
hey bill, im basically done with the major editing of the site, check it out :) Site

 

Thanks for all the help from you and anyone else that has contributed :) , lol sorry for some non-sts related or "dumb" questions, because im post happy

 

:)

Hey Ash, Congrats on the site! Well Done! I'm glad to see that you ironed out the wrinkles and are now well on your way to being a STS Pro! :thumbsup:

Bill Kellum

 

Sounds Good Productions

STS Tutorials & more: STSv4.6, STS Add-ons (STS Power Pack), STS V4 Forum STS Forum FREE TEMPLATE

Share this post


Link to post
Share on other sites

hi bill

thanks for the help. I moved everything over just like the instructions said. the only problem im having is trying to configure when i go to the admin side and click under modules and then click sts the screen acts like its loading but nothing loads it just keeps the authorization modules up. It will not go so that i can configure the sts. thanks if you can help in any way thanks.

Share this post


Link to post
Share on other sites
Doug, what do you mean by "didn't move any folders over"?

 

You need to copy over the files in the same folder structure that the contribution is packed in otherwise it will not work.

 

 

hai bill kellum i need ur help bacly am the beginner of the oscommerce i installed v2.2rc1 and installed sts latest version everything worked well but now i want to design my site for my purpose i want to change the default oscommerce style to for my online shop for mobile designing i dont know how to design could u pls guide me..................

Share this post


Link to post
Share on other sites
hai bill kellum i need ur help bacly am the beginner of the oscommerce i installed v2.2rc1 and installed sts latest version everything worked well but now i want to design my site for my purpose i want to change the default oscommerce style to for my online shop for mobile designing i dont know how to design could u pls guide me..................

 

That's what STS is all about. Just modify the templates to suit your needs. Your making a site for mobile designing but don't know how to design? I think that may have been written wrong?

Share this post


Link to post
Share on other sites
hi bill

thanks for the help. I moved everything over just like the instructions said. the only problem im having is trying to configure when i go to the admin side and click under modules and then click sts the screen acts like its loading but nothing loads it just keeps the authorization modules up. It will not go so that i can configure the sts. thanks if you can help in any way thanks.

 

 

Bill just helped me out with this problem. For me, the problem was that another mod (UPSchoice) overwrote catalog/admin/modules.php and left out the important STS block of code. Make sure the below is still in that file. Hope that helps. If not, I'm sure Bill will know what's up.

 

	  // START STS 4.1
  case 'sts':
       $module_type = 'sts';
       $module_directory = DIR_FS_CATALOG_MODULES . 'sts/';
       $module_key = 'MODULE_STS_INSTALLED';
       define('HEADING_TITLE', HEADING_TITLE_MODULES_STS);	    
    break;
  // END STS 4.1	

Share this post


Link to post
Share on other sites
hai bill kellum i need ur help bacly am the beginner of the oscommerce i installed v2.2rc1 and installed sts latest version everything worked well but now i want to design my site for my purpose i want to change the default oscommerce style to for my online shop for mobile designing i dont know how to design could u pls guide me..................

 

no still am not designing i dont know how to design now am having only default oscommerce template could u pls guide me to design......................

Share this post


Link to post
Share on other sites
hi bill

thanks for the help. I moved everything over just like the instructions said. the only problem im having is trying to configure when i go to the admin side and click under modules and then click sts the screen acts like its loading but nothing loads it just keeps the authorization modules up. It will not go so that i can configure the sts. thanks if you can help in any way thanks.

 

Doug,

Do you know what version of osCommerce you are using? Is it 060817 or RC1? The 060817 version had a bug in the modules that prevented them to refresh (all of the modules such as shipping, payment, etc., not just with STS).

 

Here is the 060817 Module Refresh fix:

 

http://forums.oscommerce.com/index.php?sho...p;#entry1117449

 

Hope this helped,


Bill Kellum

 

Sounds Good Productions

STS Tutorials & more: STSv4.6, STS Add-ons (STS Power Pack), STS V4 Forum STS Forum FREE TEMPLATE

Share this post


Link to post
Share on other sites

hi all, I've installed STS v4 on 2.2rc1 and all is well, it sure looks like its going to be very useful. I was wondering if anyone could point me in the direction of an advanced template I could use as a referance, or possibly a tutorial that teaches how to edit the template files for the navigation bar etc.

I'm profishent in Joomla template design and, well i guess im just hoping STS works in a simular way.

thanks for any help

/b14de

Share this post


Link to post
Share on other sites
no still am not designing i dont know how to design now am having only default oscommerce template could u pls guide me to design......................

Hello Sundar,

 

Have you looked at the manual? I spent a lot of time writing the STS User Manual and included a lot of detail to help you out with using STS and osC. Give it a look and then if you still have questions, come back and let us know just what you need help with.

 

Have fun,


Bill Kellum

 

Sounds Good Productions

STS Tutorials & more: STSv4.6, STS Add-ons (STS Power Pack), STS V4 Forum STS Forum FREE TEMPLATE

Share this post


Link to post
Share on other sites
hi all, I've installed STS v4 on 2.2rc1 and all is well, it sure looks like its going to be very useful. I was wondering if anyone could point me in the direction of an advanced template I could use as a referance, or possibly a tutorial that teaches how to edit the template files for the navigation bar etc.

I'm profishent in Joomla template design and, well i guess im just hoping STS works in a simular way.

thanks for any help

/b14de

Lawrence,

 

As for navigation, you really have just two options; static or dynamic.

 

STATIC METHOD:

If you want an easy way to modify your navigation and your shop has just a few categories or products, then go the static route. The static route is where you create each link to each category/product manually. This gives you total control over the look and feel of your site's navigation.

 

To create the links manually, follow these rules:

STS Link to a category:

<a href="<?php echo tep_href_link('index.php', 'cPath=21&', 'NONSSL'); ?>">Category Name Here</a>

STS Link to a product:

<a href="<?php echo tep_href_link('product_info.php', 'products_id=53&', 'NONSSL'); ?>">Product Name Here</a>

You can use the links above to create your menus.

 

DYNAMIC


Bill Kellum

 

Sounds Good Productions

STS Tutorials & more: STSv4.6, STS Add-ons (STS Power Pack), STS V4 Forum STS Forum FREE TEMPLATE

Share this post


Link to post
Share on other sites
hi all, I've installed STS v4 on 2.2rc1 and all is well, it sure looks like its going to be very useful. I was wondering if anyone could point me in the direction of an advanced template I could use as a referance, or possibly a tutorial that teaches how to edit the template files for the navigation bar etc.

I'm profishent in Joomla template design and, well i guess im just hoping STS works in a simular way.

thanks for any help

/b14de

Lawrence,

You really have just two options; static or dynamic, when it comes to osC navigation.

 

STATIC METHOD:

 

If you want total control over your category/product navigation menus, and you only have a few categories/products, then go the static route. The static method requires you to create the links manually, therefore you would not choose this method if you have a lot of categories/products.

 

Use the following to create your menus:

 

STS Link to a category:

 

<a href="<?php echo tep_href_link('index.php', 'cPath=21&', 'NONSSL'); ?>">Category Name Here</a>

 

STS Link to a product:

 

<a href="<?php echo tep_href_link('product_info.php', 'products_id=53&', 'NONSSL'); ?>">Product Name Here</a>

 

DYNAMIC METHOD:

 

If you want to stick with the osCommerce way of creating the links automatically depending upon what you enter in the admin, then you would certainly want to use the dynamic method. This method requires more skill if you want to have total control over the look and feel of your menus but it can be done (STS makes it easier as well).

 

I suggest using one of the two contributions below to edit/design your dynamic navigation menus:

 

1. Category Box as Nested Unordered List

http://www.oscommerce.com/community/contributions,4201

 

2. Dynamenu

http://www.oscommerce.com/community/contributions,4228

 

By using either contribution, you will need to know or have a basic understanding of CSS. After installing one of the above, you will be able to modify your menu in the stylesheet.css file to have the exact look and feel that you desire.

 

I have created a step by step for Dynamenu but it can be used for Category Box as Nested Unordered List as well. Basically it shows how to create the STS tag ($categorybox_css) to be used in place of the default STS tag for the category box. You can find it in the STS Power Pack site (a STS addon site for STS users).

 

Hope this helped you out,


Bill Kellum

 

Sounds Good Productions

STS Tutorials & more: STSv4.6, STS Add-ons (STS Power Pack), STS V4 Forum STS Forum FREE TEMPLATE

Share this post


Link to post
Share on other sites

Lawrence,

Sorry about the double post above....My browser locked up before I was finished typing in my response. The post directly above this one has the full response.

:-

Edited by bkellum

Bill Kellum

 

Sounds Good Productions

STS Tutorials & more: STSv4.6, STS Add-ons (STS Power Pack), STS V4 Forum STS Forum FREE TEMPLATE

Share this post


Link to post
Share on other sites

Bill thanks for the reply earlier :) Just so I know we're on the same page so to speak ... do I understand it correctly. ..that if I wish to edit the way my product info pages appear, I add a product.info.php.html page in my contents[/] folder (for the sts_templates/full/product.info.php.html to read)? On thests_templates/full/contents/product.info.php.html page, I use html, say a table, to put the variables where I want them on the page? Also, do I use the single $ or do I use $-$ with these variables?

 

Mucho thanks :blush: :blink: :rolleyes:

Share this post


Link to post
Share on other sites
Hello Sundar,

 

Have you looked at the manual? I spent a lot of time writing the STS User Manual and included a lot of detail to help you out with using STS and osC. Give it a look and then if you still have questions, come back and let us know just what you need help with.

 

Have fun,

 

 

hai i tried myself something this one is the home page link http://test1.srimeenakshimobiles.org/index.php in this page i add only nokia product details if i click the nokia products in the home page am getting abt nokia product all details but image not shown in nokia products page even i change all image path correctly for nokia product html here is the link http://test1.srimeenakshimobiles.org/inclu...ndex_nokia.html wat i did wrong here could u pls guide to add for only one product after tat i will manage....................

Edited by sundar

Share this post


Link to post
Share on other sites
Bill thanks for the reply earlier :) Just so I know we're on the same page so to speak ... do I understand it correctly. ..that if I wish to edit the way my product info pages appear, I add a product.info.php.html page in my contents[/] folder (for the sts_templates/full/product.info.php.html to read)? On thests_templates/full/contents/product.info.php.html page, I use html, say a table, to put the variables where I want them on the page? Also, do I use the single $ or do I use $-$ with these variables?

 

Mucho thanks :blush: :blink: :rolleyes:

Viona,

You would only need a product_info.php.html template in the contents folder if you wanted to change the layout of the the product page. For example: If you wanted to move the price, "Click to enlarge" text, product picture, and so on, you would use the content template.

 

If you were only interested in making a template for the product_info page, you would just make a template product_info.php.html and place it in your template folder along with your other templates.

 

The template structure is easier to understand if you start with the most basic setup; which is the default template. The default template would be used for all pages if you didn't have anymore page specific templates in your template folder. When a page is opened in the browser, STS will look to see if there is a template for that specific page, if not it would use the default template. Take a look at the STS User Manual in section 3 for how this is done.

 

Also, take a look at section 5.2.1 for placeholder stop characters and how to properly use them in your STS tags.

 

Hope this helped,


Bill Kellum

 

Sounds Good Productions

STS Tutorials & more: STSv4.6, STS Add-ons (STS Power Pack), STS V4 Forum STS Forum FREE TEMPLATE

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×