Jump to content
rigadin2

[Contribution] STS v4

Recommended Posts

Is it possible to get Dynamic Meta Tags working with STS?

 

I´ve been reading old posts for a while now but I can't seem to find any solutions.

 

/Mattias

Share this post


Link to post
Share on other sites
Is it possible to get Dynamic Meta Tags working with STS?

 

I´ve been reading old posts for a while now but I can't seem to find any solutions.

 

/Mattias

 

 

Use this one, its compatible with STS: Easy Meta Tags

Share this post


Link to post
Share on other sites
Hi

 

I have a lingerie shop and I need to have option choises for bras and option choices for thongs in separated boxes with a text between like this:

 

option.jpg

 

For now it appears like this way:

 

optionwrong.jpg

 

Do you know how can I do that?

 

Thank you.

 

To place elements where you want on the product_info.php page, you have to enable the product info module in admin and create a content template for it. After that you have 3 placeholders to display your attributes: one for title like "options:", one for the name of the options "size, color, ..." and one for the values "L, XL, blue, red", but they won't do what you want. Sorry. You can change the code in catalog/includes/modules/sts_inc/product_info.php to display the options differently. This is how QTPro is doing (stock management for attributes), you can see it in the STS Power Pack.


STS v4.5 SP5 is out, and check the STS Power Pack contribution too!

New thumbnailer using phpThumb: oscThumb. Works great.

Share this post


Link to post
Share on other sites
STS plus Product Attributes Option Type

I'm using STS 4.5.2 with HTCv 2.6.3, which are working really well. I'm now trying to use the contribution Product Attributes Option Type to add a text field where users can add a line of customisation text.

 

PAOT is working well if templates are switched off. If I switch templates on, instead of a text field in the product_info.php page I'm getting a drop-down box containing the option type and attributes value price "Text +£1.00".

 

This happens if I use a product_info.php.html template using the $optionchoices placeholder. If I switch off just the product_info.php.html template, the text field is displayed correctly. The product_info page still picks up basic page layout from the default sts_template.html, but I lose the simple control of layout that the product_info template provides.

 

I have also tried using Option Type to add a textarea for a larger amount of text and that gives similar problems - but doesn't even display well if just the product_info template is switched off.

 

I think I need to create a new placeholder for the text field and use that placeholder in my product_info.php.html template. But I'm not sure how to do it.

 

Or would I be better just hacking the product_info.php page without a template to give me the layout I need?

 

I appreciate that Option Type is not the subject of this forum, but I'd be really grateful for any advice.

 

Same answer as the post before, when using content template for the product_info.php page, the code to display is not coming from catalog/product_info.php anymore, but from catalog/includes/modules/sts_inc/product_info.php, so the code for PAOT must be placed there, and the result must be placed in a placeholder (an easy way is to remove the old code, paste the new one between $sts->start_capture() and $template_pinfo['optionchoices'] = $sts->stop_capture(), then use $optionchoices on your template but not $optionnames.


STS v4.5 SP5 is out, and check the STS Power Pack contribution too!

New thumbnailer using phpThumb: oscThumb. Works great.

Share this post


Link to post
Share on other sites

Question:

How to define default Header Title or Text headings in a template depending on language ?

 

For examble:

HEADER_TITLE_CART_CONTENTS

 

The Text Tags are defined in "catalog/german.php" (or english.php)


OSC Webmakers Edition modiefied with many other contribs and enhancements.

+ STS 4.5.7 for 2.2MS2 and RC1

Share this post


Link to post
Share on other sites
http://www.run-x.de/shop-2/catalog/login.php

 

...there is no login form visible.... :huh:

This is not a STS problem. Looks like your purchased template removed the stock content for the login.php file or you removed yourself. Look in your login.php file or compare it with a stock login.php file.


Bill Kellum

 

Sounds Good Productions

STS Tutorials & more: STSv4.6, STS Add-ons (STS Power Pack), STS V4 Forum STS Forum FREE TEMPLATE

Share this post


Link to post
Share on other sites
Robert,

I hope you have already considered the advice that I gave to you previously and have setup your STS modules to their default settings.

Yes, I've copied all the standard templates into their respective folders, uninstalled and re-installed all the STS modules in the Admin/modules/STS/ section.

So everything should be standard, but still I get the error msg if I enable index.php.html, untill I copy that index.php.html file into my catalogincludes/modules/sts_inc/ folder.

I can't figure that one out, so I just leave that file in place.

I have answered to the post where you replied to me about that particular problem, but it's on the prevoius page and something has gone wrong with the sequence of answers so it's hard to find, but it's there.

 

Thanks for the advice you gave about getting different content on the catagories pages and the index page.

I will try that tomorrow.

Share this post


Link to post
Share on other sites

For some reason, my footer is now inside the main part of my table, I've tried resizing the table to 780 in the four places this can be done but it still shows full screen and wonder if this is due to the footer placement.

 

This is my code:

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN">
<html $htmlparams>
<head>
<!--$headcontent-->
 <link rel="stylesheet" type="text/css" href="stylesheet.css">
</head>
<body marginwidth="0" marginheight="0" topmargin="0" bottommargin="0" leftmargin="0" rightmargin="0">

<table width="780" height="100" border="0"  align="center" cellpadding="10" cellspacing="0">
<tr class="header">
	<td valign="centre" bgcolor="#000000">
		<div align="center"><img border="0" src="images/logo.jpg">
			<a href="$urlmyaccount"></a>
			<a href="$urlcartcontents"></a>
		  <a href="$urlcheckout"></a> </div></td>
</tr>
</table>

<table border="0" width="780" cellspacing="0" cellpadding="1" align="center">
<tr class="headerNavigation">
	<td class="headerNavigation">
		  
		$breadcrumbs
	</td>
	<td align="right" class="headerNavigation">
		<a href="http://www.mydomain.co.uk">Home</a> | $myaccountlogoff | $cartcontents | $checkout 
		  
	</td>
</tr>
</table>

<table border="0" width="780" cellspacing="3" cellpadding="3" align="center">
 <tr>
<td width="125" height="167" valign="top">

  <table border="0" width="125" cellspacing="0" cellpadding="2">
	<tr><td>$catmenu</td></tr>
	<tr><td>$categorybox</td></tr>
	<tr><td>$specialbox</td>
	</tr>
	<tr><td>$searchbox</td>
	</tr>
	<tr><td>$informationbox</td>
  </table>
</td>
<td valign="top">
  <p>$content</p>
  <p> </p>
</td>
<td valign="top" width="125">
  <table border="0" width="125" cellspacing="0" cellpadding="2">
	<tr><td>$cartbox</td></tr>
  </table>
</td>
 </tr>
</table>

<table border="0" width="780" cellspacing="0" cellpadding="1" align="center">
 <tr class="footer">
<td class="footer">
  $date  
</td>
<td align="right" class="footer"><span class="smallText">$footer_text </span></td>
 </tr>
</table>



</body>
</html>

 

Any suggestions?

 

Thanks

Share this post


Link to post
Share on other sites
This is not a STS problem. Looks like your purchased template removed the stock content for the login.php file or you removed yourself. Look in your login.php file or compare it with a stock login.php file.

 

I turn off STS-System - Login-page is OK

When turn on - No Login.

 

What do you mean with "compare it with a stock login.php file ?


OSC Webmakers Edition modiefied with many other contribs and enhancements.

+ STS 4.5.7 for 2.2MS2 and RC1

Share this post


Link to post
Share on other sites

OK - found the problem:

 

I had no "infobox.php.html" into my boxes folder of my new template.

 

I copied it from "full" folder and now my Loginpage works - but only standard login information is to see.

I have the additional "Purchase without accout" in my OSC-Version installed.

 

Any idea how i can activate it in the template ?


OSC Webmakers Edition modiefied with many other contribs and enhancements.

+ STS 4.5.7 for 2.2MS2 and RC1

Share this post


Link to post
Share on other sites

A couple of layout issues - I'm not sure if these are STS related:

  1. How can I alter the white space on my text pages such as terms and conditions at the top
  2. How can I justify this text
  3. How can I make this text go across the right column too, I only have my box contents on the right so should be able to use all the info if the text starts under this, I think

Many thanks

 

Lotti

Share this post


Link to post
Share on other sites

what is involved in upgrading from an old sts version of the template to the latest one ? i have sts version 2.01 and because of that i am not being able to add new stuff on the site because all the contributions are done for version 4.

 

can any one help ?

 

thanks

 

amit

Share this post


Link to post
Share on other sites
what is involved in upgrading from an old sts version of the template to the latest one ? i have sts version 2.01 and because of that i am not being able to add new stuff on the site because all the contributions are done for version 4.

 

can any one help ?

 

thanks

 

amit

Yes, remove all instances of the old STSv2 from your store. Save your sts_user_code.php (only if you added any custom tags to that file) and template files (html pages).

 

Install the latest version of STS and then add any custom tags that you had in your previous setup. You can use your old STS template pages by creating a template folder called something like "mytemplates" in the catalog/includes/sts_templates/ folder.

 

If you want to use any of the content template and infobox template features, you will need to create a folder called "content" and "boxes" within your newly created "mytemplates" folder as so: catalog/includes/sts_templates/mytemplates/content

catalog/includes/sts_templates/mytemplates/boxes

 

:thumbsup: If your templates use any of the "outdated" tags, you will need to replace them with thier new counterparts. Look in the STS User Manual for more details.

 

Have fun,


Bill Kellum

 

Sounds Good Productions

STS Tutorials & more: STSv4.6, STS Add-ons (STS Power Pack), STS V4 Forum STS Forum FREE TEMPLATE

Share this post


Link to post
Share on other sites
Yes, remove all instances of the old STSv2 from your store. Save your sts_user_code.php (only if you added any custom tags to that file) and template files (html pages).

 

Install the latest version of STS and then add any custom tags that you had in your previous setup. You can use your old STS template pages by creating a template folder called something like "mytemplates" in the catalog/includes/sts_templates/ folder.

 

If you want to use any of the content template and infobox template features, you will need to create a folder called "content" and "boxes" within your newly created "mytemplates" folder as so: catalog/includes/sts_templates/mytemplates/content

catalog/includes/sts_templates/mytemplates/boxes

 

:thumbsup: If your templates use any of the "outdated" tags, you will need to replace them with thier new counterparts. Look in the STS User Manual for more details.

 

Have fun,

thanks bill, this will be a good project for me because i am not that web savvy but i think i will take it up.

 

ill try it somewhere else first. will my stylesheet still work ? or do i have to create a new one ?

Share this post


Link to post
Share on other sites
thanks bill, this will be a good project for me because i am not that web savvy but i think i will take it up.

 

ill try it somewhere else first. will my stylesheet still work ? or do i have to create a new one ?

The latest version of STS allows you to use a stylesheet dependent upon the template folder being used or you can do it the osCommerce way and just use the stylesheet that is in the root of the catalog. Whichever one you use, just be sure to link to it in your template. The sample templates provided in the STSv4 show how to do this.

Bill Kellum

 

Sounds Good Productions

STS Tutorials & more: STSv4.6, STS Add-ons (STS Power Pack), STS V4 Forum STS Forum FREE TEMPLATE

Share this post


Link to post
Share on other sites
Now, create your specific category templates that you want to be different for that specific category such as index.php_1.html, index.php_2.html and so on coinsiding with your category ids.

 

When I'm in the admin section od OSC, and go: Modules/STS/STS Modules/Index

In the "Files for index.php template" I must put in the whole name "index.php.html" (notice the html extension), or I get an error msg.

If I put the html extension, I get the $myaccountlogoff | $cartcontents | $checkout thingies in stead of the real navigation (the same goes for the all the other STS placeholders.

And after the "content" that page I still get the contents of the index.php.html in my catalog/includes/sts_templates/ folder.

 

What am I doing wrong?

Share this post


Link to post
Share on other sites
When I'm in the admin section od OSC, and go: Modules/STS/STS Modules/Index

In the "Files for index.php template" I must put in the whole name "index.php.html" (notice the html extension), or I get an error msg.

If I put the html extension, I get the $myaccountlogoff | $cartcontents | $checkout thingies in stead of the real navigation (the same goes for the all the other STS placeholders.

And after the "content" that page I still get the contents of the index.php.html in my catalog/includes/sts_templates/ folder.

 

What am I doing wrong?

You SHOULD NOT be adding index.php.html into that field.

 

The only thing you should have there by default is:

sts_user_code.php

 

The field is for telling STS where to look for extra files that you need included such as headertags.php, files that have custom placeholders, etc.


Bill Kellum

 

Sounds Good Productions

STS Tutorials & more: STSv4.6, STS Add-ons (STS Power Pack), STS V4 Forum STS Forum FREE TEMPLATE

Share this post


Link to post
Share on other sites
Question:

How to define default Header Title or Text headings in a template depending on language ?

 

For examble:

HEADER_TITLE_CART_CONTENTS

 

The Text Tags are defined in "catalog/german.php" (or english.php)

Jacksmith,

I'm not sure what you are really asking here. In a stock osC, you make the defines in catalog/includes/languages/*your language*.php file.

 

In STS, the $cartlogo and $cartcontents are defined in the catalog/includes/modules/sts_inc/general.php file. STS will automatically use what language is selected by the user and display what is defined in your language files above.


Bill Kellum

 

Sounds Good Productions

STS Tutorials & more: STSv4.6, STS Add-ons (STS Power Pack), STS V4 Forum STS Forum FREE TEMPLATE

Share this post


Link to post
Share on other sites
A couple of layout issues - I'm not sure if these are STS related:
  1. How can I alter the white space on my text pages such as terms and conditions at the top
  2. How can I justify this text
  3. How can I make this text go across the right column too, I only have my box contents on the right so should be able to use all the info if the text starts under this, I think

Many thanks

 

Lotti

Lotti,

I would suggest you install the IE Developers Toolbar. It has several options to assist you in finding things such as what is causing the "white space" on your web page. It will let you know if it is CSS related (most likely), if a transparent image is the culprit (good possibility) or if a table/cell is the issue.

 

The toolbar will also inform you of any CSS in your stylesheet that could be effecting your text.

 

Here is the link.

http://www.microsoft.com/downloads/details...;displaylang=en

 

Good luck,


Bill Kellum

 

Sounds Good Productions

STS Tutorials & more: STSv4.6, STS Add-ons (STS Power Pack), STS V4 Forum STS Forum FREE TEMPLATE

Share this post


Link to post
Share on other sites
OK - found the problem:

 

I had no "infobox.php.html" into my boxes folder of my new template.

 

I copied it from "full" folder and now my Loginpage works - but only standard login information is to see.

I have the additional "Purchase without accout" in my OSC-Version installed.

 

Any idea how i can activate it in the template ?

 

I don't think there is anything to activate. It should work on it's own whether or not your have STS or a stock osCommerce shop.

 

:thumbsup: By the way, the STS User Manual explains that you need to have the boxes folder in your template folder in order for the infobox templates to work.


Bill Kellum

 

Sounds Good Productions

STS Tutorials & more: STSv4.6, STS Add-ons (STS Power Pack), STS V4 Forum STS Forum FREE TEMPLATE

Share this post


Link to post
Share on other sites

I've been searching up and down the net trying to fix this problem:

 

i have a clean install of osc and sts4. all the lastest versions.

 

Im trying to create a new template but everytime i put the $content placeholder the contents drop to the bottom of the page and doesnt get put in the table i put the place holder in.

 

<table width="900" border="0" align="center" cellpadding="0" bordercolor="#99CC66" bgcolor="#CC0033">
 <tr>
<td width="138"><p> $breadcrumbs </p>
  <table border="0" width="125" cellspacing="0" cellpadding="2">
	<tr>
	  <td>$catmenu</td>
	</tr>
	<tr>
	  <td>$categorybox</td>
	</tr>
  </table>
  <p> </p>
<td width="756">$content  </tr>
</table>

 

 

You can see what im talking about at http://www.winecabinet-vinotemp.com/

i made the table that i want it in as pink but as u can see the content is not in table that i want it to be.

 

ps. this also happends with the default template that comes with sts4.

 

thanks in advance

robbie

Share this post


Link to post
Share on other sites

:thumbsup: A new STS version is available: STSv4.5.8

 

- BUG FIXED: STSv4.5.6 introduced a bug regarding how the buffer was cleaned. STSv4.5.8 reverts back to STSv4.5.5 method of destroying the buffer to allow cascading buffers. Files modified: catalog/includes/classes/sts.php.

 

- Added new STS placeholder $langid to allow dynamic images according to the language selected by the user.

 

- Merged STSv4.5.4 and STSv4.5.5 by Rigadin into STSv4.5.8.

 

- Updated documents.

 

Enjoy,


Bill Kellum

 

Sounds Good Productions

STS Tutorials & more: STSv4.6, STS Add-ons (STS Power Pack), STS V4 Forum STS Forum FREE TEMPLATE

Share this post


Link to post
Share on other sites
Jacksmith,

I'm not sure what you are really asking here. In a stock osC, you make the defines in catalog/includes/languages/*your language*.php file.

 

In STS, the $cartlogo and $cartcontents are defined in the catalog/includes/modules/sts_inc/general.php file. STS will automatically use what language is selected by the user and display what is defined in your language files above.

 

Yes - but in these files are defined some more Text cases than cartlogo or cartcontents.

 

I mean to be free to place a text from the language file somewhere in the template (not hard coded !).

EXAMPLE:

I would place "ERROR_CONDITIONS_NOT_ACCEPTED" (from the includes/languages/* fodler) somewhere in the template without any further functions or boxes, that at this place the defined text (for english) would be placed:

 

"If you do not accept our conditions, we cannot process your order!"

 

So text cases would be free from any functions or infoboxes....


OSC Webmakers Edition modiefied with many other contribs and enhancements.

+ STS 4.5.7 for 2.2MS2 and RC1

Share this post


Link to post
Share on other sites
Same answer as the post before, when using content template for the product_info.php page, the code to display is not coming from catalog/product_info.php anymore, but from catalog/includes/modules/sts_inc/product_info.php, so the code for PAOT must be placed there, and the result must be placed in a placeholder (an easy way is to remove the old code, paste the new one between $sts->start_capture() and $template_pinfo['optionchoices'] = $sts->stop_capture(), then use $optionchoices on your template but not $optionnames.

 

Thanks very much for the reply - I really appreciate the help! I must admit this solution sounds a bit complicated for me - not sure I can do this reliably! So I've decided to disable the product_info template and make the layout changes I need in the product_info.php file. But thanks again for the help.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×