Jump to content
rigadin2

[Contribution] STS v4

Recommended Posts

thank you. it worked fine.

But i've found another problem:

When i enter http://www.nameofmystore.com/catalog/index.php , it shows me index.php_0.html as expected. But if i put http://www.nameofmystore.com/catalog/, it shows me sts_template.php.html instead of index.php_0.html

 

any idea?

 

Billsoft.

Billsoft,

In your stores admin, go to the Modules section, click on STS.

Be sure you have the Default Module installed and configured as so:

---------------------------

Default template (v2.0.0)

 

Use Templates?

true

 

Code for debug output

debug

 

Files for normal template

sts_user_code.php

 

Base folder

includes/sts_templates/

 

Template folder

full

 

Default template file

sts_template.html

 

Use template for infoboxes (optional)

true

-------------------------------

 

Be sure you have the Index Module installed and configured as so:

----------------------------------

Index template (v2.0.0)

 

Use template for index page

true

 

Files for index.php template

sts_user_code.php

 

Check parent templates

true

--------------------------------

 

Hope this helped,

Edited by bkellum

Bill Kellum

 

Sounds Good Productions

STS Tutorials & more: STSv4.6, STS Add-ons (STS Power Pack), STS V4 Forum STS Forum FREE TEMPLATE

Share this post


Link to post
Share on other sites

STS plus Product Attributes Option Type

I'm using STS 4.5.2 with HTCv 2.6.3, which are working really well. I'm now trying to use the contribution Product Attributes Option Type to add a text field where users can add a line of customisation text.

 

PAOT is working well if templates are switched off. If I switch templates on, instead of a text field in the product_info.php page I'm getting a drop-down box containing the option type and attributes value price "Text +£1.00".

 

This happens if I use a product_info.php.html template using the $optionchoices placeholder. If I switch off just the product_info.php.html template, the text field is displayed correctly. The product_info page still picks up basic page layout from the default sts_template.html, but I lose the simple control of layout that the product_info template provides.

 

I have also tried using Option Type to add a textarea for a larger amount of text and that gives similar problems - but doesn't even display well if just the product_info template is switched off.

 

I think I need to create a new placeholder for the text field and use that placeholder in my product_info.php.html template. But I'm not sure how to do it.

 

Or would I be better just hacking the product_info.php page without a template to give me the layout I need?

 

I appreciate that Option Type is not the subject of this forum, but I'd be really grateful for any advice.

Share this post


Link to post
Share on other sites
... and create individual STS templates for the index page and each category page......

How do I tell STS to use a template I made in stead of te default one?

In the admin section I see only a few options to install templates, and categories isn't among them.

Share this post


Link to post
Share on other sites

The User Manual for STS will explain how to name your category templates :)

 

For example - you might have index.php_1.html for your first parent category, and index.php_1_4.html for a subcategory within category 1. If you look at your URL when you are on a category page it will tell you what number you will need in your template file name :thumbsup:

 

How do I tell STS to use a template I made in stead of te default one?

In the admin section I see only a few options to install templates, and categories isn't among them.


~Tracy
 

Share this post


Link to post
Share on other sites

Hmm - are your template folder and default template areas set as they should be too? (if you scroll up, Bill just posted how the Default should look in your Admin) ;)

 

If it's not one of the settings in your Admin that is causing STS to not pull the templates - then I'm at a loss :huh:

 

It says: includes/sts_templates/

So that is as it should be


~Tracy
 

Share this post


Link to post
Share on other sites

Good Morning everyone --

 

I am attempting to do an install of STS v 4.5 over a fresh install of OsCommerce 2.2 RC1. I followed the directions for a fresh install from the Install Text.doc file and readme.txt file.

 

So, here's my set up:

 

I uploaded all of the following:

 

- catalog\includes\classes\sts.php

- catalog\includes\functions\sts.php

- catalog\includes\languages\english\modules\sts folder

- catalog\includes\modules\sts folder

- catalog\includes\modules\sts_inc folder

- catalog\includes\sts_templates: all files

 

Per the readme.txt file, I also updated the following:

 

- application_top.php

- header.php

- column_left.php

- column_right.php

- footer.php

- application_bottom.php

 

As soon as I did this, I noticed two things:

 

1) STS does not appear under modules in the admin

2) When I access the catalog, I get the message: "Fatal error: Call to a member function restart_capture() on a non-object in D:\Inetpub\marslumber\catalog\includes\header.php on line 14"

 

 

So, my questions are:

 

1) What would I be missing that would prevent STS from appearing in the admin?

2) How can I correct the fatal error?

 

Any help everyone can provide would be appreciated!

 

Thanks,

 

-- Chris

Share this post


Link to post
Share on other sites

Update: I am still having the same problems as above, except for #2, I now get this error when I try to access my main catalog:

 

Fatal error: Call to a member function image() on a non-object in D:\Inetpub\marslumber\catalog\includes\functions\html_output.php on line 78

 

Can someone assist me with these issues?

 

Thanks in advance for your help.

 

-- Chris

Share this post


Link to post
Share on other sites

Hello all :) ... I've installed a fresh copy of OSC RC1 and the STS v4.5.7 upgrade.

 

When I go to install the 4 modules listed, I have a problem with the last one.

 

When I press INSTALL for the Product Info module, nothing happens (no changes and it doesn't appear to be installed).

 

the other 3 modules installed just fine ... any suggestions as to what has gone wrong?

 

Thanks in advance - Keith

 

Edit: OK ... now I'm really confused, as I went back in and now the Product Info module doesn't even show anymore in the list

Edited by Dunedon

Share this post


Link to post
Share on other sites

Right then ... please ignore as I found my (rather stupid) mistake :)

 

Hello all :) ... I've installed a fresh copy of OSC RC1 and the STS v4.5.7 upgrade.

 

When I go to install the 4 modules listed, I have a problem with the last one.

 

When I press INSTALL for the Product Info module, nothing happens (no changes and it doesn't appear to be installed).

 

the other 3 modules installed just fine ... any suggestions as to what has gone wrong?

 

Thanks in advance - Keith

 

Edit: OK ... now I'm really confused, as I went back in and now the Product Info module doesn't even show anymore in the list

Share this post


Link to post
Share on other sites

How can i modify a template to a get category-box and products_new (content) like this one here ?

http://osc3.template-help.com/osc_16625/index.php?os

I think I´l need the custom boxes feature here ? But how to use it...? In the readme of STS it is not subscribed how to make custom boxes for a template.

Edited by runweb

OSC Webmakers Edition modiefied with many other contribs and enhancements.

+ STS 4.5.7 for 2.2MS2 and RC1

Share this post


Link to post
Share on other sites

I want to center my shop. So I checked out Centershop v.3.0. But when STS is enabled Centershop doesn't work.

 

Some days ago someone asked the same question. The answer was put a div tag around the page (I think around <body> and </body>). So I tried but nothing happened. The shop is still filling out the whole page.

 

'Can someone tell me what I have to do to center my shop?

Share this post


Link to post
Share on other sites

When I enable the Index template in STS 4.5 the contents of the index page also appears when I click on a category.

I only want the contents of the index page to appear only on the first page of the shop, not on a category page.

Is there a way in STS 4.5 to do that?

 

In the admin section there is no way to enable different templates for the categories

 

Can sombody help me please?

Edited by wotsupdoc

Share this post


Link to post
Share on other sites
How can i modify a template to a get category-box and products_new (content) like this one here ?

http://osc3.template-help.com/osc_16625/index.php?os

I think I´l need the custom boxes feature here ? But how to use it...? In the readme of STS it is not subscribed how to make custom boxes for a template.

There are a couple of ways to get custom looks to your category box.

  1. Install a category box contribution that does this for you.
  2. Edit the catalog/includes/boxes/categories.php file and hard code your changes.
  3. Use the Infobox Template feature in STS alone or in combination with the above (depends on what you want to do and your skill set).

You're on your own with 1 & 2 but I can point you in the right direction with #3.

 

The STS User Manual goes into detail on how to use the infobox template feature in STS. To sum it up briefly, you can use this feature in a couple different ways:

  1. Create an infobox template that templates all parts of the infobox in one template. "infobox_information.php.html"
  2. Create an infobox template just for the header portion of the infobox. "infobox_information_header.php.html"
  3. Create an infobox template just for the content portion of the infobox. If you choose to use the $content tag here, then this just creates a "wrap" around the actual box script (categories.php). If you leave the $content tag out, you can then create your own links to the categories and then customize them anyway you desire.
    • You can also edit the stylesheet to get a custom look to your category box as well.

Hope this helped,


Bill Kellum

 

Sounds Good Productions

STS Tutorials & more: STSv4.6, STS Add-ons (STS Power Pack), STS V4 Forum STS Forum FREE TEMPLATE

Share this post


Link to post
Share on other sites
When I enable the Index template in STS 4.5 the contents of the index page also appears when I click on a category.

I only want the contents of the index page to appear only on the first page of the shop, not on a category page.

Is there a way in STS 4.5 to do that?

 

In the admin section there is no way to enable different templates for the categories

 

Can sombody help me please?

 

Robert,

I hope you have already considered the advice that I gave to you previously and have setup your STS modules to their default settings. Now, enable each of the STS Modules in the admin (infobox, popup and product templates are optional).

 

With that said, you should create an index.php_0.html template in your template folder. Insert the content that you only want on your front page in that template.

 

Create a Category template using the index.php.html template. This will be the default category template used.

 

Now, create your specific category templates that you want to be different for that specific category such as index.php_1.html, index.php_2.html and so on coinsiding with your category ids.

 

If you continue to have problems after doing the above, then you have not installed STS correctly. Reinstall.

 

Hope this helped,


Bill Kellum

 

Sounds Good Productions

STS Tutorials & more: STSv4.6, STS Add-ons (STS Power Pack), STS V4 Forum STS Forum FREE TEMPLATE

Share this post


Link to post
Share on other sites
I want to center my shop. So I checked out Centershop v.3.0. But when STS is enabled Centershop doesn't work.

 

Some days ago someone asked the same question. The answer was put a div tag around the page (I think around <body> and </body>). So I tried but nothing happened. The shop is still filling out the whole page.

 

'Can someone tell me what I have to do to center my shop?

Erik, you are making this more difficult than what it actually is. STS does not do anything different than how you would normally center a HTML document. You can do it several different ways by using CSS, Tables, etc.

 

Using a div tag just before the body tag as so:

<div align="center">
<body marginwidth="0" marginheight="0" topmargin="0" bottommargin="0" leftmargin="0" rightmargin="0">

**HTML code for the body goes here**

</body> 
</div>
</html>

 

Take a look at the sample templates. They have the shop centered already.

 

If you want to add to the margins, I would suggest adding the following to the stylesheet:

 

BODY {
 background: #ffffff;
 color: #000000;
 margin: 0px;
 margin-left:100px;
 margin-right:100px;

 

Hope this helped,

Edited by bkellum

Bill Kellum

 

Sounds Good Productions

STS Tutorials & more: STSv4.6, STS Add-ons (STS Power Pack), STS V4 Forum STS Forum FREE TEMPLATE

Share this post


Link to post
Share on other sites
There are a couple of ways to get custom looks to your category box.
  1. Install a category box contribution that does this for you.
  2. Edit the catalog/includes/boxes/categories.php file and hard code your changes.
  3. Use the Infobox Template feature in STS alone or in combination with the above (depends on what you want to do and your skill set).

You're on your own with 1 & 2 but I can point you in the right direction with #3.

 

The STS User Manual goes into detail on how to use the infobox template feature in STS. To sum it up briefly, you can use this feature in a couple different ways:

  1. Create an infobox template that templates all parts of the infobox in one template. "infobox_information.php.html"
  2. Create an infobox template just for the header portion of the infobox. "infobox_information_header.php.html"
  3. Create an infobox template just for the content portion of the infobox. If you choose to use the $content tag here, then this just creates a "wrap" around the actual box script (categories.php). If you leave the $content tag out, you can then create your own links to the categories and then customize them anyway you desire.
    • You can also edit the stylesheet to get a custom look to your category box as well.

Hope this helped,

 

OK - thanks !

I`ll try out Step 3 to make realy working templates. When I take 1 or 2 than other tempaltes would have this code, too...and that`s not efficient.

Just have to look in User Manual again...did not find it at first...

I think I have to make templates for information-boxes and content box to fit in the corresponding template.

 

I´ll give feedback when I got in trouble :blush:

Edited by runweb

OSC Webmakers Edition modiefied with many other contribs and enhancements.

+ STS 4.5.7 for 2.2MS2 and RC1

Share this post


Link to post
Share on other sites

Perfect, thanks! That's exactly what I needed. I put the div tags before after the bodytags - didn't know that you can put them also outside and now it works.

Now I only have to figure out hwo to place a image in the way I want (stretch in the y-axis, mirror in the x-axis). Maybe I make two div-tags one for the first part (darker part of the image) to mirror ownly on the x-axis and another under the first one to mirror on all axis with the lighter part.

Share this post


Link to post
Share on other sites

Ok - I checked working of infobox-templates, too.

But I´m hanging here now:

 

Created a box "infobox_categories.php.html" with "$content" and included it in Main file as "categorybox".

That`s just working - My own categories are just in right place.

 

But there seems to be a problem with the tables...my content is put on the right side now and there`s much space between categories and content...

Can someone find out what`s the problem here ?

http://www.run-x.de/shop-2/catalog/index.php


OSC Webmakers Edition modiefied with many other contribs and enhancements.

+ STS 4.5.7 for 2.2MS2 and RC1

Share this post


Link to post
Share on other sites
Ok - I checked working of infobox-templates, too.

But I´m hanging here now:

 

Created a box "infobox_categories.php.html" with "$content" and included it in Main file as "categorybox".

That`s just working - My own categories are just in right place.

 

But there seems to be a problem with the tables...my content is put on the right side now and there`s much space between categories and content...

Can someone find out what`s the problem here ?

http://www.run-x.de/shop-2/catalog/index.php

 

To help troubleshoot your issues, I would suggest installing the "Developers Toolbar" for IE (if you are using Internet Explorer). This little tool will allow you to click on areas of your website to show what is doing what.

For example, it allows you to turn off all CSS to help rule out if a CSS class is causing your text to shift. It also allows you to click on each table in your page to determine its attributes and so much more.

 

Here is the link:

Internet Explorer Toolbar

http://www.microsoft.com/downloads/details...;displaylang=en

 

Hope this helped,


Bill Kellum

 

Sounds Good Productions

STS Tutorials & more: STSv4.6, STS Add-ons (STS Power Pack), STS V4 Forum STS Forum FREE TEMPLATE

Share this post


Link to post
Share on other sites

OK - found it by myself with "try and error" - there was a </table> tag too much in the template.

 

Categories and content is now in place.

BUT:

When I click a product tp see more than in the header of the template the following error message comes up:

 

Warning: main(includes/modules/sts_inc/sts_lingerie_template.html) [function.main]: failed to open stream: No such file or directory in /var/www/web22/html/shop-2/catalog/includes/modules/sts_inc/sts_display_output.php on line 21

 

Warning: main(includes/modules/sts_inc/sts_lingerie_template.html) [function.main]: failed to open stream: No such file or directory in /var/www/web22/html/shop-2/catalog/includes/modules/sts_inc/sts_display_output.php on line 21

 

Warning: main() [function.include]: Failed opening 'includes/modules/sts_inc/sts_lingerie_template.html' for inclusion (include_path='.') in /var/www/web22/html/shop-2/catalog/includes/modules/sts_inc/sts_display_output.php on line 21

 

Why is the script looking for the template-file in the folder "/modules/sts_inc/" ???

Edited by runweb

OSC Webmakers Edition modiefied with many other contribs and enhancements.

+ STS 4.5.7 for 2.2MS2 and RC1

Share this post


Link to post
Share on other sites
OK - found it by myself with "try and error" - there was a </table> tag too much in the template.

 

Categories and content is now in place.

BUT:

When I click a product tp see more than in the header of the template the following error message comes up:

 

 

 

Why is the script looking for the template-file in the folder "/modules/sts_inc/" ???

 

How do you have your Default Module setup in admin?

Particularily:

Files for normal template

sts_user_code.php

 

Base folder

includes/sts_templates/

 

Template folder

full

 

Default template file

sts_template.html

 

The files for normal template should stay the same unless you have created a page for custom user tags other than in sts_user_code.php

 

The base folder should stay the same.

 

The template folder should be where your templates in use are located.

 

The Default template file should be the template that you want displayed where you have no other specific templates created.

 

Hope this helps,

Edited by bkellum

Bill Kellum

 

Sounds Good Productions

STS Tutorials & more: STSv4.6, STS Add-ons (STS Power Pack), STS V4 Forum STS Forum FREE TEMPLATE

Share this post


Link to post
Share on other sites

Hi

 

I have a lingerie shop and I need to have option choises for bras and option choices for thongs in separated boxes with a text between like this:

 

option.jpg

 

For now it appears like this way:

 

optionwrong.jpg

 

Do you know how can I do that?

 

Thank you.

Share this post


Link to post
Share on other sites
Hi

 

I have a lingerie shop and I need to have option choises for bras and option choices for thongs in separated boxes with a text between like this:

 

option.jpg

 

For now it appears like this way:

 

optionwrong.jpg

 

Do you know how can I do that?

 

Thank you.

If you can't do it with the stock product attributes already available in osCommerce, I would suggest looking into one of the option type contributions that are available.


Bill Kellum

 

Sounds Good Productions

STS Tutorials & more: STSv4.6, STS Add-ons (STS Power Pack), STS V4 Forum STS Forum FREE TEMPLATE

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×