Jump to content
rigadin2

[Contribution] STS v4

Recommended Posts

TO SHOW PRODUCT QUANTITY IN PRODUCT DETAIL PAGE (using osc 2.2-MS2, sts 4.5.4)

Helena,

What you are wanting to do is not an "out of the box" osCommerce feature. OsCommerce has an option in the admin to show the products quantity on the product listing page but not as an option on the product detail page.

 

If you want to do this, you will need to modify the code yourself or install a contribution that does this for you. STS has nothing to do with it other than allowing you to add the PHP code needed to perform this task directly within the template itself.

Hello Bill .. before I go any further, I just need to say I don't know how you do this coz you have such a BIG heart to answer so many questions and help so many people! :thumbsup: Thank you.

 

Yes, I know it is an "out of the box" modification. I was hoping someone would tell me how I could modify the code so I can display the quantity in the product detail page. I thought maybe I could define a placeholder (maybe in /includes/modules/sts_inc/sts_user_code.php file?). But I just didn't know how to do that.

 

And obviously there is some sort of variable/placeholder in osc ($products_quantity) from somewhere so that the qty shows in the Product Listing pages, I thought maybe I could caputre that somehow and put it into my (sts) product contents template?

 

If anyone can give me some pointers, that would be like heaven! Thanks,

Helena

Share this post


Link to post
Share on other sites
TO SHOW PRODUCT QUANTITY IN PRODUCT DETAIL PAGE (using osc 2.2-MS2, sts 4.5.4)

 

Hello Bill .. before I go any further, I just need to say I don't know how you do this coz you have such a BIG heart to answer so many questions and help so many people! :thumbsup: Thank you.

 

Yes, I know it is an "out of the box" modification. I was hoping someone would tell me how I could modify the code so I can display the quantity in the product detail page. I thought maybe I could define a placeholder (maybe in /includes/modules/sts_inc/sts_user_code.php file?). But I just didn't know how to do that.

 

And obviously there is some sort of variable/placeholder in osc ($products_quantity) from somewhere so that the qty shows in the Product Listing pages, I thought maybe I could caputre that somehow and put it into my (sts) product contents template?

 

If anyone can give me some pointers, that would be like heaven! Thanks,

Helena

 

Helena,

Here is the code you would be interested in:

 

If you are using the product_info content templates, then this is very simple to do.

 

How to add the Product Quantity to your product detail pages (using content templates):

Open your catalog/includes/modules/sts_inc/product_info.php file.

Find:

 

	$template_pinfo['productname'] = $product_info['products_name'];
$template_pinfo['productmodel'] =  $product_info['products_model'];

 

Add this line after:

	$template_pinfo['productquantity'] = $product_info['products_quantity'];

It should look like this:

	$template_pinfo['productname'] = $product_info['products_name'];
$template_pinfo['productmodel'] =  $product_info['products_model'];
$template_pinfo['productquantity'] = $product_info['products_quantity'];

 

Now add the following placeholder anywhere you want in your catalog/includes/sts_templates/template folder/content/product_info.php.html file:

$productquantity$

 

You may have to tweak the above but that should get you in the right direction.

Hope it helped,

Edited by bkellum

Bill Kellum

 

Sounds Good Productions

STS Tutorials & more: STSv4.6, STS Add-ons (STS Power Pack), STS V4 Forum STS Forum FREE TEMPLATE

Share this post


Link to post
Share on other sites
Helena,

Here is the code you would be interested in:

 

If you are using the product_info content templates, then this is very simple to do.

 

How to add the Product Quantity to your product detail pages (using content templates):

Open your catalog/includes/modules/sts_inc/product_info.php file.

.....

oh my goodness me Bill ... THANK YOU!

 

You are just THE Best!

 

thank you so much. It worked. It worked. It worked. I am so happy I feel like crying!

thank you,

Helena

Share this post


Link to post
Share on other sites

Hi,

I'm trying to customize my front page with some highlights that will appears only in that page and no placeholder $content. So I've created an index.php.html page.

The problem is that categories listings also use index.php. So i've put a cPath test in my index.php.html like this:

 

<?php
if (isset($cPath) && tep_not_null($cPath)){
?>
  $content
<?php
}
else{
?>
  <br>
  My Front Page, without index.php content...
  <br>
<?php
}
?>

 

but i always returns the else part because cPath always returns NULL.

 

Can anyone tells me what i'm doing wrong?

 

Tks,

Billsoft.

Share this post


Link to post
Share on other sites
Hi,

I'm trying to customize my front page with some highlights that will appears only in that page and no placeholder $content. So I've created an index.php.html page.

The problem is that categories listings also use index.php. So i've put a cPath test in my index.php.html like this:

 

<?php
if (isset($cPath) && tep_not_null($cPath)){
?>
$content
<?php
}
else{
?>
<br>
My Front Page, without index.php content...
<br>
<?php
}
?>

 

but i always returns the else part because cPath always returns NULL.

 

Can anyone tells me what i'm doing wrong?

 

Tks,

Billsoft.

 

:thumbsup: You should create a "home page" template and name it index.php_0.html and then you will not need to do any of the above.


Bill Kellum

 

Sounds Good Productions

STS Tutorials & more: STSv4.6, STS Add-ons (STS Power Pack), STS V4 Forum STS Forum FREE TEMPLATE

Share this post


Link to post
Share on other sites
oh my goodness me Bill ... THANK YOU!

 

You are just THE Best!

 

thank you so much. It worked. It worked. It worked. I am so happy I feel like crying!

thank you,

Helena

You are welcome. I didn't understand your question at first and thought you were wanting to install some type of contribution named "TO SHOW PRODUCT QUANTITY IN PRODUCT DETAIL PAGE". :blush:

 

Glad it worked for you and thank you for the donation! :thumbsup:


Bill Kellum

 

Sounds Good Productions

STS Tutorials & more: STSv4.6, STS Add-ons (STS Power Pack), STS V4 Forum STS Forum FREE TEMPLATE

Share this post


Link to post
Share on other sites
I'm sure you already checked your languages files for:

// specials box text in includes/boxes/specials.php
define('BOX_HEADING_SPECIALS', 'Specials');

 

Yep - that's in my languages/english.php file (I don't use any of the other language files currently). It's slightly different as it also has the link to see all specials. It does show up and the link does work, provided I turn off the "Use Templates".

 

I just don't understand what I might be missing as the Shopping Cart heading is setup the same way, and it does work with the templates turned on. It's only this one box that isn't working properly and for the life of me I just can't find the problem - LOL What's really bad is that it was working a while back, and I just don't remember how long ago that was as I haven't had specials up for a few months (at least).

 

Got any ideas on STS Specific files that help to handle the box headings?


~Tracy
 

Share this post


Link to post
Share on other sites

Thanks Bill - but nothing appears to be missing here either. I also did a comparison between my current file and the one I used in June and didn't see anything missing. I then compared the one from STS v4.5.2 (stock) which I had upgraded to several months ago (June I believe) - and again I don't see anything missing.

 

Any other ideas on where to check?

:blush:

 

Also, for good measure...

 

Compare your classes/boxes.php file with the boxes.php file from the latest version of STS to see if you may have deleted some of the STS code for the infobox templates:

 

 

function infoBoxHeaderTemplate($headertext,$right_arrow) {
// STS 4.3: put header template and tags in $sts object, do not display them now.
// STS 4.5.2: BUG corrected, was checking content cache instead of header cache
  global $sts;

 $btrace=debug_backtrace();
 $boxname=basename($btrace[1]['file'],".php");
 $boxprefix = "infobox_";

 // Added in v4.4: allows to use catalog_filename.html as template for boxes created directly in a catalog script.
 $boxname2 = basename($btrace[2]['file'],".php"); // backtrace 2 is the file calling the calling file (like sts_column_left.php)
if ($boxname2=='') $boxprefix = "catalog_";

  if (file_exists(STS_TEMPLATE_DIR."boxes/$boxprefix".$boxname."_header.php.html")) {
  $template=sts_read_template_file (STS_TEMPLATE_DIR."boxes/$boxprefix".$boxname."_header.php.html");
 } elseif (isset($sts->infobox['default_header'])) { // Corrected in v4.5.2, was checking content cache
$template = $sts->infobox['default_header']; // Default box already in memory, get it from there
 } elseif (file_exists(STS_TEMPLATE_DIR."boxes/infobox_header.php.html"))  { // v4.5.2: header template optional
  $template=sts_read_template_file (STS_TEMPLATE_DIR."boxes/infobox_header.php.html");
  $sts->infobox['default_header'] = $template;
 } else $sts->infobox['default_header'] = ''; // v4.5.2: If no header template, cache an empty string
 $sts->infobox_header_template = $template;
 $sts->infobox_headertext = $headertext;
 $sts->infobox_right_arrow = $right_arrow;
}

function infoBoxTemplate($content) {
// STS 4.3: read content, display header & content.
// STS 4.4: reset headertext and right_arrow variables in case next box has no header.
  global $sts;
 $btrace=debug_backtrace();
 $boxname=basename($btrace[1]['file'],".php"); // backtrace 1 is the calling file
 $boxprefix = "infobox_"; // Added in v4.3SP2.

 // Added in v4.4: allows to use catalog_filename.html as template for boxes created directly in a catalog script.
 $boxname2 = basename($btrace[2]['file'],".php"); // backtrace 2 is the file calling the calling file (like sts_column_left.php)
if ($boxname2=='') $boxprefix = "catalog_";

  if (file_exists(STS_TEMPLATE_DIR."boxes/$boxprefix$boxname.php.html")) {
  $template=sts_read_template_file (STS_TEMPLATE_DIR."boxes/$boxprefix$boxname.php.html");
 } elseif (isset($sts->infobox['default_content'])) {
$template = $sts->infobox['default_content']; // Default box already in memory, get it from there
 } else { // Otherwise read it from file and save it
$template = sts_read_template_file (STS_TEMPLATE_DIR."boxes/infobox.php.html");
  $sts->infobox['default_content'] = $template;

 }

 $template = $sts->infobox_header_template."\n".$template; // Add header before the content. Header can be empty.
 $template = str_replace('$headertext', $sts->infobox_headertext, $template);
 $template = str_replace('$right_arrow', $sts->infobox_right_arrow, $template);
 $template = str_replace('$content', $content, $template);

 echo $template;
 $sts->infobox_header_template = '';
 $sts->infobox_headertext = '';
 $sts->infobox_right_arrow = '';
}
 } // END tableBox class

:thumbsup: I did not post the entire STS changes to the boxes.php file above.


~Tracy
 

Share this post


Link to post
Share on other sites

STS 4.5.4 & HTC 2.6.3

Hello! I have installed the above (latest) versions of STS and HTC, in that sequence.

From the STS contribution page (http://www.oscommerce.com/community/contributions,1524), it states:

 

-----------------------------------------------------------------------------

BONUS FEATURES: Simple HEADER TAG CONTROLLER Integration

-----------------------------------------------------------------------------

This contribution also allows you to use WebMakers.com's

Header Tag Controller contribution without having to modify every file on

the system. Just copy the Header Tag Controller's include files into place

and STS will automatically add them to all pages without having to modify

every PHP script in the /catalog/ directory.

 

STS will auto-detect if Header Tag Controller is installed and use it if

available.

 

problem

When I installed the HTC, I did all the installation instructions that came with it. But I could see no changes to the meta tags.

So I rolled everything back.

And since I already have the STS latest version, and from the "Bonus Features" (as per above), I assumed that after installing the database changes required for HTC and then copying all the HTC include files into place, as stated .. I would see some changes.

Again, I cannot see any changes.

 

On checking the view source of any page, all I see in the <head> section, after the <title> and <base> tags are:

<!-- start get_javascript(applicationtop2header) //-->

 

<!-- end get_javascript(applicationtop2header) //-->

 

Can anyone please tell me what I have done wrong or have not done?

 

Thanks so much!

Helena

Share this post


Link to post
Share on other sites
STS 4.5.4 & HTC 2.6.3

Hello! I have installed the above (latest) versions of STS and HTC, in that sequence.

From the STS contribution page (http://www.oscommerce.com/community/contributions,1524), it states:

 

 

 

problem

When I installed the HTC, I did all the installation instructions that came with it. But I could see no changes to the meta tags.

So I rolled everything back.

And since I already have the STS latest version, and from the "Bonus Features" (as per above), I assumed that after installing the database changes required for HTC and then copying all the HTC include files into place, as stated .. I would see some changes.

Again, I cannot see any changes.

 

On checking the view source of any page, all I see in the <head> section, after the <title> and <base> tags are:

 

 

Can anyone please tell me what I have done wrong or have not done?

 

Thanks so much!

Helena

 

Helena,

 

Keep in mind that STS has gone through a lot of major changes since the "Bonus Feature" text was posted on the contribution page. That was like, so many versions ago. :lol:

The code in STS and HTC has changed dramatically since then as well.

 

STS still makes using HTC a lot easier since you do not (and should not) add any of the HTC code to the catalog/includes/ files. With that said, I have posted an easy step by step on how to install HTC onto a shop that has STS installed (see link in my signature below: How to install HTC with STS).

 

With that said, you are way off base with your HTC installation and will get tons of error messages until you follow my step by step. Once you do, the outdated "Bonus Feature" text will once again apply. :thumbsup:

 

Have fun,

Edited by bkellum

Bill Kellum

 

Sounds Good Productions

STS Tutorials & more: STSv4.6, STS Add-ons (STS Power Pack), STS V4 Forum STS Forum FREE TEMPLATE

Share this post


Link to post
Share on other sites

re: STS 4.5.4 & HTC 2.6.3

Helena,

 

Keep in mind that STS has gone through a lot of major changes since the "Bonus Feature" text was posted on the contribution page. That was like, so many versions ago. :lol:

The code in STS and HTC has changed dramatically since then as well.

 

STS still makes using HTC a lot easier since you do not (and should not) add any of the HTC code to the catalog/includes/ files. With that said, I have posted an easy step by step on how to install HTC onto a shop that has STS installed (see link in my signature below: How to install HTC with STS).

 

With that said, you are way off base with your HTC installation and will get tons of error messages until you follow my step by step. Once you do, the outdated "Bonus Feature" text will once again apply. :thumbsup:

 

Have fun,

 

Hello Bill!

oh that sounds so hopeful, it literally puts a (hopefully justifiable) grin on my face and a tingling hope in my fingers.

I will go and try that out but knowing my absmal lack of knowledge in this area, it may be a while before I can complete the process.

 

I will take you advice and 'have fun' and will report back as soon as I can.

Thank you very much for your kindness & time again,

cheers,

Helena

Share this post


Link to post
Share on other sites

re: STS 4.5.4 & HTC 2.6.3

Helena,

Keep in mind that STS has gone through a lot of major changes since the "Bonus Feature" text was posted on the contribution page. That was like, so many versions ago. :lol:

The code in STS and HTC has changed dramatically since then as well.

 

STS still makes using HTC a lot easier since you do not (and should not) add any of the HTC code to the catalog/includes/ files. With that said, I have posted an easy step by step on how to install HTC onto a shop that has STS installed (see link in my signature below: How to install HTC with STS).

 

With that said, you are way off base with your HTC installation and will get tons of error messages until you follow my step by step. Once you do, the outdated "Bonus Feature" text will once again apply. :thumbsup:

 

:lol: :D :P Bill!

I did a mightly long reply to you with quotes and codes and colours and everything ... coz it didn't work. Whew .. lucky I didn't send it!!

I think it is working now. I need to do some final tweaks and then i will know for sure. I have sat up all night and now it is early morn. and I am off to bed.

I just wanted to say ... THANK YOU SO MUCH again!

You & your help are INVALUABLE!!!

Big Thanks,

Helena

Share this post


Link to post
Share on other sites

I am using sts4. I want to reduce the size of my shop so it doesn't take up the whole window and make the white space that will be created around the table black. Does anyone know if I can use osC-CenterShop v2.1 for MS2 is I have STS installed or any alternative way of doing it?

 

Thanks

 

Lotti

Share this post


Link to post
Share on other sites
I have upgraded and now use STS 4.1. Everything works as it should except for the Error Message stacks - specifically at credit card checkout_payment.php when using the authorize.net AIM module. This problem was fixed in earlier versions, but the fix doesn't work now in STS 4.1.

 

Basically, Error Message stacks show up in the URL only and not within the header. Please help! Thanks!

 

Did anyone fix this issue, please?

Share this post


Link to post
Share on other sites
I am using sts4. I want to reduce the size of my shop so it doesn't take up the whole window and make the white space that will be created around the table black. Does anyone know if I can use osC-CenterShop v2.1 for MS2 is I have STS installed or any alternative way of doing it?

 

Thanks

 

Lotti

No, you do not need the centershop contribution. STS makes it very easy to center your page. Since the templates are HTML, use standard web practises to center your page. You can center the tables or wrap everything in a div ( <div align="center"> ). Edited by bkellum

Bill Kellum

 

Sounds Good Productions

STS Tutorials & more: STSv4.6, STS Add-ons (STS Power Pack), STS V4 Forum STS Forum FREE TEMPLATE

Share this post


Link to post
Share on other sites
:thumbsup: You should create a "home page" template and name it index.php_0.html and then you will not need to do any of the above.

 

thank you. it worked fine.

But i've found another problem:

When i enter http://www.nameofmystore.com/catalog/index.php , it shows me index.php_0.html as expected. But if i put http://www.nameofmystore.com/catalog/, it shows me sts_template.php.html instead of index.php_0.html

 

any idea?

 

Billsoft.

Share this post


Link to post
Share on other sites
I'm still not being able to duplicate your problem. Maybe it's because I came across this a while back and just don't recall what I did to fix it. :blink:

 

If I get time this week, I will create a test shop running RC1 & STSv4.5.6 and see if I can duplicate it and then come up with a fix or a work around.

 

 

So it IS an existing problem, good to know I'm not the only one.

Hope you can solve it, it's quite annoying.

 

Erm, I found another problem.

If I switch on "Use template for index page" in the admin section, I get:

Warning: main(includes/modules/sts_inc/index.php) [function.main]: failed to open stream: No such file or directory in /usr/home/ws/color/www.coloursite.nl/www/naaldkunst/includes/modules/sts_inc/sts_display_output.php on line 21

 

Warning: main() [function.include]: Failed opening 'includes/modules/sts_inc/index.php' for inclusion (include_path='.:/usr/local/lib/php') in /usr/home/ws/color/www.coloursite.nl/www/naaldkunst/includes/modules/sts_inc/sts_display_output.php on line 21

And I copied the content from the sts_template.html into the index.php.html

Oh, and I'm using the header/footer includes as desctibed in the STS powerpack, and the newpage as well

 

Have you got any ideas?

Share this post


Link to post
Share on other sites
Bad configuration of your index module. Use the default parameters and it'll work.

Well, if I copy the contents of the original index.php.html file and paste it onto my custom index.php.html file and upload it, nothing changes (I get the same errors)

Then I went into the admin section of my shop and changed the name of the Template folder from temp to full (so everything would be defaoult) I still get the same errors

The only way to get rid of the errors, is to prevent STS using the index.php.html page, like this

Use template for index page

Do you want to use templates for index page?

O true

X false

 

 

Anyway, why would STS be looking in the wrong directory for the index.php file?

Warning: main(includes/modules/sts_inc/index.php) [function.main]: failed to open stream: No such file or directory

It should be looking in the includes/modules/sts_templates directory, right?

 

In what file does STS tell the server to look for the index.php file?

Appearantly STS has decided in that "if (!empty($sts_modules_inc)) {" is true (line 19 in sts_display_output.php), but why?

 

If I copy the file index.php.html from my includes\sts_templates\test\ into the \includes\modules\sts_inc\ directory, I get no more error msgs.

However if I click on a category page, I still get my index page (with appropriate the category on it) Is this normal?

Can you tell me what has gone wrong?

 

TIA

Share this post


Link to post
Share on other sites

If I copy the file index.php.html from my includes\sts_templates\test\ into the \includes\modules\sts_inc\ directory, and if I click on a category name, I still get my index page (with appropriate the category content on it too) The url is: catalog/index.php?cPath=2

How can I have a category page that does not thave the contents of my index.php.html on it?

 

Can anyone help me?

Share this post


Link to post
Share on other sites

One option is to remove the text content from the index.php file, and create individual STS templates for the index page and each category page and just use HTML to enter the text content you want on each page into the template for that page.

 

Another option I have heard mentioned is a contribution that allows you to do this - I think it's this one: Unique Category Descriptions (made simple) http://addons.oscommerce.com/info/4053

 

Those are the options I know of :)

 

If I copy the file index.php.html from my includes\sts_templates\test\ into the \includes\modules\sts_inc\ directory, and if I click on a category name, I still get my index page (with appropriate the category content on it too) The url is: catalog/index.php?cPath=2

How can I have a category page that does not thave the contents of my index.php.html on it?

 

Can anyone help me?


~Tracy
 

Share this post


Link to post
Share on other sites

Go into your Admin side and click on Modules>STS - with Default highlighted, look on the right had side and see what you have under "Base Folder" - this should be the filepath to your template folder.

 

 

Well, if I copy the contents of the original index.php.html file and paste it onto my custom index.php.html file and upload it, nothing changes (I get the same errors)

Then I went into the admin section of my shop and changed the name of the Template folder from temp to full (so everything would be defaoult) I still get the same errors

The only way to get rid of the errors, is to prevent STS using the index.php.html page, like this

Use template for index page

Do you want to use templates for index page?

O true

X false

Anyway, why would STS be looking in the wrong directory for the index.php file?

Warning: main(includes/modules/sts_inc/index.php) [function.main]: failed to open stream: No such file or directory

It should be looking in the includes/modules/sts_templates directory, right?

 

In what file does STS tell the server to look for the index.php file?

Appearantly STS has decided in that "if (!empty($sts_modules_inc)) {" is true (line 19 in sts_display_output.php), but why?

 

If I copy the file index.php.html from my includes\sts_templates\test\ into the \includes\modules\sts_inc\ directory, I get no more error msgs.

However if I click on a category page, I still get my index page (with appropriate the category on it) Is this normal?

Can you tell me what has gone wrong?

 

TIA


~Tracy
 

Share this post


Link to post
Share on other sites
Well, if I copy the contents of the original index.php.html file and paste it onto my custom index.php.html file and upload it, nothing changes (I get the same errors)

Then I went into the admin section of my shop and changed the name of the Template folder from temp to full (so everything would be defaoult) I still get the same errors

The only way to get rid of the errors, is to prevent STS using the index.php.html page, like this

Use template for index page

Do you want to use templates for index page?

O true

X false

Anyway, why would STS be looking in the wrong directory for the index.php file?

Warning: main(includes/modules/sts_inc/index.php) [function.main]: failed to open stream: No such file or directory

It should be looking in the includes/modules/sts_templates directory, right?

 

In what file does STS tell the server to look for the index.php file?

Appearantly STS has decided in that "if (!empty($sts_modules_inc)) {" is true (line 19 in sts_display_output.php), but why?

 

If I copy the file index.php.html from my includes\sts_templates\test\ into the \includes\modules\sts_inc\ directory, I get no more error msgs.

However if I click on a category page, I still get my index page (with appropriate the category on it) Is this normal?

Can you tell me what has gone wrong?

 

TIA

 

In admin, in the index module parameters, you can define extra files to include from the includes/modules/sts_inc/ folder. You have place there index.php, so STS tries to include it. Remove it and it'll work. Or uninstall - install the index module to get the default parameters.

This parameter is to add files that creates new placeholders, without having to edit php files. Like plugins.


STS v4.5 SP5 is out, and check the STS Power Pack contribution too!

New thumbnailer using phpThumb: oscThumb. Works great.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×