Latest News: (loading..)
Sign in to follow this  
Followers 0
olsonsp4c

USPS Shipping Insurance

113 posts in this topic

Hey Scott,

 

I think I may have found the reason that tax is not cal

culated on the shipping insurance. I have CCGV(trad) loaded and I found the following code in checkout_confirmation:

$payment_modules->update_status();

 

$order_total_modules = new order_total;// CCGV

$order_total_modules->collect_posts();// CCGV

$order_total_modules->pre_confirmation_check();// CCGV

 

// Line edited for CCGV

// if ( ( is_array($payment_modules->modules) && (sizeof($payment_modules->modules) > 1) && !is_object($$payment) ) || (is_object($$payment) && ($$payment->enabled == false)) ) {

if ( (is_array($payment_modules->modules)) && (sizeof($payment_modules->modules) > 1) && (!is_object($$payment)) && (!$credit_covers) ) {

tep_redirect(tep_href_link(FILENAME_CHECKOUT_PAYMENT, 'error_message=' . urlencode(ERROR_NO_PAYMENT_MODULE_SELECTED), 'SSL'));

}

 

if (is_array($payment_modules->modules)) {

$payment_modules->pre_confirmation_check();

}

 

// load the selected shipping module

require(DIR_WS_CLASSES . 'shipping.php');

$shipping_modules = new shipping($shipping);

$_SESSION['choose_insurance'] = $_POST[choose_insurance]; //USPS shipping insurance

//Lines below repositioned for CCGV

// require(DIR_WS_CLASSES . 'order_total.php');

// $order_total_modules = new order_total;

 

It appears that the repositioned lines keep the shipping insurance from getting added into the order total. Any suggestions on how to fix this? I am a php dummy.

 

TIA

Kim

 

Kim,

 

try reposition the shipping lines to right before: $order_total_modules = new order_total;// CCGV

 

let me know what happens...

 

Scott

Share this post


Link to post
Share on other sites
(Adding information for my PayPal problem posting above.)

 

The variable for insurance needs to be added to the /ext/ipn.php as it is for shipping below in ipn.php. Or, shipping and insurance could be added together on the order_confirmation page and then the variable "shipping" would be fine.

Would someone write the code for either of those?

[sat Mar 15 17:13:10 2008] [error] PP TEST received POST variable: shipping : 1.98

 

some paypal modules need the following fix... if you install this contribution and the shipping insurance is not included in your paypal totals, TRY making the changes outlined below.

 

You will need to MOVE the lines that you are instructed to insert into checkout_process.php so that the following three lines (not counting blanks):

 

require(DIR_WS_CLASSES . 'order_total.php');

$order_total_modules = new order_total;

 

$order_totals = $order_total_modules->process();

 

are just ABOVE the added part instead of below it and these 2 lines:

 

// load the before_process function from the payment modules

$payment_modules->before_process();

 

are JUST BELOW it

 

SO IT LOOKS LIKE THIS:

========================================

require(DIR_WS_CLASSES . 'order.php');

$order = new order;

require(DIR_WS_CLASSES . 'order_total.php');

$order_total_modules = new order_total;

 

$order_totals = $order_total_modules->process();

 

Try this and let me know if it helps...

 

Scott

Share this post


Link to post
Share on other sites

Hi Scott:

 

Wow! Thanks for getting back so quickly.

 

I am certain that is the way my PayPal module is already set up. I have posted the code below:

   // load selected payment module
 require(DIR_WS_CLASSES . 'payment.php');
 $payment_modules = new payment($payment);

  // load the selected shipping module
 require(DIR_WS_CLASSES . 'shipping.php');
 $shipping_modules = new shipping($shipping);

 require(DIR_WS_CLASSES . 'order.php');
 $order = new order;

  //Shifted this way down to transport shopping points to paypal
  // load the before_process function from the payment modules
  //  $payment_modules->before_process();

 require(DIR_WS_CLASSES . 'order_total.php');
 $order_total_modules = new order_total;

 $order_totals = $order_total_modules->process();

  // load the before_process function from the payment modules
 $payment_modules->before_process();

 $sql_data_array = array('customers_id' => $customer_id,
						 'customers_name' => $order->customer['firstname'] . ' ' . $order->customer['lastname'],
						 'customers_company' => $order->customer['company'],
						 'customers_street_address' => $order->customer['street_address'],
						 'customers_suburb' => $order->customer

Share this post


Link to post
Share on other sites
Kim,

 

try reposition the shipping lines to right before: $order_total_modules = new order_total;// CCGV

 

let me know what happens...

 

Scott

 

I guess that wasn't the problem. Made the change and still not sales tax calculated on shipping insurance. There is no place on the admin side when setting up the insurance to identify what tax class to use. Should there be? Maybe I did something wrong during the install.

Share this post


Link to post
Share on other sites
I guess that wasn't the problem. Made the change and still not sales tax calculated on shipping insurance. There is no place on the admin side when setting up the insurance to identify what tax class to use. Should there be? Maybe I did something wrong during the install.

 

OK, change the code back to the way it was - let me check into your question and get back with you :)

 

Scott

Share this post


Link to post
Share on other sites
I guess that wasn't the problem. Made the change and still not sales tax calculated on shipping insurance. There is no place on the admin side when setting up the insurance to identify what tax class to use. Should there be? Maybe I did something wrong during the install.

 

That is the issue Kimm... this is the adjustment - i will update it in the next release - sorry about that:

 

1. Remove the order total module

2. Open includes/modules/order_total/ot_uspsinsurance.php

 

FIND this:

 

	  tep_db_query("insert into " . TABLE_CONFIGURATION . " (configuration_title, configuration_key, configuration_value, configuration_description, configuration_group_id, sort_order, set_function, date_added) values ('Insure Tax', 'MODULE_OT_USPSINSURANCE_INSURE_TAX', 'True', 'Insure tax on packages shipped by USPS?', '6', '2', 'tep_cfg_select_option(array(\'True\', \'False\'), ', now())");

 

AFTER add this:

 

	  tep_db_query("insert into " . TABLE_CONFIGURATION . " (configuration_title, configuration_key, configuration_value, configuration_description, configuration_group_id, sort_order, use_function, set_function, date_added) values ('Tax Class', 'MODULE_SHIPPING_USPSFLAT_TAX_CLASS', '0', 'Use the following tax class on the shipping fee.', '6', '0', 'tep_get_tax_class_title', 'tep_cfg_pull_down_tax_classes(', now())");

 

3. Re-install

4. Make the sort order appropriate and choose options

 

it should work :)

 

Scott

Share this post


Link to post
Share on other sites
That is the issue Kimm... this is the adjustment - i will update it in the next release - sorry about that:

 

1. Remove the order total module

2. Open includes/modules/order_total/ot_uspsinsurance.php

 

FIND this:

 

	  tep_db_query("insert into " . TABLE_CONFIGURATION . " (configuration_title, configuration_key, configuration_value, configuration_description, configuration_group_id, sort_order, set_function, date_added) values ('Insure Tax', 'MODULE_OT_USPSINSURANCE_INSURE_TAX', 'True', 'Insure tax on packages shipped by USPS?', '6', '2', 'tep_cfg_select_option(array(\'True\', \'False\'), ', now())");

 

AFTER add this:

 

	  tep_db_query("insert into " . TABLE_CONFIGURATION . " (configuration_title, configuration_key, configuration_value, configuration_description, configuration_group_id, sort_order, use_function, set_function, date_added) values ('Tax Class', 'MODULE_SHIPPING_USPSFLAT_TAX_CLASS', '0', 'Use the following tax class on the shipping fee.', '6', '0', 'tep_get_tax_class_title', 'tep_cfg_pull_down_tax_classes(', now())");

 

3. Re-install

4. Make the sort order appropriate and choose options

 

it should work :)

 

Scott

Ok I made the change in the file and can see the changed in the database but I don't get a drop down box in admin for the tax class.

Share this post


Link to post
Share on other sites
Ok I made the change in the file and can see the changed in the database but I don't get a drop down box in admin for the tax class.

 

oops, i forgot another...

 

1. Remove the module

2. make these changes

 

 

FIND this:

 

	  return array('MODULE_OT_USPSINSURANCE_STATUS', 'MODULE_OT_USPSINSURANCE_INSURE_TAX', 'MODULE_OT_USPSINSURANCE_CHOICE', 'MODULE_OT_USPSINSURANCE_SORT_ORDER', 'MODULE_OT_USPS_INS1', 'MODULE_OT_USPS_INS2', 'MODULE_OT_USPS_INS3','MODULE_OT_USPS_INS4', 'MODULE_OT_USPS_INS5', 'MODULE_OT_USPS_INS6', 'MODULE_OT_USPS_INS7', 'MODULE_OT_USPS_INS8', 'MODULE_OT_USPS_INS9', 'MODULE_OT_USPS_INS10');

 

REPLACE with this:

 

	  return array('MODULE_OT_USPSINSURANCE_STATUS', 'MODULE_OT_USPSINSURANCE_INSURE_TAX', 'MODULE_OT_USPSFLAT_TAX_CLASS', 'MODULE_OT_USPSINSURANCE_CHOICE', 'MODULE_OT_USPSINSURANCE_SORT_ORDER', 'MODULE_OT_USPS_INS1', 'MODULE_OT_USPS_INS2', 'MODULE_OT_USPS_INS3','MODULE_OT_USPS_INS4', 'MODULE_OT_USPS_INS5', 'MODULE_OT_USPS_INS6', 'MODULE_OT_USPS_INS7', 'MODULE_OT_USPS_INS8', 'MODULE_OT_USPS_INS9', 'MODULE_OT_USPS_INS10');

 

FIND this:

 

	  tep_db_query("insert into " . TABLE_CONFIGURATION . " (configuration_title, configuration_key, configuration_value, configuration_description, configuration_group_id, sort_order, use_function, set_function, date_added) values ('Tax Class', 'MODULE_SHIPPING_USPSFLAT_TAX_CLASS', '0', 'Use the following tax class on the shipping fee.', '6', '0', 'tep_get_tax_class_title', 'tep_cfg_pull_down_tax_classes(', now())");

 

REPLACE with this:

	  tep_db_query("insert into " . TABLE_CONFIGURATION . " (configuration_title, configuration_key, configuration_value, configuration_description, configuration_group_id, sort_order, use_function, set_function, date_added) values ('Tax Class', 'MODULE_OT_USPSINSURANCE_TAX_CLASS', '0', 'Use the following tax class on the shipping fee.', '6', '0', 'tep_get_tax_class_title', 'tep_cfg_pull_down_tax_classes(', now())");

 

3. Re-install and choose options...

 

Hopefully it works! I made these changes on my test store and got the dropdown box... let me know!

 

:)

 

Scott

Edited by olsonsp4c

Share this post


Link to post
Share on other sites
oops, i forgot another...

 

1. Remove the module

2. make these changes

FIND this:

 

	  return array('MODULE_OT_USPSINSURANCE_STATUS', 'MODULE_OT_USPSINSURANCE_INSURE_TAX', 'MODULE_OT_USPSINSURANCE_CHOICE', 'MODULE_OT_USPSINSURANCE_SORT_ORDER', 'MODULE_OT_USPS_INS1', 'MODULE_OT_USPS_INS2', 'MODULE_OT_USPS_INS3','MODULE_OT_USPS_INS4', 'MODULE_OT_USPS_INS5', 'MODULE_OT_USPS_INS6', 'MODULE_OT_USPS_INS7', 'MODULE_OT_USPS_INS8', 'MODULE_OT_USPS_INS9', 'MODULE_OT_USPS_INS10');

 

REPLACE with this:

 

	  return array('MODULE_OT_USPSINSURANCE_STATUS', 'MODULE_OT_USPSINSURANCE_INSURE_TAX', 'MODULE_OT_USPSFLAT_TAX_CLASS', 'MODULE_OT_USPSINSURANCE_CHOICE', 'MODULE_OT_USPSINSURANCE_SORT_ORDER', 'MODULE_OT_USPS_INS1', 'MODULE_OT_USPS_INS2', 'MODULE_OT_USPS_INS3','MODULE_OT_USPS_INS4', 'MODULE_OT_USPS_INS5', 'MODULE_OT_USPS_INS6', 'MODULE_OT_USPS_INS7', 'MODULE_OT_USPS_INS8', 'MODULE_OT_USPS_INS9', 'MODULE_OT_USPS_INS10');

 

FIND this:

 

	  tep_db_query("insert into " . TABLE_CONFIGURATION . " (configuration_title, configuration_key, configuration_value, configuration_description, configuration_group_id, sort_order, use_function, set_function, date_added) values ('Tax Class', 'MODULE_SHIPPING_USPSFLAT_TAX_CLASS', '0', 'Use the following tax class on the shipping fee.', '6', '0', 'tep_get_tax_class_title', 'tep_cfg_pull_down_tax_classes(', now())");

 

REPLACE with this:

	  tep_db_query("insert into " . TABLE_CONFIGURATION . " (configuration_title, configuration_key, configuration_value, configuration_description, configuration_group_id, sort_order, use_function, set_function, date_added) values ('Tax Class', 'MODULE_OT_USPSINSURANCE_TAX_CLASS', '0', 'Use the following tax class on the shipping fee.', '6', '0', 'tep_get_tax_class_title', 'tep_cfg_pull_down_tax_classes(', now())");

 

3. Re-install and choose options...

 

Hopefully it works! I made these changes on my test store and got the dropdown box... let me know!

 

:)

 

Scott

Ok now I get a space in admin where I assume the new drop down should be but there is nothing in that area.

Share this post


Link to post
Share on other sites
Ok now I get a space in admin where I assume the new drop down should be but there is nothing in that area.

 

Kimm,

 

I'm making mistakes... i apologize, it's late here in Portland.

 

the changes should have read this:

 

FIND this:

 

 

	  return array('MODULE_OT_USPSINSURANCE_STATUS', 'MODULE_OT_USPSINSURANCE_INSURE_TAX', 'MODULE_OT_USPSINSURANCE_CHOICE', 'MODULE_OT_USPSINSURANCE_SORT_ORDER', 'MODULE_OT_USPS_INS1', 'MODULE_OT_USPS_INS2', 'MODULE_OT_USPS_INS3','MODULE_OT_USPS_INS4', 'MODULE_OT_USPS_INS5', 'MODULE_OT_USPS_INS6', 'MODULE_OT_USPS_INS7', 'MODULE_OT_USPS_INS8', 'MODULE_OT_USPS_INS9', 'MODULE_OT_USPS_INS10');

 

REPLACE with this:

 

 

	  return array('MODULE_OT_USPSINSURANCE_STATUS', 'MODULE_OT_USPSINSURANCE_INSURE_TAX', 'MODULE_OT_USPSINSURANCE_TAX_CLASS', 'MODULE_OT_USPSINSURANCE_CHOICE', 'MODULE_OT_USPSINSURANCE_SORT_ORDER', 'MODULE_OT_USPS_INS1', 'MODULE_OT_USPS_INS2', 'MODULE_OT_USPS_INS3','MODULE_OT_USPS_INS4', 'MODULE_OT_USPS_INS5', 'MODULE_OT_USPS_INS6', 'MODULE_OT_USPS_INS7', 'MODULE_OT_USPS_INS8', 'MODULE_OT_USPS_INS9', 'MODULE_OT_USPS_INS10');

 

FIND this:

 

 

	  tep_db_query("insert into " . TABLE_CONFIGURATION . " (configuration_title, configuration_key, configuration_value, configuration_description, configuration_group_id, sort_order, use_function, set_function, date_added) values ('Tax Class', 'MODULE_SHIPPING_USPSFLAT_TAX_CLASS', '0', 'Use the following tax class on the shipping fee.', '6', '0', 'tep_get_tax_class_title', 'tep_cfg_pull_down_tax_classes(', now())");

 

REPLACE with this:

 

	  tep_db_query("insert into " . TABLE_CONFIGURATION . " (configuration_title, configuration_key, configuration_value, configuration_description, configuration_group_id, sort_order, use_function, set_function, date_added) values ('Tax Class', 'MODULE_OT_USPSINSURANCE_TAX_CLASS', '0', 'Use the following tax class on the shipping fee.', '6', '0', 'tep_get_tax_class_title', 'tep_cfg_pull_down_tax_classes(', now())");

 

 

for you at this point it just means changing MODULE_OT_USPSFLAT_TAX_CLASS to MODULE_OT_USPSINSURANCE_TAX_CLASS in the 1st REPLACE

 

Scott

Edited by olsonsp4c

Share this post


Link to post
Share on other sites

Joseph,

 

You are correct. Could you let me know which Paypal Module and version you are using?

 

One quick suggestion is to try making the same edit you made in checkout_confirmation.php to your Paypal file.

 

Scott

Edited by olsonsp4c

Share this post


Link to post
Share on other sites
Kimm,

 

I'm making mistakes... i apologize, it's late here in Portland.

 

the changes should have read this:

 

FIND this:

	  return array('MODULE_OT_USPSINSURANCE_STATUS', 'MODULE_OT_USPSINSURANCE_INSURE_TAX', 'MODULE_OT_USPSINSURANCE_CHOICE', 'MODULE_OT_USPSINSURANCE_SORT_ORDER', 'MODULE_OT_USPS_INS1', 'MODULE_OT_USPS_INS2', 'MODULE_OT_USPS_INS3','MODULE_OT_USPS_INS4', 'MODULE_OT_USPS_INS5', 'MODULE_OT_USPS_INS6', 'MODULE_OT_USPS_INS7', 'MODULE_OT_USPS_INS8', 'MODULE_OT_USPS_INS9', 'MODULE_OT_USPS_INS10');

 

REPLACE with this:

	  return array('MODULE_OT_USPSINSURANCE_STATUS', 'MODULE_OT_USPSINSURANCE_INSURE_TAX', 'MODULE_OT_USPSINSURANCE_TAX_CLASS', 'MODULE_OT_USPSINSURANCE_CHOICE', 'MODULE_OT_USPSINSURANCE_SORT_ORDER', 'MODULE_OT_USPS_INS1', 'MODULE_OT_USPS_INS2', 'MODULE_OT_USPS_INS3','MODULE_OT_USPS_INS4', 'MODULE_OT_USPS_INS5', 'MODULE_OT_USPS_INS6', 'MODULE_OT_USPS_INS7', 'MODULE_OT_USPS_INS8', 'MODULE_OT_USPS_INS9', 'MODULE_OT_USPS_INS10');

 

FIND this:

	  tep_db_query("insert into " . TABLE_CONFIGURATION . " (configuration_title, configuration_key, configuration_value, configuration_description, configuration_group_id, sort_order, use_function, set_function, date_added) values ('Tax Class', 'MODULE_SHIPPING_USPSFLAT_TAX_CLASS', '0', 'Use the following tax class on the shipping fee.', '6', '0', 'tep_get_tax_class_title', 'tep_cfg_pull_down_tax_classes(', now())");

 

REPLACE with this:

 

	  tep_db_query("insert into " . TABLE_CONFIGURATION . " (configuration_title, configuration_key, configuration_value, configuration_description, configuration_group_id, sort_order, use_function, set_function, date_added) values ('Tax Class', 'MODULE_OT_USPSINSURANCE_TAX_CLASS', '0', 'Use the following tax class on the shipping fee.', '6', '0', 'tep_get_tax_class_title', 'tep_cfg_pull_down_tax_classes(', now())");

for you at this point it just means changing MODULE_OT_USPSFLAT_TAX_CLASS to MODULE_OT_USPSINSURANCE_TAX_CLASS in the 1st REPLACE

 

Scott

I see you're a fellow night owl, its almost 3am here. I made the change and now get the drop down for tax class, however still no sales tax in the shipping calculation. I tried it with both versions of the checkout_confirmation mod.

Share this post


Link to post
Share on other sites
I see you're a fellow night owl, its almost 3am here. I made the change and now get the drop down for tax class, however still no sales tax in the shipping calculation. I tried it with both versions of the checkout_confirmation mod.

 

Did you update the sort order so that shipping insurance is numbered 1 higher than tax?

 

could you clarify on the "both" versions of the checkout_confirmation.php file? I have not updated anything in this file (just the 1 edit - 1 added line)...

 

Scott

Share this post


Link to post
Share on other sites

I just issued version 1.1 of this contribution:

 

Changes since v1.0

------------------

* Corrected the colspan to "3" instead of "4" in the second half of checkout_payment.php

* Corrected the table alignment issues in checkout_payment.php

* Added BEGIN and END comments to the stylesheet

* Added the missing Tax Class database entry and corresponding code edits

* Added update instructions

 

http://addons.oscommerce.com/info/5782

 

Scott

Share this post


Link to post
Share on other sites
I see you're a fellow night owl, its almost 3am here. I made the change and now get the drop down for tax class, however still no sales tax in the shipping calculation. I tried it with both versions of the checkout_confirmation mod.

 

A few more edits and let me know what happens:

 

FIND this:

 

	  $this->enabled = MODULE_OT_USPSINSURANCE_STATUS;

 

ADD this AFTER:

 

	  $this->tax_class = MODULE_OT_USPSINSURANCE_TAX_CLASS;

 

FIND this:

 

		$this->output[] = array('title' => $this->title . ':',
							'text' => $currencies->format($insurance, true, $order->info['currency'], $order->info['currency_value']),
							'value' => ($insurance * $shipping_num_boxes));

 

ADD this AFTER:

 

		if ($this->tax_class > 0) {
	  $this->output['tax'] = tep_get_tax_rate($this->tax_class, $order->delivery['country']['id'], $order->delivery['zone_id']);
	}

 

Let me know... i'm off to bed, hope this works...

 

Scott

Edited by olsonsp4c

Share this post


Link to post
Share on other sites

Hi Scott:

 

I see you like a challenge. Me to.

 

I have updated to the newest version 1.1.

 

I am using osCommerce PayPal IPN v2.3.0.0.

 

I cannot find the correct place in the ipn.php to make the edit as I did in the checkout_confirmation.php. I would like you to look at the ipn.php file so you could make a suggestion about adding the edit. I have posted a copy of the file here.

 

I am going to test a PayPal payment again. If the problem was solved by updating to the newest version I let you know here shortly.

 

Thanks for all your help.

 

Joseph,

 

You are correct. Could you let me know which Paypal Module and version you are using?

 

One quick suggestion is to try making the same edit you made in checkout_confirmation.php to your Paypal file.

 

Scott

Share this post


Link to post
Share on other sites

To make it clear what is happening.

 

This is what the transaction should be:

Sub-Total: $56.95

United States Postal Service (1 x 0.52lbs) (First Class Mail (Estimated: 2 - 5 Days)): $2.32

USPS Shipping Insurance: $2.05

State Sales Tax: $3.70

Total: $65.02

 

 

At PayPal

Subtotal: $60.65

Shipping and Handling: $2.32

Tax: (6.500% in Minnesota): $3.94

Total: $66.91 USD

It appears the sales tax is getting added to the cost of merchandise and the insurance charge does not get added to PayPal total.

Share this post


Link to post
Share on other sites
To make it clear what is happening.

 

This is what the transaction should be:

Sub-Total: $56.95

United States Postal Service (1 x 0.52lbs) (First Class Mail (Estimated: 2 - 5 Days)): $2.32

USPS Shipping Insurance: $2.05

State Sales Tax: $3.70

Total: $65.02

 

 

At PayPal

Subtotal: $60.65

Shipping and Handling: $2.32

Tax: (6.500% in Minnesota): $3.94

Total: $66.91 USD

It appears the sales tax is getting added to the cost of merchandise and the insurance charge does not get added to PayPal total.

 

thanks for the update... i am out all day today, so I take a peek tomorrow.

 

if you need to, temporarily disable the mod so you don't lose money.

 

Scott

Share this post


Link to post
Share on other sites
A few more edits and let me know what happens:

 

FIND this:

 

	  $this->enabled = MODULE_OT_USPSINSURANCE_STATUS;

 

ADD this AFTER:

 

	  $this->tax_class = MODULE_OT_USPSINSURANCE_TAX_CLASS;

 

FIND this:

 

		$this->output[] = array('title' => $this->title . ':',
							'text' => $currencies->format($insurance, true, $order->info['currency'], $order->info['currency_value']),
							'value' => ($insurance * $shipping_num_boxes));

 

ADD this AFTER:

 

		if ($this->tax_class > 0) {
	  $this->output['tax'] = tep_get_tax_rate($this->tax_class, $order->delivery['country']['id'], $order->delivery['zone_id']);
	}

 

Let me know... i'm off to bed, hope this works...

 

Scott

Hey Scott,

Sorry but still no tax calculation. Have tried with the change to confirmation page and also with unchanged confirmation page. Have included all the changes to the order_total/ot_uspsinsurance.php file. Have different sort orders in admin side. No matter what I do it is not calculating sales tax on the insurance.

Share this post


Link to post
Share on other sites
To make it clear what is happening.

 

This is what the transaction should be:

Sub-Total: $56.95

United States Postal Service (1 x 0.52lbs) (First Class Mail (Estimated: 2 - 5 Days)): $2.32

USPS Shipping Insurance: $2.05

State Sales Tax: $3.70

Total: $65.02

 

 

At PayPal

Subtotal: $60.65

Shipping and Handling: $2.32

Tax: (6.500% in Minnesota): $3.94

Total: $66.91 USD

It appears the sales tax is getting added to the cost of merchandise and the insurance charge does not get added to PayPal total.

 

Thanks for the clarity - it seems that it might be getting passed to Paypal actually... well, it might be - adding the insurance to the sub-total and then passing it on to Paypal, but there is extra coming from somewhere that is unaccounted for... also, have you looked at this:

 

QUOTE(Aldebaran @ Dec 13 2007, 12:58 AM) *

Hi,

Running osCommerce 2.2-MS2 and installed the PayPal IPN module.

 

Get no errors, but if you enter a discount code, it is NOT getting passed to PayPal. PayPal uses the full amount and charges the full amount to customer, whether they have a credit card or are using a PayPal account.

 

I have the module set to aggregate, which others have said solved this issue, but this doesn't solve issue.

 

When you go back to store, the order shows the discounted amount and so does the email sent to customer - so there's a big mismatch.

 

All suggestions welcome rolleyes.gif

 

Everything else appears to work normally.

 

Jill

 

 

I have the same problems as you. discount and insurance do not pass to paypal. I tried the following way. I am not sure it will solve the problem until my customer buy one product. do you set up any thing in paypal-->profile-->shipping calculation???

 

1.) make sure you have your shipping mods. set up like you want in os.

2.)Log into your paypal account.

3.)Click on "profile"

4.)Click on "Set Up Shipping Calculations"

5.)Make sure there is NOTHING set up here.

 

thanks!

 

Scott

Share this post


Link to post
Share on other sites

For now anyway I am just not accepting PayPal for payment of orders. That seems to make life a lot simpler.

Share this post


Link to post
Share on other sites
For now anyway I am just not accepting PayPal for payment of orders. That seems to make life a lot simpler.

 

I use an older version of the Paypal IPN, version 1.4 by windfif and it works very will and does pass things along properly. You might try that version.

 

Scott

Edited by olsonsp4c

Share this post


Link to post
Share on other sites

I do not see an option for the insurance in the admin

Modules

Order total

I just see

Low order fee

Shipping

Sub total

Tax

Total

 

Bu tI dont see anything resembling the instructions

 

**********

* STEP 6 *

**********

 

Activate in admin section of your site (Modules->Order Total) and edit the following settings.

 

1. Use Shipping Insurance? Set to "True" if you want to use this module.

2. Insure Tax? Set to "True" if you want to insure tax on packages shipped by USPS.

3. Customer Choice? Set to "True" if you desire the shipping insurance checkbox to

default to "unchecked" when the customer arrives at your checkout payment screen.

The customer must choose to SELECT shipping insurance. Set to "False" if you

desire the shipping insurance checkbox to default to "checked" when the customer

arrives at your checkout payment screen. The customer must choose to DESELECT

shipping insurance.

4. Sort Order? Set this to the order you want it to appear in the totals table.

See how your Order Total Modules have a Sort Order? Well, I use Shipping

as 3 and Shipping Insurance as 4. Be careful NOT to have two modules with

the same order number. Note that ANY modules ordered after it, excluding

shipping, will not be included in the total insured.

5. Insert accurate insurance amounts in the appropriate input boxes. You can verify

current rates at the USPS website. Links are provided in the module description.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0