Jump to content
Sign in to follow this  
BirdBrain

JUST RELEASED! Printable Catalog

Recommended Posts

Hi all,

I've seen this problem before - it has to do with the mysql syntax and adding brackets in newer versions of mysql.

this is the code that worked fo me:

 

$products_query_raw = "select distinct p.products_id, p.products_image, p.products_model, p.products_quantity, p.products_weight, pd.products_name, p.manufacturers_id, p.products_price, p.products_date_added, IF(s.status, s.specials_new_products_price, NULL) as specials_new_products_price, IF(s.status, s.specials_new_products_price, p.products_price) as final_price, m.manufacturers_name, pd.products_description, cd.categories_name, p.products_tax_class_id, p2c.categories_id from (" . TABLE_PRODUCTS_DESCRIPTION . " pd, " . TABLE_PRODUCTS . " p left join " . TABLE_MANUFACTURERS . " m on p.manufacturers_id = m.manufacturers_id, " . TABLE_PRODUCTS_TO_CATEGORIES . " p2c) left join " . TABLE_CATEGORIES_DESCRIPTION . " cd on p2c.categories_id = cd.categories_id left join " . TABLE_SPECIALS . " s on p.products_id = s.products_id where p.products_status = '1' and p.products_id = p2c.products_id and pd.products_id = p2c.products_id and pd.language_id = '" . $languages_id . "' and cd.language_id = '" . $languages_id . "' order by $order";

 

Note the added open and close brackets "(" & ")" near TABLE_PRODUCTS_DESCRIPTION and TABLE_PRODUCTS_TO_CATEGORIES.

Change this in both catalog_products_with_images.php & in catalog_products_with_images_full.php

 

Hope this helps!

And Thanks for the great contrib!

:thumbsup:

 

 

The above fix works for Printable Catalog V 35 Sept 11-2005 when catalog_products_with_images.php and catalog_products_with_images_full.php are both getting the 1054 MySQL 5.0 error.

 

In Catalog/catalog_products_with_images.php around line 344, replace with the above code posted by weerd.

 

In Catalog/catalog_products_with_images_full.php around line 347, replace with the same code above.

 

This should really be posted as an offical fix at the Contribution page

Share this post


Link to post
Share on other sites
Hi,

Just wondering if anyone had solved the duplication problem or had any ideas?

The only idea I can think of is I moved some entries from the "root" into a category, could this cause a double entry as if there is a 'ghost' impression in the db?

Even though i removed all the sample categories from the default installation and added only four items into the catalog, the printable catalog page says:- "Displaying 1 to 3 (of 18 products)"

But after all that, a lovely contrib, wish I could help!

Penge

 

Hi Richard: I want to ask you aquestion do you know how to fix browser compatiblity.

because for some reason in my site i can see the pictures in product_inf.php when Ia m using firefox, but if I am using internet explore is gone.

my site is http://www.cgiftshop.com

Share this post


Link to post
Share on other sites

I had the same deaded 1054 - Unknown column 'p.products_id' in 'on clause' error. the above fixs solved my error. I have another problem though, in the upper left hand side where store details appear my store name appears twice. How can I fix that?

Great contribution

 

thanks

Share this post


Link to post
Share on other sites

hi

is it supposed to take alot of time to load the catalog

i have over 7,000 items in my store and it take like 3-4 minutes to load

any way to make it faster

 

Thanks

Tom

Share this post


Link to post
Share on other sites

Sorry, I might be stupid but I am having the:

 

1054 - Unknown column 'p.products_id' in 'on clause'

 

select distinct p.products_id, p.products_image, p.products_model, p.products_quantity, p.products_weight, pd.products_name, p.manufacturers_id, p.products_price, p.products_date_added, IF(s.status, s.specials_new_products_price, NULL) as specials_new_products_price, IF(s.status, s.specials_new_products_price, p.products_price) as final_price, m.manufacturers_name, pd.products_description, cd.categories_name, p.products_tax_class_id, p2c.categories_id from products_description pd, products p left join manufacturers m on p.manufacturers_id = m.manufacturers_id, products_to_categories p2c left join categories_description cd on p2c.categories_id = cd.categories_id left join specials s on p.products_id = s.products_id where p.products_status = '1' and p.products_id = p2c.products_id and pd.products_id = p2c.products_id and pd.language_id = '1' and cd.language_id = '1' order by pd.products_name, cd.categories_name

 

[TEP STOP]

 

 

Image

 

Sort Asending

Sort Desending Name

 

Sort Asending

Sort Desending Category

 

Sort Asending

Sort Desending Model

 

Sort Asending

Sort Desending Price

 

Problem as well. I have tried the mentioned solution, but I can't make it work! Could I get a little more detailed instructions on how to make this work please?

 

Chantal :blush:

Share this post


Link to post
Share on other sites

I have installed the Print Catalog and I am getting this error

 

 

Fatal error: Cannot redeclare tep_db_connect() (previously declared in /home/kicknscr/public_html/store/catalog/includes/functions/database.php:13) in /home/kicknscr/public_html/store/catalog/includes/functions/database.php on line 13

 

 

I am not sure where to fix this error, as I have never encountered it before.

 

If any one has any info or know of a way to fix this please email me John Smith

 

Time is of the essence.

Share this post


Link to post
Share on other sites
I notice it is "sorted" by category if thats what u wanna call it, but u cannot jump from one category to the next, and what category you are currently looking at is not mentioned anywhere... any plans to add something like that?

too much bugs, so better dont try it

Share this post


Link to post
Share on other sites

Hi,

 

has anybody made an addition to this contrib. So that it shows the attributes as well ? Eg. different prices, sizes, colors and so forth .....

 

Anybody ??

 

Regards

jarzom

Share this post


Link to post
Share on other sites

hi everybody i displey this error:

 

 

Warning: main(includes/languages/italian/catalog_products_with_images.php) [function.main]: failed to open stream: No such file or directory in /home/militit/public_html/shop/catalog_products_with_images.php on line 19

 

Fatal error: main() [function.require]: Failed opening required 'includes/languages/italian/catalog_products_with_images.php' (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/militit/public_html/shop/catalog_products_with_images.php on line 19

 

somebody can hel me :rolleyes: :rolleyes:

Share this post


Link to post
Share on other sites

I've go the catalog working, but how do I maintain the proportions of my pictures? They are all being scaled at some wrong amount, but not sure where to find it.

 

Thanks ;)

Share this post


Link to post
Share on other sites

I have tried to get this to work so many times but it still wont... please have a look at what it is doing and see if you know why...

 

http://nawtytoys.co.uk/catalog_products_with_images.php

 

When i tell it to go to page 2 it takes me to this url http://catalog_products_with_images.php/?listing=&page=2 instead of http://nawtytoys.co.uk/catalog_products_wi...ing=&page=2

 

Please can someone help... i really like this contribution and will cry if it doesnt work :blink:

Share this post


Link to post
Share on other sites
I have tried to get this to work so many times but it still wont... please have a look at what it is doing and see if you know why...

 

http://nawtytoys.co.uk/catalog_products_with_images.php

 

When i tell it to go to page 2 it takes me to this url http://catalog_products_with_images.php/?listing=&page=2 instead of http://nawtytoys.co.uk/catalog_products_wi...ing=&page=2

 

Please can someone help... i really like this contribution and will cry if it doesnt work :blink:

 

I see you got it working, i have the same problem, can you help

Share this post


Link to post
Share on other sites

I need some help with Printable Catalog V 3.5 Sept 12-2005

 

 

On catalog_products_with_images.php

None of the buttons [Product Name - Category - Model - Price] or links on the bottom work with Php5

 

Under Php4 the work fine

 

My provider will be moving to php 5 permanently, any help will be appreciated.

 

Can test it at:

http://spiceupyourlifenow.com/php5/catalog...with_images.php

 

when I hit the next button the address changes to

 

http://www.spiceupyourlifenow.com/php5/cat...ing=&page=2

 

but the page is still the same.

Share this post


Link to post
Share on other sites

I just installed the mod and I figured out that I don´t have the information box neither the category box so I tried to install at the header.php but it didn´t work. Can somebody tell me how to set the link at the header.php? I tried at the top of the page, if you check at my site www.perfectfragranceshop.com I tried to make a link between Customer Login and FAQ´s. Somebody knows how to do it? I am new in it.

Share this post


Link to post
Share on other sites

Can anyone send some links with this working? I would like to see how it functions with the links on the tops of each page along with the printable pages to try before I add the contribution. Thanks in advance. sbrenusa

Share this post


Link to post
Share on other sites

This is a great contribution. Thanks to all that worked on it. I was lucky and got it to work after just a bit of tinkering.

 

Did anyone ever get it so that you could choose it to print only a selected category? I have a category called ALL that has all the items and then I copy them to the other categories. My option at this point is to delete the ALL category and just use the printable catalog as the "ALL" option,in order to make it so that there are not multiple entries. I'd prefer the ability to select the category since the template I'm using doesn't allow for the description in the columns.

 

If anyone is still out there and has any thoughts, I'd appreciate it. Thanks in advance, Stephanie

Share this post


Link to post
Share on other sites
Can anyone send some links with this working? I would like to see how it functions with the links on the tops of each page along with the printable pages to try before I add the contribution. Thanks in advance. sbrenusa

 

Did you ever find a working link?

Share this post


Link to post
Share on other sites
I need some help with Printable Catalog V 3.5 Sept 12-2005

 

 

On catalog_products_with_images.php

None of the buttons [Product Name - Category - Model - Price] or links on the bottom work with Php5

 

Under Php4 the work fine

 

My provider will be moving to php 5 permanently, any help will be appreciated.

 

Can test it at:

http://spiceupyourlifenow.com/php5/catalog...with_images.php

 

when I hit the next button the address changes to

 

http://www.spiceupyourlifenow.com/php5/cat...ing=&page=2

 

but the page is still the same.

 

I have the same problem (none of the buttons or links on the bottom page work). Did you solve it? Can you explain me how? Thanks

Share this post


Link to post
Share on other sites

CAN YOU CHANGE THE ORDER OF THE COLUMNS? I would like the image, then model number to appear. I assumed that the numbers you put in the admin page would order them but they do not seem to be changing. NOr does the column in which it auto sorts from.

 

Thank you in advance for any advice?

Share this post


Link to post
Share on other sites
I have the same problem (none of the buttons or links on the bottom page work). Did you solve it? Can you explain me how? Thanks

 

I started over and have the same problem http://client-demo.com/catalog_products_with_images.php The next page brings back the same descriptions and the sort does not work. Also, the sort "buttons" don't appear. The two gif files are in the /includes/languages/english/images/buttons/

 

I also ran uninstall_printable_catalog_admin3_3.sql and than install_printable_catalog_admin.sql

 

I have seen this work and really like the function, but I can't figure out what is going on here. Yes, I'll be happy to make a contribution if we can get this thing working. I am running PHP Version 4.3.9.

Share this post


Link to post
Share on other sites

I had the printable catalog working fine a few months ago and just went into it again and am now getting this message...

1054 - Unknown column 'p.products_id' in 'on clause'

 

select distinct p.products_id, p.products_image, p.products_model, p.products_quantity, p.products_weight, pd.products_name, p.manufacturers_id, p.products_price, p.products_date_added, IF(s.status, s.specials_new_products_price, NULL) as specials_new_products_price, IF(s.status, s.specials_new_products_price, p.products_price) as final_price, m.manufacturers_name, pd.products_description, cd.categories_name, p.products_tax_class_id, p2c.categories_id from products_description pd, products p left join manufacturers m on p.manufacturers_id = m.manufacturers_id, products_to_categories p2c left join categories_description cd on p2c.categories_id = cd.categories_id left join specials s on p.products_id = s.products_id where p.products_status = '1' and p.products_id = p2c.products_id and pd.products_id = p2c.products_id and pd.language_id = '1' and cd.language_id = '1' order by cd.categories_name, pd.products_name

 

[TEP STOP]

I understand from a google search that this is probably caused by an upgrade on my mysqul database. I was checking with them to see when they upgraded and the tech support was pretty clueless "we'll get back to you." 2 days later no word. My current version is MySQL 5.0.45.

 

I assume I need to change a reference in the code regarding the p.products column somewhere. Any specifics would be greatly appreciated.

Share this post


Link to post
Share on other sites
I had the printable catalog working fine a few months ago and just went into it again and am now getting this message...

1054 - Unknown column 'p.products_id' in 'on clause'

 

select distinct p.products_id, p.products_image, p.products_model, p.products_quantity, p.products_weight, pd.products_name, p.manufacturers_id, p.products_price, p.products_date_added, IF(s.status, s.specials_new_products_price, NULL) as specials_new_products_price, IF(s.status, s.specials_new_products_price, p.products_price) as final_price, m.manufacturers_name, pd.products_description, cd.categories_name, p.products_tax_class_id, p2c.categories_id from products_description pd, products p left join manufacturers m on p.manufacturers_id = m.manufacturers_id, products_to_categories p2c left join categories_description cd on p2c.categories_id = cd.categories_id left join specials s on p.products_id = s.products_id where p.products_status = '1' and p.products_id = p2c.products_id and pd.products_id = p2c.products_id and pd.language_id = '1' and cd.language_id = '1' order by cd.categories_name, pd.products_name

 

[TEP STOP]

I understand from a google search that this is probably caused by an upgrade on my mysqul database. I was checking with them to see when they upgraded and the tech support was pretty clueless "we'll get back to you." 2 days later no word. My current version is MySQL 5.0.45.

 

I assume I need to change a reference in the code regarding the p.products column somewhere. Any specifics would be greatly appreciated.

 

 

Solved this with the new files in the Nov 2007 update.

http://addons.oscommerce.com/info/1410

catalog_products_with_images.php

catalog_products_with_images_full.php

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×