Jump to content
Sign in to follow this  
BirdBrain

JUST RELEASED! Printable Catalog

Recommended Posts

Hi

I'm installing the mod, but when I upload information.php the entire right side of my store disappers.

My categories and top is still there , but nothing else.

 

Anyone knows what I'm doing wrong.

Share this post


Link to post
Share on other sites

This mod seems great, but I have one question. Is there anyway you can print it out according to catagory or sub categories? It seems that it prints out in alphabetical order. Being able to specify which categories to print or what order to print them would be great.

 

Thanks.

Shawn

Share this post


Link to post
Share on other sites

Let me say.. this contrib is exactly what I needed. Thank you, thank you, thank you!

 

But, did we ever figure out how to break it up into several pages, or defining how many items per page? I have thousands of products, and my customers (especially those on 56k modem) are having to wait a very long time for the page to load, if they even get to the end of the load before their computer locks up!

 

Any help would be greatly appreciated. Thanks in advance!

Share this post


Link to post
Share on other sites

Hi,

 

I have installed this contribution, excellent one might i add!

 

Just have a question, is there a way i can get the display to show only the picture, price and description?

 

I.E. leave out the manufacturers etc.????

 

Cheers,

Dave.

Share this post


Link to post
Share on other sites

Thanks for the contribution. I'm just wondering where the print_catalog.php page pulls the "welcome in your [store name] shop"??

Share this post


Link to post
Share on other sites

Dave,

 

In catalog/print_catalog.php delete the reference to "manufacturer' "date added" etc. then go into catalog/english/print_catalog.php and delete the text between the quote marks relating to manufacturer, added to the catalog, etc.

 

That should do it for you.

 

I still can't work out where it pulls "welcome in" from. Also, is there any way to set the layout so that it is printer friendly - my description keeps going off the side of the paper.

Share this post


Link to post
Share on other sites

I just installed the mod and I am having the same problem as Quin is. My info is:

I'm not a php guru, but I am certain I installed everything very very carefully. Any ideas?

 

When i click on the printable catalog i get an error like all the others I'm using Printable Catalog v3.4 with oscmax 2:

 

1064 - You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near '-10, 10' at line 1 

select distinct p.products_id, p.products_image, p.products_model, p.products_quantity, p.products_weight, pd.products_name, p.manufacturers_id, p.products_price, p.products_date_added, IF(s.status, s.specials_new_products_price, NULL) as specials_new_products_price, IF(s.status, s.specials_new_products_price, p.products_price) as final_price, m.manufacturers_name, pd.products_description, cd.categories_name, p.products_tax_class_id, p2c.categories_id from products_description pd, products p left join manufacturers m on p.manufacturers_id = m.manufacturers_id, products_to_categories p2c left join categories_description cd on p2c.categories_id = cd.categories_id left join specials s on p.products_id = s.products_id where p.products_status = '1' and p.products_id = p2c.products_id and pd.products_id = p2c.products_id and pd.language_id = '1' and cd.language_id = '1' order by p.products_price DESC, pd.products_name LIMIT -10, 10 

[TEP STOP]

Has anyone fond the cause of the problem, i have products, and removed all (' ). Pleae help... :rolleyes:

 

Share this post


Link to post
Share on other sites
Doh - stupid mistake on my part.

 

open catalog/includes/modules/print_catalog.php

 

find

 

Hey Lewis,

 

I was hoping this was my problem too, but no such luck...

 

I'm getting no images at all, though everything else seems fine

 

Any help would be most appreciated. If it helps, the site is located: http://www.marjsquiltfabrics.com/eCatalog/catalog/

 

Thanks!

Lou

Share this post


Link to post
Share on other sites
Doh - stupid mistake on my part.

 

open catalog/includes/modules/print_catalog.php

 

Hey again, Lewis,

 

Just to make sure I wasn't doing something incredibly stupid, which is well within the realm of possibility, I tried the contrib on a second site with the same result of no images.

 

http://www.wintertreeshoppe.com/eCatalog/

 

Thanks!

Lou

Share this post


Link to post
Share on other sites

Thank you for this great contribution

 

My question is:

 

Is there any way to get the same for every product separate? not need to show all catalog but for every product I want to make a printable format with image and description...

 

Thank you again :thumbsup:

Share this post


Link to post
Share on other sites

Hi.. I have installed this and have same problems as others earlier that the page comes out BLANK. I wasn't able to see any replies as to how to fix this issue.

 

any help would be much appreciated.

 

the store is located at http://scrapmode.com/osc/catalog/ and printable catalog is linked on lower right side of the page.

 

thanks

Share this post


Link to post
Share on other sites

I still can't figure out why this add-on outputs blank page.. Could someone please please help me resolve this?

 

 

thanks

Share this post


Link to post
Share on other sites
Hi.. I have installed this and have same problems as others earlier that the page comes out BLANK.

 

Finally this issue is resolved thanks to Tom St.Croix who did the contribution. He was kind enough to trouble shoot my problem and realize that it was caused by STS template system..

He pointed the printable catalog php file to point to default files header.php footer.php application_top.php and application_bottom.php before the STS mod was installed

 

You could see a demo of the fixed files on http://www.scrapmode.com/osc/catalog/catal...images_full.php

 

Thanks for a great job Tom!

Share this post


Link to post
Share on other sites
Finally this issue is resolved thanks to Tom St.Croix who did the contribution. He was kind enough to trouble shoot my problem and realize that it was caused by STS template system..

He pointed the printable catalog php file to point to default files header.php footer.php application_top.php and application_bottom.php before the STS mod was installed

 

You could see a demo of the fixed files on http://www.scrapmode.com/osc/catalog/catal...images_full.php

 

Thanks for a great job Tom!

 

 

Hi,

 

I am going crazy. I apologize by I do not understand what do you mean by the above statement. I have them same exact problem using the STS template system and desprately need this issues resolved. Is it possible to post how tio fix this problem.

 

Thanks a great deal

Share this post


Link to post
Share on other sites

Great contribution!

 

I have a different challenge than most!

 

The good thing is that mine is working! with no problems

 

I have installed another contributopn (three pics in admin) which gives you three pics per product :P

 

I have managed to code this contribution so it gives me the three pictures. But some of my products only have 1 or 2 pictures. How do I stop the square box with the cross when no picture os present??

 

Also the pricing doesn't pull the sale price (contribution=salemaker) into the print catalog? it keeps the original price! any ideas on the coding for this??

 

Cheers

Dave

Share this post


Link to post
Share on other sites
Great contribution!

 

I have a different challenge than most!

 

The good thing is that mine is working! with no problems

 

I have installed another contributopn (three pics in admin) which gives you three pics per product :P

 

I have managed to code this contribution so it gives me the three pictures. But some of my products only have 1 or 2 pictures. How do I stop the square box with the cross when no picture os present??

 

Also the pricing doesn't pull the sale price (contribution=salemaker) into the print catalog? it keeps the original price! any ideas on the coding for this??

 

Cheers

Dave

 

BUMP

:P

Share this post


Link to post
Share on other sites

I'm thrilled to have found this contribution, it is VERY nice, but I have a problem, and after reading through this thread, I don't see a solution, so I am hoping someone might be reading through here that can help.

 

In the coding I changed the default URL for the images from the Rock store to my own store, thinking that would allow my images to appear. They are still not there. Can anyone help me figure out why my images are not showing up?

 

How might I delete the word MANUFACTURER from the product list on the printable catalog?

 

Thank you!

Jewls

Share this post


Link to post
Share on other sites

I should have searched this out further before posting, but for anyone else who is struggling with this, I found the solution, at least for me.

 

I had to create the IMAGES folder just inside my public_html folder (which is the root). The coding wanted to read the images folder like this: www.mydomain.com/images I hadn't realized it.

 

Jewls

 

I'm thrilled to have found this contribution, it is VERY nice, but I have a problem, and after reading through this thread, I don't see a solution, so I am hoping someone might be reading through here that can help.

 

In the coding I changed the default URL for the images from the Rock store to my own store, thinking that would allow my images to appear. They are still not there. Can anyone help me figure out why my images are not showing up?

 

How might I delete the word MANUFACTURER from the product list on the printable catalog?

 

Thank you!

Jewls

Share this post


Link to post
Share on other sites

I uploaded all the files but, for some reason I get this message: (what did I do wrong??)

 

 

Internal Server Error

The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator, webmaster@xxx.com and inform them of the time the error occurred, and anything you might have done that may have caused the error.

 

More information about this error may be available in the server error log.

 

 

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.

Share this post


Link to post
Share on other sites
I am going crazy. I apologize by I do not understand what do you mean by the above statement. I have them same exact problem using the STS template system and desprately need this issues resolved. Is it possible to post how tio fix this problem.

 

Hi, I have the same problem. I'm using STS and my catalog does not show any products at all. Can somebody please post the code corrections needed for STS template users to make this show?

 

Thank you:-)

Kjolebutikken


Best regards

Kjolebutikken

Share this post


Link to post
Share on other sites
Hey Lewis,

 

I was hoping this was my problem too, but no such luck...

 

I'm getting no images at all, though everything else seems fine

 

Any help would be most appreciated. If it helps, the site is located: http://www.marjsquiltfabrics.com/eCatalog/catalog/

 

Thanks!

Lou

 

I had a similar problem. Fixed it by pointing the url to the directory where my images are. For example if your images were uploaded to /catalog/images, then the url would be http://www.yourdomain.com/osCommerce/catalog/images.

 

Images came right up!

Share this post


Link to post
Share on other sites

Here is the fix that Tom helped me with.. I have zipped it up and you can download it from http://ftagurus.com/printablecat_fix.zip put the 2 catalog_product files in the catalog directory and the other files in the "includes" directory. Let me know if it works.

 

Thanks

H.

 

Hi,

 

I am going crazy. I apologize by I do not understand what do you mean by the above statement. I have them same exact problem using the STS template system and desprately need this issues resolved. Is it possible to post how tio fix this problem.

 

Thanks a great deal

Share this post


Link to post
Share on other sites
Here is the fix that Tom helped me with.. I have zipped it up and you can download it from http://ftagurus.com/printablecat_fix.zip put the 2 catalog_product files in the catalog directory and the other files in the "includes" directory. Let me know if it works.

 

Thanks

H.

 

Hi again Hooman. Thanks for the fix. Now I can see the products catalog.

 

I have encountered some problems that I need to solve though. Wonder if you had some of the same:-)

 

1. The links I have added in the header navigation bar require the files includes/sts_display_output.php and includes/sts_template.html. because the all callsto sts is removed in the new files, these will not show. Only the standard links (my account, checkout and shoppingcart) shows. I need to find a way tomake them show, or make new ones for this one page.

 

2. In my shop I have a image carousel in my header. The code for this is in includes/sts_template.htm. This would not show on the products catalog page. I fixed this with adding the code for the carousel in includes/header1.php. This worked.

 

3. For some reason I have now a second headbar, above my headernavigation bar with the links. I have to find a solution for removing this. This is now on all pages in my shop.

 

4. I thought that the text size for the table was too big and I want to reduce it. I managed to reduce the size of the tableheading text in stylesheet.css, but not for the text in the table itselves. I think this might be in html and that that is the reason. I need to find a way to reduce the size of this text.

 

Hope you or someone else can help me a little here.

 

Thanks for the help so far:-)

 

Kjolebutikken


Best regards

Kjolebutikken

Share this post


Link to post
Share on other sites

Anyone know which files are used to put in the 'Store name', 'Address', 'Country', and 'Phone'? My catalog looks great but the left portion of the header says exactly that:

 

Store Name

Address

Country

Phone

 

I've looked at some of the obivous files (english.php, filenames, php, etc), but can't figure out how to fix this to insert my store information.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×