Jump to content

Archived

This topic is now archived and is closed to further replies.

darrenultra

Shared SSL with 1and1 - I'm going crazy!

Recommended Posts

Plug this into application_top.php

 

$request_type = (getenv('HTTP_X_FORWARDED_SERVER') == 'sslrelay.com') ? 'SSL' : 'NONSSL';


If I suggest you edit any file(s) make a backup first - I'm not perfect and neither are you.

 

"Given enough impetus a parallelogramatically shaped projectile can egress a circular orifice."

- Me -

 

"Headers already sent" - The definitive help

 

"Cannot redeclare ..." - How to find/fix it

 

SSL Implementation Help

 

Like this post? "Like" it again over there >

Share this post


Link to post
Share on other sites

OK problem solved. The reason shared ssl wasn't working was, embarrassingly, all to do with permissions.

 

I have developed the whole site on my local server (WAMP) and have only recently put it online and tried to set SSL up. It would appear that the permission settings of some of my files - most notably my configure.php - were stopping them from being updated with my changes.

 

Shared SSL is now working fine.

 

Thanks to everyone who tried to solve this problem for me.

Share this post


Link to post
Share on other sites

×