Jump to content
Latest News: (loading..)
Sign in to follow this  
burt

DC GV RC1 RC2 RC2a

Recommended Posts

Looks like you may be missing some PHP tags when you added the link.

 

Post the line where you added the link, and maybe a dozen lines on each side for good measure.

:)


If I suggest you edit any file(s) make a backup first - I'm not perfect and neither are you.

 

"Given enough impetus a parallelogramatically shaped projectile can egress a circular orifice."

- Me -

 

"Headers already sent" - The definitive help

 

"Cannot redeclare ..." - How to find/fix it

 

SSL Implementation Help

 

Like this post? "Like" it again over there >

Share this post


Link to post
Share on other sites

I already covered this at least 5 times in the past on the proper support channel.


This is a signature that appears on all my posts.  
IF YOU MAKE A POST REQUESTING HELP...please state the exact version
of osCommerce that you are using. THANKS

 
Get the latest current code (community-supported responsive 2.3.4.1BS Edge) here

 

Share this post


Link to post
Share on other sites

which of the admin files did you want me to post? :)

 

boxes - customers

functions - general

database tables

filenames

language - english

 

sorry to be a PITA :)

 

thanks jim

Edited by silkvixen

Share this post


Link to post
Share on other sites

If you can't find what Burt is referring to, reread my last post.


If I suggest you edit any file(s) make a backup first - I'm not perfect and neither are you.

 

"Given enough impetus a parallelogramatically shaped projectile can egress a circular orifice."

- Me -

 

"Headers already sent" - The definitive help

 

"Cannot redeclare ..." - How to find/fix it

 

SSL Implementation Help

 

Like this post? "Like" it again over there >

Share this post


Link to post
Share on other sites

?>
<!-- customers //-->
         <tr>
           <td>
<?php
 $heading = array();
 $contents = array();

 $heading[] = array('text'  => BOX_HEADING_CUSTOMERS,
                    'link'  => tep_href_link(FILENAME_CUSTOMERS, 'selected_box=customers'));

 if ($selected_box == 'customers') {
   $contents[] = array('text'  => '<a href="' . tep_href_link(FILENAME_CUSTOMERS, '', 'NONSSL') . '" class="menuBoxContentLink">' . BOX_CUSTOMERS_CUSTOMERS . '</a><br>' .
                                  '<a href="' . tep_href_link(FILENAME_CUSTOMERS_POINTS, '', 'NONSSL') . '" class="menuBoxContentLink">' . BOX_CUSTOMERS_POINTS . '</a><br />' .// Points/Rewards Module V2.1rc2a
                                  '<a href="' . tep_href_link(FILENAME_CUSTOMERS_POINTS_PENDING, '', 'NONSSL') . '" class="menuBoxContentLink">' . BOX_CUSTOMERS_POINTS_PENDING . '</a><br />' .// Points/Rewards Module V2.1rc2a
                                  '<a href="' . tep_href_link(FILENAME_CUSTOMERS_POINTS_REFERRAL, '', 'NONSSL') . '" class="menuBoxContentLink">' . BOX_CUSTOMERS_POINTS_REFERRAL . '</a><br />' .// Points/Rewards Module V2.1rc2a
                                  '<a href="' . tep_href_link(FILENAME_ORDERS, '', 'NONSSL') . '" class="menuBoxContentLink">' . BOX_CUSTOMERS_ORDERS . '</a>');
 }

 $box = new box;
 echo $box->menuBox($heading, $contents);


?>
'<a href="' . tep_href_link(FILENAME_COUPONS) . '" class="menuBoxContentLink">' . BOX_TOOLS_COUPONS . '</a>' .
           </td>
         </tr>
<!-- customers_eof //-->

 

 

 

thanks again jim. Sorry Burt i couldnt find it in the other forum

Share this post


Link to post
Share on other sites

Wrong file.

 

in the admin i have the tool box coupons section in the side menu but when i click on that it comes up with page not found:

I need the file you added the link to that's giving you problems.

 

That's what I originally asked for.


If I suggest you edit any file(s) make a backup first - I'm not perfect and neither are you.

 

"Given enough impetus a parallelogramatically shaped projectile can egress a circular orifice."

- Me -

 

"Headers already sent" - The definitive help

 

"Cannot redeclare ..." - How to find/fix it

 

SSL Implementation Help

 

Like this post? "Like" it again over there >

Share this post


Link to post
Share on other sites

this is from the admin/includes/filename

 

define('FILENAME_TAX_RATES', 'tax_rates.php');

define('FILENAME_WHOS_ONLINE', 'whos_online.php');

define('FILENAME_ZONES', 'zones.php');

//Options as Images

define ('FILENAME_OPTIONS_IMAGES', 'options_images.php');

define('FILENAME_COUPONS', 'coupons.php');

 

?>

admin/includes/functions/general

 

// make sure no duplicate category IDs exist which could lock the server in a loop

$tmp_array = array();

$n = sizeof($cPath_array);

for ($i=0; $i<$n; $i++) {

if (!in_array($cPath_array[$i], $tmp_array)) {

$tmp_array[] = $cPath_array[$i];

}

}

 

return $tmp_array;

}

function tep_set_coupon_status($coupon_id, $status) {

if ($status == '1') {

return tep_db_query("update " . TABLE_COUPONS . " set coupon_status = '1' where coupon_id = '" . $coupon_id . "'");

} elseif ($status == '0') {

return tep_db_query("update " . TABLE_COUPONS . " set coupon_status = '0' where coupon_id = '" . $coupon_id . "'");

} else {

return -1;

}

}

 

 

function tep_get_coupon_type($coupon_type_id) {

if ($coupon_type_id == '1') {

return ENTRY_FIXED;

} else {

return ENTRY_PERCENT;

}

}

 

function tep_get_coupon_use($coupon_use_id) {

if ($coupon_use_id == '1') {

return ENTRY_MULTI;

} else {

return ENTRY_ONCE;

}

}

 

?>

 

admin/languages/english

 

//Options as Images

define('BOX_CATALOG_OPTIONS_IMAGES', 'Options as Images');

define('BOX_TOOLS_COUPONS', 'Coupons');

define('TEXT_DISPLAY_NUMBER_OF_COUPONS', 'Displaying <b>%d</b> to <b>%d</b> (of <b>%d</b> coupons)');

 

 

?>

 

 

 

alot of whats inserted is only 1 line and unless stated in the instructions doesnt tell you where to put it so i have just been putting it at the bottom of the files

Share this post


Link to post
Share on other sites

That aint it neither.

 

Until you can find the file with the link that you added that doesn't work, and post the code from it, I can't help.


If I suggest you edit any file(s) make a backup first - I'm not perfect and neither are you.

 

"Given enough impetus a parallelogramatically shaped projectile can egress a circular orifice."

- Me -

 

"Headers already sent" - The definitive help

 

"Cannot redeclare ..." - How to find/fix it

 

SSL Implementation Help

 

Like this post? "Like" it again over there >

Share this post


Link to post
Share on other sites

the only ther 2 files that were with it that had to be added were 2 coupon.php files and that was it for the admin side the rest are on the catlog side......i might just delete it all and try again....again lol

 

now i just have to figure out how to delete the SQL file off my server lol

Share this post


Link to post
Share on other sites

I have installed this mod and works fine. I´d be interested on having the coupon prompt at the shopping cart, instead of the checkout_payment.php, with some submit button so the customers know the discount applied already, before placing the order. I´m not a programmer, so if someone could throw me some lights on this would be highly appreciated.

 

Thanks!

Share this post


Link to post
Share on other sites

The commercial version of this script moves the coupon input box from the checkout_payment into the shopping_cart


This is a signature that appears on all my posts.  
IF YOU MAKE A POST REQUESTING HELP...please state the exact version
of osCommerce that you are using. THANKS

 
Get the latest current code (community-supported responsive 2.3.4.1BS Edge) here

 

Share this post


Link to post
Share on other sites

Just been looking at this script, and it seem sot work quite well except if you have a coupon with a greater value than the shopping cart and shipping costs you end up with a negative total and it still tries to take payment. But that shouldnt be too hard to track down.

Share this post


Link to post
Share on other sites

is there any what I can add a start and expiry date?

 

I have changed the files and Im not sure if I can use the Discount Coupon Codes contribute.

 

I've been trying to install this module on my site with OSC RC2 v2.2. It doesn't seem to be an exact fit but I think I've done about the best I can. It all seems to be working on the admin side but no sign of it shows up in the checkout. Where do I need to focus to sort this out?

 

Thanks!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×