Jump to content
Sign in to follow this  
zero41

Authorize.net AIM 1.0 on Godaddy

Recommended Posts

I'm trying to get AIM 1.0 to work on a site hosted by Godaddy on a shared server. I know that you need to add the cURL proxy info into the authorizenet_cc_aim.php for godaddy hosting, but I'm not sure where to add it and exactly what the code should be. The code I am trying to use is:

curl_setopt($curl, CURLOPT_HTTPPROXYTUNNEL, TRUE);
curl_setopt($curl, CURLOPT_PROXYTYPE, CURLPROXY_HTTP);
curl_setopt($curl, CURLOPT_PROXY, "http://proxy.shr.secureserver.net:3128");

 

That seems to do a lot better than not having it. I changed the $ch to $curl and inserted the 3 lines above into the authorizenet_cc_aim.php at line 341 just below:

      if (function_exists('curl_init')) {                                     
       $curl = curl_init($server['scheme'] . '://' . $server['host'] . $server['path'] . (isset($server['query']) ? '?' . $server['query'] : ''));.....

 

I am running AIM in test mode and all I get back is that there was an error processing my credit card. Any ideas? Also, the AIM module wants to know the curl program location. Does anyone know this for godaddy?

 

Thanks a million!

Share this post


Link to post
Share on other sites
I'm trying to get AIM 1.0 to work on a site hosted by Godaddy on a shared server. I know that you need to add the cURL proxy info into the authorizenet_cc_aim.php for godaddy hosting, but I'm not sure where to add it and exactly what the code should be. The code I am trying to use is:

curl_setopt($curl, CURLOPT_HTTPPROXYTUNNEL, TRUE);
curl_setopt($curl, CURLOPT_PROXYTYPE, CURLPROXY_HTTP);
curl_setopt($curl, CURLOPT_PROXY, "http://proxy.shr.secureserver.net:3128");

 

That seems to do a lot better than not having it. I changed the $ch to $curl and inserted the 3 lines above into the authorizenet_cc_aim.php at line 341 just below:

      if (function_exists('curl_init')) {                                     
       $curl = curl_init($server['scheme'] . '://' . $server['host'] . $server['path'] . (isset($server['query']) ? '?' . $server['query'] : ''));.....

 

I am running AIM in test mode and all I get back is that there was an error processing my credit card. Any ideas? Also, the AIM module wants to know the curl program location. Does anyone know this for godaddy?

 

Thanks a million!

 

 

First - thank YOU for listing the code above to add to authorizenet_cc_aim.php, I've been searching the forums for two days now and this did the trick!

Second - to answer your question about the curl program location & goDaddy - I changed the default location from "/usr/bin/curl" to just "curl" and my transactions are now processing correctly. Hope this helps!!

 

~Ruthanna Birchfield

goCoursing.com

Share this post


Link to post
Share on other sites
I'm trying to get AIM 1.0 to work on a site hosted by Godaddy on a shared server. I know that you need to add the cURL proxy info into the authorizenet_cc_aim.php for godaddy hosting, but I'm not sure where to add it and exactly what the code should be. The code I am trying to use is:

curl_setopt($curl, CURLOPT_HTTPPROXYTUNNEL, TRUE);
curl_setopt($curl, CURLOPT_PROXYTYPE, CURLPROXY_HTTP);
curl_setopt($curl, CURLOPT_PROXY, "http://proxy.shr.secureserver.net:3128");

 

That seems to do a lot better than not having it. I changed the $ch to $curl and inserted the 3 lines above into the authorizenet_cc_aim.php at line 341 just below:

      if (function_exists('curl_init')) {                                     
       $curl = curl_init($server['scheme'] . '://' . $server['host'] . $server['path'] . (isset($server['query']) ? '?' . $server['query'] : ''));.....

 

I am running AIM in test mode and all I get back is that there was an error processing my credit card. Any ideas? Also, the AIM module wants to know the curl program location. Does anyone know this for godaddy?

 

Thanks a million!

 

All I can say is thank you! Thank You! Thank You!............. I've been messing with authorize.net for 2 weeks now and after adding this code and making the update to the curl location, it works great. Again, THANK YOU! I'm going to put together a simple guide to help others out in the future with the GoDaddy nightmares. If I knew then what I know now, I would have never used GoDaddy as a host.

Share this post


Link to post
Share on other sites
All I can say is thank you! Thank You! Thank You!............. I've been messing with authorize.net for 2 weeks now and after adding this code and making the update to the curl location, it works great. Again, THANK YOU! I'm going to put together a simple guide to help others out in the future with the GoDaddy nightmares. If I knew then what I know now, I would have never used GoDaddy as a host.

 

i tried both of the answers here (the code, and the curl in the path box) and before i did those, it would just time out and go page cannot be displayed. now it actually loads but gives me:

There has been an error processing your credit card

Please try again and if problems persist, please try another payment method.

 

test mode, live mode, real CC #, test CC #...nothing really works except putting it on check/money order LOL which is not an option.

 

I wanna die--i can't believe this isn't already working. This is my 3rd OSC install and none of them have problems cept this one.

Share this post


Link to post
Share on other sites

Where are the defines for CURLPROXY_HTTP etc - I do not have it- can someone help suggest what it's value should be and where to place it

 

Thanks

 

George

Edited by nettravel99

Share this post


Link to post
Share on other sites
Where are the defines for CURLPROXY_HTTP etc - I do not have it- can someone help suggest what it's value should be and where to place it

 

Thanks

 

George

 

 

Yes, I need this too!

 

I need to figure out where to place this, who said they're going to make a guide?

 

Please!

Share this post


Link to post
Share on other sites
CURLOPT_PROXYTYPE Either CURLPROXY_HTTP (default) or CURLPROXY_SOCKS5 .

 

It's a PHP constant. It's not a osCommerce-defined value.

Edited by collink

Share this post


Link to post
Share on other sites

You guys are lifesavers!!! Thanks so much fellas, this now works flawlessly. Ponce should a include this information in the pdf that comes with the contribution.

 

It it wasn't for you guys, I would be using the less secure authorize.net contribution (i.e. no hash, or the extra cc #) and I would have to pay my merchant 5 cents and 1% more than normal.

 

AWESOME!!

 

GoDaddy sucks, but they are cheap.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×