Jump to content
Sign in to follow this  
FWR Media

[Contribution] Independent SEO URL Validation

Recommended Posts

Ok look this isn't a validation issue so please take this post to the SEO URL support topic.

 

The fact that you have modified the file though takes it out of the realms of "support".

Share this post


Link to post
Share on other sites
Ok look this isn't a validation issue so please take this post to the SEO URL support topic.

 

The fact that you have modified the file though takes it out of the realms of "support".

The Sql statements was just changed to it's full form, in order to update the database with the neccessary SEO entries, since the form it was originally in, failed to update the database.

Share this post


Link to post
Share on other sites
The Sql statements was just changed to it's full form, in order to update the database with the neccessary SEO entries, since the form it was originally in, failed to update the database.

I resolved this issue.

 

Basically I ran a compare on admin/categories.php (beyond compare), and noticed that with the implementation of the SEO Header Tags contrib certain seo_url entries were overwritten. I also upgraded to 2.1d admin settings for products and categories.

 

Seo Validation now works perfectly as well.

 

Regards

 

Elroy

Share this post


Link to post
Share on other sites

Hi Robert!

 

Thank you very much for this contribution!

 

My website was removed from Google results because of "301 - too many redirects" problem, I am sure that it will return to normal after your contribution.

 

I installed it and the contrib is working as it should.

 

Now I will wait and see.

 

Thanks!

 

Best Regards

Share this post


Link to post
Share on other sites
Hi Robert!

 

Thank you very much for this contribution!

 

My website was removed from Google results because of "301 - too many redirects" problem, I am sure that it will return to normal after your contribution.

 

I installed it and the contrib is working as it should.

 

Now I will wait and see.

 

Thanks!

 

Best Regards

 

Hi There,

 

I am still getting the 301 - too many redirects from Google Webmasters Sitemaps.

 

Using:

- // Ultimate SEO URLs v2.1

if (SEO_ENABLED == 'true' or (SEO_ENABLED != 'true' and SEO_ENABLED != 'false')) {

include_once(DIR_WS_CLASSES . 'seo.class.php');

 

- Google XML Sitemap Feed Cron Script

 

- Independent SEO URL Validation (for ULTIMATE SEO URLs)

 

The contribs are working fine, but Google doesnt like it.

 

The sitemap links are all like the original oscommerce without the Ultimate SEO contrib.

 

I disabled the option on Admin/Configuration/SEO URLs:

Enable automatic redirects

 

But this is not the ideal solution because Google will index the pages using the original urls.

 

Any suggestion?

 

Thansk in advance.

Share this post


Link to post
Share on other sites
The contribs are working fine, but Google doesnt like it.

 

The sitemap links are all like the original oscommerce without the Ultimate SEO contrib.

 

You can't do this.

 

You are providing Google with a bunch of old osc links .. when Google visits it is redirected to the SEO URL for every single one.

 

Dump the sitemap as it is badly coded (it should be using tep_href_link). There are plenty of well coded sitemaps in contributions.

Share this post


Link to post
Share on other sites

I believed that i solved my 301 X Google problem:

 

I installed the following contrib that generate sitemap using the ultimate SEO links:

 

Google Sitemap Generator for MS2

http://addons.oscommerce.com/info/3226

version: 27 May 2008

 

Is in french :/ . Google Translator helped a lot.

 

I will wait to see the google behavior.

Share this post


Link to post
Share on other sites
I believed that i solved my 301 X Google problem:

 

I installed the following contrib that generate sitemap using the ultimate SEO links:

 

Google Sitemap Generator for MS2

http://addons.oscommerce.com/info/3226

version: 27 May 2008

 

Is in french :/ . Google Translator helped a lot.

 

I will wait to see the google behavior.

 

Dynamic sitemap v1.6 I think is a pretty good bet

 

http://addons.oscommerce.com/info/3306

Share this post


Link to post
Share on other sites

Howdy everyone,

 

After a couple of hours installing this contrib and reading this thread, I have to say that it seems to be working great, but I have 3 comments to make:

 

- validation_installer.php has hardcoded the table names. That should not be a problem with 99.9% of OSC stores, but some of us have different names on our tables. I share my database with several stores, so my tables have a prefix to make them different. On my test store my configuration table is "tr_configuration" and not "configuration", so I had to change that.

It is strange that in some places we have FROM `configuration_group` and in others FROM `".TABLE_CONFIGURATION_GROUP."`, it would be better if everywhere on validation_installer.php was using the information from database_tables.php

 

- I have seen several people in this thread asking how to use their current error 404 page. I have tried the 2-3 ways of doing it that have been posted here, and none of them seemed to work for me. It is not such a big deal, but I have a customized error page with logging that tells me what page the visitor was coming from and where they were going to: http://www.twistedtienda.com/non_existing_page.html

But with this contrib with the wrong product URLs I will get the included 404 page: http://www.twistedtienda.com/non_existing_...uct-p-9999.html

Is there any easy way to make the wrong products show the default 404 error page?

 

- Last, I use the following page to check out the returned headers on my pages: http://oyoy.eu/page/headers/

When I go to http://www.twistedtienda.com/non_existing_...uct-p-9999.html the error code is ok, 404.

When I go to a real product like http://www.twistedtienda.com/kit-camaras-c...leto-p-247.html, I get a 200 code, OK.

But, when I go to a real product with a wrong URL, like http://www.twistedtienda.com/wrong-name-p-247.html, I get a 301 that redirects that URL to the right one, but with an attached osCsid.

http://www.twistedtienda.com/kit-camaras-c...8593f2da05cfc0a

Won't this be a problem for GoogleBot, which will index with osCsid? Or since I have "prevent spider sessions" set to true on my config, I am only seeing this osCsid because the web page I am using for checking it, but GoogleBot will not see the osCsid on the redirected page? I wouldn't like GoogleBot indexing my pages with osCsid on the URL.

 

Many thanks, great work Robert!


MindTwist of Twisted Reality and Twisted Tienda

Share this post


Link to post
Share on other sites
Howdy everyone,

 

After a couple of hours installing this contrib and reading this thread, I have to say that it seems to be working great, but I have 3 comments to make:

 

- validation_installer.php has hardcoded the table names. That should not be a problem with 99.9% of OSC stores, but some of us have different names on our tables. I share my database with several stores, so my tables have a prefix to make them different. On my test store my configuration table is "tr_configuration" and not "configuration", so I had to change that.

It is strange that in some places we have FROM `configuration_group` and in others FROM `".TABLE_CONFIGURATION_GROUP."`, it would be better if everywhere on validation_installer.php was using the information from database_tables.php

 

- I have seen several people in this thread asking how to use their current error 404 page. I have tried the 2-3 ways of doing it that have been posted here, and none of them seemed to work for me. It is not such a big deal, but I have a customized error page with logging that tells me what page the visitor was coming from and where they were going to: http://www.twistedtienda.com/non_existing_page.html

But with this contrib with the wrong product URLs I will get the included 404 page: http://www.twistedtienda.com/non_existing_...uct-p-9999.html

Is there any easy way to make the wrong products show the default 404 error page?

 

- Last, I use the following page to check out the returned headers on my pages: http://oyoy.eu/page/headers/

When I go to http://www.twistedtienda.com/non_existing_...uct-p-9999.html the error code is ok, 404.

When I go to a real product like http://www.twistedtienda.com/kit-camaras-c...leto-p-247.html, I get a 200 code, OK.

But, when I go to a real product with a wrong URL, like http://www.twistedtienda.com/wrong-name-p-247.html, I get a 301 that redirects that URL to the right one, but with an attached osCsid.

http://www.twistedtienda.com/kit-camaras-c...8593f2da05cfc0a

Won't this be a problem for GoogleBot, which will index with osCsid? Or since I have "prevent spider sessions" set to true on my config, I am only seeing this osCsid because the web page I am using for checking it, but GoogleBot will not see the osCsid on the redirected page? I wouldn't like GoogleBot indexing my pages with osCsid on the URL.

 

Many thanks, great work Robert!

 

You are quite right about the hardcoded tables, I just haven't bothered to change them as yet tbh.

 

Won't this be a problem for GoogleBot, which will index with osCsid?

 

The osCsid is only there because $spider_flag is false if it were true (a bot) then it would not be there.

Share this post


Link to post
Share on other sites

Re: 404 file you should be able just to replace the function four_o_four_die() with

 

function four_o_four_die() { // 404 then redirect doesn't work as Google records a 302 so we need to die here with a 404
echo
header("HTTP/1.0 404 Not Found") .
include('<PATH>my404file.php');
}

Share this post


Link to post
Share on other sites
The osCsid is only there because $spider_flag is false if it were true (a bot) then it would not be there.

 

I have checked my "who's online" module, and my store sees the connection from http://oyoy.eu/page/headers/ which comes ipcolo1.softplus.net checking out the URL, and it does not recognise it as being a bot. Does any one know how I could check the result codes myself easily? I would like to make sure that GoogleBot will never get to see those osCsids...

Thx! :D


MindTwist of Twisted Reality and Twisted Tienda

Share this post


Link to post
Share on other sites
Re: 404 file you should be able just to replace the function four_o_four_die() with

 

I had already tried that one out, and it doesn't seem to work for me. It will just show me a blank page with no code at all, no source to be seen... :(

I might just integrate my logging code from 404.php into the four_o_four_die function. Hopefully, that 404 integrated error should never be shown anyway.


MindTwist of Twisted Reality and Twisted Tienda

Share this post


Link to post
Share on other sites
I have checked my "who's online" module, and my store sees the connection from http://oyoy.eu/page/headers/ which comes ipcolo1.softplus.net checking out the URL, and it does not recognise it as being a bot. Does any one know how I could check the result codes myself easily? I would like to make sure that GoogleBot will never get to see those osCsids...

Thx! :D

 

oscommerce uses a text file called spiders.txt that is contributed and exhaustively maintained by stevel

 

1) Make sure you have the latest includes/spiders.txt (see contributions)

 

2) if it is not a known bot then it will not be in spiders.txt and therefore will be allocated a session.

 

I suppose you could check the site by momentarily hardcoding $spiders_flag to true in includes/application_top.php but you must to remember to set it back on as no sessions will be possible.

 

You would do it like ..

 

Find ..

 

	if ($spider_flag == false) {
  tep_session_start();
  $session_started = true;
}

 

Replace TEMPORARILY with ..

 

// BOF REMOVE ME I KILL YOUR SHOP
 $spider_flag == true;
// EOF REMOVE ME I KILL YOUR SHOP
  if ($spider_flag == false) {
  tep_session_start();
  $session_started = true;
}

Edited by FWR Media

Share this post


Link to post
Share on other sites

It is not a known bot, it is not even a bot I would say, just some script on a web page that will connect to a given URL and show the returned resultcodes/headers.

 

I did try the trick of forcing $spider_flag == true and then, indeed, the returns are a 301 moved permanently and a new URL that doesn't have an osCsid on it. As GoogleBot should see it, great! :D

 

I have also been able to easily adapt $do_validation to work with my SEOed URLs for the NewsDesk module (-n- for a news item and -nc- for a news category). It was very easy and it works great!

 

All in all, I only have the problem of not knowing how to make it show my default 404 error page, but I won't lose my sleep over that. I put my logging code on four_o_four_die(), so that is enough for me.

 

Great contribution! :D


MindTwist of Twisted Reality and Twisted Tienda

Share this post


Link to post
Share on other sites

Hi folks!

 

I took a look at my Google sitemaps today and noticed a bunch of warning for duplicate metadescriptions and dupliacte title tags.

Google obciously considers as duplicate content pages from the same product viewed with different currencies and called from manufacturers searches...

 

Any way to prevent this with this mod - or with the original Chemo's mod?

 

‎/marius-fabre-200g-olive-oil-soap-cube-p-891.html?currency=AUD‎

‎/marius-fabre-200g-olive-oil-soap-cube-p-891.html?currency=CAD‎

‎/marius-fabre-200g-olive-oil-soap-cube-p-891.html?currency=EUR‎

‎/marius-fabre-200g-olive-oil-soap-cube-p-891.html?currency=JPY‎

‎/marius-fabre-200g-olive-oil-soap-cube-p-891.html?currency=NZD‎

 

 

‎/roger-gallet-bath-soap-in-travel-box-sandalwood-35-oz-p-223.html‎

‎/roger-gallet-bath-soap-in-travel-box-sandalwood-35-oz-p-223.html?manufacturers_id=53‎

 

Thanks

Share this post


Link to post
Share on other sites

I would try to put a Disallow on your robots.txt for *currency* and *manufacturers_id*, might be worth a try

 

You can also try to makeit so everywhere on your store where you have one of those links to make them "nofollow"


MindTwist of Twisted Reality and Twisted Tienda

Share this post


Link to post
Share on other sites
I would try to put a Disallow on your robots.txt for *currency* and *manufacturers_id*, might be worth a try

 

Regex are not allowed in robots.txt files, so I'm afraid that wouldn't work.

 

 

You can also try to makeit so everywhere on your store where you have one of those links to make them "nofollow"

 

This approach might be interesting, by dynamically adding a NOFOLLOW if there is either a currency other than the deafult one or a manufacturer passed i the URL. I will do some research in that direction.

 

thanks!

Share this post


Link to post
Share on other sites
Regex are not allowed in robots.txt files, so I'm afraid that wouldn't work.

 

 

 

 

This approach might be interesting, by dynamically adding a NOFOLLOW if there is either a currency other than the deafult one or a manufacturer passed i the URL. I will do some research in that direction.

 

thanks!

 

There is a thread for this ..

 

http://forums.oscommerce.com/index.php?sho...p;#entry1298423

Share this post


Link to post
Share on other sites
I had already tried that one out, and it doesn't seem to work for me. It will just show me a blank page with no code at all, no source to be seen... :(

I might just integrate my logging code from 404.php into the four_o_four_die function. Hopefully, that 404 integrated error should never be shown anyway.

 

This is the solution :

 

function four_o_four_die() { // 404 then redirect doesn't work as Google records a 302 so we need to die here with a 404
echo
header("HTTP/1.0 404 Not Found") .
include(HTTP_SERVER . DIR_WS_HTTP_CATALOG . 'http_error.php?error_id=404');
exit;
}

for example if you have a customised http error page.

 

Didier.

Share this post


Link to post
Share on other sites
This is the solution :

 

function four_o_four_die() { // 404 then redirect doesn't work as Google records a 302 so we need to die here with a 404
echo
header("HTTP/1.0 404 Not Found") .
include(HTTP_SERVER . DIR_WS_HTTP_CATALOG . 'http_error.php?error_id=404');
exit;
}

for example if you have a customised http error page.

 

Didier.

 

Yup that looks nice Didier.

Share this post


Link to post
Share on other sites
This is the solution :

 

function four_o_four_die() { // 404 then redirect doesn't work as Google records a 302 so we need to die here with a 404
echo
header("HTTP/1.0 404 Not Found") .
include(HTTP_SERVER . DIR_WS_HTTP_CATALOG . 'http_error.php?error_id=404');
exit;
}

for example if you have a customised http error page.

 

This worked great for me, thx! :D


MindTwist of Twisted Reality and Twisted Tienda

Share this post


Link to post
Share on other sites

Having said that it is exactly what I wrote a few posts up.

Share this post


Link to post
Share on other sites

I have added the validation for the 4 faqdesk urls. Here are the 4 lines to add in general.php, fct. tep_validate_seo_urls() :

 

( strpos($_SERVER['REQUEST_URI'], '-fc-') ? ($querytype = 'filename_faqdesk_index-faqPath=' . $HTTP_GET_VARS['faqPath']) : 
( strpos($_SERVER['REQUEST_URI'], '-f-') ? ($querytype = 'filename_faqdesk_info-faqdesk_id=' . $HTTP_GET_VARS['faqdesk_id']) :
( strpos($_SERVER['REQUEST_URI'], '-fri-') ? ($querytype = 'filename_faqdesk_reviews_info-faqdesk_id=' . $HTTP_GET_VARS['faqdesk_id']) :
( strpos($_SERVER['REQUEST_URI'], '-fra-') ? ($querytype = 'filename_faqdesk_reviews_article-faqdesk_id=' . $HTTP_GET_VARS['faqdesk_id']) :

 

You'll have to add 4 extra ")" to the line below..you get the picture.

 

Otherwise the latest version of this contrib works fine with USU 2.5 that is based on 2.1d.

 

Cool & thanks !

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×