Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Sign in to follow this  
ScampNZ

Paymate 1.0

Recommended Posts

I have just installed the payment mod paymate 1.0 - everything went well with the install. The problem I am encountering is when I go to the checkout there is no option for paying via Paymate. When I go to admin, it is installed, it comes up with blurb on the right hand side which I imagine should be showing on the payment method page.

 

Is there anyone who has used this mod and can help me get it working?

Share this post


Link to post
Share on other sites
Guest
I have just installed the payment mod paymate 1.0 - everything went well with the install. The problem I am encountering is when I go to the checkout there is no option for paying via Paymate. When I go to admin, it is installed, it comes up with blurb on the right hand side which I imagine should be showing on the payment method page.

 

Is there anyone who has used this mod and can help me get it working?

Use this one, it is designed by paymate.

Share this post


Link to post
Share on other sites
Guest
thanks it seems to be working much better!

Don't forget that in includes\modules\paymatespi.php that for NZ you should chamge the below

 

if (is_object($order)) $this->update_status();

 

$this->form_action_url = 'https://www.paymate.com.au/PayMate/ExpressPayment'; // for Australian websites

// $this->form_action_url = 'https://www.paymate.com.au/PayMate/GenExpressPayment'; // for New Zealand websites

 

to be

 

if (is_object($order)) $this->update_status();

 

//$this->form_action_url = 'https://www.paymate.com.au/PayMate/ExpressPayment'; // for Australian websites

$this->form_action_url = 'https://www.paymate.com.au/PayMate/GenExpressPayment'; // for New Zealand websites

Edited by Coopco

Share this post


Link to post
Share on other sites
Don't forget that in includes\modules\paymatespi.php that for NZ you should chamge the below

 

if (is_object($order)) $this->update_status();

 

$this->form_action_url = 'https://www.paymate.com.au/PayMate/ExpressPayment'; // for Australian websites

// $this->form_action_url = 'https://www.paymate.com.au/PayMate/GenExpressPayment'; // for New Zealand websites

 

to be

 

if (is_object($order)) $this->update_status();

 

//$this->form_action_url = 'https://www.paymate.com.au/PayMate/ExpressPayment'; // for Australian websites

$this->form_action_url = 'https://www.paymate.com.au/PayMate/GenExpressPayment'; // for New Zealand websites

 

OMG thank you!!! What amazing timing you have!! I just came on here to look for this answer - I knew it was something with this code and had a feeling I had to remove the localhost:8080 part but wanted to double check before I did anything. Wow thank you for posting that!!

Share this post


Link to post
Share on other sites
Guest
OMG thank you!!! What amazing timing you have!! I just came on here to look for this answer - I knew it was something with this code and had a feeling I had to remove the localhost:8080 part but wanted to double check before I did anything. Wow thank you for posting that!!

No problem, I don't think it was mentioned in the install instructions.

Share this post


Link to post
Share on other sites
No problem, I don't think it was mentioned in the install instructions.

 

No there was nothing in the install instructions :rolleyes:

Share this post


Link to post
Share on other sites

I don't know how you guys got this to work, everytime I tried to add it to my existing website it completely killing my orders page.

Share this post


Link to post
Share on other sites
Guest
I don't know how you guys got this to work, everytime I tried to add it to my existing website it completely killing my orders page.

How is it killing it?

Share this post


Link to post
Share on other sites

Most of the page is was missing, all the order contents and such. I don't know what i did wrong but i tried twice to install it and both times it messed up my website big time.

 

Coopco, is there any chance you know enough about the express module to get it to work with the currencies? It's not switching the way it's meant to, it ALWAYS defaults to AUD and nothing I do changes that. So it'll pass say $40 USD through to Paymate as $40 AUD.

Share this post


Link to post
Share on other sites
Guest
Most of the page is was missing, all the order contents and such. I don't know what i did wrong but i tried twice to install it and both times it messed up my website big time.

 

Coopco, is there any chance you know enough about the express module to get it to work with the currencies? It's not switching the way it's meant to, it ALWAYS defaults to AUD and nothing I do changes that. So it'll pass say $40 USD through to Paymate as $40 AUD.

I think the problem is that it was written when paymate only accepted AUD.

 

Does the module have

$this->form_action_url = 'https://www.paymate.com.au/PayMate/ExpressPayment?mid=withmyoscnameofcoopco';

If it does you need to change it.

 

BTW

I updated the install instuctions, for spi. Email me if you want a copy (noone else did)!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×