Jump to content
Sign in to follow this  
shimonp

eShipper (UPS, Fedex, DHL, Canada Post, Trucking) Integration Module Support Forum

Recommended Posts

Ok so since last week I solved alot my problems. It seems that I didnt load the SQL right when installing it a while back. Now when I do the Export to Eshipper everything is exported to eshipper right, I no longer getting any error message on eshipper export but now I am not getting any information like the Status Order# Destination Service Tracking# . The table loads fine but there is no information in the table eShipper Order#. Also it seems that I am not getting the label either. I have to login to eshippers website in order to get it which is ok for now. Can anyone help. In eshipper admin my Relative path to store shipping labels is set to /ship/. Also I have that directory as read and write I even change the permission to 777 but still nothing.

Share this post


Link to post
Share on other sites
Ok so since last week I solved alot my problems. It seems that I didnt load the SQL right when installing it a while back. Now when I do the Export to Eshipper everything is exported to eshipper right, I no longer getting any error message on eshipper export but now I am not getting any information like the Status Order# Destination Service Tracking# . The table loads fine but there is no information in the table eShipper Order#. Also it seems that I am not getting the label either. I have to login to eshippers website in order to get it which is ok for now. Can anyone help. In eshipper admin my Relative path to store shipping labels is set to /ship/. Also I have that directory as read and write I even change the permission to 777 but still nothing.

 

Hi Qbfinest83,

 

Well today I just got the same problems that you are describing, including the label having FedEx Pri Overnight as well. I had to manually create eshipper/orders_documentation/ with 777 permissions. After that fix I get tep stop could not "update orders set CP_track_num = '123456789012' where orders_id = 1". So I'm smarter than that! I added the column with int(12) and the next thing that happened is the order disappeared off the orders page. Still exists in the database and you can manually alter the URL to see it. Looking back at the doc there is no information about CP_track_num. I canceled the incorrect shipping orders at eShipper and manually created a correct shipping order with UPS ground.

 

This was the first time I used eShipper, someone else has to have had this problem? Any help out there?

 

Thanks!

Share this post


Link to post
Share on other sites
Here's a screenshot of the shipping interface. Each order has a "Ship via eShipper" button regardless of the type of shipping the customer has selected. But it automatically pre-selects the customer's choice in the selection list. The selection list shows the exact price for each shipping method.

 

When ship button is clicked, everything is sent to eShipper and a label is returned & saved

 

Hi Natrium42,

 

I posted a confirmation to a problem another user is having and would be interested in you mod to eShipper as the current workaround is to manually create labels at the eShipper site. Perhaps you can post the mod somewhere we can all have access to it.

 

Thanks!

Share this post


Link to post
Share on other sites
... the next thing that happened is the order disappeared off the orders page. Still exists in the database and you can manually alter the URL to see it.

 

Sorry to post so often, but if I don't note it I won't remember to post it later :)

 

The order reappeared once I inserted "Shipped" to Localization -> Orders Status. Forgot to do that in our production server.

Share this post


Link to post
Share on other sites

I think I'm getting close. Everything seems to work on the Admin side, but when I try to check out on the catalog side I get a blank page when it is supposed to go to the shipping page. Any suggestions?

Share this post


Link to post
Share on other sites
I think I'm getting close. Everything seems to work on the Admin side, but when I try to check out on the catalog side I get a blank page when it is supposed to go to the shipping page. Any suggestions?

Got past the blank page issue but now it's showing "No quotes available for this destination". Is anybody else having this problem? Does anybody have a solution?

Share this post


Link to post
Share on other sites

That's problem with your account. Ask eShipper support to check your account configuration.

 

Shimon

 

Got past the blank page issue but now it's showing "No quotes available for this destination". Is anybody else having this problem? Does anybody have a solution?

Share this post


Link to post
Share on other sites

I notice that when I select UPS I pick ground, third day and Next Day Air, and Saver, however only Next Day and Third day are showing up. Has anyone else had this problem? I check the logs and it gives me

 

Dec-8-09 12:31:48 Number of quotes found: 9

Dec-8-09 12:31:48 Available services:Array

(

[uPS Expedited] => 601

[uPS Standard (Ground)] => 604

[uPS Three-Day Select] => 606

[uPS Saver] => 607

)

 

Dec-8-09 12:31:48 serviceId=601

Dec-8-09 12:31:48 Carrier: eShipper

Dec-8-09 12:31:48 Service name: Second Day Air

Dec-8-09 12:31:48 Total charge: 9.49

Dec-8-09 12:31:48 Days in transit: 2

Dec-8-09 12:31:48 serviceId=606

Dec-8-09 12:31:48 Carrier: eShipper

Dec-8-09 12:31:48 Service name: Three-Day Select

Dec-8-09 12:31:48 Total charge: 9.22

Dec-8-09 12:31:48 Days in transit: 3

Dec-8-09 12:31:48 Available quotes: Array

 

and if I go to the eshipper website it give me the information for all of them, but not in oscommernce

Share this post


Link to post
Share on other sites

Is this module still supported? I looked into it a few months back when i was gathering information before I opened my store, at the point now were I am looking for a method to ship again but seems this addon has died?

 

Anyone still using it? or know if it is still supported?

 

Couldnt even find it on the contribs page anymore.

 

EDIT ** Retract that last part, i found it again, rest still stands**

Edited by RCK

Share this post


Link to post
Share on other sites

Just started using this contrib. Had to do a fair bit of modifications to make things work on a heavily modified store - I dont weigh every product, or supply dims to them, because i have over ten thousand products. I just flat rate based on a 5lb box. Also, perhaps im alone here, but I had some issues with Tax - where it was adding tax to the quote, and then taxing it on the final page. Had to hack in a way to remove the tax before displaying the quote to the customer.

 

Still - so far, only got the customer side (quotes) working, and not label printing yet, as that's going to require a lot of work.

I'd love to see the mod Natrium has - where each order is shipped separately, rather than the batch processing in the export_eshipper offers, because I am also offering other shipping options that will conflict, and i'd like to see what my options are - after plugging in real dimensions and weight (instead of trying to hack it in).

 

Has anyone developed a mod for this which will allow each order to be shipped separately with dims/weight?

 

I'd expect more renewed interest in this mod with the Canada Post Strike.

Also, I was told eshipper will support Canada Post again by the end of Q3. lets see if it happens.

Share this post


Link to post
Share on other sites

Is anybody using this right now ? We are having a hardtime actually getting a shipping request going. No problems with a quote request.. Any help would be appreicated!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×