Jump to content
ptothew

Cannot process a credit card successfully

Recommended Posts

Hello,

 

I wanted to know if there was any additional log or error information in case the payment process doesn't complete successfully. I just installed this authorizenet_cc_aim payment module and so far I cannot get a payment to process successfully. I do have the standard authorizenet module, and it is running just fine.

 

The error I get (even when all of the billing and credit card information is valid) is "Please try again and if problems persist, please try another payment method.", which is just the general error message.

 

I tested the existence of curl on the server and that's working fine. I copied the login id and transaction key from the version of the authorize.net payment module that works. I set the MD5 hash in Authorize.net and set it in the Modules -> Payments -> Authorize.net Credit Car AIM module. There are no PHP or MySQL errors reported.

 

I'm just have a hard time with the lack of information or clues as to what could be going wrong, so anything would be helpful at this point.

 

Thanks in advance for your help.

 

Patrick

Share this post


Link to post
Share on other sites

Hi Patrick, did you find a solution to this, I'm suffering the same problem... the old AIM works but I want the added security of the new version.

 

I can't make the new AIM or SIM work.... when I try with SIM it goes to Auth.net and I get a screen that says:

The following errors have occurred.

 

(14) The referrer, relay response or receipt link URL is invalid

Thanks!

Akoss

Edited by akoss

Share this post


Link to post
Share on other sites

I'm having the same problem with this module, only I didn't have Authorize.net working before; I was using PayPal WPP. I eagerly look forward to a solution, or failing that, a way to get meaningful error messages!

Share this post


Link to post
Share on other sites

I feel bad for e-mailing you but I cant seem to get an answer from the forums.

 

I have online merchant v2.2 rc2

 

I have dedicated ip, SSL signed up with a.net, I have the log in and transaction key and I dont know aht MD5 has.

 

From OS administrator I removed all the payment module and just intalled AIM .net . I entered the following.

 

Aim payment TRUE

Log in id

transaction key

MD5 hash left it blank

transaction sever TEST

transaction mode TEST

transaction method AUTHORIZATION

zone NY

sort order 0

cURL program location /usr/bin/curl

 

after doing all that. My website doesn't have any payment method and nowhere to enter credit card information.

 

My a.net is set up and i download curl information note and php_aim.php that i dont know where to place.

 

Would you mind sharing some information about this.

 

 

 

Regards,

 

 

Deo

Share this post


Link to post
Share on other sites
I feel bad for e-mailing you but I cant seem to get an answer from the forums.

 

I have online merchant v2.2 rc2

 

I have dedicated ip, SSL signed up with a.net, I have the log in and transaction key and I dont know aht MD5 has.

 

From OS administrator I removed all the payment module and just intalled AIM .net . I entered the following.

 

Aim payment TRUE

Log in id

transaction key

MD5 hash left it blank

transaction sever TEST

transaction mode TEST

transaction method AUTHORIZATION

zone NY

sort order 0

cURL program location /usr/bin/curl

 

after doing all that. My website doesn't have any payment method and nowhere to enter credit card information.

 

My a.net is set up and i download curl information note and php_aim.php that i dont know where to place.

 

Would you mind sharing some information about this.

 

 

 

Regards,

 

 

Deo

 

 

This post was BY FAR the most useful for helping me figure out why I couldn't get anything back useful from auth.net!

 

Removing the MD5 hash made it work!

Share this post


Link to post
Share on other sites
This post was BY FAR the most useful for helping me figure out why I couldn't get anything back useful from auth.net!

 

Removing the MD5 hash made it work!

 

how do you remove the md5 hash? i have the same problem. setup everything in test mode and cc processing isnt going through.

Share this post


Link to post
Share on other sites
This post was BY FAR the most useful for helping me figure out why I couldn't get anything back useful from auth.net!

 

Removing the MD5 hash made it work!

 

how do you remove the md5 hash? i have the same problem. setup everything in test mode and cc processing isnt going through.

Share this post


Link to post
Share on other sites
This post was BY FAR the most useful for helping me figure out why I couldn't get anything back useful from auth.net!

 

Removing the MD5 hash made it work!

 

how do you remove the md5 hash? i have the same problem. setup everything in test mode and cc processing isnt going through.

Share this post


Link to post
Share on other sites

now i get the following error message:

 

Fatal error: Call to a member function call_api() on a non-object in /home/beautif2/public_html/checkout_process.php on line 127

 

somebody??

Share this post


Link to post
Share on other sites

Of course.....my osc is broken again.

 

Worked great 2 days ago. Back to the wonderful world of no replies and lack of product support.

Share this post


Link to post
Share on other sites
.... Back to the wonderful world of no replies and lack of product support.

I hear ya!

 

I notice many, many posts go unanswered. This is an extremely frustrating cart to work with.

I am presently having the same 'error message'. I have an oscommerce "guru" looking at it for me and even HE is stumped why it is doing that.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×