Jump to content
Sign in to follow this  
mikes

Graphical Borders on RSS News

Recommended Posts

Graphical Boxes [Contribution]

 

This contribution wraps a graphical box around all infoboxes, content boxes and product listing boxes as well as the 37 other files that display content in the center column.

 

Infoboxes will be wrapped automatically. All others may be turned on or off individually.

 

Gif files are used to allow transparency. Repeating patterns are supported on all sides.

 

A sample set of images and the .psd file to create them are included with this package.

 

Additional sets of images may be found at http://www.sentientshopping.com

 

An additional set of functions are defined in mws_functions.php that allow you to create additional boxes.

 

Check the website for a demo of how this works.

 

Have fun!

Share this post


Link to post
Share on other sites

In opera 7.21 your site appears to have the bottom image missing..I have downloaded your contrib and it looks nice. I will see if i can add it to my MS1 site

Share this post


Link to post
Share on other sites

Thanks for the feedback.

 

All my testing has been in IE but it is pretty straightforward stuff so I assumed it would be ok in netscape and others. I'll take a look and get back to you.

 

Thanks for posting the link for me jwsfun... I can't believe I forgot that :)

 

I will be doing web design on the site over the next couple of days so the demo may look odd occasionally. :)

 

Already working on the update. It should include:

 

1. Admin control to turn on/off graphical borders around individual boxes.

2. Changing skin on a per box basis, also controlled via admin.

3. Adding borders to individual products within boxes (new products, etc).

4. How to files for making skins, slicing them and using repeating patterns.

 

Once I get the site design done, I'll start adding borders. Hopefully, I should have a good start on that before the weekend. In addition to borders, I'll be adding button sets, navbars, interfaces, etc. so be sure to check back frequently!

Share this post


Link to post
Share on other sites

I don't have opera or netscape to test with atm. I did have a couple of friends with netscape take a look at my site and they both reported that it looked ok. It may have been that I was working on the site when you looked before.

 

If anyone has problems with the site not looking correct please post browser and version and I'll try to get a copy to test with. Especially interested in whether the opera problem persists or if it was just me doing upgrades when you were there.

Share this post


Link to post
Share on other sites

I am impressed, so much so I thought I would give it a go. I tried it on my test site first rather than my live site and I'm glad I did!

 

Instead of editing the files manually I uploaded everything in the contribution. Hey presto, lovely looking left column infoboxes, but thats it. Every page throughs up the same error

 

Fatal error: Cannot redeclare mws_header() (previously declared in /homepages/46/d85331627/htdocs/ssl/catalog/includes/mws_functions.php:9) in /homepages/46/d85331627/htdocs/ssl/catalog/includes/mws_functions.php on line 9

Got any ideas where I have gone wrong?

 

Never the less I am still very impressed and would love to sort this out.

 

I viewed your site with netscape 6.2, some of the images appear not to be loading correctly, it works fine in IE 6.

 

Thanks


If things don't change, things will definetley stay as they are!

Share this post


Link to post
Share on other sites

Remove the line:

 

<?php include(DIR_WS_INCLUDES . 'mws_functions.php'); ?>

 

from the following files:

 

includes/modules/downloads.php

includes/modules/new_products.php

includes/modules/product_listing.php

includes/modules/upcoming_products.php

 

Apparently, I created the contribution from a prior set of files. I'll double check and see if there are any other mods that didn't get in.

 

I'm hoping to have an update with more features in a few days. Hopefully, there isn't anything critical enough to require a fix release before that.

Share this post


Link to post
Share on other sites

I,

 

I liked your contribution a lot so I decided to give the install a go.

the admin part works fine,

but in the catalog I get a error about a missing funtions:

Fatal error: Call to undefined function: tep_output_string() in c:\phpdev\www\catalog\includes\classes\boxes.php on line 37

 

It's about that tep_output_string() funtion that being used in boxes.php.

where is it supposed to be? I double checked all your install instructions. and don't think I missed anything..

 

could you give me a hint please?

I'm using a heavily modified MS1 shop btw

 

thanks for the help

 

DicE


_____.:::.________###__________|/______

:(o o): . (o o) (o o)

ooO--(_)--Ooo-ooO--(_)--Ooo-ooO--(_)--Ooo-

Share this post


Link to post
Share on other sites

WTG, Mike!!

 

You know I've been waiting for you to release this :)

 

BTW and just FYI: On the Mac ::hears the boos from the crowd:: in Safari, the boxes have just the slightest bleed over of the tan colored background. It almost looks like a box that should include some kind of text and covers the bottom of the graphical box above it.

 

I have no idea what this could mean, but you know how screwed up Safari is :(

 

I'll have a go at it in IE and Netscape and get back to you soon!

 

Hoody Hoo and Thank you!

 

Khim~

 

Update:

 

Ok. I took a look at it in IE and Netscape (latest versions for the Mac) and it's perfect in IE but has the same characteristical "phantom" of the background that is covering up the bottom of the graphical boxes. So I'm thinking that it has to do with something in the code that is IE proprietary only.

 

I'll have a look and see what I see.

 

Khim~

Edited by inetchoices

Do not meddle in the affairs of Dragons, for you are crunchy and good with ketchup :-)

Share this post


Link to post
Share on other sites

Arrgh!

 

I hate it when I edit my edit and still screw it up.

 

I meant to say that it looks perfect in IE, but in Netscape I sill get the phantom background bleedover.

 

Blah!

 

Khim~

::going to get more coffee and hoping to grow more brain cells::

Edited by inetchoices

Do not meddle in the affairs of Dragons, for you are crunchy and good with ketchup :-)

Share this post


Link to post
Share on other sites

Dice,

 

Graphical Boxes doesn't use tep_output_string() :)

 

You may be thinking of infobox skin manager. His contribution is similar but approaches it differently and the two are evolving to serve two different purposes.

Share this post


Link to post
Share on other sites

hehe.. thx Khim!

 

I'm installing netscape this afternoon so I can track down what the issue is. The basis for the mod is simply a table with four graphics in the corners, four classes showing the four sides as backgrounds and a class for the center (text) area. It didn't occur to me that any browser wiould have a problem with that so I never tested beyond IE. Hopefully, it is something I overlooked and can fix easily. :)

Share this post


Link to post
Share on other sites

I installed Netscape and looked at my demo site. Fortunately, I was able to easily reproduce the problem and found the culprit. Thumb-fingered typists like me shouldn't write code late at night. :)

 

In my stylesheet, I left off a ; and IE allowed it while netscape had a display error. With it fixed, all is better. It showed up a couple of other typos that I will correct on my site when I am a bit more awake.

 

If you install the contribution and have any sort of similar problems check the stylesheet and make sure the syntax is correct for the relavent classes. Sorry it took so long to track this down but I'm coming into finals week.

Share this post


Link to post
Share on other sites

The *minimum* width of the right and left column is controlled by the variable BOX_WIDTH in the file "includes\application_top.php". If the content within the right or left column is wider than this setting, the associated column will become wider and the center column will shrink. The content within the center column can only shrink so much. After that the page will be forced to become wider resulting in a left-right scrollbar. That is just the nature of html tables; not any contribution.

 

There are a couple of ways of dealing with this:

 

1. Design border graphics that aren't as wide. The sample set that comes with this contribution are 30 pixels wide on all four sides. That means that the right and left column will each need to be 60 pixels wider. Designing a border set that is narrower on the sides should take care of the problem.

 

2. A better solution might be to get rid of the right column. Many of the infoboxes that come with the standard osc install are unneccessary. Remove what you don't need and put the remaining ones in the left column. In general, this tends to give oscommerce sites a cleaner, less busy look.

 

3. Reduce the width of the content in the center column to allow it to become narrower. This involves quite a bit more work. Solution #2 is much easier to accomplish.

 

Hope that helps!

 

I realize that I've been ignoring the Support Site but I will try to finish it up and start adding some borders and button sets this weekend.

Share this post


Link to post
Share on other sites

Hi all,

 

after install i have this message (OSC MS2):

Fatal error: Class messagestack: Cannot inherit from undefined class tablebox in /home/ultrasonique/www/includes/classes/message_stack.php on line 20

 

I use STS 1.8 too and manny add-on

 

Idea ??? help !!!!

 

Tks a lot,

Mike

Edited by madmike

Share this post


Link to post
Share on other sites

I took a look at a recent snapshot and it works with this mod so there doesn't seem to be any osc changes that stop it from working. It has to be another mod that is causing the problem. Sorry.

 

One thing to try would be to back up your current files, do a fresh install and then copy your backed up files over the fresh install one by one. That will help identify which file is causing the trouble and hopefully point you towards the culprit.

 

Hope that helps!

Share this post


Link to post
Share on other sites

Hi

 

This is about the cross browser issue.

 

Everything renders fine in my IE5.

 

Problem is when using Netscape 6. When I log on to my internal test site the screen is drawn with the side bars and the bottom bar of the box graphic missing. The top bar of the graphic is okay though.

 

Ive been to sentientshopping.com with the same browser and I get the same result.

 

Ive stared at the stylesheet for ages but im unable to see any obvious syntax errors (which doesnt prove anything) or missing ;

 

Any clues as to what to try next?

 

 

Cheers

 

 

John

Edited by jbc

Share this post


Link to post
Share on other sites

have a couple of quick 'tweaking' questions. which don't exactly relate to this fantastic contribution which i managed to install very easily, but more the changes to make as a result.

 

firstly how do i make my catagories box a little bit bigger? i'm using sts as well and what's new goes to the edge of the column but catagories doesnt, some of my catagory names are a bit long and i don't want them on 2 lines.

 

i had backgrounds and stuff looking nice by messing with the stylesheet, but i guess something in this has changed it. so how do i get the info box background changed.

 

oh and where can i get more fantastic borders? i like the licorice look but quite fancy another colour or style...

 

thanks.

Share this post


Link to post
Share on other sites
1. Design border graphics that aren't as wide. The sample set that comes with this contribution are 30 pixels wide on all four sides. That means that the right and left column will each need to be 60 pixels wider. Designing a border set that is narrower on the sides should take care of the problem.

Great Contribution, thanks a lot!!

 

Quick question....I changed the size of the borders to 15 pixels and they look fine, however, now the box title is partially covered by the border.

 

What would be the best way to drop the text/title a line to clean up the look?

Share this post


Link to post
Share on other sites

anyone know about this kind of error?

 

>>being error msg>>>

Parse error: parse error in /domain/catalog/includes/application_top.php on line 434

 

Warning: main(DIR_WS_LANGUAGES/FILENAME_DEFAULT): failed to open stream: No such file or directory in /domain/catalog/index.php on line 33

 

Fatal error: main(): Failed opening required 'DIR_WS_LANGUAGES/FILENAME_DEFAULT' (include_path='.:/usr/local/lib/php') in /domain/catalog/index.php on line 33

<<<end<<<

 

 

I swear I followed the instructions :)

Incedently, I added my lines from install.txt to application_top.php on line 434

Thanks,

Ashish

Share this post


Link to post
Share on other sites

Hi

 

Can i use this to add a graphical boarder around product thumbs?

 

Or if anyone knows about any other way of getting it done...

 

HELP please!

Share this post


Link to post
Share on other sites

Hi!

 

First it?s a real great Contribution! :D

I?ve got only a little Problem with it. I tried by myself, but i couldn?t solve so maybee you can help me.

 

I have installed the changes all the way. I changed the graphics with the .psd File for my needs. After that i had a look at my shop and.... the edges are at the boxes but the borders are missing!?!?!

 

What went wrong? Where did i made an mistake?

 

Hope you can help me!

 

 

 

 

 

P.S.: Please excuse any errrors, english isn?t my best language! :unsure:

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×