Jump to content
Sign in to follow this  
CatDadRick

PHP Fatal error: in vendor_order_data.php

Recommended Posts

Not sure if this is a PHP5/MySQL5 compatibility issue, but prior to upgrading my server I didn't get this error.

 

When I log on as my test customer and go to Account > Order History and click View to view an order, I get an empty box where the order information should be. In my log file I get this error message...

PHP Fatal error:  Using $this when not in object context in /var/www/catalog/includes/classes/vendor_order_data.php on line 17, referer: https://secure.rlknight.com/account_history.php

 

This is the code (catalog/includes/classes/vendor_order_date.php) at line 17 and immediately after...

	$this->products[$index2] = array('Vid' => $vendor_order['vendors_id'],
									   'Vname' => $vendor_order['vendors_name'],
										'Vmodule' => $vendor_order['shipping_module'],
										'Vmethod' => $vendor_order['shipping_method'],
										'Vcost' => $vendor_order['shipping_cost'],
										'Vship_tax' => $vendor_order['shipping_tax'],
										'Vnoname' => 'Shipper',
										 'spacer' => '-');

 

Can someone help me solve this?

 

Thanks,

Rick

Share this post


Link to post
Share on other sites
Not sure if this is a PHP5/MySQL5 compatibility issue, but prior to upgrading my server I didn't get this error.

 

When I log on as my test customer and go to Account > Order History and click View to view an order, I get an empty box where the order information should be. In my log file I get this error message...

PHP Fatal error:  Using $this when not in object context in /var/www/catalog/includes/classes/vendor_order_data.php on line 17, referer: https://secure.rlknight.com/account_history.php

 

This is the code (catalog/includes/classes/vendor_order_date.php) at line 17 and immediately after...

	$this->products[$index2] = array('Vid' => $vendor_order['vendors_id'],
									   'Vname' => $vendor_order['vendors_name'],
										'Vmodule' => $vendor_order['shipping_module'],
										'Vmethod' => $vendor_order['shipping_method'],
										'Vcost' => $vendor_order['shipping_cost'],
										'Vship_tax' => $vendor_order['shipping_tax'],
										'Vnoname' => 'Shipper',
										 'spacer' => '-');

 

Can someone help me solve this?

 

Thanks,

Rick

 

Hey Rick

I'm having the same problem! Did you get any solution yet?

Thanks

Rosie

Share this post


Link to post
Share on other sites

Hi there

 

Can someone please help me with this? The website is working beautifully except for this problem?

 

Thanks

Rosie :blush:

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×