Jump to content
Sign in to follow this  
swimp

Module sometimes acting weird

Recommended Posts

Sometimes my 2checkout module sends the wrong URL to 2co, causing 2checkout to not working (since it doesn't recognize the URL).

It sends the whole page in the url which is really weird.

 

Does anyone know what this is?

 

I've tried several different 2co modules and I can't seem to find a reason why it acts this way. Today it was sending the wrong url and then a minute or two later everything worked fine..

Share this post


Link to post
Share on other sites

I ahve the same problem - My site ever so often allows the customer to go through all the checkout part of OS COMM but when it gets to 2checkout.com it claims Parameter Error and doesnt let them check out. I have noticed that if the customer tries again and again it is still the same, as if it was locked in with the cart the started or the account. On the next order - it goes through just fine. I can't figure out what the problem is.. or why the cart produces a URL to 2checkout that is incorrect causing the error.

 

2checkout claimed that the url that the customer provided them when they got the error didn't even have my 2checkout ID in it.... so that make me a bit confused aswell.

 

IF anyone has a solution, I would LOVE to hear it...

Share this post


Link to post
Share on other sites

We have actually solved that problem before. The problem might be with 2Checkout. Lat I remember they will pause your account when they see that there is a problem or they are missing information. When they do it this error will occur.

 

I ahve the same problem - My site ever so often allows the customer to go through all the checkout part of OS COMM but when it gets to 2checkout.com it claims Parameter Error and doesnt let them check out. I have noticed that if the customer tries again and again it is still the same, as if it was locked in with the cart the started or the account. On the next order - it goes through just fine. I can't figure out what the problem is.. or why the cart produces a URL to 2checkout that is incorrect causing the error.

 

2checkout claimed that the url that the customer provided them when they got the error didn't even have my 2checkout ID in it.... so that make me a bit confused aswell.

 

IF anyone has a solution, I would LOVE to hear it...

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×