Jump to content
henri

OSC-Affiliate

Recommended Posts

Seems like this thread has stopped. I have all installed but does not appear to be working as sales do not seem to be recorded.

 

Anyone have ideas or is there better documentation on setting this up?

Share this post


Link to post
Share on other sites

I haven't completely got it working yet either. There are a number of issues I have come across:

 

  1. The "$HTTP_POST_VARS", "$HTTP_GET_VARS" etc. all need changing to "$_POST", $GET" etc. to bring them up-to-date.
  2. Have come across some files which have "<?" instead of "<?php" which needs to be changed to avoid ambiguity as "<?" won't correctly parse as PHP on some server configurations.
  3. I also haven't managed to get the images to display on banner links, although the text versions work just fine and both types of link at least take you to the correct page on the site, so it looks like the code to select and display the image needs re-working somehow.

Unfortunately, it looks like the original developers of this mod are no longer working on it, :( so we're going to have to work this stuff out ourselves. Still, it should be a lot less work than trying to write the whole thing from scratch huh?!?:)

 

 

In the meantime, it is now 5:00am and I need to get some shut-eye...

Edited by porpoise1954

* * * * * * * * * * * * * * * * * * * * *

Porpoises are most happy when wet!

\ _ \ _ \ _ \ _ \ _ \ _ \ _ \ _ \ _ \ _ \ _ \ _

Share this post


Link to post
Share on other sites

Well, I've gone through every file and updated all the deprecated $HTTP_******_VARS variables to the newer $_POST, $_GET, $_SERVER, $_SESSION etc. variables and everything is pretty much working (not perfectly, as there are still a few tweaks and a bit of prettifying [getting rid of all the schoolboyish icons! :x for example] to do) and Anglicizing all the English to "PROPER" English! ;).

 

:) Found a great little stand-alone executable to do the "find-and-replace-text" part - TurboSR Search & Replace

 

It required quite a lot of tweaking to get it to work on a highly modified osC 2.2-MS2 site running on PHP 4.4.9 and Apache on Linux 2.6.28.8 and MySQL 5.0.91

 

Had to make a "New News Item" button, as there wasn't one in the distrib!

 

So, back to the MUST_DO list (the stuff that NEEDS to be done before I can actually put it live!):

 

1. Currently working on generating differing affiliate rates based on MANUFACTURER as the margins vary widely between manufacturers and the commissions need to reflect this but also need to take into account different affiliate rates and compound the two. Have modified the Manufacturers table to add a commission percentage rate for each manufacturer via the admin page and am currently still testing the code within "affiliate_checkout_process.php" to do all the necessary calculations checking the manufacturer of each product and applying the correct rate to the item before adding it to the affiliate total.

Still testing!

 

2. Still need to incorporate adjustments where Discount Codes/GIFT Vouchers come into play.

 

So, back to the grind-stone - check back later...


* * * * * * * * * * * * * * * * * * * * *

Porpoises are most happy when wet!

\ _ \ _ \ _ \ _ \ _ \ _ \ _ \ _ \ _ \ _ \ _ \ _

Share this post


Link to post
Share on other sites

This is great, Thank you very much for your time and effort on this! We look forward to testing your updated solution.

 

-jim

Share this post


Link to post
Share on other sites

Hi everyone,

 

For what it's worth - I had the same issue with the affiliate_sales table not being populated when it should be.

I solved the problem by changing the following line in affiliate_checkout_process.php :

 

if ($HTTP_SESSION_VARS['affiliate_ref']) {

 

to

 

if ($affiliate_ref) {

 

 

Hope that can be of use to somebody.

 

:)

 

Yes... work.

Thanks.

Share this post


Link to post
Share on other sites

sorry for this question but...

what does this contribution do? purpose? advantages? and so on...

 

thanks

Share this post


Link to post
Share on other sites

hello anyone get succed?

i use this aos affliate, and work well,

just i misssss

 

product banner affilate , no show image?

anyone succed solve it?

Share this post


Link to post
Share on other sites

hello anyone get succed?

i use this aos affliate, and work well,

just i misssss

 

product banner affilate , no show image?

anyone succed solve it?

solve by my self, just dell S from https

Share this post


Link to post
Share on other sites

sorry for this question but...

what does this contribution do? purpose? advantages? and so on...

 

thanks

 

i dont know neither

Share this post


Link to post
Share on other sites

Hi,

 

Is there a way to allow the affiliates of my shop to display products via a feed on their website or blog? Much in the same way as Amazon's store widgets.

 

Thanks for any assistance with this


Nancy

Share this post


Link to post
Share on other sites

I apologize if I've missed this information somewhere in this thread - I tried google searching, but I only know how to search the oscommerce support forums - but not the individual threads.

 

I just installed osc Affiliate v2.8 Nov 09 on my test server. I think things are working but it's hard to tell. Are there any instructions on where to find things - like how to setup an affiliate account?

 

I was hoping to have the ability in the Admin area to create an affiliate account for our clients rather than making them do it. Is this an option?

 

Some people may not have their own website to advertise on - is there a way to let them create an affiliate account without having their own site?

 

I can't seem to find how to let an affiliate simply link to the home page or a category page rather than a specific product page. Is there a way to do this? (I've seen the question in the forums, but have found no answers yet).

 

The javascript popup windows aren't working (for the ? marks on affiliate_summary.php for example)- has anyone else experienced this difficulty.

 

Occasionally we need to change a customers order on the website (we have a module installed for that) and it changes their total. Will this module automatically see the difference in the changed orders total?

 

I do have a lot of other contributions installed on this site currently, so I am sure there will be some custom coding happening here and there to get things running smoothly - so far though I haven't found anything that I need to do - so if you happen to already know of any changes needing to happen for STS Templates, Master Products or Separate Pricing Per Customer contributions please let me know. Those are the most likely candidates IMHO that may cause a need for some custom coding.

 

Thanks in advance for any suggestions or assistance you may offer :)

Share this post


Link to post
Share on other sites

Hi TracyS!

 

I have been searching these forums looking for light w/ the osC Affiliate Add-on. I got int installed and it seems to run, but i can't find where to add a affiliate to it. I noticed you had asked the same. Did you get an answer :)

 

Any info is greatly appreciated!

 

Aaron

Share this post


Link to post
Share on other sites

Hello!

 

I have just installed the osC Affiliate add-on. So far it seems to work. I haven't been able to figure out how to add a new affiliate. Could you steer me in the right direction?

 

Thank you,

Aaron

 

I haven't completely got it working yet either. There are a number of issues I have come across:

 

  1. The "$HTTP_POST_VARS", "$HTTP_GET_VARS" etc. all need changing to "$_POST", $GET" etc. to bring them up-to-date.
  2. Have come across some files which have "<?" instead of "<?php" which needs to be changed to avoid ambiguity as "<?" won't correctly parse as PHP on some server configurations.
  3. I also haven't managed to get the images to display on banner links, although the text versions work just fine and both types of link at least take you to the correct page on the site, so it looks like the code to select and display the image needs re-working somehow.

Unfortunately, it looks like the original developers of this mod are no longer working on it, :( so we're going to have to work this stuff out ourselves. Still, it should be a lot less work than trying to write the whole thing from scratch huh?!?:)

 

 

In the meantime, it is now 5:00am and I need to get some shut-eye...

Share this post


Link to post
Share on other sites

I have to say after trawling through this addon code - there are a huge number of issues with the code!

 

However, I have found that osCmax.com have this installed in their new v2.5 version (currently Release Candidate) - found the code in their SVN (on google code) which may provide some pointers to people to fix the numerous issues ...

 

Or like me - you could save yourself a load of time and simply use osCmax! Loads of other modules pre-installed for you as well. Basically a version of osCommerce with a load of work done for you! Still works with almost all of the addons from osCommerce ...

 

Worth a look if you are trying to fix up this module.

 

Hope this helps someone.

Edited by gilo_m

Share this post


Link to post
Share on other sites

There's also a published fix for osCommerce Pay Pal IPN in its support thread to get it to work with osC Affiliate properly.

Vger

 

Can you give me a pointer to this fix please, I'm not finding it. My problem is that the affiliate sales record is not being added.

Share this post


Link to post
Share on other sites

Can you give me a pointer to this fix please, I'm not finding it. My problem is that the affiliate sales record is not being added.

 

Hi,

 

The affiliate module 2.8.1 works well. However, if a payment service provider is used it generally fails to add the sales record because session values are lost when the customer leaves the osc site and moves to the payment service provider's pages. You can test this by allowing Cash on Delivery payments, for your site, and see if the sales record is then updated.

 

 

The PayPal fix is as follows: this is not my fix but was posted by pbirm on the 4 Nov 2007

 

To combine the two, open /includes/modules/payment/paypal_ipn.ph.

*********************************************

Find this code around line 76:
function confirmation() {
global $cartID, $cart_PayPal_IPN_ID, $customer_id, $languages_id, $insert_id, $order, $order_total_modules;

directly below add this code:
global $affiliate_ref, $affiliate_clientdate, $affiliate_clientbrowser, $affiliate_clientip, $affiliate_clickthroughs_id, $HTTP_SESSION_VARS;

*********************************************

Find this code around line 245:
tep_session_register('cart_PayPal_IPN_ID');
$cart_PayPal_IPN_ID = $cartID . '-' . $insert_id;
}
}
return false;
}

and change to:
tep_session_register('cart_PayPal_IPN_ID');
$cart_PayPal_IPN_ID = $cartID . '-' . $insert_id;
}
}

// Include OSC-AFFILIATE
require(DIR_WS_INCLUDES . 'affiliate_checkout_process.php');

return false;
}

*********************************************

 

I have also been able to get the module to work with WorldPay. If anybody would like this fix please let me know and I will post here.

Share this post


Link to post
Share on other sites

It's not written for v2.3.1

 

That much I can tell by looking at the install directions.

 

It might need some edits to be 2.3.1 compatible.


If I suggest you edit any file(s) make a backup first - I'm not perfect and neither are you.

 

"Given enough impetus a parallelogramatically shaped projectile can egress a circular orifice."

- Me -

 

"Headers already sent" - The definitive help

 

"Cannot redeclare ..." - How to find/fix it

 

SSL Implementation Help

 

Like this post? "Like" it again over there >

Share this post


Link to post
Share on other sites

hi guys .....

 

i installed the OSC affiliate 2.8.1 hwever doesn't work with the template

the css is out of order however got nlu n etheme to work with it

is there any fix for that

 

anther questin i wonder if it is working with Alertpay payment module

Share this post


Link to post
Share on other sites

Hello,

 

I've gotten this to fit in version 2.3.1! Here's what I did:

 

1. followed a tutorial by kymation http://forums.oscommerce.com/topic/368538-guide-to-converting-addons-from-22x-to-23x/

 

2. recoded admin/includes/modules/boxes/affiliates.php

 

3. then correct the 'TABLE_AFFILIATE doesn't exist' database errors. Several files in admin produce that error.

In those files change all instances of

TABLE_AFFILIATE

 

to:

TABLE_AFFILIATE_AFFILIATE

 

All that I believe that needs to be done is to recode the buttons and test functioning. Also, an operational manual needs to be written so shop owners can operate this.

 

I think the right contributors can really debug this mod.

 

Thanks for reading

Edited by discxpress

Share this post


Link to post
Share on other sites

Please, I need some help solving one issue with this addon :)

 

catalog/affiliate_banners_build_cat.php is producing a product image instead of the categorie image

 

Anyone know how to fix this to show categorie image??


Thanks to all source contributors, 2.3.4 Edge just works fine

https://github.com/gburton/Responsive-osCommerce/archive/master.zip

Share this post


Link to post
Share on other sites

Hello,

 

I've gotten this to fit in version 2.3.1! Here's what I did:

 

1. followed a tutorial by kymation http://forums.oscommerce.com/topic/368538-guide-to-converting-addons-from-22x-to-23x/

 

2. recoded admin/includes/modules/boxes/affiliates.php

 

3. then correct the 'TABLE_AFFILIATE doesn't exist' database errors. Several files in admin produce that error.

In those files change all instances of

TABLE_AFFILIATE

 

to:

TABLE_AFFILIATE_AFFILIATE

 

All that I believe that needs to be done is to recode the buttons and test functioning. Also, an operational manual needs to be written so shop owners can operate this.

 

I think the right contributors can really debug this mod.

 

Thanks for reading

 

@@discxpress, could you put your files up as a contribution in the 2.3 section so the rest of us can get our hands on them?

 

Thanks!

Edited by matta

Share this post


Link to post
Share on other sites

@@discxpress, could you put your files up as a contribution in the 2.3 section so the rest of us can get our hands on them?

 

Thanks!

Ok. I'm a little tied up at the moment but give me a few days to upload the files. It'll be my very first contribution so bare with me. :)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×