Jump to content
Latest News: (loading..)
henri

OSC-Affiliate

Recommended Posts

Hello,

 

We have just installed this great contribution. One thing i remarked is, that the pop up window affiliate_validproducts php shows all products. Is there a way that it only shows products with active status ?

 

Greetings and thanks in advance :)

 

ooops, solved my self:

 

in the file affiliate_validproducts php find in line 38

$result = mysql_query("SELECT * FROM products, products_description WHERE products.products_id = products_description.products_id and products_description.language_id = '" . $languages_id . "' ORDER BY products_description.products_name");

 

and change into:

 

$result = mysql_query("SELECT * FROM products, products_description WHERE products.products_id = products_description.products_id and products_status = '1' and products_description.language_id = '" . $languages_id . "' ORDER BY products_description.products_name");

Edited by girolimoni

Share this post


Link to post
Share on other sites

Hello,

 

I am pretty new to this contribution though I have had it installed for a while.

 

What I don't like about it is that it requires the user to sign up for a second account when they already have signed up for an account on my site. I was wondering if there was already someone out there who has made it so that when the user signs up for an account originally an affiliate account would be created as well. And if anyone has the procedure to share so that I can do it to that would be amazing!

 

Thanks. If you have any tips on getting started on this I would greatly appreciate that as well.

 

Rob

Share this post


Link to post
Share on other sites

hi,

 

i've installed KissER Error Handling & Debugging contrib (http://addons.oscommerce.com/info/7217)!

 

KissER has found the following errors produced by oscAffiliate:

 

Error: Constant AFFILIATE_KIND_OF_BANNERS already defined
File: includes/affiliate_configure.php
Line: 17
Error: Constant AFFILIATE_SHOW_BANNERS_DEBUG already defined
File: includes/affiliate_configure.php
Line: 19
Error: Constant AFFILIATE_SHOW_BANNERS_DEFAULT_PIC already defined
File: includes/affiliate_configure.php
Line: 22
Error: Constant FILENAME_AFFILIATE_LOGOUT already defined
File: includes/affiliate_application_top.php
Line: 92
Error: Undefined variable: HTTP_SESSION_VARS
File: includes/affiliate_application_top.php
Line: 107
Error: Undefined index: ref
File: includes/affiliate_application_top.php
Line: 110
Error: Undefined index: affiliate_ref
File: includes/affiliate_application_top.php
Line: 152
Error: Use of undefined constant breadcrumb - assumed 'breadcrumb'
File: includes/affiliate_application_top.php
Line: 164

 

maybe one should correct this in an upcoming version.

 

greetz

piou

Share this post


Link to post
Share on other sites
Hi everyone,

 

For what it's worth - I had the same issue with the affiliate_sales table not being populated when it should be.

I solved the problem by changing the following line in affiliate_checkout_process.php :

 

if ($HTTP_SESSION_VARS['affiliate_ref']) {

 

to

 

if ($affiliate_ref) {

 

 

Hope that can be of use to somebody.

 

 

Thanks Silus!

 

this was really helpful!

Share this post


Link to post
Share on other sites

Im getting this error on /affiliate_signup.php

 

Fatal error: Call to undefined function: affiliate_insert()

 

Also, when I manually enter Affiliates into the database, the affiliate link codes are not generating anywhere.

Edited by kc8grq

Share this post


Link to post
Share on other sites

Checking if anybody is monitoring this anymore.

 

After reading a lot of this thread I have everything installed correctly and I am getting sales to show up in the database but I am not able to switch the affilaites status from pending to anything. There is not a lot of documentaion on what to do. I have used the start billing featute but do not see anything happining.

 

Is there a date function in the configuration that tells the module to wait for so many days before they are elligable to get paid. Then will these fuctions work so you can pay your affiliats?

 

Does anyone have a good demo of the admin area that can be seen?

Or can anyone show images of theirs so it can be seen to make sure I am getting the correct results?

 

Any help on this would be awesome.

Share this post


Link to post
Share on other sites

Does anyone know if there is a list of the features of this contribution somewhere? I've been to the sourceforge site and googled the osC forums and haven't really found a list stating what all this contribution is capable of?

 

We are trying to compare it with some other affiliate software options and knowing what this can do without going through install on a heavily modified store to find out would be very helpful :)

Edited by TracyS

~Tracy
 

Share this post


Link to post
Share on other sites

Hi everyone!

I'm new here and I have a question about OscAffiliate.

In the Affiliate Account-->Click (Klick) I can see some of the referred URLs, just sometime yes and sometime not.

Is that correct? One of my affiliate asked me about it, but I don't know what to answer...

I tried to delete cookie on my browser and click on an affiliate link and the URL appear; then delete again cookies and click and the Url again is there, but when I don't delete cookies doesn't even appear clicks. In the control panel of my affiliate instead there is the products where he clicked ,but not always the referred url...is everything ok or I'm missing something?

 

Can anyone light me up about that?

I hope I explain it well!

I use OsCommerce 2.2 RCa2 and OscAffiliate 2.8.

 

Thank you everyone

Share this post


Link to post
Share on other sites

Ok,

the first Release.

 

Differences to Steve Alpha:

-Optimised a lot of SQL Querys

-Bugfixes

-new Database Strukture

-removed not yet working things

-Introduced a billing system in the Admin

 

Get it here

contributions

 

Test it and find the bugs

(hope i didn't produced some news with the last changes i did today)

 

what do i want to do until 1.0:

- registration: more fields

- perhaps a change of the bannermanger

- some codeoptimation (getting it to OSC-Standards)

- check for unused defines and other old stuff which is in the code

 

 

I will try to fix upcoming bugs very fast, new features have to wait due lack of time.

 

Whats would be usefull:

- someone makes the missing / changes the worse Buttons

- Translation to german/espanol

 

Have Fun

Henri

 

 

Hai my name Is Ifa, i just want to ask about my problem installation of Osc-Affiliate, when i finished install the interface of my osc-affliate , mainly affiliate menu is aligned to right, i want to move it to be center, how can i do it?what is file i have to edit?please give me answer to my email zulfanceo21@gmail.com. i give u the screenshot of my interface my websitep>

Share this post


Link to post
Share on other sites

Hi,

 

The banner image is not showing.

 

Iexplorer is show a missing image error

 

When I do a properties of the image I get a link like:

 

example.com/affiliate_show_banner.php?ref=1&affiliate_banner_id=2

 

Is there any fix for this.

Share this post


Link to post
Share on other sites

Checking if anybody is monitoring this anymore.

 

After reading a lot of this thread I have everything installed correctly and I am getting sales to show up in the database but I am not able to switch the affilaites status from pending to anything. There is not a lot of documentaion on what to do. I have used the start billing featute but do not see anything happining.

 

Is there a date function in the configuration that tells the module to wait for so many days before they are elligable to get paid. Then will these fuctions work so you can pay your affiliats?

 

Does anyone have a good demo of the admin area that can be seen?

Or can anyone show images of theirs so it can be seen to make sure I am getting the correct results?

 

Any help on this would be awesome.

 

Maybe this will help?

 

How to use OSC Affiliate:

++++++++++

CONFIGURATION TAB IN ADMIN:

 

Affiliate Pay Per Sales Payment % - amount of commission you will pay each affiliate for each order. This is a global %.

Payment Threshold - minimum amount an affiliate has to have earned before you will payout. This is a total of all commissions, not per sale.

(example: if your threshold is $25, when you press payment, commissions to be paid won't be calculated until their cumulative commissions equals $25 or more.)

Cookie Timeout - how long the cookie to track affiliate clicks will be active. This is in seconds.

Billing Time - How aged an order needs to be before you will pay commission. This is important so you can exclude any returns. Recommend 30 days

Order Min Status - The status the account needs to be in before it will calculate a commission for an affiliate sale. In my shop, "1"= pending, "2"= processing and "3" = completed/shipped.

Pay Affilaites by (check, bank, paypal) - Payment methods you will offer your affiliates for paying their commissions. This program does not have a payment system.. you will have to do that seperately/on your own using paypal or writing checks, etc.

Individual Affliate Percentage - If you want to assign a specific percentage to an affiliate instead of the global %

Use Affiliate Tier - set whether your affiliate can have affiliates

Tier Levels - how many levels? Just an affiliate and one affiliate under, or can the affiliate under the affiliate have an affiliate under them and so on?

Percentage Rate for Tier Levels - Payout options for the tier affiliates. You must have Individual affiliate turned off

to use tier levels

Affiliate News - How many "Affiliate News" items appear under news for affiliates when they log into their affiliate account.

 

+++++++++

AFFILIATE TAB IN ADMIN:

 

Summary - Self Explanatory

Affiliates - Names of affiliates signed up and a link to their individual stats (similar to "Summary")

Payment - This will generate a "payment sheet" for any affiliate sales that qualify for a commission and have the commission amount as pending. That is, the customer's order must be in the "STATUS" that you set in configuration (1, 2, 3, etc.) AND the "billing time" must have passed (set up in configuration) AND the total of commissions for the affiliate must exceed your set "payment threshold". After you actually pay your affiliate, you mark the sale as paid and send an email update to affiliate (similar to how you send one to a customer for a update to their order). This module does not automatically pay any $$ towards affiliate. You do that separately.

Sales - Sales made by the affiliates.

Clicks - Clicks made on affiliate links (sources)

Banners - Set up banners (and text links) for your products/categories

- Set up a banner link and ti will automatically set up a text only link as well, using the name of the banner link.

- Click on the little double squares graphic to the left of the listing of the banners, to see a popup of the banner.

Affiliate News - News to your affiliates. Displays on the screen once your affiliate has logged in. HTML can be used.

Affiliate Newsletter - create affiliate newsletter if you want to mail a newsletter to your affiliates. If you

want HTML newsletters, see below how to make this change.

Contacts - If you want to send an email to an individual affiliate or all affiliates.

 

++++++++

CHANGE AFFILIATE NEWSLETTER FROM TEXT HTML:

 

in admin/includes/modules/newsletters/affiliate_newsletter.php

Find this:

$mimemessage->add_text($this->content);

change to:

$mimemessage->add_html($this->content);

++++++++

DISABLE PAYING TAXES ON AFFILIATE PAYMENTS:

 

Find in admin/affiliate_configure.php:

define ('AFFILIATE_TAX_ID','1'); // Tax Rates used for billing the affiliates

 

Put this from a 1 to a 0 tax rate.

 

++++++++

"From" email address on affiliate newsletters or regular affiliate email is not correct:

 

-Make sure you have set up the email address for your server.

-Make sure you have entered the return email address under the configuration tab.

 

+++++++

FAQ can be found and edited here:

includes/languages/english/affiliate_faq.php

 

TERMS can be found and edited here:

includes/languages/english/affiliate_terms.php

 

+++++++

OTHER CONFIGURATION OPTIONS:

Other configuration options change from false to true or true to false to suit your needs. Where the option

is days, you either enter "false" or the # of days:

 

/admin/includes/affiliate_configure.php

 

define ('AFFILIATE_NOTIFY_AFTER_BILLING','false'); // Notify affiliate if he got a new invoice

define ('AFFILIATE_DELETE_ORDERS','false'); // Delete affiliate_sales if an order is deleted (Warning: Only not yet billed sales are deleted)

define ('AFFILIATE_DELETE_CLICKTHROUGHS','false'); // (days / false) To keep the clickthrough report small you can set the days after which they are deleted (when calling affiliate_summary in the admin)

define ('AFFILIATE_DELETE_AFFILIATE_BANNER_HISTORY','false'); // (days / false) To keep thethe table AFFILIATE_BANNER_HISTORY small you can set the days after which they are deleted (when calling affiliate_summary in the admin)

Share this post


Link to post
Share on other sites

Hi,

 

The banner image is not showing.

 

Iexplorer is show a missing image error

 

When I do a properties of the image I get a link like:

 

example.com/affiliate_show_banner.php?ref=1&affiliate_banner_id=2

 

Is there any fix for this.

 

 

A general problem with that can be found in the configure.php file in the catalog folder.

 

I had a missing slash (/) at the end of the path in:

 

define('DIR_FS_CATALOG', '/var/www/vhosts/USERNAME/httpdocs/');

 

The show affiliates script puts the path together with these defines. My path showed .../httpdocsimages/..

 

The slash was missing between “httpdocs” and “images” and an open_basedir error showed up.

 

Hope this helps somebody..

 

Have a great one.

Share this post


Link to post
Share on other sites

I am having problems with the banner system. When I create a banner the image is HUGE, takes up the whole page. I should say I am creating the banner as a user signed in as an affiliate. Is there any way to set the size of the image used? Or maybe go into the images and process all the ones used for the affiliate banners? I have not read this entire topic, and I will scan through it, but if someone knows the answer because they have had the problem before I would appreciate an answer.

Share this post


Link to post
Share on other sites

OK I have been working on this for quite some time and can not for the life of me figure it out.

 

My banners are not shopping up.

 

I when to affiliate_configure.php

turned on the debugging for banners.

 

and this is what I got


Notice: Undefined variable: prod_banner_id in /home/hera/public_html/shop/affiliate_show_banner.php on line 129

Notice: Undefined variable: banner in /home/hera/public_html/shop/affiliate_show_banner.php on line 142

Notice: Undefined variable: sql in /home/hera/public_html/shop/affiliate_show_banner.php on line 142
Check the pathes! (catalog/includes/configure.php)
absolute path to picture:	/home/hera/public_html/shop/images/
build with:	/home/hera/public_html/shop/images/
DIR_FS_CATALOG	/home/hera/public_html/shop/
DIR_WS_CATALOG	
Notice: Use of undefined constant DIR_WS_CATALOG - assumed 'DIR_WS_CATALOG' in /home/hera/public_html/shop/affiliate_show_banner.php on line 84
DIR_WS_CATALOG
DIR_WS_IMAGES	images/
$banner	
SQL-Query used:	
Try to find error:	 
SQL-Query:	No result
Locating Pic	images/
failed

 

here is my shop/includes/configure.php looks like.

// Define the webserver and path parameters
// * DIR_FS_* = Filesystem directories (local/physical)
// * DIR_WS_* = Webserver directories (virtual/URL)
 define('HTTP_SERVER', 'http://herasonlinemarket.com'); // eg, http://localhost - should not be empty for productive servers
 define('HTTPS_SERVER', 'https://herasonlinemarket.com'); // eg, https://localhost - should not be empty for productive servers
 define('ENABLE_SSL', true); // secure webserver for checkout procedure?
 define('HTTP_COOKIE_DOMAIN', 'herasonlinemarket.com');
 define('HTTPS_COOKIE_DOMAIN', 'herasonlinemarket.com');
 define('HTTP_COOKIE_PATH', '/shop/');
 define('HTTPS_COOKIE_PATH', '/shop/');
 define('DIR_WS_HTTP_CATALOG', '/shop/');
 define('DIR_WS_HTTPS_CATALOG', '/shop/');
 define('DIR_WS_IMAGES', 'images/');
 define('DIR_WS_ICONS', DIR_WS_IMAGES . 'icons/');
 define('DIR_WS_INCLUDES', 'includes/');
 define('DIR_WS_BOXES', DIR_WS_INCLUDES . 'boxes/');
 define('DIR_WS_FUNCTIONS', DIR_WS_INCLUDES . 'functions/');
 define('DIR_WS_CLASSES', DIR_WS_INCLUDES . 'classes/');
 define('DIR_WS_MODULES', DIR_WS_INCLUDES . 'modules/');
 define('DIR_WS_LANGUAGES', DIR_WS_INCLUDES . 'languages/');
 define('DIR_WS_DOWNLOAD_PUBLIC', 'pub/');
 define('DIR_FS_CATALOG', '/home/hera/public_html/shop/');
 define('DIR_FS_DOWNLOAD', DIR_FS_CATALOG . 'download/');
 define('DIR_FS_DOWNLOAD_PUBLIC', DIR_FS_CATALOG . 'pub/');

 

 

please help.. i am getting a headahe over this.

thank you the osc guru's

noppie


Peace is possible.. Please don't give up.

 

"War is --the old betraying the young"

Share this post


Link to post
Share on other sites

Noami,

 

The current release in the contribution area does not work properly, has not worked since it was updated for use with RC2a. Unfortunately, there is no longer any real support for this contribution. I ended up reworking the code so that it is functional but, I still have to FTP the images to the server as I never did figure out how to get the upload button to work properly.

 

 

Chris


:|: Was this post helpful ? Click the LIKE THIS button :|:

 

See my Profile to learn more about add ons, templates, support plans and custom coding (click here)

Share this post


Link to post
Share on other sites

Noami,

 

The current release in the contribution area does not work properly, has not worked since it was updated for use with RC2a. Unfortunately, there is no longer any real support for this contribution. I ended up reworking the code so that it is functional but, I still have to FTP the images to the server as I never did figure out how to get the upload button to work properly.

 

 

Chris

 

anyway of sharing what you did,. I really need this bad,.

Naomi


Peace is possible.. Please don't give up.

 

"War is --the old betraying the young"

Share this post


Link to post
Share on other sites

Guys, i am trying to set up my affiliate program and I have an issue.

 

I don't know where inside the admin to add the affiliate information.

 

When an affiliate is logged in and he click on affiliate information here is what appears: Your Affiliate Information Goes in /catalog/includes/languages/YOUR LANGUAGE/affiliate_info.php.

 

I tried to go to that destination, but it doesn't exist it seems, I only end up in languages, there is no "YOUR LANGUAGE/affiliate_info.php."

 

How can I address this issue please.

 

Any and all help is appreciated

Share this post


Link to post
Share on other sites

Jeffry,

 

YOUR LANGUAGE is either english, spanish or german usually as those are the 3 default languages installed with OSC.

 

 

Chris


:|: Was this post helpful ? Click the LIKE THIS button :|:

 

See my Profile to learn more about add ons, templates, support plans and custom coding (click here)

Share this post


Link to post
Share on other sites

Jeffry,

 

YOUR LANGUAGE is either english, spanish or german usually as those are the 3 default languages installed with OSC.

 

 

Chris

 

 

Thanks, I got it.

 

Now I need to add my affiliate terms, I am having trouble finding out where this is.

 

Please help

Share this post


Link to post
Share on other sites

Jeffry,

 

You will find affiliate terms in catalog/includes/languages/english/affiliate_terms.php

 

Don't forget affiliate_faq.php as well.

 

 

 

Chris


:|: Was this post helpful ? Click the LIKE THIS button :|:

 

See my Profile to learn more about add ons, templates, support plans and custom coding (click here)

Share this post


Link to post
Share on other sites

I installed the latest package (osCAffiliate v2.8 - including changes) then I signed up as an affiliate for testing purposes and I got this email:

 

 

 

1. "mycigsdirect.com" is not my website!

2. The rest of the email body is broken.

 

I had to track down all the variables and recode the entire email body, but who knows what else could be wrong? Am I the first to notice?

Share this post


Link to post
Share on other sites

Have anyone get the affiliate system working in their OSCOMMERCE??

I am new....hope to get some advice from everyone.....or send me the working php code for the affiliate system.

 

thank you

Share this post


Link to post
Share on other sites

I posted this in an other topic I am reposting here because I believe this is where I should have posted it

 

 

Does anyone have osCAffiliate v2.8 working?

 

I install osCAffiliate v2.8 - including changes

And I also installed Correção no arquivo affiliate_show_banner.php.

 

But I still can not get the Affiliate banners to work.

What am I doing wrong? I even tried to install it on a fresh copy of osCommerce but still the same problem...

 

When logged in as an affiliate and I try to make links and banners, I get if; I click on:.....

 

Banner Links I get:

Parse error: syntax error, unexpected $end in C:\wamp\www\test aff\catalog\affiliate_banners_banners.php on line 135

 

 

Product Links I get:

Affiliate Program - Product Links

Choose the product you want to display on your website from the choices below:

 

Banners made in the admin are there but no banner images Also the code generated does not produce an image.

 

 

Build a Link I get:

Enter the product number you wish to link to and press the enter

Click Here[/i]: to view available products.

Select the product number from the popup window and enter the number in the Build A Link field.

 

If I click on the Click Here I get a popup window with:

\n"; echo " ".$row["products_name"]." \n"; echo "

\n"; } while($row = mysql_fetch_array($result)); } echo " \n"; ?>

Close Window [x]

 

Category links also produce the same error.

 

Text Links I get:

Parse error: syntax error, unexpected $end in C:\wamp\www\test aff\catalog\affiliate_banners_text.php on line 148

 

 

What am I doing wrong? If osCAffiliate v2.8 does not work then which version of osCAffiliate do I use, with osCommerce Online Merchant v2.2 RC2?

 

Thank you in advance for all your help.

Share this post


Link to post
Share on other sites

I posted this in an other topic I am reposting here because I believe this is where I should have posted it

 

 

Does anyone have osCAffiliate v2.8 working?

 

I install osCAffiliate v2.8 - including changes

And I also installed Correção no arquivo affiliate_show_banner.php.

 

But I still can not get the Affiliate banners to work.

What am I doing wrong? I even tried to install it on a fresh copy of osCommerce but still the same problem...

 

When logged in as an affiliate and I try to make links and banners, I get if; I click on:.....

 

Banner Links I get:

Parse error: syntax error, unexpected $end in C:\wamp\www\test aff\catalog\affiliate_banners_banners.php on line 135

 

 

Product Links I get:

Affiliate Program - Product Links

Choose the product you want to display on your website from the choices below:

 

Banners made in the admin are there but no banner images Also the code generated does not produce an image.

 

 

Build a Link I get:

Enter the product number you wish to link to and press the enter

Click Here[/i]: to view available products.

Select the product number from the popup window and enter the number in the Build A Link field.

 

If I click on the Click Here I get a popup window with:

\n"; echo " ".$row["products_name"]." \n"; echo "

\n"; } while($row = mysql_fetch_array($result)); } echo " \n"; ?>

Close Window [x]

 

Category links also produce the same error.

 

Text Links I get:

Parse error: syntax error, unexpected $end in C:\wamp\www\test aff\catalog\affiliate_banners_text.php on line 148

 

 

What am I doing wrong? If osCAffiliate v2.8 does not work then which version of osCAffiliate do I use, with osCommerce Online Merchant v2.2 RC2?

 

Thank you in advance for all your help.

 

I got it working on an other server. With a fresh install of OScommerce and osCAffiliate it works fine with 2.2 RC2a I did the same with my 1st server and fresh install but it just wont work. So it must be in the server configuration. PHP, Mysql or Apache somthing in the ini files or php extensions or Apache modules need to be on or off. The server I got this working on is a hosted Verizon superpages server and I don't have access to the PHP Mysql or Apache .ini files or extensions or modules so I don't know what server configuration is needed to make this work. I do know it has PHP 5.2.13 and MySQL 5.0.90 My other server is a Wampserver 2.0 PHP 5.2.6 and MySQL 5.0.51a. And I have been able to get every thing to work on this server even heavly moded OSC with multiple add-ons and never had a problem till osCAffiliate. I even tried it with a fresh install of the older OSC 2.2 MS2, 2.2 RC1, 2.2 RC2 and 2.2 RC2a So Any one that has any version working please post your .ini files and what php extensions or Apache modules you have on. Or anyone knows why this may not be working and has any ideas for me to try Please Help. Thank You

Share this post


Link to post
Share on other sites

I apologize if I've missed this information somewhere in this thread - I tried google searching, but I only know how to search the oscommerce support forums - but not the individual threads.

 

I just installed osc Affiliate v2.8 Nov 09 on my test server. I think things are working but it's hard to tell. Are there any instructions on where to find things - like how to setup an affiliate account?

 

I was hoping to have the ability in the Admin area to create an affiliate account for our clients rather than making them do it. Is this an option?

 

Some people may not have their own website to advertise on - is there a way to let them create an affiliate account without having their own site?

 

I can't seem to find how to let an affiliate simply link to the home page or a category page rather than a specific product page. Is there a way to do this? (I've seen the question in the forums, but have found no answers yet).

 

The javascript popup windows aren't working (for the ? marks on affiliate_summary.php for example)- has anyone else experienced this difficulty.

 

Occasionally we need to change a customers order on the website (we have a module installed for that) and it changes their total. Will this module automatically see the difference in the changed orders total?

 

I do have a lot of other contributions installed on this site currently, so I am sure there will be some custom coding happening here and there to get things running smoothly - so far though I haven't found anything that I need to do - so if you happen to already know of any changes needing to happen for STS Templates, Master Products or Separate Pricing Per Customer contributions please let me know. Those are the most likely candidates IMHO that may cause a need for some custom coding.

 

Thanks in advance for any suggestions or assistance you may offer :)


~Tracy
 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×