Jump to content
Latest News: (loading..)
henri

OSC-Affiliate

Recommended Posts

Struggling a little here. using V2.8 with mod for 2.2RCA

 

installed the mod, then had a few problems with sql database side, basically the file didnt update mysql, so Looked at the file and used the parts that related to the missing tables.

 

Had to create the field new_status in the database, if you run this below in in phpmyadmin or eqivalent of slq this will correct the table:-

 

DROP TABLE IF EXISTS `affiliate_news`;

CREATE TABLE IF NOT EXISTS `affiliate_news` (

`news_id` int(11) NOT NULL auto_increment,

`headline` varchar(255) NOT NULL default '',

`content` text NOT NULL,

`date_added` datetime NOT NULL default '0000-00-00 00:00:00',

`news_status` tinyint(1) default NULL,

PRIMARY KEY (`news_id`)

) ENGINE=MyISAM DEFAULT CHARSET=latin1 AUTO_INCREMENT=4 ;

 

To get the newsletter to work properly I had to change the following in affiliate_application_top.php

from:- define('FILENAME_AFFILIATE_NEWSLETTERS', 'affiliate_newsletters.php')

to:- define('FILENAME_AFFILIATE_NEWSLETTERS', 'newsletters.php');

 

That appears to be the admin sorted, however have to look how the front end works now with admin, fingers crossed

 

Johnny


Getting better with mods but no programmer am I.

Share this post


Link to post
Share on other sites

Okay so when setting up a link the image file doesn't show.

 

There are two reasons for this.

 

1. link is down as https instead of http, however this really should be some kind of else so that if https settings is on it will display or off and they will diplay ? needs extra code?

 

2. the affiliate_banner_image is storing the filename of the image only, and not the sub directory where the image actually is.

 

So a_bugs_life.gif on standard install is actually in yourdomain.com/images/dvd, but the code only gets you yourdomain.com/images/

 

if you change the affiliate_banner_image to products_image then this puts the correct path 'dvd' into the link as well.

 

looking at changing this so its automatic, easiest way is to use the products_image I guess, but then whats the point in storing the value in the database?


Getting better with mods but no programmer am I.

Share this post


Link to post
Share on other sites

Hi,

 

I have Affiliates that order products at my store and have referred themselves, hence getting the commission for Affiliate Sales as well. I have set the rules that Affiliates will NOT get commission if they made the purchase themselves. I want to delete that Sales Commission but I do not want to delete the order.

 

Can someone add a DELETE button in Affilate Sales to have the option of deleting a particular Sales Commission? I want to add the Delete button in admin/affiliate_sales.php

 

Something similar to deleting order from admin/orders.php.

 

Thank you very much!

 

(Sorry, I am not familiar with php codes.)


Best regards,

Koh Kho King

Share this post


Link to post
Share on other sites

halo... i'm new one in here. plizz help me for installation OSCAffiliate v.2.8. My question:

1. is oscaffiliate designed for oscommerce which use paypal as payment modul? only paypal? b'couse i use bank transfer solution

2. in INSTALL_ENG.txt, i can't find

################################################################################
##################################


ADMIN ALTERATIONS

In index.php in the admin directory find line 13 approx

 require('includes/application_top.php');

and on a new line add the following code after it:

 require(DIR_WS_CLASSES . 'currencies.php');
 $currencies = new currencies();


In index.php in the admin directory find line 50 approx

array('title' => REPORTS_ORDERS, 'link' => tep_href_link(FILENAME_STATS_CUSTOMERS, 'selected_box=reports')))),

and on a new line add the following code after it:

		   array('title' => BOX_HEADING_AFFILIATE,
				 'image' => 'affiliate.gif',
				 'href' => tep_href_link(FILENAME_AFFILIATE_SUMMARY, 'selected_box=affiliate'),
				 'children' => array(array('title' => BOX_AFFILIATE, 'link' => tep_href_link(FILENAME_AFFILIATE, 'selected_box=affiliate')),
									 array('title' => BOX_AFFILIATE_BANNERS, 'link' => tep_href_link(FILENAME_AFFILIATE_BANNERS, 'selected_box=affiliate')))),


In index.php in the admin directory find line 106 approx

			<td width="140" valign="top"><table border="0" width="140" height="390" cellspacing="0" cellpadding="2">


and replace that line with the following code :

			<td width="160" valign="top"><table border="0" width="160" height="390" cellspacing="0" cellpadding="2">



In index.php in the admin directory find lines 167 to 173 approx

 $contents[] = array('params' => 'class="infoBox"',
				  'text'  => BOX_ENTRY_CUSTOMERS . ' ' . $customers['count'] . '<br>' .
							 BOX_ENTRY_PRODUCTS . ' ' . $products['count'] . '<br>' .
							 BOX_ENTRY_REVIEWS . ' ' . $reviews['count']);

 $box = new box;
 echo $box->menuBox($heading, $contents);

 echo '<br>';

and on a new line add the following code after it:


$affiliate_sales_raw = "select count(*) as count, sum(affiliate_value) as total, sum(affiliate_payment) as payment from " . TABLE_AFFILIATE_SALES . " ";
$affiliate_sales_query= tep_db_query($affiliate_sales_raw);
$affiliate_sales= tep_db_fetch_array($affiliate_sales_query);

$affiliate_clickthroughs_raw = "select count(*) as count from " . TABLE_AFFILIATE_CLICKTHROUGHS . " ";
$affiliate_clickthroughs_query=tep_db_query($affiliate_clickthroughs_raw);
$affiliate_clickthroughs= tep_db_fetch_array($affiliate_clickthroughs_query);
$affiliate_clickthroughs=$affiliate_clickthroughs['count'];

$affiliate_transactions=$affiliate_sales['count'];
if ($affiliate_transactions>0) {
$affiliate_conversions = tep_round($affiliate_transactions/$affiliate_clickthroughs,6)."%";
}
else $affiliate_conversions="n/a";

$affiliate_amount=$affiliate_sales['total'];
if ($affiliate_transactions>0) {
$affiliate_average=tep_round($affiliate_amount/$affiliate_transactions,2);
}
else {
$affiliate_average="n/a";
}
$affiliate_commission=$affiliate_sales['payment'];

$affiliates_raw = "select count(*) as count from " . TABLE_AFFILIATE . "";
$affiliates_raw_query=tep_db_query($affiliates_raw);
$affiliates_raw = tep_db_fetch_array($affiliates_raw_query);
$affiliate_number= $affiliates_raw['count'];


 $heading = array();
 $contents = array();

 $heading[] = array('params' => 'class="menuBoxHeading"',
				 'text'  => BOX_TITLE_AFFILIATES);

 $contents[] = array('params' => 'class="infoBox"',
				  'text'  => BOX_ENTRY_AFFILIATES . ' ' . $affiliate_number . '<br>' .
							 BOX_ENTRY_CONVERSION . ' ' . $affiliate_conversions . '<br>' .
							 BOX_ENTRY_COMMISSION . ' ' . $currencies->display_price($affiliate_commission, ''));

 $box = new box;
 echo $box->menuBox($heading, $contents);

 echo '<br>';

 

i am confused very well @,@ ... one step to crazy... why can I find these script in index.php in admin direction like that said in the note???

3. is that true OSCaffiliate just for mill stone? I use RC2 and install it via fantastico...

Share this post


Link to post
Share on other sites

Hi,

 

I've installed OSC affiliate and have a couple problems, have searched but not found a solution.

 

When a new Affiliate signs up, the confirmation email sent does not contain their details. They just get the following:

 

"Your Affiliate ID is:Your Affiliate Username is:Your Affiliate ID is:Your

Password is:Your Password is:Link to your account:Link to your account:"

 

Any ideas would be appreciated.

Share this post


Link to post
Share on other sites

Hi,

 

I really need some help here before I turn nuts. I have installed osC Affiliate V2.8 Contribution and it work except that I need to login as a regular customer before I can login again as an Affiliate. If I try to login using the affiliate login page it just reload it self. If I login as a regular customer than I am able to login via the affiliate login page using an affiliate account.

 

After i did the testing, i find out is because of the following of the affiliate_summary.php

 

if (!tep_session_is_registered('affiliate_id')) {

$navigation->set_snapshot();

tep_redirect(tep_href_link(FILENAME_AFFILIATE, '', 'SSL'));

}

 

I echo the $_SESSION['affiliate_id'] but i can not display and see the session....but when i can see the session when i echo the session in following function of the includes/functions/sessions.php

 

function tep_session_register($variable) {

global $session_started;

 

if ($session_started == true) {

if (PHP_VERSION < 4.3) {

return session_register($variable);

} else {

if (isset($GLOBALS[$variable])) {

$_SESSION[$variable] =& $GLOBALS[$variable];

echo $_SESSSION['$variable'];

exit;

} else {

$_SESSION[$variable] = null;

}

}

}

 

return false;

}

 

The session is the id of the affiliate.

 

Pls help me...i was try to look up the solution almost 3 - 4 days already...in the end still fail.....I almost want to cry..... :'(

Anyone as an idea on where to look? Can help me?

 

Regards,

Cindy

Share this post


Link to post
Share on other sites
Hi,

 

I've installed OSC affiliate and have a couple problems, have searched but not found a solution.

 

When a new Affiliate signs up, the confirmation email sent does not contain their details. They just get the following:

 

"Your Affiliate ID is:Your Affiliate Username is:Your Affiliate ID is:Your

Password is:Your Password is:Link to your account:Link to your account:"

 

Any ideas would be appreciated.

 

Here's how you fix it. Open store/includes/languages/english/affiliate_signup.php and replace the code there with this:

 

define('NAVBAR_TITLE', 'Affiliate Program');
define('HEADING_TITLE', 'Affiliate Program - Sign Up');

define('MAIL_AFFILIATE_SUBJECT', 'Welcome to ' . STORE_NAME . ' Affiliate Program');
define('MAIL_GREET_NONE', 'Dear %s' . "\n\n");//em001
define('MAIL_AFFILIATE_HEADER', 'Thank you for joining <b>' . STORE_NAME . '</b> Affiliate Program' . "\n\n" .'Your Account Information:
**********************************************'."\n\n");
define('MAIL_AFFILIATE_ID', 'Your Affiliate ID is: %s'  . "\n");
define('MAIL_AFFILIATE_USERNAME', 'Your Affiliate Username is: %s' . "\n");
define('MAIL_AFFILIATE_PASSWORD', 'Your Password is: %s' . "\n");
define('MAIL_AFFILIATE_LINK', 'Link to your account: %s');
define('MAIL_AFFILIATE_FOOTER', 'Have fun earning referral fees!'."\n\n".'Your <b>' . STORE_NAME . '</b> Affiliate Team' . "\n" . 'affiliate@mycigsdirect.com');

 

That will get the user variables into the email and put a line break after each piece of information.

Share this post


Link to post
Share on other sites

I used the fixed-width-container contribution (http://addons.oscommerce.com/info/4910), which makes the center column of the site a fixed width. For some reason, the affiliate seems to ignore this modification. Is there anyway to make it a fixed width and follow the template used in the rest of the site?

Edited by m u r

Share this post


Link to post
Share on other sites
Hi,

 

I have Affiliates that order products at my store and have referred themselves, hence getting the commission for Affiliate Sales as well. I have set the rules that Affiliates will NOT get commission if they made the purchase themselves. I want to delete that Sales Commission but I do not want to delete the order.

 

Can someone add a DELETE button in Affilate Sales to have the option of deleting a particular Sales Commission? I want to add the Delete button in admin/affiliate_sales.php

 

Something similar to deleting order from admin/orders.php.

 

Thank you very much!

 

(Sorry, I am not familiar with php codes.)

 

Ok Good People

Download the full pack from the following links

1. RAR format…. http://www.mediafire.com/file/zjnxqnm3zoz/...iliate_2.8a.rar

OR

2. Zip Format…. http://www.mediafire.com/file/nmdbmldnmen/...Saffiliate.zipx

OR

3. Zipx Format… http://www.mediafire.com/file/zvngyonmzjt/...liate_2.8a.zipx

 

( The Full pack is over 2.50 MB, it contains “ OSCommerce 2.2rc2a “in one folder and “ OSCaffiliate 2.8a full “ in another folder. )

This Pack contains every thing in one. All pervious contributions have been added or removed to make the installation processes as easy as 1234 or abcde.

You don’t have to do anything just upload the full package one by one, as a new install or you can use only the OSCaffiliate core pack….no amending of codes involved. Every thing has been done for you good people.

After installing Just login to your site to test. (all new instructions have been enclosed in the pack)

No language packs have been added except the original english.

So far I made the install process easy…checked admin area out it works. Need to work on adding banners for the affiliates. Checked the affiliate signup and login it work.

I Will be testing the 8 tiers soon ( it takes time). I’m positive it will works as it gave me the option to change in admin area. I have tried this module in JAN 2008 it worked back then.

I Will up date soon on that….mean while you people also should try it out and keep this module going.

If you need to have a feel of the pack before you begin your installation you can check it out here.

Affiliate area http://www.vipcoffeehut.com/testshop

Admin area http://www.vipcoffeehut.com/testshop/admin

Password details are included in the latest install instructions inside the Full Pack

If you have question you can always ask using the live help on the above location.

Share this post


Link to post
Share on other sites

Isn't it strange that there's no "Log Off" option for the affiliate? Does any one have solution?

Also we tested and the affiliate banner doesn't work on MySpace. Anyone has similar issue or solution?

Thank you for your help.

Share this post


Link to post
Share on other sites

regarding logoff issue its there in the left column in catalog ..the last line Affiliate Log out.

I too installed this mod...really nice mo..but its tough for me to understand the flow of this mod .

is there's some document to understand the flow like how admin sets up products and how affiliates add those products to their site etc..

Please reply soon !!

Need help

Share this post


Link to post
Share on other sites
Any new in fixing this???? - I have same problem...

 

best regards M.

 

 

Just to let you know I to have the same problem and have tried renaming the data base tabe checked out all the things my very limited knowledge could and sorry no answers

Share this post


Link to post
Share on other sites

When I try and set up a banner, I get the green bar up top telling me it worked, but the image doesn't upload.

 

I also have Master Products add-on installed -- hopefully there is no conflict there.

Share this post


Link to post
Share on other sites

I tried the mediafire.com links and cannot download. All I get is "Invalid File. This error has been forwarded to MediaFire's development team."

Please advise. Thanks.

 

 

Ok Good People

Download the full pack from the following links

1. RAR format…. http://www.mediafire.com/file/zjnxqnm3zoz/...iliate_2.8a.rar

OR

2. Zip Format…. http://www.mediafire.com/file/nmdbmldnmen/...Saffiliate.zipx

OR

3. Zipx Format… http://www.mediafire.com/file/zvngyonmzjt/...liate_2.8a.zipx

 

( The Full pack is over 2.50 MB, it contains “ OSCommerce 2.2rc2a “in one folder and “ OSCaffiliate 2.8a full “ in another folder. )

Share this post


Link to post
Share on other sites

I am also trying to get the latest affiliate and cant do so because of the invalid file link can anyone help us out withe the file.

 

you can e-mail it to me perhaps, pm me for email address or can someone upload it to the contributions page if possible.

 

Thanks

Jjohnny


Getting better with mods but no programmer am I.

Share this post


Link to post
Share on other sites
I am also trying to get the latest affiliate and cant do so because of the invalid file link can anyone help us out withe the file.

 

you can e-mail it to me perhaps, pm me for email address or can someone upload it to the contributions page if possible.

 

Thanks

Johnny

 

 

Can anyone tell me how to ressolve the banner image problem, banners not showing in product banners?

 

Thanks

 

Johnny


Getting better with mods but no programmer am I.

Share this post


Link to post
Share on other sites

Okay, I have a system thats sort of working.

 

I do have a few issues yet to ressolve, these being the valid cats and valid products files, as they dont appear to work with sts. They do work out side of sts.

 

However rather than try and get them to work, I think they are a little outdated, and think it is time to look at something more user friendly to work with.

 

If I can get something like the select_feautured_products mod to work, ie, search and select a product then I will be much happier, to call a product by its id number, is going to be difficult at best as you would need to know what the product id is for every product, whereas if you have an idea of the product name or model then you can search for a list of, same applies to categories etc I guess.

 

Is there anyone that knows how to do this, I will be having another look at this but it maybe sometime.

 

Thanks

Johnny


Getting better with mods but no programmer am I.

Share this post


Link to post
Share on other sites

Hi all, in the section of contrib "osCaffiliate 2.8a full pack" in a txt the link is down, why?

is it possible have a correct link?

Thanks in advance...

 

Daniele aka Dundi ;-)

Share this post


Link to post
Share on other sites

I"m trying to figure out what field the 2nd tier affiliate ID is recordered in the affiliate table.

I think it is one of these:

 

affiliate_lft affiliate_rgt affiliate_root...

 

Can anyone verify that for me, or tell me which field is actually is?

Share this post


Link to post
Share on other sites

As stated above, all links to mediafire for download of this contribution do not work! Perhaps someone watching this forum has a current zip of osC Affiliate 2.8a that they can share ???

 

Or does someone have an active link for download?

 

Thanks

Share this post


Link to post
Share on other sites
As stated above, all links to mediafire for download of this contribution do not work! Perhaps someone watching this forum has a current zip of osC Affiliate 2.8a that they can share ???

 

Or does someone have an active link for download?

 

Thanks

 

Yes. Download links are all down, can somebody give some links. Waiting for several days, but nobody help!

Share this post


Link to post
Share on other sites

I do not what is happening but... I have installed this module and no sales are being recorded.

Someone has any clue about this kind of behavior?

Share this post


Link to post
Share on other sites
I do not what is happening but... I have installed this module and no sales are being recorded.

Someone has any clue about this kind of behavior?

 

Sales probably are being recorded in the usual way via customers/orders.php etc but I think what you are trying to say is that the affiliates sales are not being recorded.

 

As you have not elaborated on your circumstances I can only presume admin/affiliates are showing the sale and commission etc but when logged in as an affiliate using catalog/affiliate_affiliate.php the affiliate can see no sales. Is this right?

 

If you explain exactly what the problem is, someone will try to help.

Edited by chooch

Upon receiving fixes and advice, too many people don't bother to post updates informing the forum of how it went. Until of course they need help again on other issues and they come running back!

 

Why receive the information you require in good faith for free, only to then have the attitude to ignore the people who gave it to you?

 

There's no harm in saying, 'Thanks, it worked'. On the contrary, it creates a better atmosphere.

 

CHOOCH

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×