Jump to content
henri

OSC-Affiliate

Recommended Posts

affiliate_id	affiliate_lft	affiliate_rgt	affiliate_root
1		1		2		1

Ok lets insert No2 as child of 1:

affiliate_id	affiliate_lft	affiliate_rgt   affiliate_root
1		1		4		1
2		2		3		1

Ok lets insert No3 as child of 1:

affiliate_id	affiliate_lft	affiliate_rgt   affiliate_root
1		1		6		1
2		2		3		1
3		4		5		1

 

No4 is child of 3

affiliate_id	affiliate_lft	affiliate_rgt   affiliate_root
1		1		8		1
2		2		3		1
3		4		7		1
4		5		6		1

 

clear?

 

test it here:

http://www.klempert.de/nested_sets/demo/in...e=r2&node=0

Share this post


Link to post
Share on other sites

Henri, you are a life saver!

 

Thank you so much!


My website's address is in My Profile, since it's not allowed to be in my signature.

Share this post


Link to post
Share on other sites
Henri, you are a life saver!

 

Thank you so much!

Kindly let us know how your fix went, prefereably with coding so others can benefit from it :thumbsup:


Upon receiving fixes and advice, too many people don't bother to post updates informing the forum of how it went. Until of course they need help again on other issues and they come running back!

 

Why receive the information you require in good faith for free, only to then have the attitude to ignore the people who gave it to you?

 

There's no harm in saying, 'Thanks, it worked'. On the contrary, it creates a better atmosphere.

 

CHOOCH

Share this post


Link to post
Share on other sites
From what I read, the categories ones have never worked.

 

The way my shop is set up, it is better for me not to have the categories sections for the affiliates anyway. But I am sure others would like it to work.

One thing I would like though, is for the individual products links to use the thumbnail view instead of the full size image. (My fullsize ones are 800x600+)

 

Also, in the build a product link "Click Here: to view available products." area, I made it show the model number as well as the product name and number, but is it possible to eith show the thumnails as well, or make the number a clickable popup link to show the item?

Another thing I did in the build a products link was to add a forums friendly version of the link, if anyone is interested then please let me know and i will post the changes

Hello, did you finally get the individual product link to use the thumbnail view instead of the full size image.

I'm having the same issue.

Thanks in avance

Share this post


Link to post
Share on other sites

I keep trying this for 2 weeks already, still can't find the solution, some body, help me, please!

 

 

* I'm using this free php hosting - http://www.icshost.org/

 

After installed "osCAffiliate v2.0", I got this error message when I tried to signup as an affiliate:

 

 

1146 - Table '******.affiliate_sales' doesn't exist

 

select count(*) as count, sum(affiliate_value) as total, sum(affiliate_payment) as payment from affiliate_sales

 

[TEP STOP]

 

 

 

When I go to admin section, worse! My "store configuration section" gone!

 

goneiv5.jpg

http://img454.imageshack.us/img454/8977/goneiv5.jpg

 

I really dun know how to insert the new tables?

Share this post


Link to post
Share on other sites

I keep trying this for 2 weeks already, still can't find the solution, some body, help me, please!

 

 

* I'm using this free php hosting - http://www.icshost.org/

 

After installed "osCAffiliate v2.0", I got this error message when I tried to signup as an affiliate:

 

 

1146 - Table '******.affiliate_sales' doesn't exist

 

select count(*) as count, sum(affiliate_value) as total, sum(affiliate_payment) as payment from affiliate_sales

 

[TEP STOP]

 

 

 

When I go to admin section, worse! My "store configuration section" gone!

 

goneiv5.jpg

http://img454.imageshack.us/img454/8977/goneiv5.jpg

 

I really dun know how to insert the new tables?

Share this post


Link to post
Share on other sites
I really dun know how to insert the new tables?

 

Unfortunately, like so many others on this forum, you appear to have installed the contribution in the hope that running the sql file into the database was an optional extra which could be ignored, or else did not read the installation instructions.

 

When a contribution comes with an sql file or files then that file has to be run into the database.

 

To run the sql file:

 

1. Access the database via phpMyAdmin

2. Click on the SQL or Import tab at top-centre of the page.

3. Then use the Browse button to locate the copy of the sql file you have on your computer

4. Click the Go button

5. When it is complete you should see some text which says the import was successful

6. Always backup your database before running SQL queries - just in case.

 

Vger

Share this post


Link to post
Share on other sites
Unfortunately, like so many others on this forum, you appear to have installed the contribution in the hope that running the sql file into the database was an optional extra which could be ignored, or else did not read the installation instructions.

 

When a contribution comes with an sql file or files then that file has to be run into the database.

 

To run the sql file:

 

1. Access the database via phpMyAdmin

2. Click on the SQL or Import tab at top-centre of the page.

3. Then use the Browse button to locate the copy of the sql file you have on your computer

4. Click the Go button

5. When it is complete you should see some text which says the import was successful

6. Always backup your database before running SQL queries - just in case.

 

Vger

 

This part I did million times, I spend 2 weeks to figure out, I reinstalled the whole script more than 10 times, I read the instruction very carefull, but it doesn't help!

Share this post


Link to post
Share on other sites

Do those tables exist in the database? If they do then you didn't add them to the includes/database_tables.php files.

 

Vger

Share this post


Link to post
Share on other sites

Hi,

 

I osCAffiliate v2.6 and the bug fix associated with it. I keep getting the following basic error in several of the Admin options for this contribution. Here is an example of one of the error messages:

 

__________________

 

Page: /affiliate_affiliates.php?listing=id-desc

 

 

Affiliates Search:

1064 - You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near '-20, 20' at line 1

 

select * from affiliate_affiliate order by affiliate_id DESC limit -20, 20

 

[TEP STOP]

 

__________________

 

I can't find limit mentioned anywhere in the source files. I just installed this and we do not currently have any affiliates. So perhaps it is upset since there are no affiliate entries in the database yet?

 

We are running MySQL client version: 4.1.15

 

 

The other issue that I have been having is with the affiliate application. I filled it out and received this error:

 

Warning: mail() [function.mail]: SMTP server response: 501 5.5.4 Invalid

Address in

C:\hshome\athink\athletesink.com\catalog\includes\classes\email.php on

line 502

 

Warning: Cannot modify header information - headers already sent by

(output started at

C:\hshome\athink\athletesink.com\catalog\includes\classes\email.php:502)

in

C:\hshome\athink\athletesink.com\catalog\includes\functions\general.php

on line 29

 

 

 

 

Any help would be appreciated.

 

Thanks!

Edited by aink

Share this post


Link to post
Share on other sites
Kindly let us know how your fix went, prefereably with coding so others can benefit from it :thumbsup:

 

Well, i really didn't "fix" anything, what i did was program all the users into the applet at his "Test it here" link, then i went into the SQL tables and manually edited them

 

the problem was i had no idea they were nested set's, or even what nested sets were at the time. I've read a couple more articles on them now, and understand it enough that i can make all the edits i need manually.

 

Unfortunately it seems that PHP/SQL coding is above me, way above. I'd gladly work with anyone who thought they could do that end of the coding, to help with the nested set's side of things, as well as helping to integrate it (i understand how OSCommerce works well enough to know what files do what)

 

Unfortunately i cant really shed any more light on what i did, since it was a very specific "he should have hierarchy over her", when the cookie had failed to do it for some reason. Once i learned about nested set's, I just made the change that was required.


My website's address is in My Profile, since it's not allowed to be in my signature.

Share this post


Link to post
Share on other sites

Hi everyone,

I have searched google for this little issue I'm having. I have been playing around creating some general banners, product banners and category banners. What I notice is that when I create a category banner, it also gets placed under the website banners link (as well as the category banners link). This doesnt happen when I create a product banner (which just gets included under the product banners link).

 

Is this a known issue? Is there a solution out there?

 

Many thanks/ Luke

Share this post


Link to post
Share on other sites

hey everyone, does the osc affiliate system generate a code for your affililiate so they can put a banner on their site, ergo where the tracking comes in, in the osc admin?

 

or, does it just give them a code and they make the purchase for the people they bring in? i hope what i am asking makes sense

Share this post


Link to post
Share on other sites
The contribution is just one big mess now. I wouldn't use anything after v2.5a plus a few bug fixes.

 

Vger

 

 

hey Vger, would you say that 2.5a is the best version if i wanted to do an install over the next couple of days?

Edited by tec

Share this post


Link to post
Share on other sites
Unfortunately i cant really shed any more light on what i did, since it was a very specific "he should have hierarchy over her", when the cookie had failed to do it for some reason. Once i learned about nested set's, I just made the change that was required.

I have seen the preview of the next release and that 'nesting' stuff is covered in there but obviously that has been pending for 4 months so i don't think it is wise to wait for it as it may be a long time away. Good luck with your modifications.


Upon receiving fixes and advice, too many people don't bother to post updates informing the forum of how it went. Until of course they need help again on other issues and they come running back!

 

Why receive the information you require in good faith for free, only to then have the attitude to ignore the people who gave it to you?

 

There's no harm in saying, 'Thanks, it worked'. On the contrary, it creates a better atmosphere.

 

CHOOCH

Share this post


Link to post
Share on other sites

Hi there, ok, I have successfully, install the lastest version of the OSC-affiliate, using the STS 4 PLUS system.

 

Now, my question is this...when i go to admin>affiliates>payment

 

there is a button that says 'start billing' is this the button you press to make the payments to the affilates?

 

also, during testing, as an affiliate I made a few sales, now, my payout amount is set to $50.00.

these sales are not showing up under asdmin>affiliates>payment

 

will they only show up there once that affilates account has reached the $50.00 mark?

 

thnx muchly

Share this post


Link to post
Share on other sites

hi again, :)

ok, i lowered the Payment Threshold to 0.05, my affilate sales total equals 0.12, which means i have enough to receive payment, but still, when i go into the admin>affiliates>payment

i still dont see anything

 

please, anyone? this is the last thing i need to do and the site can go live :)

Share this post


Link to post
Share on other sites

sory folks, wouldnt let me edit my post

here are the settings for the configuration>affiliates

affsettings.jpg

Share this post


Link to post
Share on other sites
I have seen the preview of the next release and that 'nesting' stuff is covered in there but obviously that has been pending for 4 months so i don't think it is wise to wait for it as it may be a long time away. Good luck with your modifications.

I am using the OSC-affiliate contribution. When I "build a product link" the images show up as the original size(which is quite big) Do you know how to resize the images or make it smaller?Any help will be appreciated. I have looked thru this forum twice already.

People have talk about it for a moment but, I have found no solution.

Thanks in advance.

Share this post


Link to post
Share on other sites

Tec - all of your recent questions would be answered by reading the files that come with the contribution.

 

Britney - the image size used is the same as you upload. If you want it to be smaller then use smaller images.

 

Vger

Share this post


Link to post
Share on other sites

haha, that is what i like about you Vger, you have always been efficient when it comes to getting the point accross. I will take another run through the docs. I have had many late nights lately so its likely i missed something :)

 

hahaha, all be forwarned, i shall return if my quest is not fullfilled :)

 

thanks vger :)

Share this post


Link to post
Share on other sites

hey there, ok, i looked, and looked,...the only doc i have is an install doc that doesnt mention anything about the sales section...i went back and looked at the install doc for 2.5a and nothing mentioned there either

 

this is all it says...nothing about the sales section in the admin

 

 

******** TO USE THIS MODULE **********

 

All you will need to do is go into your stores admin and select the store configuration section.

You will find a tab under this section called Affiliate Configuration. Select this tab and and

set up your basic info such as affiliate rate percent, contact email etc.

 

Then move into the Affiliate Section of your store's admin and setup Banners, Links etc.

 

Taxes:

It's possible to use taxes on the affiliate provision. At the moment you can adjust the settings in the

affiliate_configure.php file located in the admin/includes/ folder.

 

Please tell us, if you handle the taxes for provisions in an other way at your country.

Share this post


Link to post
Share on other sites

ok, back again...miss me yet? hahaha

 

i am trying to remove fields from the affliliate sign up page, I havae managed to do it successfully under edit account for the affiliate but....

 

I want to remove all address info, phone number, fax

 

all i want is name, email addy and paypal address, but when i try to remove these fields, and sign up as an affiliate, when i click 'continue' button it doesnt do anything, just reloaded the affiliate sign up page again with the info i had put in it

 

thoughts? hahaha, i know this one aint in the read me doc

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×