Jump to content
henri

OSC-Affiliate

Recommended Posts

Hope all is well,

 

I'm baffled....

 

Everything on the affiliate module works except the affiliate payments side.

 

I don't understand how the affiliate member can request a payment....there are no buttons?

 

Also the payment report has no figures...it's not working....does it actually work?

 

or is it incomplete and

 

so it is up to us the ones that use the module to fix that up our selves or

 

is there a solution that someone has done to make this side of the module work?

 

I've insatlled 2.5a Osc affiliate

Apart from that the comissions, links and every other aspect are sound

Any information or help would be really appreciated

 

Please :'(

Share this post


Link to post
Share on other sites
Hope all is well,

 

I'm baffled....

 

Everything on the affiliate module works except the affiliate payments side.

 

I don't understand how the affiliate member can request a payment....there are no buttons?

 

Also the payment report has no figures...it's not working....does it actually work?

 

or is it incomplete and

 

so it is up to us the ones that use the module to fix that up our selves or

 

is there a solution that someone has done to make this side of the module work?

 

I've insatlled 2.5a Osc affiliate

Apart from that the comissions, links and every other aspect are sound

Any information or help would be really appreciated

 

Please :'(

 

 

Uh huh!

 

I think I can answer my own question...the date on the affiliate commission sales need to be at least 30 days old (as a minimum) in order for the billing to work.

 

I wonder is that such a good idea (to make them wait for 30 days)?

Share this post


Link to post
Share on other sites

Yes, it's a good idea to make them wait for 30 days. What if you get something purchased which is returned?

 

Vger

Share this post


Link to post
Share on other sites
The links work perfectly... Only the images don't show...

 

I am having the same problem. Links created by affiliate work but do NOT show pic.

Links created by ADMIN do NOT work or show pic. The admin link that is created is: <a href="http://www.montebellokitchens.com/montebellokitchens/catalog/index.php?ref=1&affiliate_banner_id=7" target="_blank"><img src="http://www.montebellokitchens.com/montebellokitchens/catalog/affiliate_show_banner.php?ref=1&affiliate_banner_id=7" border="0" alt="sel 2"></a>

 

Somewhere it is getting and extra MONTEBELLOKITCHENS before /catalog

 

Anyone have a suggestion that may help?

Share this post


Link to post
Share on other sites

Some time ago there was code posted here showing how to change the files in such a way that, once a customer registered through an affiliate, he would always be recognized as a customer of that affiliate (i.e. the affiliate would always get comission for the life time of that particular customer) irrespective of any cookie life.

 

Now, reading through 92 pages I can't find that code. :(

 

Anybody who knows what changes need to be done and where?

Share this post


Link to post
Share on other sites
I am having the same problem. Links created by affiliate work but do NOT show pic.

Links created by ADMIN do NOT work or show pic. The admin link that is created is: <a href="http://www.montebellokitchens.com/montebellokitchens/catalog/index.php?ref=1&affiliate_banner_id=7" target="_blank"><img src="http://www.montebellokitchens.com/montebellokitchens/catalog/affiliate_show_banner.php?ref=1&affiliate_banner_id=7" border="0" alt="sel 2"></a>

 

Somewhere it is getting and extra MONTEBELLOKITCHENS before /catalog

 

Anyone have a suggestion that may help?

 

I've seen it too. The solution : put your banner with your ftp on catalog/images/

Then tape the same name with extension (.gif, .jpg...) in the admin panel.

 

I've an error message on Admin with the Affiliate News / Announcements

 

1146 - Table 'oscdemo.TABLE_AFFILIATE_NEWS_CONTENTS' doesn't exist

 

select news_id, affiliate_news_headlines as headline, affiliate_news_contents as content, news_status from affiliate_news, TABLE_AFFILIATE_NEWS_CONTENTS where news_id = affiliate_news_id and affiliate_news_languages_id = '2' order by date_added desc

 

[TEP STOP]

What can I do ?

Share this post


Link to post
Share on other sites

Either you didn't install the sql file correctly into the database, or you didn't add the extra tables to the two database_tables.php files.

 

Vger

Edited by Vger

Share this post


Link to post
Share on other sites

hello everyone. i have browsed through almost this entire topic (phew) but didn't really get the answer what is wrong with my tier system. it currently only works for 2 tiers no matter what settings i use. i have the individual rates turned off, tiers set to 4 and percentages for tiers fixed. i created users like they should be created and tested purchases from different ips. i am however using a polish translation which i made myself but it shows no errors for me anywhere so that should be ok. i'm using oscA 2.5a.

Share this post


Link to post
Share on other sites
Does this contribution work with Ultimate SEO URL?

Yes and No....

 

...... even though your affiliate URL's still end with php it doesn't affect in anyway the userbility of the affiliates contribution or the SEO contribution.

Edited by chooch

Upon receiving fixes and advice, too many people don't bother to post updates informing the forum of how it went. Until of course they need help again on other issues and they come running back!

 

Why receive the information you require in good faith for free, only to then have the attitude to ignore the people who gave it to you?

 

There's no harm in saying, 'Thanks, it worked'. On the contrary, it creates a better atmosphere.

 

CHOOCH

Share this post


Link to post
Share on other sites
but didn't really get the answer what is wrong with my tier system. it currently only works for 2 tiers no matter what settings i use. i have the individual rates turned off, tiers set to 4 and percentages for tiers fixed.

I remember playing around with this contribution in the early days of it's release and clocked on to the fact that number of tiers can't go beyond two - I never looked deeply in to the reason why that happens but maybe someone else can.

Edited by chooch

Upon receiving fixes and advice, too many people don't bother to post updates informing the forum of how it went. Until of course they need help again on other issues and they come running back!

 

Why receive the information you require in good faith for free, only to then have the attitude to ignore the people who gave it to you?

 

There's no harm in saying, 'Thanks, it worked'. On the contrary, it creates a better atmosphere.

 

CHOOCH

Share this post


Link to post
Share on other sites

The cookie lifetime (in seconds) is the allowed time between someone coming to your site from an affiliate site and them buying something. One day would be 86400 seconds, one week 604800, the default setting is only for 2 hours.

 

I think the tier level of 2 is hardcoded into the contrib.

 

Vger

Share this post


Link to post
Share on other sites

I thought a good cookie lifetime could be one week? How long times do you have?

 

So if a someone clicks my banner and he/she comes to my site inside the week to buy it will be recorded as a buy?

 

Does this effect to my database size anyway, so the cookies wont be safed to my database?

Share this post


Link to post
Share on other sites
I think the tier level of 2 is hardcoded into the contrib.

Vger

 

are you certain? i remember reading in this thread that someone reported that more then 2 tiers of affiliates worked for him. hmm

Share this post


Link to post
Share on other sites

No, I'm not 100% certain, and that's why I said "I think". It's been a while since I went through all of the coding but I thought that '2' was hardcoded somewhere.

 

Vger

Share this post


Link to post
Share on other sites

How about if customers click two banners in different sites before he buys? Do I have to pay for both?

Share this post


Link to post
Share on other sites
How about if customers click two banners in different sites before he buys? Do I have to pay for both?

1. The easiest way to find out is for you to create 2 or more affiliate accounts on your osC store and test it out yourself and give us all a review of your experiment so we can benefit from it.

 

2. In my 'opinion' I would say that if a purchaser clicked on 100 banners from 100 sites and then decided to buy via an affiliate link on site 101 - there is no way 101 affiliates get paid for the same sale, and if there are 101 tiers involved then that figure could rise to 202....

 

..... so that probably would mean the first or the last affiliate (and co-associated tier) would be the ones who the sale would be registered/credited with.

 

When I did a brief test with this many blue moons ago I think the actual click from where the sale was made would be the one that gets credited with the sale, not any of the other sites.


Upon receiving fixes and advice, too many people don't bother to post updates informing the forum of how it went. Until of course they need help again on other issues and they come running back!

 

Why receive the information you require in good faith for free, only to then have the attitude to ignore the people who gave it to you?

 

There's no harm in saying, 'Thanks, it worked'. On the contrary, it creates a better atmosphere.

 

CHOOCH

Share this post


Link to post
Share on other sites
The cookie lifetime (in seconds) is the allowed time between someone coming to your site from an affiliate site and them buying something. One day would be 86400 seconds, one week 604800, the default setting is only for 2 hours.

WOW-WEE! :'(

 

You learn new things all the time. I never knew a day had 86400 seconds.

 

Thanks for the conversion rates - Vger

Edited by chooch

Upon receiving fixes and advice, too many people don't bother to post updates informing the forum of how it went. Until of course they need help again on other issues and they come running back!

 

Why receive the information you require in good faith for free, only to then have the attitude to ignore the people who gave it to you?

 

There's no harm in saying, 'Thanks, it worked'. On the contrary, it creates a better atmosphere.

 

CHOOCH

Share this post


Link to post
Share on other sites

Hi,

does anyone know how the stats are reset in the user's affiliate account once i payed him/her? Also affiliate stats in admin section.

 

I can't seem to find this on this contribution

Or do we need to change that manually into mysql database each month when affiliate payments are done?

 

Also, i would like to know how i can prevent the payment of optional prices to the affiliate

For example if a product costs $100 and the buyer chooses a $19 option extra, how can i prevent my affiliates from getting a share of this $19 too?

I want him to have only a percantage of that $100

 

Michael

Edited by Michaelaff

Share this post


Link to post
Share on other sites

Since i can't seem to edit my original post:

 

Also, i would like to know how i can prevent the payment of optional prices to the affiliate

For example if a product costs $100 and the buyer chooses a $19 option extra, how can i prevent my affiliates from getting a share of this $19 too?

I want him to have only a percantage of that $100

 

 

Maybe a solution to this would be to pay the affiliate a fixed price.

Is that possible to do this with this contribution.

So instead of 25% commission, give affiliate $10 per sale or something.

 

Possible? If so, how?

 

Michael

Share this post


Link to post
Share on other sites

I have similar problem as michael.

 

in admin/affiliate_affiliates.php I can see the commission to the affiliate but how can I reset it after I 've paid his share?

 

And in admin/affiliate_payment.php there isnt nothint.. First time I tested there was something but I pressed "start billing" and everuthing dissapeared and now there's nothing coming.

Share this post


Link to post
Share on other sites

Where you see the commission to the affiliates that's the total commission, so you can't reset it.

 

When you press 'Start Billing' you are electing to pay the outstanding (unpaid) commissions - so of course they disappear, they're no longer 'unpaid'.

 

If you go to the start of this thread and read through you'll find your questions asked and answered many times.

 

Vger

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×