Jump to content
henri

OSC-Affiliate

Recommended Posts

If I use this variable products commission (http://www.oscommerce.com/community/contributions,1580), how should I set the Affiliate contrib in the Admin section? We have the Affiliate contrib and it seems to be working OK.

 

Anyone using both with no trouble?

 

DKM

Once you do it, please let us know how it went and what you think of the contribution... it'll help a lot of people make up there minds on this one - thanks


Upon receiving fixes and advice, too many people don't bother to post updates informing the forum of how it went. Until of course they need help again on other issues and they come running back!

 

Why receive the information you require in good faith for free, only to then have the attitude to ignore the people who gave it to you?

 

There's no harm in saying, 'Thanks, it worked'. On the contrary, it creates a better atmosphere.

 

CHOOCH

Share this post


Link to post
Share on other sites

What i mean is that i look for a way to keep the affiliate ref visible during the complete session of an custommer. Now the affiliate ref dissapears after the first click.

 

I was thinking there was a way to make this happen but can not remember how.

Hope someone nows this.

Share this post


Link to post
Share on other sites

im getting errors when you are signing up as an affiliate and dont input filds right.

it will throw the mysql error at the top of the page, not the normal generated error messgae in a red div

 

also when the signup fails what page is being loaded. im formatting the input fields and colors on my pages and i have to change the doctype on all my pages, and i can easily see if i havent changed it on any page by the text getting all messed up. and i already changed it on affiliate_signup.php but when i fial the signup the text all all messed up so im guessing its loading a seperate php file


Check out my fully customized oscommerce site by viewing my profile.

Share this post


Link to post
Share on other sites
Ok sorted my problem out, created a field in customers table and write to there, then in Affiliate_checkout_process check for the refere id being set and then give commision, quite easy really, just took a little figuring out.

 

Dear Ally,

I believe that what you accomplish is what I have been looking for, for the past few days.

Let me explain to see if this is what you have:

Since not everybody has a website, but I still want people with out a website to become affiliates to earn commission and bring my needed sales to my site, I need for a way of adding like a coupon code at the affiliate_signup.php so that they can give this coupon code to their customers or friends, so that wend the customer or fried come to my site they can either enter this coupon code at the create_account.php or at the checkout_payment.php and I could still track down from what affiliate the sale came from???

Is kind of combining the REFERRAL POINT SYSTEM and the OSCAFFILIATE

If this is what you have, could you tell me how to do it..

 

I hope you are the one that will solve my puzzle.

 

Regards,

Cool

:rolleyes:

Share this post


Link to post
Share on other sites

Hi All,

 

Just a quick question, when 'building a link' ratehr than being able to select a product using my allocating product codes, the contirbution appears to be using the numbers to pull product id's from the database, in teh same way teh category's are numbered and they can be selected by number....is this correct? Is there anyway round it so my affiliates can use the product code i have allocated?

 

Hope this makes sense

 

Best Regards

 

Donna

Share this post


Link to post
Share on other sites

Hi Everyone,

 

I have installed the affiliate program on my shop, all was well in the install however I have to following problem.

 

In admin - affiliates - admin - affiliates I have signed myself up as an affiliate, but there is no record on the admin side of things saying that there are any affiliates.

 

How can I fix this? Does anyone know what I've done wrong?

 

Cheers,

Dave.

Share this post


Link to post
Share on other sites
In admin - affiliates - admin - affiliates I have signed myself up as an affiliate, but there is no record on the admin side of things saying that there are any affiliates.

Have you installed/FTP'd the affiliate_summary.php file to the admin?

Edited by chooch

Upon receiving fixes and advice, too many people don't bother to post updates informing the forum of how it went. Until of course they need help again on other issues and they come running back!

 

Why receive the information you require in good faith for free, only to then have the attitude to ignore the people who gave it to you?

 

There's no harm in saying, 'Thanks, it worked'. On the contrary, it creates a better atmosphere.

 

CHOOCH

Share this post


Link to post
Share on other sites

<tr>
		<td class="main" colspan=2>If you want to link the Banner to a specific CATEGORY enter its CATEGORY ID here. If you want to link to the default page enter "0"</td>

	  </tr>
	  <tr>
		<td class="main" colspan=2>  </b><a href="java script:popupWindow('http://XXXXX/admin/FILENAME_AFFILIATE_VALIDCATS')"><b>Click Here:</b></a>  to view available CATEGORIES.</td>

 

Hi all, this is the problem i meet - FILENAME_AFFILIATE_VALIDCATS

Look likes i make the mistake ...

Could you tell me which filename i should re-check again ?

Thanks you..

Share this post


Link to post
Share on other sites

Does anyone know how to get this to work with Ultimate SEO URLS?

 

Thank you for any help


Eric

 

Keep up on osCommerce changes and updates at

Github | Understand osCommerce a little further at OsCommerce Documentation | Copy and paste your error message in Google add "in osCommerce" at the end to get relevant answers to most issues.

Share this post


Link to post
Share on other sites
Does anyone know how to get this to work with Ultimate SEO URLS?

 

Thank you for any help

Well, what problems are you having? Error messages? Which error messages are stumping you?


Doctor Mason, World's #1 "Temporary Webmaster"

Share this post


Link to post
Share on other sites
Does anyone know how to get this to work with Ultimate SEO URLS?

 

Thank you for any help

I didn't know it wasn't working with SEO's... mine works fine.


Upon receiving fixes and advice, too many people don't bother to post updates informing the forum of how it went. Until of course they need help again on other issues and they come running back!

 

Why receive the information you require in good faith for free, only to then have the attitude to ignore the people who gave it to you?

 

There's no harm in saying, 'Thanks, it worked'. On the contrary, it creates a better atmosphere.

 

CHOOCH

Share this post


Link to post
Share on other sites
It's a repetitve question......

 

There's no need for a fix as nothing is wrong... the billing question you asked was answered sometime ago, go back a few pages. Read it.

 

At least you tell me which page is.... >_< <_<

 

by the way...how do i set....manually...INDIVIDUALLY.....sales percentage??

 

Like... product A : 3%

product B : 10%

'' C : 50%

 

can i do that?

Share this post


Link to post
Share on other sites
At least you tell me which page is.... >_< <_<

 

by the way...how do i set....manually...INDIVIDUALLY.....sales percentage??

 

Like... product A : 3%

product B : 10%

'' C : 50%

 

can i do that?

The whole idea of the support thread is for people to read them to find a possible fix before posting a question that already has been asked and answered. It took took me around 4 minutes to go back and skip through the posts to find that page - you can find it too.

 

The answer is to the question is no, you cannot set the date to zero and start billing affiliates. The fact that you posted your original query on 28th April and that today is 28th May means we are on day 31 from your post, so if you try billing now, it will work.

 

There is a more complicated way to do it to manipulate the affiliates module in processing the billing immediately but it's slightly awkward so I won't go in to it yet.

 

The tough part of this is to actually have to wait for 30 days after installing before you know that the billing works and that the affiliates module was added correctly or not, but we were all in the same boat.

 

Try your billing now, it should work.


Upon receiving fixes and advice, too many people don't bother to post updates informing the forum of how it went. Until of course they need help again on other issues and they come running back!

 

Why receive the information you require in good faith for free, only to then have the attitude to ignore the people who gave it to you?

 

There's no harm in saying, 'Thanks, it worked'. On the contrary, it creates a better atmosphere.

 

CHOOCH

Share this post


Link to post
Share on other sites
I didn't know it wasn't working with SEO's... mine works fine.

 

Sorry it was my browser that needed to be refreshed. Sorry for the miss hap.

 

Thanks,


Eric

 

Keep up on osCommerce changes and updates at

Github | Understand osCommerce a little further at OsCommerce Documentation | Copy and paste your error message in Google add "in osCommerce" at the end to get relevant answers to most issues.

Share this post


Link to post
Share on other sites
That's an excellent explanation, and the missing piece of the puzzle.

 

I'm assuming that if your 1st Tier rate is 10% and your 2nd Tier rate is 2%, then sales generated by the 2nd Tier affiliate cost the site owner 12% - 10% for the 2nd Tier Affiliate and 2% for the 1st Tier affiliate.

 

Sorry but still not understood.

 

I've a default commission rate, for affiliate of 18%

Now I want to set-up affiliate-tier program.

I set a commission of 10.00;5.00

Now, the situation is:

- Master Affiliate: it earns 18%. The site cost is 18%

- 2tier Affiliate: It earns 10%. Master affiliate ears 5%. The site cost is 15%

 

Is this right?

 

Or have I to set the tiers percentage as master commission? In my case for example: 18.00;7.00

And so:

- Master Affiliate: it earns 18%. The site cost is 18%

- 2tier Affiliate: It earns 18%. Master affiliate ears 7%. The site cost is 25%

 

Thanks for the time answering.

Share this post


Link to post
Share on other sites

If your default rate for main affiliates is 18% and the second tier affiliate level is 10% then each time a second tier affiliate generates a sale they get the 18% and the first level (main) affiliate gets the 10% - 28% in all.

 

Vger

Share this post


Link to post
Share on other sites

Nice to see you got the hang of that Vger, nearly rolls off the tongue now eh :P

 

Sorry but still not understood.

 

I've a default commission rate, for affiliate of 18%

Now I want to set-up affiliate-tier program.

I set a commission of 10.00;5.00

Now, the situation is:

- Master Affiliate: it earns 18%. The site cost is 18%

- 2tier Affiliate: It earns 10%. Master affiliate ears 5%. The site cost is 15%

 

Is this right?

 

Or have I to set the tiers percentage as master commission? In my case for example: 18.00;7.00

And so:

- Master Affiliate: it earns 18%. The site cost is 18%

- 2tier Affiliate: It earns 18%. Master affiliate ears 7%. The site cost is 25%

 

Thanks for the time answering.

 

Right back to business:

 

SCENARIO ONE: Basically, just forget affiliates for a moment. You set an affiliate rate at 18%. You affiliate (affiliate A) adds some text links on their site which brings customers to your site and they buy some items from you. This means affiliate A will get 18% of the sale so to speak - simple.

 

SCENARIO TWO: You set the 'use tier levels' to true and set levels at 18.00;7.00 What will happen is that affiliate A has introduced affiliate B to you via his site, therefore if any sale is made on affiliate A's site he is not subjected to tiers as he was not introduced via another affiliate.

 

In the meantime a customer arrives at your store via a link from affiliate B's webite and generates a sale. affiliate B will get the 18.00 part of the sale and affiliate A will get 7.00 of the sale. Basically 25% in total.

 

You must make sure you get the figures right or all hell will break loose. If you set the master affiliate at 18% then the tier must be set at 18.00 and whatever 2nd rate you want (1%, 4%, 7%) the reason is because you can't tell an affiliate they will get less money than a master rate because they were 'introduced'

 

The way you should tackle this is by having a reasonable master rate (and SAME higher tier rate) followed by a very small tier rate just keep the introducers happy.

 

I am using 10% for the master rate and the tier is set up as 10.00;2.25 so this way I will pay between 10-12.25% per affiliate sale.

 

For example sake: You can of course set the tier to whatever you want and also the individual percentage rate so that a master rate for a very good performing affiliate is 18% and your average ones get 12% but

do bare in mind you have to advertise your rates and adjust them after informing your affiliates that they will get the more beneficial rate.

 

Hope that helps... if it doesn't, please use your catalog to create an affiliate and then generate some code to fake a tier affiliate by creating another, so you have two affiliate accounts - one on each tier. Then, make lots of test sales adjusting the rates and tier levels etc and look at what happens in admin/affiliate_sales.php

Edited by chooch

Upon receiving fixes and advice, too many people don't bother to post updates informing the forum of how it went. Until of course they need help again on other issues and they come running back!

 

Why receive the information you require in good faith for free, only to then have the attitude to ignore the people who gave it to you?

 

There's no harm in saying, 'Thanks, it worked'. On the contrary, it creates a better atmosphere.

 

CHOOCH

Share this post


Link to post
Share on other sites

guys - a little problem I have -

IPN doesn't want to work together with osCAfilliate --

simply transactions are not being registered in affiliate sales

 

---------- what I did -

1. created affiliate account

2. generated a link and placed it on outside site

3. used link to buy

 

and nothing - no trace of transaction in affiliate sales record - other ways (cc, COD, check/money order) work fine.

does it have anything to do with outside payment processing gateway?

 

any thoughts to get me out of misery ?

---

your HM tankman

Share this post


Link to post
Share on other sites

The osCommerce Pay Pal IPN duplicates part of checkout_process in its file set, and uses that instead of the standard checkout_process. osC Affiliate has its own file set, including its own application_top. Therein lays the problem!

 

Vger

Share this post


Link to post
Share on other sites

I came across a situation:

================

 

When I tested mod in default language (English) in affiliate payment (file: affiliate_payment.php) all was fine.

But in other languages there was a problem.

Here's description:

1. example - default language :

Your Payments: 2

Payment-ID [?] Payment Date [?] Affiliate Earnings [?] Payment Status [?]

2-------------------06/01/2006-----------------GBP11.57----------------Paid

1-------------------05/31/2006-----------------GBP17.19----------------Paid

 

Displaying 1 to 2 (of 2 payments) Result Pages: 1

 

Your current earnings amount to: GBP28.76

 

2. example - Other language exmaple (I leave it in English - untranslated, but that what it shows in another LangMod)

 

Your Payments: 0

 

Payment-ID [?] Payment Date [?] Affiliate Earnings [?] Payment Status [?]

 

No payments have been recorded yet.

 

Your current earnings amount to: GBP28.76

 

================

Please note: a. Your payments = 0, and no payments recorded.

 

I still analize code, but at this point unsuccessfully (no wonder, my adventure with PHP, MYsql is pretty fresh).

this not for a client, so no rush, but if anyone points me in the right direction and help me to understand - I appreaciate very much.

 

jeffz

jeffz

Share this post


Link to post
Share on other sites

There is a problem with the language file set in admin. The catalog side German language files were used in the admin side. If you haven't noticed this then you need to delete all admin/includes/languages/german/ files and replace them with the admin/includes/languages/english/ files

 

Vger

Share this post


Link to post
Share on other sites
There is a problem with the language file set in admin. The catalog side German language files were used in the admin side. If you haven't noticed this then you need to delete all admin/includes/languages/german/ files and replace them with the admin/includes/languages/english/ files

 

Vger

Hello Vger,

Thank you for your reply...

and yupp .. I haven't noticed that - since I do not use german ...

but that has nothing to do with that little problem I noticed (at least I think so).

 

to recreate this problem do as follows:

1. Login to osCAffiliates (I,m testing v. 2.5)

2. go to: affiliate reports -> payment report (use English and it would be good if you have any transactions there - otherwise the flaw will not show)

3. now switch to another language - any language really apart from default English

and you see the difference - transactions will disappear - leaving only info: "No payments have been recorded yet." (even thou they are there), the number of transactions will be reduced to zero and total at the bottom will show amount of missing transactions.

 

See: my previous post for example regarding mentioned differences

 

regards,

Jeffz

Share this post


Link to post
Share on other sites

I think you'll find that if someone comes to your site from an affiliate but that their default language is not english then their transaction will only show (as an inidividual transaction - not as part of the total) when you're viewing admin in their language.

 

It's not my contribution so I am not 100% sure on this, but I don't think that the affiliate system was originally built to be multi-language. Over time language files for other languages have been added to it but I don't think that the core code has been altered.

 

Vger

Share this post


Link to post
Share on other sites
I think you'll find that if someone comes to your site from an affiliate but that their default language is not english then their transaction will only show (as an inidividual transaction - not as part of the total) when you're viewing admin in their language.

 

It's not my contribution so I am not 100% sure on this, but I don't think that the affiliate system was originally built to be multi-language. Over time language files for other languages have been added to it but I don't think that the core code has been altered.

 

Vger

 

Yupp,

That was also my innitial recollection of this situation.

But on the other hand Sales section works fine, so maybe it is just some not necesarily flawless coding?

I will work on that, the only "harm" which may come out of that is that I get to know php better :)

 

 

Jeffz

Share this post


Link to post
Share on other sites

I noticed a disturbing problem

I tested that on customized version, but also same problem appears on standard new installation.

 

 

Here's description:

1. I created 2 separate acounts for 2 affiliates

2. prepared and placed two banners (one for each affiliates with approprate code -

....php?ref=1&affiliate_banner_id=2

....php?ref=2&affiliate_banner_id=2)

3. banners were placed on defferent www sites for testing.

---problem bottom line:

when I tried to test both banners I noticed, that always affiliate with higher ID number gets entire credit for all transactions and nothing gets credited to account of second affiliate.

 

Have anybody experienced anything sililar?

 

---- and another thing

automatic billing fails to take effect even

when biling time (in admin/configuration/affiliate) is set to eg. one day.

 

jeffz

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×