Jump to content
henri

OSC-Affiliate

Recommended Posts

Yup, thats working fine now... many thanks for saving the day again Phocea :-)

 

this great contribution looks like it just got better!

 

@chooch:

I installed the affiliate cotrib, too and I think I?ll have the same trouble (not tested, yet).

 

Could you please send me your modified files or set them into the contrib-section as contrib additional download ?

 

i think there will be many users which will have the same problems.

 

Great Contrib !!


OSC Webmakers Edition modiefied with many other contribs and enhancements.

+ STS 4.5.7 for 2.2MS2 and RC1

Share this post


Link to post
Share on other sites

Small bug:

 

When opening

"Click Here: to view available products."
a new windows starts and lists all available products for affialiates.

 

But there is a

"&nbsb"
before each product number so that it looks like this: :o

 

&nbsp50 "TEST"

&nbsp9 Alarmstufe: Rot

&nbsp10 Alarmstufe: Rot 2

&nbsp5 Blade Runner - Director's Cut

&nbsp38 Contact Lenses

&nbsp8 Das Gro?e Krabbeln

&nbsp4 Die Ersatzkiller

&nbsp33 Die Hard out of stock

&nbsp24 Disciples: Sacred Land

&nbsp7 e-m@il f?r Dich

&nbsp11 Fire Down Below

&nbsp15 Frantic

 

How to fix that ? :blink:


OSC Webmakers Edition modiefied with many other contribs and enhancements.

+ STS 4.5.7 for 2.2MS2 and RC1

Share this post


Link to post
Share on other sites

I have now tryed search in here, and olso gone trough this tread, but I don't get an answer to my problem..

 

 

Warning: Cannot modify header information - headers already sent by (output started at /home/timotina/public_html/nettbutikk/admin/includes/boxes/affiliate.php:20) in /home/timotina/public_html/nettbutikk/admin/includes/functions/general.php on line 21

 

There are no blank spaces so I dont know what is wrong.... I have olso cheked that everything is with the right code..

Share this post


Link to post
Share on other sites
Small bug:

 

When opening a new windows starts and lists all available products for affialiates.

 

But there is a before each product number so that it looks like this: :o

 

&nbsp50 "TEST"

&nbsp9 Alarmstufe: Rot

&nbsp10 Alarmstufe: Rot 2

&nbsp5 Blade Runner - Director's Cut

&nbsp38 Contact Lenses

&nbsp8 Das Gro?e Krabbeln

&nbsp4 Die Ersatzkiller

&nbsp33 Die Hard out of stock

&nbsp24 Disciples: Sacred Land

&nbsp7 e-m@il f?r Dich

&nbsp11 Fire Down Below

&nbsp15 Frantic

 

How to fix that ? :blink:

 

are you using the modified version where admin can select which items affiliates get a commission on (or build links on).....?

 

or just the normal affiliate without hacks? which version did you add? Did you add any hacks to it?


Upon receiving fixes and advice, too many people don't bother to post updates informing the forum of how it went. Until of course they need help again on other issues and they come running back!

 

Why receive the information you require in good faith for free, only to then have the attitude to ignore the people who gave it to you?

 

There's no harm in saying, 'Thanks, it worked'. On the contrary, it creates a better atmosphere.

 

CHOOCH

Share this post


Link to post
Share on other sites
are you using the modified version where admin can select which items affiliates get a commission on (or build links on).....?

 

or just the normal affiliate without hacks? which version did you add? Did you add any hacks to it?

 

It`s the version with admin-selection of possible affiliate items.

I forgot that this is a add on for the aff. contrib.... :blush:

 

Sorry - so it seems to be a bug in the add on and not in the default affiliate contrib...but perhaps you know waht is wrong here ?


OSC Webmakers Edition modiefied with many other contribs and enhancements.

+ STS 4.5.7 for 2.2MS2 and RC1

Share this post


Link to post
Share on other sites
It`s the version with admin-selection of possible affiliate items.

I forgot that this is a add on for the aff. contrib.... :blush:

 

Sorry - so it seems to be a bug in the add on and not in the default affiliate contrib...but perhaps you know waht is wrong here ?

you should follow the un-install instructions of the 'admin allow affiliate items' because probably the author and no-one else would be able to help you....

 

... I haven't installed it for one simple reason, if the affiliate makes a text link and advertises it and the keeps seeing $0.00 commission in his/her affiliate account then it is apparent they won't be with me much longer!

 

remove the add-on and see how it goes.

Edited by chooch

Upon receiving fixes and advice, too many people don't bother to post updates informing the forum of how it went. Until of course they need help again on other issues and they come running back!

 

Why receive the information you require in good faith for free, only to then have the attitude to ignore the people who gave it to you?

 

There's no harm in saying, 'Thanks, it worked'. On the contrary, it creates a better atmosphere.

 

CHOOCH

Share this post


Link to post
Share on other sites
Just to verify: May be a language problem? Is the language file properly installed?

 

Regards

 

Jose Manuel

 

I've got the same problem... could you solve it? Please tell me how.

Thank you!

Share this post


Link to post
Share on other sites

I have gotn the tier system to work if it is set at 2 tier only....

 

When i try to enter a 3 tier system it doesn't work - does anyone have a 3 tier system working the way it should?

 

Please let me know how you set up the 3 tier (or 4, 5 or 6 tier!), the reason isn't that it is required now, it's just something that may be required in the future so it is wise to try to find a solution now.

 

Thanks


Upon receiving fixes and advice, too many people don't bother to post updates informing the forum of how it went. Until of course they need help again on other issues and they come running back!

 

Why receive the information you require in good faith for free, only to then have the attitude to ignore the people who gave it to you?

 

There's no harm in saying, 'Thanks, it worked'. On the contrary, it creates a better atmosphere.

 

CHOOCH

Share this post


Link to post
Share on other sites

I get this messeges when I try to ad a banner in admin..

 

I guess it's sometihing missing in database? :-"

 

1054 - Unknown column 'affiliate_category_id' in 'field list'

 

insert into affiliate_banners (affiliate_banners_title, affiliate_products_id, affiliate_category_id, affiliate_banners_image, affiliate_banners_group, affiliate_date_added, affiliate_status) values ('totlogo1', '0', '0', 'banner1.gif', '', now(), '1')

 

[TEP STOP]

Share this post


Link to post
Share on other sites
I get this messeges when I try to ad a banner in admin..

 

I guess it's sometihing missing in database? :-"

 

1054 - Unknown column 'affiliate_category_id' in 'field list'

 

insert into affiliate_banners (affiliate_banners_title, affiliate_products_id, affiliate_category_id, affiliate_banners_image, affiliate_banners_group, affiliate_date_added, affiliate_status) values ('totlogo1', '0', '0', 'banner1.gif', '', now(), '1')

 

[TEP STOP]

did you insert the SQL?


Upon receiving fixes and advice, too many people don't bother to post updates informing the forum of how it went. Until of course they need help again on other issues and they come running back!

 

Why receive the information you require in good faith for free, only to then have the attitude to ignore the people who gave it to you?

 

There's no harm in saying, 'Thanks, it worked'. On the contrary, it creates a better atmosphere.

 

CHOOCH

Share this post


Link to post
Share on other sites

hahah, guess who?

 

when i went to admin?Affiliates, i got this.

 

1054 - Unknown column 'AFFILIATE_PAYMENT_ORDER_MIN_STATUS' in 'where clause'

 

select count(*) as count, sum(affiliate_value) as total, sum(affiliate_payment) as payment from affiliate_sales a left join orders o on (a.affiliate_orders_id = o.orders_id) where o.orders_status >= AFFILIATE_PAYMENT_ORDER_MIN_STATUS

 

[TEP STOP]

 

 

I have done the install from may 25 (2.5a) and all the bug fixes

http://www.oscommerce.com/community/contributions,158

Share this post


Link to post
Share on other sites

it seems to be coming up only in the affiliate summary, all the other pages display, they dont have any buttons on them, but they show up

Share this post


Link to post
Share on other sites

grr, sometimes it lets me edit, sometimes it doesnt

 

ok, so the error above is coming up on the summary page,

when i click the 'start billing' under payment i get this

 

1054 - Unknown column 'AFFILIATE_PAYMENT_ORDER_MIN_STATUS' in 'where clause'

 

SELECT a.affiliate_id, sum(a.affiliate_payment) FROM affiliate_sales a, orders o WHERE a.affiliate_billing_status != 1 and a.affiliate_orders_id = o.orders_id and o.orders_status >= AFFILIATE_PAYMENT_ORDER_MIN_STATUS and a.affiliate_date <= '2006-04-20' GROUP by a.affiliate_id having sum(a.affiliate_payment) >= 'AFFILIATE_THRESHOLD'

 

[TEP STOP]

 

and when i click on the News i get this

 

1146 - Table 'sailboats1.affiliate_news_contents' doesn't exist

 

select news_id, affiliate_news_headlines as headline, affiliate_news_contents as content, news_status from affiliate_news, affiliate_news_contents where news_id = affiliate_news_id and affiliate_news_languages_id = '1' order by date_added desc

 

[TEP STOP]

 

I dropped all of the affiliate tables in phpmyadmin and ran the .sql again and got this...

 

Error

SQL-query:

 

INSERT INTO configuration_group

VALUES ( 900, 'Affiliate Program', 'Options for the Affiliate Program', 50, 1 )

MySQL said:

 

#1062 - Duplicate entry '900' for key 1

 

Warning: mysql_result(): supplied argument is not a valid MySQL result resource in /home/servage_net/secure/admin/phpMyAdmin-2.6.1/libraries/common.lib.php on line 685

 

 

but it did create these tables

affiliate_affiliate

affiliate_banners

affiliate_banners_history

affiliate_clickthroughs

affiliate_news

affiliate_newsletters

affiliate_payment

affiliate_payment_status

affiliate_payment_status_history

affiliate_sales

Share this post


Link to post
Share on other sites
did you insert the SQL?

 

Yes, and I didn't get eny errors when I did it, s? I dont understand why I get sql error..

Share this post


Link to post
Share on other sites

Okey...

 

Now I have manually dropt all affeliate sql and put everything in manually insted of just the file..

 

This will not be altered:

 

"INSERT INTO configuration_group VALUES (900, 'Affiliate Program', 'Options for the Affiliate Program', 50, 1)"

 

I det this error:

 

"Error

SQL query:

 

INSERT INTO configuration_group

VALUES ( 900, 'Affiliate Program', 'Options for the Affiliate Program', 50, 1 )

MySQL said:

 

#1062 - Duplicate entry '900' for key 1

"

Share this post


Link to post
Share on other sites
I det this error:

 

"Error

SQL query:

 

INSERT INTO configuration_group

VALUES ( 900, 'Affiliate Program', 'Options for the Affiliate Program', 50, 1 )

MySQL said:

 

#1062 - Duplicate entry '900' for key 1

"

 

well atleast i know i am not the only one getting this error, any thoughts on the other ones?

Share this post


Link to post
Share on other sites
Okey...

 

Now I have manually dropt all affeliate sql and put everything in manually insted of just the file..

 

This will not be altered:

 

"INSERT INTO configuration_group VALUES (900, 'Affiliate Program', 'Options for the Affiliate Program', 50, 1)"

 

I det this error:

 

"Error

SQL query:

 

INSERT INTO configuration_group

VALUES ( 900, 'Affiliate Program', 'Options for the Affiliate Program', 50, 1 )

MySQL said:

 

#1062 - Duplicate entry '900' for key 1

"

as far as i know it shouldn't do that

Edited by chooch

Upon receiving fixes and advice, too many people don't bother to post updates informing the forum of how it went. Until of course they need help again on other issues and they come running back!

 

Why receive the information you require in good faith for free, only to then have the attitude to ignore the people who gave it to you?

 

There's no harm in saying, 'Thanks, it worked'. On the contrary, it creates a better atmosphere.

 

CHOOCH

Share this post


Link to post
Share on other sites
as far as i know it shouldn't do that

When I had the same problem, it clearly was a MySQL database problem. So, to fix it, I went into phpMyAdmin and selected the database. Then clicked on "IMPORT" and located the affiliate.sql file and uploaded it.

 

All worked fine for me since then. May work for you too!


Doctor Mason, World's #1 "Temporary Webmaster"

Share this post


Link to post
Share on other sites
When I had the same problem, it clearly was a MySQL database problem. So, to fix it, I went into phpMyAdmin and selected the database. Then clicked on "IMPORT" and located the affiliate.sql file and uploaded it.

 

All worked fine for me since then. May work for you too!

I agree that's what should happen BUT the person who posted the request for help said that they are getting the error after inserting the SQL once they've cleared it out - that's strange


Upon receiving fixes and advice, too many people don't bother to post updates informing the forum of how it went. Until of course they need help again on other issues and they come running back!

 

Why receive the information you require in good faith for free, only to then have the attitude to ignore the people who gave it to you?

 

There's no harm in saying, 'Thanks, it worked'. On the contrary, it creates a better atmosphere.

 

CHOOCH

Share this post


Link to post
Share on other sites
When I had the same problem, it clearly was a MySQL database problem. So, to fix it, I went into phpMyAdmin and selected the database. Then clicked on "IMPORT" and located the affiliate.sql file and uploaded it.

 

All worked fine for me since then. May work for you too!

 

Well I have done that and it still gives me the stupid error message.. :buhuuu:

 

I need to imprt banners so that my partners can advertise.. ooooffff.. can't understand what is wrong!

Share this post


Link to post
Share on other sites

Is there some information available how the Affiliate Contrib works ?

how to set "banners", Product images and so on for affiliate partners ?

 

Could not find a documentation of the affiliate program ??


OSC Webmakers Edition modiefied with many other contribs and enhancements.

+ STS 4.5.7 for 2.2MS2 and RC1

Share this post


Link to post
Share on other sites
Is there some information available how the Affiliate Contrib works ?

how to set "banners", Product images and so on for affiliate partners ?

 

Could not find a documentation of the affiliate program ??

there isn't a manual as such... I guess it's a matter of just playing around with it to get an idea of how it works


Upon receiving fixes and advice, too many people don't bother to post updates informing the forum of how it went. Until of course they need help again on other issues and they come running back!

 

Why receive the information you require in good faith for free, only to then have the attitude to ignore the people who gave it to you?

 

There's no harm in saying, 'Thanks, it worked'. On the contrary, it creates a better atmosphere.

 

CHOOCH

Share this post


Link to post
Share on other sites
I need to imprt banners so that my partners can advertise.. ooooffff.. can't understand what is wrong!

Perhaps you have other mods - contributions that conflict? When I logged on as an affiliate and went into and looked into the Affiliate mod, I was able to select one of my "products" and it showed the picture of the product and gave me some html to place onto my webpage.

 

May I suggest that you install a clean copy of osC onto some sub domain you have, and only add the Affiliate mod? You should see that it works fine. Believe me, I'm NO php guru and I was able to do it.


Doctor Mason, World's #1 "Temporary Webmaster"

Share this post


Link to post
Share on other sites
I have gotn the tier system to work if it is set at 2 tier only....

 

Thanks

Mine is also set for 2tiers. How do you test it to see your downline? I did not see anything in the reports section once I logged in as an affiliate.


Doctor Mason, World's #1 "Temporary Webmaster"

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×