Jump to content
henri

OSC-Affiliate

Recommended Posts

Ok .. let me keep it simple (and my plans changed someone so disregard post above:

 

I'm looking to install the UPSXML contrib and have a few advanced setup/custom tweak questions ... I know this is the OscAffiliate support forum, but anyone with indepth knowledge will know where to stear me (hopefully!)

 

First, can we generate UPS tracking labels from the site as an order comes in?

 

Once we get an approval, we would need to generate a tracking#/label and have this available for printing from the website directly. We are building out a Vendor based drop shipping affiliate program and need the entire process automated.

 

When we get an order (assuming its there stock) they would get an email with a name and address to send the order to. They would also receive a link to a page containing a pre-populated label for that order. They would only have to get the package out of door.

 

There affiliate account would get credited and they would be issued a check at months end.

 

I'm thinking of combining and expanding OscAffiliate with Multi Vendor Shipping to include the above functionality.

 

Has anyone done this? Anything of the shelf I can use? Anyone experienced enough to assist in development?. Have budget, will pay. contact me for more info.

 

Thanks

 

Chris

Share this post


Link to post
Share on other sites
I am having exactly the same problem here, with STS (V2.01) & osCaffiliate (V2.5a) installed. Anyone figured out why?

 

Thank you very much.

 

I'm also having the help files pop-up problem with STS.

How to fix this?

Are there people who have no problems with v2.5a?

I've installed this version yesterday but now I read there're bugs in this version (what kind of bugs?).

Share this post


Link to post
Share on other sites

Hi everyone,

 

Sorry for what is probably a really stupid question, but having successfully installed this great contrib I attempted to build some category links using the test affiliate account that I had set up.

 

However, I can successfully build the links but where an image is required I am left with a red x box indicating that the image was not there. Please would someone tell me:

(a) Where does OSC Affiliate reference the image files from?

(B) Should all of the categoy images be saved and uploaded into a specific folder? If so where? I can see a DIR_WS_IMAGES but not completely sure what this means or where it refers to.

 

I would really be grateful for a point in the right direction.

 

Many thanks.


You will never learn if you don't try. And boy am I trying....!

Share this post


Link to post
Share on other sites

STS Affiliate Pop-Up issue

 

I had the same problem and have a solution. (That works for me, hope it will work for you as well)

 

In the file named sts_display_output.php it states that:

// If script name contains "popup" then turn off templates and display the normal output

 

So, looking at the two files that need to pop up for the affiliate 'create a link' pages (category and products)

 

affiliate_validcats.php & affiliate_validproducts.php

 

They do not have the word 'popup' in their names.

 

So I renamed them:

 

popup_affiliate_validcats.php & popup_affiliate_validproducts.php

 

Then i opened the file - includes/affiliate_application_top.php

 

i changed the file names to match the new ones.

 

Hope this helps. :)

 

I'm also having the help files pop-up problem with STS.

How to fix this?

Are there people who have no problems with v2.5a?

I've installed this version yesterday but now I read there're bugs in this version (what kind of bugs?).


What would you do if you knew you could not fail?

Share this post


Link to post
Share on other sites
Hi everyone,

 

Sorry for what is probably a really stupid question, but having successfully installed this great contrib I attempted to build some category links using the test affiliate account that I had set up.

 

However, I can successfully build the links but where an image is required I am left with a red x box indicating that the image was not there. Please would someone tell me:

(a) Where does OSC Affiliate reference the image files from?

(B) Should all of the categoy images be saved and uploaded into a specific folder? If so where? I can see a DIR_WS_IMAGES but not completely sure what this means or where it refers to.

 

I would really be grateful for a point in the right direction.

 

Many thanks.

 

Can anyone help with this problem please? It's driving me nuts!!

 

Many thanks.


You will never learn if you don't try. And boy am I trying....!

Share this post


Link to post
Share on other sites

Monica,

Thank you so much for the help, it worked for me too :)

STS Affiliate Pop-Up issue

 

I had the same problem and have a solution. (That works for me, hope it will work for you as well)

Share this post


Link to post
Share on other sites

Hi,

 

I Have a big problem with this contrib OSC Affiliate 2.5a!!!

 

I can see that the sale is in fact made and is recorded to the affiliate_sales table.

It just seems to stop working when it tries to retrieve this information to the affiliate payment page (admin panel).

Obviously, no info being posted means no payments being billed.

 

My sales are recording in the affiliate system correctly (affiliate_payment_status_ID=0).

My affiliate_payment_status Table is correct.

My affiliate configuration is at 0 day.

 

In fact affiliate_payment is always empty !!

 

Any ideas ?

Edited by fets

Share this post


Link to post
Share on other sites

Hi

Another way to fix the issue with the Affiliate help files and STS Template is to edit sts_display_output.php where is looks for the word 'popup' in the filename.

 

At about line 47 I have replaced:

 

if (strpos($scriptname, "popup") !== false || strpos($scriptname, "info_shopping_cart") !== false) {

$display_normal_output = 1;

$display_template_output = 0;

}

 

with:

 

if (strpos($scriptname, "popup") !== false || strpos($scriptname, "affiliate_help") !== false || strpos($scriptname, "info_shopping_cart") !== false) {

$display_normal_output = 1;

$display_template_output = 0;

}

 

You can also add any other filenames if needed.

 

Hope this helps.

 

CD


"Imagination is more important than knowledge" - Albert Einstein

Share this post


Link to post
Share on other sites
Hi,

 

I Have a big problem with this contrib OSC Affiliate 2.5a!!!

 

I can see that the sale is in fact made and is recorded to the affiliate_sales table.

It just seems to stop working when it tries to retrieve this information to the affiliate payment page (admin panel).

Obviously, no info being posted means no payments being billed.

 

My sales are recording in the affiliate system correctly (affiliate_payment_status_ID=0).

My affiliate_payment_status Table is correct.

My affiliate configuration is at 0 day.

 

In fact affiliate_payment is always empty !!

 

Any ideas ?

 

Does this contrib go correctly for somebody?

Share this post


Link to post
Share on other sites

I am really new to SQL and PHP (so maybe it is really stupid of me to even attempt to use this contribution). I have followed most of the installation instructions (I think - hopefully I did it right!), but when I get to this part, I am completely lost. I have no idea what this means:

 

Install:

 

catalog/product_info.php

 

 

After:

 

<?php echo '<a href="' . tep_href_link(DIR_WS_IMAGES . $product_info['products_image']) . '" target="_blank">' . tep_image(DIR_WS_IMAGES . $product_info['products_image'], $product_info['products_name'], SMALL_IMAGE_WIDTH, SMALL_IMAGE_HEIGHT, 'hspace="5" vspace="5"') . '<br>' . TEXT_CLICK_TO_ENLARGE . '</a>'; ?>

</noscript>

 

 

Add:

 

<br><br>

<?php

//affiliate build a link begin

if (tep_session_is_registered('affiliate_id')) {

?>

<?php echo '<a href="' . tep_href_link(FILENAME_AFFILIATE_BANNERS_BUILD, 'individual_banner_id=' . $product_info['products_id']) .'" target="_self">' . tep_image('includes/languages/english/images/buttons/button_affiliate_build_a_link.gif', 'Make a link') . ' </a>'; ?><?php

}

//affiliate build a link begin

?>

 

FILENAMES.PHP in CATALOG

ADD

define('FILENAME_CATEGORIES_INFO', 'index.php');

 

Can someone clarify this for me? What does it mean to "install" that particular file? I tried just plain running it, but came up with errors, so I'm not sure if I got errors due to something else, or if I got errors because that isn't what I was supposed to be doing. I don't know what else would be meant by "install." After that, where am I adding the remaining text? To product_info.php? Thanks in advance!

Share this post


Link to post
Share on other sites
Can someone clarify this for me? What does it mean to "install" that particular file?

 

Add a button on product_info only for affiliates! they can create a link just by clicking on this button!

 

It's wonderfull !!

 

News about my problem someone?

Share this post


Link to post
Share on other sites

When clicking on "affiliate Information" on my frontpage (www.drikkegel.dk/catalog/) i get the error:

Fatal error: Cannot redeclare tep_db_connect() (previously declared in /home/drikkege/public_html/catalog/includes/functions/database.php:13) in /home/drikkege/public_html/catalog/includes/functions/database.php on line 25

 

 

Also, when in Admin, adding a banner, i get:

1054 - Unknown column 'affiliate_category_id' in 'field list'

 

insert into affiliate_banners (affiliate_banners_title, affiliate_products_id, affiliate_category_id, affiliate_banners_image, affiliate_banners_group, affiliate_date_added, affiliate_status) values ('banner1', '0', '0', 'banners/', '', now(), '1')

 

[TEP STOP]

 

 

Anyone encountered this?

I did a search on google and oscommerce. Files in language/dansk/ seems to be correct.


Timo Jensen

Share this post


Link to post
Share on other sites

Affiliate and missing banner

 

When issuing banners, they are not available. The link works fine. Inserting the link in a browser, leads to my shop. But the banner does not show on pages with the code.

 

Feel free to try this:

 

<a href="http://drikkegel.dk/catalog/index.php?ref=1&affiliate_banner_id=2" target="_blank"><img src="http://drikkegel.dk/catalog/affiliate_show_banner.php?ref=1&affiliate_banner_id=2" border="0" alt="drikkegel.dk"></a>

 

I've made two banners. One with a gif, and one with jpg, to see if that's the reason.

No luck so far.

 

Anyone?

 

I've seen several people with same problem, but their solutions hasn't helped me.


Timo Jensen

Share this post


Link to post
Share on other sites
Add a button on product_info only for affiliates! they can create a link just by clicking on this button!

 

It's wonderfull !!

 

I don't need to know what it does, I need to know how to do it. "Install x file," is programmer jargon (from my perspective) and I'm not very familiar with PHP and SQL yet. How do I install catalog/product_info.php? And then where do I copy the remaining text? I'm thinking this should be a really easy question for those who know what they're doing. :)

Share this post


Link to post
Share on other sites

Hi, henri,

 

I am getting a error from my OSC Affililate part in my admin area, this is what the error says -

 

Fatal error: Cannot redeclare class currencies in /home/********/public_html/admin/includes/classes/currencies.php on line 16

 

Please help.

 

Thank you,

Michael


Michael

Share this post


Link to post
Share on other sites

Can nobody answer my installation question? I would really like to get this installed so I can move on to testing it. And, since it's only HALF installed, I really don't want to even mess with anything else in the cart until it's complete.

Share this post


Link to post
Share on other sites
I am really new to SQL and PHP (so maybe it is really stupid of me to even attempt to use this contribution). I have followed most of the installation instructions (I think - hopefully I did it right!), but when I get to this part, I am completely lost. I have no idea what this means:

 

Install:

 

catalog/product_info.php

After:

 

<?php echo '<a href="' . tep_href_link(DIR_WS_IMAGES . $product_info['products_image']) . '" target="_blank">' . tep_image(DIR_WS_IMAGES . $product_info['products_image'], $product_info['products_name'], SMALL_IMAGE_WIDTH, SMALL_IMAGE_HEIGHT, 'hspace="5" vspace="5"') . '<br>' . TEXT_CLICK_TO_ENLARGE . '</a>'; ?>

</noscript>

Add:

 

<br><br>

<?php

//affiliate build a link begin

if (tep_session_is_registered('affiliate_id')) {

?>

<?php echo '<a href="' . tep_href_link(FILENAME_AFFILIATE_BANNERS_BUILD, 'individual_banner_id=' . $product_info['products_id']) .'" target="_self">' . tep_image('includes/languages/english/images/buttons/button_affiliate_build_a_link.gif', 'Make a link') . ' </a>'; ?><?php

}

//affiliate build a link begin

?>

 

FILENAMES.PHP in CATALOG

ADD

define('FILENAME_CATEGORIES_INFO', 'index.php');

 

Can someone clarify this for me? What does it mean to "install" that particular file? I tried just plain running it, but came up with errors, so I'm not sure if I got errors due to something else, or if I got errors because that isn't what I was supposed to be doing. I don't know what else would be meant by "install." After that, where am I adding the remaining text? To product_info.php? Thanks in advance!

....

so open catalog/product_info.php

find :

<?php echo '<a href="' . tep_href_link(DIR_WS_IMAGES . $product_info['products_image']) . '" target="_blank">' . tep_image(DIR_WS_IMAGES . $product_info['products_image'], $product_info['products_name'], SMALL_IMAGE_WIDTH, SMALL_IMAGE_HEIGHT, 'hspace="5" vspace="5"') . '<br>' . TEXT_CLICK_TO_ENLARGE . '</a>'; ?>

</noscript>

after add

<br><br>

<?php

//affiliate build a link begin

if (tep_session_is_registered('affiliate_id')) {

?>

<?php echo '<a href="' . tep_href_link(FILENAME_AFFILIATE_BANNERS_BUILD, 'individual_banner_id=' . $product_info['products_id']) .'" target="_self">' . tep_image('includes/languages/english/images/buttons/button_affiliate_build_a_link.gif', 'Make a link') . ' </a>'; ?><?php

}

//affiliate build a link begin

?>

 

open catalog/filenames.php

behind last

?>

add :

define('FILENAME_CATEGORIES_INFO', 'index.php');

Share this post


Link to post
Share on other sites
I am really new to SQL and PHP (so maybe it is really stupid of me to even attempt to use this contribution). I have followed most of the installation instructions (I think - hopefully I did it right!), but when I get to this part, I am completely lost. I have no idea what this means:

 

Install:

 

catalog/product_info.php <--- look from 'catalog' directory then edit "product_info.php"

After: <------- This mean look for below code then after "</noscript>" add following code <br><br>..... etc. u get?

<?php echo '<a href="' . tep_href_link(DIR_WS_IMAGES . $product_info['products_image']) . '" target="_blank">' . tep_image(DIR_WS_IMAGES . $product_info['products_image'], $product_info['products_name'], SMALL_IMAGE_WIDTH, SMALL_IMAGE_HEIGHT, 'hspace="5" vspace="5"') . '<br>' . TEXT_CLICK_TO_ENLARGE . '</a>'; ?>

</noscript>

 

Add: <---- mean add below code after "</noscript>"

 

<br><br>

<?php

//affiliate build a link begin

if (tep_session_is_registered('affiliate_id')) {

?>

<?php echo '<a href="' . tep_href_link(FILENAME_AFFILIATE_BANNERS_BUILD, 'individual_banner_id=' . $product_info['products_id']) .'" target="_self">' . tep_image('includes/languages/english/images/buttons/button_affiliate_build_a_link.gif', 'Make a link') . ' </a>'; ?><?php

}

//affiliate build a link begin

?>

 

FILENAMES.PHP in CATALOG <----- ask u file a file name filename.php, should be iin catalog/include/filename.php

 

ADD <------- mean add a code below

 

define('FILENAME_CATEGORIES_INFO', 'index.php');

 

Can someone clarify this for me? What does it mean to "install" that particular file? I tried just plain running it, but came up with errors, so I'm not sure if I got errors due to something else, or if I got errors because that isn't what I was supposed to be doing. I don't know what else would be meant by "install." After that, where am I adding the remaining text? To product_info.php? Thanks in advance!

 

Hope its help

Share this post


Link to post
Share on other sites

Hello guys!

Is there any chance I can get a full categories path with subcategories in catalog/affiliate_validcats.php

 

I am getting now only my end subcategory in Category List but I need like

 

Category/Sub-Category/Sub-Sub-Category

 

Thanks everybody for help.

Share this post


Link to post
Share on other sites

I do not follow you people, can someone help me please.


Michael

Share this post


Link to post
Share on other sites

Apparently the "install" step I asked about has still been skipped. When I log into the admin panel, I get the following error:

 

1146 - Table 'homework_osc1.affiliate_sales' doesn't exist

 

select count(*) as count, sum(affiliate_value) as total, sum(affiliate_payment) as payment from affiliate_sales

 

[TEP STOP]

 

...and am not able to access ANYTHING in the admin panel. Can somebody PLEASE tell me what it means to "install catalog/product_info.php." Please note that this wording is DIFFERENT from anything else in the install file, which all tells which code to add to the various php files. I have added the code to all of the files, but am unsure how to install what needs to be installed so that the store recognizes the database (which does, btw, exist).

Share this post


Link to post
Share on other sites

Okay, moving right along... :) I figured out the table problem. Apparently, I had somehow managed (due to my unfamiliarity with phpMyAdmin) to install the sql in the wrong database. I fixed that. The admin side of things now seems to be working beautifully. However, I can't view the actual storefront. When I visit www.homeworksbest.net/shop/, I get the following error(s):

 

Warning: main(includes/affiliate_application_top.php): failed to open stream: No such file or directory in /home/homework/public_html/shop/includes/application_top.php on line 509

 

Warning: main(includes/affiliate_application_top.php): failed to open stream: No such file or directory in /home/homework/public_html/shop/includes/application_top.php on line 509

 

Warning: main(includes/affiliate_application_top.php): failed to open stream: No such file or directory in /home/homework/public_html/shop/includes/application_top.php on line 509

 

Fatal error: main(): Failed opening required 'includes/affiliate_application_top.php' (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/homework/public_html/shop/includes/application_top.php on line 509

 

What did I do (or not do)?

Share this post


Link to post
Share on other sites

Started getting OSCAffiliate set up today got through everything only to look at the text link page and realize it is trying to show banner links instead if text links, I have been tryin to find where to add text links for affiliates to use for an hour.

 

site is located here... http://sexappealinc.com/catalog/ it is an adult toys site, you have been warned do be offended.

 

any direction you could point me in would be great!

Share this post


Link to post
Share on other sites

Me again...hopefully for the last time for a while. I am getting better at understanding how these files work, because I have fixed all of the problems I was having, and (without any in-depth testing) it seems to be working.

 

I'm not sure where to enter my info, though, for the stuff that shows up on the catalog side. Which files should I be looking for, for the affiliate terms, faq, etc.? (I think there are a total of four that I need to edit.) Thank you!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×