Jump to content
henri

OSC-Affiliate

Recommended Posts

:blink:

Can anyone tell me what is missing that gives me this result for a category banner:

 

<a href="http://mytestsite.com/FILENAME_CATEGORIES_INFO?ref=5&cPath=34&affiliate_banner_id=1" target="_blank">Artist Crafted</a>

I'm obviously missing the definition for FILENAME_CATEGORIES_INFO. At least I think  :-"  it's obvious!  Where is this supposed to be defined and what is it set to?

Thanks!!

 

There's an update for this bug at http://www.oscommerce.com/community/contributions,158

Share this post


Link to post
Share on other sites

Henri, or whom ever...

 

I have a strange problem I hope somebody can help me figure out. Its basicly the same as a few posts above, I can not see the banners in OSCAffiliate Contribution when I set the AFFILIATE_KIND_OF_BANNERS','2'); but when I set it to 1 it works, but no click tracking. How can I get it to work in "2" with click tracking ????

 

Crazy thing, is everything seems to be working fine, but just the banner images when I try to create one.

 

I have a perfect install of OCS 2 loaded on a standard Apache server. I also set the AFFILIATE_SHOW_BANNERS_DEBUG', 'true') and this is the output I got from a NEW browser..

 

<a href="http://www.*******.com/index.php?ref=1&affiliate_banner_id=5" target="_blank"><img src="http://www.*******.com/affiliate_show_banner.php?ref=1&affiliate_banner_id=5" border="0" alt="BANNER468X60"></a>

 

I checked everything else, my https secure setting...they all seem to be set right, I checked my path settings..again all seem to be right..please can some body leand a hand here...that has had luck fixing this program before....

 

 

What else should I post to help you guys out...!!! So maybe you can double check my settings...

 

// Define the webserver and path parameters
// * DIR_FS_* = Filesystem directories (local/physical)
// * DIR_WS_* = Webserver directories (virtual/URL)
 define('HTTP_SERVER', 'http://www.*******.com'); // eg, http://localhost - should not be empty for productive servers
 define('HTTPS_SERVER', 'http://www.*******.com'); // eg, https://localhost - should not be empty for productive servers
 define('ENABLE_SSL', true); // secure webserver for checkout procedure?
 define('HTTP_COOKIE_DOMAIN', 'www.*******.com');
 define('HTTPS_COOKIE_DOMAIN', 'www.*******.com');
 define('HTTP_COOKIE_PATH', '');
 define('HTTPS_COOKIE_PATH', '');
 define('DIR_WS_HTTP_CATALOG', '/');
 define('DIR_WS_HTTPS_CATALOG', '/');
 define('DIR_WS_IMAGES', 'images/');
 define('DIR_WS_ICONS', DIR_WS_IMAGES . 'icons/');
 define('DIR_WS_INCLUDES', 'includes/');
 define('DIR_WS_BOXES', DIR_WS_INCLUDES . 'boxes/');
 define('DIR_WS_FUNCTIONS', DIR_WS_INCLUDES . 'functions/');
 define('DIR_WS_CLASSES', DIR_WS_INCLUDES . 'classes/');
 define('DIR_WS_MODULES', DIR_WS_INCLUDES . 'modules/');
 define('DIR_WS_LANGUAGES', DIR_WS_INCLUDES . 'languages/');

// define our database connection
 define('DB_SERVER', 'localhost'); // eg, localhost - should not be empty for productive servers
 define('DB_SERVER_USERNAME', '*******');
 define('DB_SERVER_PASSWORD', '*******');
 define('DB_DATABASE', '*******);
 define('USE_PCONNECT', 'false'); // use persistent connections?
 define('STORE_SESSIONS', 'mysql'); // leave empty '' for default handler or set to 'mysql'

 

Any idea....Please...!! :'(

 

I don't have these warnings ;)

but try changing

  if ($HTTP_GET_VARS['ref'])

to

  if (isset($HTTP_GET_VARS['ref']))

were thes errors happen.

Share this post


Link to post
Share on other sites

Hiya

 

I have tried searching this forum and I am getting on the catalog index.php BOX_FILENAME_INFO etc and it does not go anywhere. Now from reading I understand I need to define these links in filenames.php, ok thats fine but the install readme did not have a list of what to define, nor can i find one. Can anyone help me?

 

Also the only way I could get around the BOX_FILENAME_INFO being displayed was to edit affiliate.php

 

is this correct or should it be getting the name from elsewhere? as this seems to fix it.

 

What would FILENAME_AFFILIATE be linked to? Would that be affiliate.php?

 

Thanks

 

DJH

Share this post


Link to post
Share on other sites

Also I guess i need to do the same for the tables too.

 

And on the signup page there is stuff like ENTRY_AFFILIATE_COMPANY_TAXID_TEXT Obviously i don't want people seeing that, is it meant to be there?

 

DJH

Share this post


Link to post
Share on other sites
You should install:

 

3 May 2004 - osCAffiliate v2.03

 

You will need to scroll down a ways to get there. All others are just updates and not complete.

 

--------------

 

But anyway... Open your affiliate php files and search for "TEXT_PRICE_IS_ZERO" and you will see that it is calling a language define called "TEXT_PRICE_IS_ZERO". You should be able to just add that into your language file matching the same file name that you found "TEXT_PRICE_IS_ZERO" in.

 

Just add a new line like as follows:

 

define('TEXT_PRICE_IS_ZERO','0');

 

or

 

define('TEXT_PRICE_IS_ZERO','None');

 

or

 

define('TEXT_PRICE_IS_ZERO','N/A');

 

Hope that helps...

 

 

thanks for the help. i had already downloadad the latest version though. the one you mentioned with all additional amendments afterwards. strangely this was still missing plus some other language ommissions in the admin!

 

also i have noticed that this file does not exist in that version!! affiliate_help19.php or am i still mistaken?

 

regards.

Edited by siavash

Did you try? Did you fail? No matter! Try again. Fail again! But fail better!

Share this post


Link to post
Share on other sites

I have a unique problem. I have an affiliate who has registered her own domain name and is redirecting it to my site with the ref number. She is also masking, so it looks like you are on her domain name when at my site and the tags have been modified.

 

In the affiliate logs I see that she has many click throughs; however, when someone buys something she doesn't get credit for it. I have verified that the IP address of the person making the purchase shows up as a click through and that it doesn't show up as a sale when a sale is made.

 

Any ideas anyone? You can look in my profile to see my site name, the domain name she registered is glassforcrafts.com. I have never seen this forwarding before and haven't quite decided if I'm comfortable with it.

Share this post


Link to post
Share on other sites
Users using the Mozilla Firefox browser can't create an affiliate account.  When registering, the user gets the congratulations screen and the welcome email but the affiliate account doesn't really get created. 

Would someone know how to fix this?

 

Thanks!

i use firefox and it worked fine for me.

Share this post


Link to post
Share on other sites

OK heres a few things. Figured out how to add banner links and damn I feel fucking stupid. ANYHOW:

 

1. Why is affiliate_help19.php to like 22? missing??? Am I just blind or did I get a bad version 2.02? or where they just left out for some reason.

 

2. Does anyone have a nice set of affiliate faqs theyd be so kind to share with my lazy self

 

3. i know this contribution is uber old and super good but I'd like to know if anyone is planning on devising an easy way for ppl like myself who know nothing about php to do the following: when an affil sends a sale and they come back as a repeat customer, I want a way to give commission to the affiliate again for all other orders than the initial one if they come to the site directly? Make sense? if not I'm tired and I blame it on that.

 

Hrm I know there was so mething else I wanted to ask/suggest but I forget.

 

Thanks

Share this post


Link to post
Share on other sites

OOOOOOOOOOh I remember.

 

I posted aw;hile back about this to no avail so here goes.

 

I want to know how if its possible I can make the affiliate pages have the standard colored table where it says like "continue" and such. That way it matches the rest of my sites and besides my buttons all have colored bgs not white so thatd be SUPER.

 

Thanks again

Share this post


Link to post
Share on other sites
Does anyone have a nice set of affiliate faqs theyd be so kind to share with my lazy self

 

You can look at ours at http://www.popthetop.com/catalog/


L8r,

PopTheTop

 

Published osC Contributions:

- eCheck Payment Module v3.1

- Reviews in Product Display v2.0

- Fancier Invoice & Packingslip v6.1

- Admin Notes / Customer Notes v2.2

- Customer Zip & State Validation v2.2

- Search Box with Dropdown Category Menu v1.0

 

Pop your camper's top today!

It's a popup thing...

You wouldn't understand

Share this post


Link to post
Share on other sites

I do not understand, where did you see that? ;)


L8r,

PopTheTop

 

Published osC Contributions:

- eCheck Payment Module v3.1

- Reviews in Product Display v2.0

- Fancier Invoice & Packingslip v6.1

- Admin Notes / Customer Notes v2.2

- Customer Zip & State Validation v2.2

- Search Box with Dropdown Category Menu v1.0

 

Pop your camper's top today!

It's a popup thing...

You wouldn't understand

Share this post


Link to post
Share on other sites

Snowman,

I performed a hack to accept an optional paramater in the link. This will allow "keywords" to be stored in the database. It is useful when I use osC-Affilliate to track PPC clicks from Google/Overture etc. (PPC sites are setup as affiliates with a 0% payout.) It tells me the effectiveness of keywords used.

 

I am more than happy to donate the code as-is or when I complete the additional keyword reports. PM me if you want to consider including it in a future release.

 

FYI, It does not affect the existing functionality for real affiliates at all.

 

Rob

Share this post


Link to post
Share on other sites

Is there any way to have the affiliate system so that I pay per sale e.g. ?5 instead of a percentage?

which files would I need to change.

 

thanks

Share this post


Link to post
Share on other sites

Paying a set amount per sales as aposed to a percentage is very possible, I wrote a contribution that does exactly that, although my contribution runs along side osCommerce and not from with-in it, it requires only two lines of code added to the osCommerce pages, which is all expalined in the files...

 

http://www.oscommerce.com/community/contri...earch,affiliate

 

This has been tested and works perfectly.

 

If anybody has a problem with my contribution just email me for help...

 

:rolleyes:


Stuart Ambrose

Share this post


Link to post
Share on other sites

Hello,

how can i delete the Affiliate Clickthroughs ?? is there a mod for that ? i have now over 34555 pages witth Affiliate Clickthroughs and i need to clarear that for all users ???

Share this post


Link to post
Share on other sites

Easy, just clear that data from the database using phpMyAdmin


L8r,

PopTheTop

 

Published osC Contributions:

- eCheck Payment Module v3.1

- Reviews in Product Display v2.0

- Fancier Invoice & Packingslip v6.1

- Admin Notes / Customer Notes v2.2

- Customer Zip & State Validation v2.2

- Search Box with Dropdown Category Menu v1.0

 

Pop your camper's top today!

It's a popup thing...

You wouldn't understand

Share this post


Link to post
Share on other sites
Easy, just clear that data from the database using phpMyAdmin

 

no ... i mean automaticaly in affiliate. is there a mod where i can say delete Affiliate Clickthroughs from the last XYZ days ??

 

i have no glue how to change or add this ???

Share this post


Link to post
Share on other sites
no ... i mean automaticaly in affiliate. is there a mod where i can say delete Affiliate Clickthroughs from the last XYZ days ??

 

i have no glue how to change or add this ???

 

To my knowledge, there is no feature built-in for this.

I'm curious on why would you want to delete historical data. Wouldn't it help your analysis in the future?

 

Robert

Share this post


Link to post
Share on other sites

I just noticed a problem I am having with this mod. I have 4 banners setup for the affiliate to choose from. 2 are set to a product ID and 2 are setup to just go to our store index.

 

The problem is this, the 2 banners set with a product ID do not get displayed in the banners choices for the affiliate.

 

When I say that they are not there, I mean there is no choices at all for them, just the other 2.

 

Is there anyone else having this problem? Is the a fix?

Edited by PopTheTop

L8r,

PopTheTop

 

Published osC Contributions:

- eCheck Payment Module v3.1

- Reviews in Product Display v2.0

- Fancier Invoice & Packingslip v6.1

- Admin Notes / Customer Notes v2.2

- Customer Zip & State Validation v2.2

- Search Box with Dropdown Category Menu v1.0

 

Pop your camper's top today!

It's a popup thing...

You wouldn't understand

Share this post


Link to post
Share on other sites

Was wondering if it was possible to track clicks to pages other than products, at the moment I can link to products no problem, but I would like to link to categories & manufacturers. I would like the affiliate program to track a click to the Cat1 category, Cat2 etc. At the moment it comes up as 'startpage'?

 

Maybe the same as above but is there any way to capture the search query from google?


Thanks for any help/comments.

 

Regards,

 

Lewis Hill

Share this post


Link to post
Share on other sites

I just noticed a problem I am having with this mod. I have 4 banners setup for the affiliate to choose from. 2 are set to a product ID and 2 are setup to just go to our store index.

 

The problem is this, the 2 banners set with a product ID do not get displayed in the banners choices for the affiliate.

 

When I say that they are not there, I mean there is no choices at all for them, just the other 2.

 

Is there anyone else having this problem? Is the a fix?


L8r,

PopTheTop

 

Published osC Contributions:

- eCheck Payment Module v3.1

- Reviews in Product Display v2.0

- Fancier Invoice & Packingslip v6.1

- Admin Notes / Customer Notes v2.2

- Customer Zip & State Validation v2.2

- Search Box with Dropdown Category Menu v1.0

 

Pop your camper's top today!

It's a popup thing...

You wouldn't understand

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×